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Signal Generator Features

N5171B/N5181B, RF analog models: 9 kHz to 1 (N5171B only), 3, or 6 GHz (Options 501, 503,
and 506 respectively)

N5172B/N5182B, RF vector models: 9 kHz to 3 or 6 GHz (Options 503, and 506 respectively)

N5173B/N5183B, Microwave analog models: 9 kHz to 13, 20, 31.8 or 40 GHz (Options 513, 520,
532, and 540 respectively)

electronic attenuator (N5172B, N5172B, N5181B, N5182B)
mechanical attenuator (N5173B or N5183B, Option 1E1)
vector models can include waveforms in list sweep
automatic leveling control (ALC)

real-time modulation filtering

8648/ESG code compatible

10 MHz reference oscillator with external output

two channel power meter display

user settable maximum power limit

user flatness correction

external analog I/Q inputs (vector models)

enhanced assembly replacement

GPIB, USB 2.0, and 100Base-T LAN interfaces

deep amplitude modulation providing greater dynamic range
manual power search (ALC off)

SCPIl and IVI-COM driver

multiple baseband generator synchronization when using multiple signal generators
(master/slave setup)

with Signal Studio Software, vector models can generate 802.11 WLAN, W-CDMA, cdma2000,
1xEV-DO, GSM, EDGE, and more

real-time baseband generator (Option 660)

pulse train generator (Option 320)

LF multifunction generator (Option 303)

narrow pulse modulation, including internal pulse generator (Option UNW)

analog differential I/Q outputs (vector models, Option TEL)

analog modulation: AM, FM, and ®M (Option UNT)

arbitrary 1/Q waveform playback up to 200 MSa/s (vector models, Option 656/657)
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— external AM, FM, and ®M inputs (Option UNT)

— Wideband AM (vector models, Option UNT)

— flexible reference input, 1 = 50 MHz (Option 1ER)

— LO In/Out for phase coherency (Option 012)

— phase noise interference (vector models, Option 432)
— expanded license key upgradability (Option 099)

For more details on hardware, firmware, software, and documentation features and options, refer to
the data sheet shipped with the signal generator and available from the Keysight Technologies
website at http://www.keysight.com/find/X-Series_SG.

Modes of Operation

Depending on the model and installed options, the Keysight X-Series signal generator provides up
to four basic modes of operation: continuous wave (CW), swept signal, analog modulation, and
digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to
a single frequency and power level. Both the analog and vector models can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the
analog and vector models provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog
modulation types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used
together.

Option 303 provides a multifunction generator that consists of seven waveform generators.

Option UNW provides standard and narrow pulse modulation capability.
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Digital Modulation (Vector Models with Option 65x Only)

In this mode, the signal generator modulates a CW signal with an arbitrary I/Q waveform. I/Q
modulation is only available on vector models. An internal baseband generator (Option 65x) adds
the following digital modulation formats:

Custom Arb Waveform Generator mode can produce a single-modulated carrier or multiple—
modulated carriers. Each modulated carrier waveform must be calculated and generated before
it can be output; this signal generation occurs on the internal baseband generator. Once a
waveform has been created, it can be stored and recalled, which enables repeatable playback of
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 379.

Custom Real-Time Waveform Generator mode can produce a single-modulated carrier or
multiple-modulated carriers. Each modulated carrier waveform must be calculated and
generated before it can be output; this signal generation occurs on the internal baseband
generator. Once a waveform has been created, it can be stored and recalled, which enables
repeatable playback of test signals. To learn more, refer to “Using the Arbitrary Waveform
Generator” on page 379.

Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode,
the frequency spacing between the signals and the amplitudes are adjustable. To learn more,
refer to “Creating a Custom Multitone Waveform” on page 412.

Two-tone mode produces two separate continuous wave signals (or tones). The frequency
spacing between the signals and the amplitudes are adjustable. To learn more, refer to Chapter
17, “Multitone and Two-Tone Waveforms (Option 430).”.

Dual ARB mode is used to control the playback sequence of waveform segments that have been
written into the ARB memory located on the internal baseband generator. These waveforms can
be generated by the internal baseband generator using the Custom Arb Waveform Generator
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to
“Dual ARB Player” on page 187.
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Front Panel Overview

5. Arrows and Select 8. Trigger
4. Numeric 9. Local 7. MENUS 11. Preset and
Cancel/(Esc) User Preset
1. Host USB 2. Display Keypad
3. Softkeys
% gl 3G Veetor T MJfG y —
ﬂ!'ﬂ @
- it
=] 170w ustrgnts,
s B oo dmiams Patn
@5 S22 e I:nlnl
® 4
21. More and LED 18. Knob 16. I Input 12. RF Output

20. Return (vector (N5171B,

models only) N5172B,

N5181B,

. 15. Page 17. Q Input (vector | N5182B)

22. Power Switch and LEDs 19. Incr Set Down models only)
14. Mod On/Off and LED
13. RF On/Off and LED
1. Host USB

Connector Type A
USB Pratocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator. The
instrument also has a rear panel device USB connector (see page 14) used to remotely control the
instrument.

2. Display

The LCD screen provides information on the current function. Information can include status
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are
located on the right hand side of the display. See also, “Front Panel Display” on page 9.

3. Softkeys
A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the O through 9 hardkeys, a decimal point hardkey, a minus sign
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 41.
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h. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for
editing. See “Entering and Editing Numbers and Text” on page 41.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor”
on page 42. When text does not fit on one page in the display area, use this key in conjunction with
the Page Down key (page 7) to scroll text.

/7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access
information.

See page 159
See page 185

See page 70

See page 56

See page 43 s
ee page 68
AMPTD See page 25
See page 43
See page 46 See page 165
Active only on  See page 169 See page 62
vector models.
8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control,
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on
page 40.
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11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user-defined). See “Presetting
the Signal Generator” on page 40.

12. RF Output (N5171B, N5172B, N5181B, N5182B)

Connector Standard: female Type-N
Option TEM:  Rear panel output
Impedance: 50 Q

Damage Levels 50 Vdc, 2 W maximum RF power

12. RF Output (N5173B, N5183B)

Connector Option 513/520: male Precision APC-3.5
Option 532/540: male Precision 2.4 mm
Option TED Option  female Type-N
TEM: Rear panel output
Impedance: 50 Q

Damage Levels 0 Vdc, 0.5 W maximum RF power

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active
modulation format. This hardkey does not set up or activate a format (see “Modulating the Carrier
Signal” on page 54).

The MCD QN CFF LED lights when modulation of the output is enabled.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on
page 42. When text does not fit on one page in the display area, use this key in conjunction with the
Page Up key (page 6) to scroll text.

16. | Input (vector models only)

Connector Type: female BNC  Impedance: 50 Q
Signal An externally supplied analog, in-phase companent of 1/Q modulation.
The signal levelis [z, > = 0.5 Vi for a calibrated output level.

Damage Levels 1 Vg

See also, “I/Q Modulation” on page 245.
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17. Q Input (vector models only)

Connector Type: female BNC  Impedance: 50 Q
Signal An externally supplied analog, quadrature-phase component of I/Q modulation.
The signal levelis [, > = 0.5 Vyns for a calibrated output level.

Damage Levels 1V g

See also, “I/Q Modulation” on page 245.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit,
character, or item in a list. See also, “Front Panel Knob Resolution” on page 28.

19. Incr Set

This hardkey enables you to set the increment value of the currently active function. The increment
value also affects how much each turn of the knob changes an active function’s value, according to
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 28).

20. Return

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a Mor e
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow
LED lights and all signal generator functions deactivate. The signal generator remains connected to
the line power, and some power is consumed by some internal circuits. In the on position, the green
LED lights and the signal generator functions activate.
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4. Amplitude Area

Scroll Bar

If there is more
text than can be
displayed on one
screen, a scroll
bar appears here.
Use the Page Up
and Page Down
keys to scroll
through the text.

1. Active Function Area 2. Frequency Area 3. Annunciators
FREQUERCY AMPLITUDE
6.000 000 000 00 &z | -144.00 e
/
5. Error Message Area 6. Text Area 7. Softkey Label Area

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the
current frequency setting appears. If the currently active function has an increment value
associated with it, that value also appears.

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one annunciator; in this case, only

one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

DM Phase modulation is on. If you turn frequency modulation on, the FMannunciator replaces ®M

ARB The ARB generator is on. ARB is running and not waiting on a trigger.

ALC CFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED Asweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

AV Real Time I/Q Baseband additive white Gaussian noise is on.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DACannunciator turns off.
Anather annunciator, UNLOCK; appears in the same position and has priority over the BBG DACannunciator
(see UNLOCK, below).

CHANCCRR The internal channel correction is enabled.

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at
temperature.

D GBUS The digital bus is in use.
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This annunciator appears when...

D GVMD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of the
error messages or clear the error queue (see “Reading Error Messages” on page 68).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the @Mannunciator replaces FM

1/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or VXI-
11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MALLT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 108).

OFFS An output offset is set (see “Setting an Output Offset” on page 106).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remately controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local (see page 6).

REF An output reference is set (see “Setting an Output Reference” on page 107).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-11/Sackets (LAN)
interface.

SVEEEP The signal generator is currently sweeping in list or step mode.

SVWAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of

instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC CFF,
appears in the same position when the ALC circuit is disabled (see ALC CFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the
error messages (see “Reading Error Messages” on page 68).

WATRG The current modulation mode is waiting on the Arb trigger.

WN'T The signal generator is waiting for you to initiate a single sweep.

4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed
out).

5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent
message remains displayed. See “Reading Error Messages” on page 68.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other
information such as sweep lists and file catalogs. This area also enables you to perform functions
such as managing information (entering information, and displaying or deleting files).
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/. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of
the display. Softkey labels change, depending on the function selected.
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Rear Panel Overview (N5171B, N5172B, N5181B, & N5182B)

Digital Modulation Connectors (Vector Models 1. AC Power Receptacle

Only) on page 15
B VO  HOOOO®e - -
S 8a28 8583
CE= b

Option 1EM

only

Seepage7 2, EXT1&
EXT 2

6.TRIG1 &2 13. SD Card

8. 10 MHz OUT

5. PULSE 12. Host USB

4. SWEEP OUT 7.REFIN 11. Device USB

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, see the Getting

Started Guide.

To avoid the loss of data, GPIB settings, or current user instrument states that have not been
permanently saved to nonvolatile memory, the signal generator should always be powered down
either via the instrument’s front panel power button or the appropriate SCPI command. Signal
generators installed in rack systems and powered down with the system rack power switch rather
than the instrument’s front panel switch display a Error -310 due to the instrument not being
powered down correctly.
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2. EXT 1T & EXT 2

Connector female BNC Impedance nominally 50 Q
Signal An externally supplied £1 V, signal that produces the indicated depth.

Damage Levels 5V ysand 10V,

3. LF OUT
Connector  female BNC Impedance 50 Q
Signal Voltage range: 0 to +5 V,,

Offset: -5V to +5 V, nominal

For more information, see page 165.

4. SWEEP OUT
Connector ~ female BNC Impedance <1 Q
Can drive 2 kQ.
Signal Voltage range: 0 to +10 V, regardless of sweep width

In swept mode: beginning of sweep = 0 V; end of sweep =+10 V
In CW mode: no output

This is a multiple use connector. Far signal routing selections, see pages 47 and 169.

b. PULSE
Connector female BNC Impedance nominally 50 Q
Signal Externally supplied: +1 V =on; 0 V = off

Damage Levels <-0.3and >+5.3V

6. TRIG T & 2
Connector female BNC Impedance high Z
Signal An externally supplied TTL or CMQOS signal for triggering operations, such as paint to point in

manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels <-0.5and>+5.5V

/. REFIN
Connector  female BNC ~ Impedance nominally 50 Q
Signal An externally supplied —3.5 to +20 dBm signal from a timebase reference that is within £1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this
connector and automatically switch from internal to external reference operation. See “Presetting
the Signal Generator” on page 40. With Option TER (flexible reference input), you must explicitly
tell the signal generator the external reference frequency you wish to use; enter the information
through the front panel or over the remote interface.
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8. 10 MHz OUT

Connector  female BNC ~ Impedance nominally 50 Q
Signal A nominal signal level greater than 4 dBm.
9. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 10. LAN and
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this
connector, which enables a LAN-connected computer to remotely program the signal generator.
The LAN interface supports auto—-MDIX. The signal generator is limited to 100 meters on a single
cable (100Base-T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Connector Type B
USB Protocol ~ Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.

12. Host USB

Connector Type A
USB Protocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator.

13. SD Card

Holds the Secure Digital (SD) nonvolatile memory card.
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Digital Modulation Connectors (Vector Models Only)

| OUT, Q OUT, 1 OUT, @ OUT

m i OUT and @ OUT, require Option 1EL.

Connector

Signal
| OUT
Q OuT

1 OUT
QOuT
Damage Levels

Type: female BNC  Impedance: 50 Q
DC-coupled

The analog, in-phase component of I/Q modulation from the internal baseband generator.
The analog, quadrature-phase component of 1/Q modulation from the internal baseband
generator.

Used in conjunction with the | OUT connector to provide a balanced® baseband stimulus.

Used in conjunction with the Q OUT connector to provide a balanced® baseband stimulus.

> 1Vrms DC Origin typically <10 mV
Offset

QOutput Signal Levels into a 50 € Load

— 0.5V, typical, corresponds to one unit length of the I/Q vector

— 0.69 Vi (2.84 dB), typical, maximum crest factor for peaks for n/4 DQPSK,
alpha=0.5

— 0.71 Vy, (3.08 dB), typical, maximum crest factor for peaks for n/4 DQPSK,
alpha =0.35

— Typically 1 Vp_p maximum

a. Balanced signals are signals present in two separate conductors that are symmetrical relative
to ground, and are opposite in polarity (180 degrees out of phase).

BB TRIG T & BB TRIG 2

Connector
Signal

EVENT T

Connector
Signal

Damage Levels

female BNC Impedance nominally 50 Q
Reserved for arbitrary and real-time baseband generators I/0, such as markers or trigger inputs.

female BNC  Impedance: nominally 50 Q

A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.
Adjustable to + one timeslot; resolution = one bit

Markers

Each Arb-based waveform point has a marker on/off condition associated with it.

Marker 1 level = +3.3 V CMOS high (positive polarity selected); -3.3 V CMOS low (negative
polarity selected).

Output on this connector occurs whenever Marker 1 is on in an Arb-based waveform (see
“Using Waveform Markers” on page 203).

<=4and>+8V
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PAT TRIG
Connector female BNC
Signal ATTL/CMOS low to TTL/CMQS high, or TTL/CMOS high to TTL/CMOS low edge trigger.

The input to this connector triggers the internal digital modulation pattern generator to start a

single pattern output or to stop and re-synchronize a pattern that is being continuously output.

To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled

during the falling edge of the internal data bit clock.

This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse  (high or low) =10 ns

Width

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods
Damage Levels  <—4and > +8V

DIGITAL BUS 170

This is a proprietary bus used by Keysight Technologies signal creation software. This connector is
not operational for general purpose use. Signals are present only when a signal creation software
option is installed (for details, refer to http://www.keysight.com/find/signalcreation).

The X-Series’ Digital BUS 1/0 connector can be used for enabling
operation with the Keysight Technologies N5106A PXB MIMO Receiver
Tester.
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AUX I/0 Connector

This female 36-pin connector is available only on instruments with an internal baseband generator
(Option 653, 655, 656, 657). On signal generators without one of these options, this connector is
not present.

The AUX 170 connector allows the X-Series signal generator to interface with external equipment
by sending and/or receiving supplementary (auxiliary) signaling information. This information is
non-RF related signaling such as:

— output markers to an external device from Arbitrary waveform playback sent to external
equipment to trigger or respond to waveform changes.

— output of signal markers to an external device from real-time signal generation personalities.
Signals such as frame markers, pulse-per-second, and even-second, for example, may be
supported, depending on the signal generation personality (CDMA, 3GPP, GNSS, LTE, etc.).

— input signals from external devices under test to cause the signal generator to modify
characteristics of a signal being generated, depending on the signal generation personality
(CDMA, 3GPP, LTE, etc.).

Table 1-1 on page 19 describes the inputs and outputs accessible through the AUX I/0 connector.
The specific functions controllable by auxiliary signaling vary significantly from one real-time signal
generation personality to another. Refer to the documentation for each real-time signal generation
personality for additional information.

18 1
C: View looking into the rear panel ::)
36 19

18 17 16 15 14 13 12 11 10
W el W W W W = .

B e AR aes s AW A

e

36 35

The AUX I/0 connector is a shielded .050 series

The AUX I/0 mating connector manufacturer’s part number is
3M® 10136-3000 (wire mount plug).

NOTE The AUX I/0 connector supports standard 3.3V TTL signaling levels.
Signals support data rates up to 50 MHz with minimum rise and fall times

of 3ns. Any pins that are not connected will have a weak pull-up to 3.3V.

Keysight EXG and MXG X-Series Signal Generators User’s Guide 17



Signal Generator Overview
Rear Panel Overview (N5171B, N5172B, N51818B, & N5182B)

Markers (pins 1-4)

Each Arb—based waveform point has a marker on/off condition associated with it.

Each real-time signal can be routed to the output marker signals using SCPI commands or the real-time personalities.
Marker level = +3.3 V high (positive polarity selected); OV low (negative polarity selected).

Event 1 (pin 1)
Pin 1 outputs a pulse that can be used to trigger the start of a data pattern, frame, or timeslot.
Adjustable to + one timeslot; resolution = one bit

Data Clock Out (pin 7)

Pin 7 is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data.

Data In (pin 23)

Pin 23 accepts an externally supplied CMOS-compatible signal data input used with digital modulation applications. The
expected input is a CMOS signal where a CMOS high is equivalent to a data 1 and a CMOS low is equivalent to a data 0.

The maximum input data rate is 50 Mb/s. The data must be valid on the DATA CLOCK
falling edges.

Symbol Sync In (pin 25)

Pin 25 accepts an externally supplied symbol sync signal for use with digital modulation applications.

Data Clock In (pin 29)

Pin 29 accepts an externally supplied CMOS-compatible signal data-clock input used with digital modulation applications.
The expected input is a MCOS bit clock signal where the rising edge is aligned with the beginning data bit. The falling edge
is used to clock the DATA and SYMBOL SYNC signals.

The maximum clock rate is 50 MHz.

Event 2 (pin 31)
Pin 31 outputs data enable signal for gating external equipment. The output is applicable when the external data is clocked
into internally generated timeslots. Data is enabled when the signal is low.

18 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Signal Generator Overview
Rear Panel Overview (N5171B, N5172B, N5181B, & N5182B)

Table 1-1 AUX I/0 Connector Configuration
MXG and EXG AUX I/0 Connector Configuration
ARB & ARB-Based Real-Time Custom Real-Time BERT Capability
Applications Modulation Applications

Pin# | Input Output Input Output Input Output Input Output

1 Marker(1) Event 1 Marker(1)

2 Marker(2) Marker(2)

3 Marker(3) Marker(3)

4 Marker(4) Marker(4)

5

6 AUX

Strobe
7 Data 10MHz
Clock Clock
Output

8 AUX(0)

9 AUX(1)

10 AUX(2)

1 AUX(3)

12 AUX(4)

13 AUX(5)

14 AUX(6B) AUX1/0

15 AUX(7) BER Meas
End?

16 AUX(8) BER Sync
Loss?

17 AUX(9) BER Test
Out?

18 AUX(10) BER Gate
Out?

19 AUX(11) BER No
Data®

20 GND GND GND GND GND GND

21 AUX(12)

Keysight EXG and MXG X-Series Signal Generators User’s Guide 19



Signal Generator Overview
Rear Panel Overview (N5171B, N5172B, N51818B, & N5182B)

Table 1-1 AUX 1/0 Connector Configuration
MXG and EXG AUX 1/0 Connector Configuration
ARB & ARB-Based Real-Time Custom Real-Time BERT Capability
Applications Modulation Applications
Pin# | Input Output Input Output Input Output Input Output
22 GND GND GND GND GND GND
23 Data AUX(13)
Input
24 GND GND GND GND GND GND
25 Symbol AUX(14)
Sync
Input
26 GND GND GND GND GND GND
27 Burst AUX(15)
Input
28 GND GND GND GND GND GND
29 Data AUX
Clock Sample
Input Clock
30 GND GND GND GND GND GND
31 Event 2
32 GND GND GND GND GND GND
33 Data Out AUX
Qut(1)
34 GND GND GND GND GND GND
35 Symbol AUX
Sync Out(2)
Output
36 GND GND GND GND GND GND

a. Settings shown are for the Error Out signal configuration of the AUX /0 connector (BERT > 1/0
Setup > Aux I/0 Out). Press the Help hardkey, then either Reference Out or PN9 Out for the
respective signal configuration.

20 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Signal Generator Overview
Rear Panel Overview (N5173B & N5183B)

Rear Panel Overview (N5173B & N5183B)

14. ALC INPUT

15. Z AXIS OUTPUT
OOOO® ;
o00e®
OOOe®
MO o SO®e .

ML L] Bl
© e [C €T
WP OUT mm. out i

no-o

1. AC Power Receptacle

Oorﬁ;ion 1EM 3.LFOuT 6. TRIG 1 &2 8. 10'MHz OUT 13. SD Card
Seepage7  2.EXT1&EXT2 5. PULSE 7.REFIN - 1S.S:ost usB
. Device

4. SWEEP OUT

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, see the Getting

Started Guide.

To avoid the loss of data, GPIB settings, or current user instrument states
that have not been permanently saved to nonvolatile memory, the signal
generator should always be powered down either via the instrument’s
front panel power button or the appropriate SCPI command. Signal
generators installed in rack systems and powered down with the system
rack power switch rather than the instrument’s front panel switch display a
Error -310 due to the instrument not being powered down correctly.
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Signal Generator Overview
Rear Panel Overview (N5173B & N5183B)

2. EXT 1T & EXT 2

Connector female BNC Impedance nominally 50 Q
Signal An externally supplied £1 V, signal that produces the indicated depth.

Damage Levels 5V ysand 10V,

3. LF OUT
Connector  female BNC Impedance 50 Q
Signal Voltage range: 0 to +5 V,,

Offset: -5 V to +5 V, nominal
For more information, see page <PagenumOnlyCallout>165.

4. SWEEP OUT
Connector ~ female BNC Impedance <1 Q
Can drive 2 kQ.
Signal Voltage range: 0 to +10V, regardless of sweep width

In swept mode: beginning of sweep = 0 V; end of sweep =+10V
In CW mode: no output

This is a multiple use connector. Far signal routing selections, see pages 47 and 169.

b. PULSE
Connector female BNC Impedance nominally 50 Q
Signal Externally supplied: +1 V =on; 0 V = off

Damage Levels <-0.3and >+5.3V

6. TRIG T & 2
Connector female BNC Impedance high Z
Signal An externally supplied TTL or CMQOS signal for triggering operations, such as paint to point in

manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels <-0.5and>+5.5V

/. REFIN
Connector  female BNC ~ Impedance nominally 50 Q
Signal An externally supplied —3.5 to +20 dBm signal from a timebase reference that is within £1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this
connector and automatically switch from internal to external reference operation. See “Presetting
the Signal Generator” on page 40. With Option TER (flexible reference input), you must explicitly
tell the signal generator the external reference frequency you wish to use; enter the information
through the front panel or over the remote interface.
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Signal Generator Overview
Rear Panel Overview (N5173B & N5183B)

8. 10 MHz OUT

Connector  female BNC ~ Impedance nominally 50 Q
Signal A nominal signal level greater than 4 dBm.
9. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 10. LAN and
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this
connector, which enables a LAN-connected computer to remotely program the signal generator.
The LAN interface supports auto—-MDIX. The signal generator is limited to 100 meters on a single
cable (100Base-T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Connector Type B
USB Protocol ~ Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.

12. Host USB

Connector Type A
USB Protocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator.

13. SD Card

Holds the Secure Digital (SD) nonvolatile memory card.

14. ALC INPUT

This input connector is used for negative external detector leveling.

Connector female BNC  Impedance nominally 100 kQ
Signal -0.2mVto-05V
Damage Levels -12to 1V
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Signal Generator Overview
Rear Panel Overview (N5173B & N5183B)

15. Z AXIS OUTPUT

This female BNC connector supplies a +5 V (nominal) level during retrace and band-switch intervals
of a step or list sweep. During step or list sweep, this female BNC connector supplies a -5V
(nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on.
This signal is derived from an operational amplifier output so the load impedance should be greater
than or equal to 5 kohms.T

Connector  female BNC  Impedance nominally 50 ©
Signal A nominal signal level greater than 4 dBm.
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Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

2 Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus
in which you can enable instrument options.

Remote Operation Preferences

GPIB Address and Remote Language on page 31

Configuring the LAN Interface on page 32

Enabling LAN Services: “Browser,” “Sockets,” and “VXI-11” on page 32
Configuring the Remote Languages on page 33

1

Utility
I/0 ConfigM User Preferences
Front Panel Knob Resolution on page 28
Instrument.,
B SETETES Setting Time and Date on page 29
Displagh\REference Oscillator Tune on page 30
Pouer On/,| Display Settings on page 27
Freset

Power On and Preset on page 28
Instrument. InfoM

//

L L (e 5 Enabling an Option on page 37
Upgrading Firmware on page 31
Utility
Services———Hardware Assembly Installation and Removal Softkeys on page 38

KEYSIGHT

TECHNOLOGIES
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Preferences & Enabling Options
User Preferences

User Preferences

From the Utility menu, you can set the following user preferences:
— Display Settings, below

— Power On and Preset on page 28

— Front Panel Knob Resolution on page 28
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Display Settings

Preferences & Enabling Options

User Preferences

See also, Using Secure Display (Option 006) on page 438.

Display
Brightness-—”//
75.0 %

Utility > Display Range: 0 to 100

Screen Saver
| Of ]

Screen Saver
ode 1
(Light & Text)

Screen Saver prevent the text from burning the display.

Oelau: 1 hr

Range: 1 to 12 hours, in 1 hour increments

Display
Select EDlEr

=)
(Bright Color)

P — /When on, commands executed through
poats mane the remote control bus update the signal
generator display accordingly.

Activate,
Secure Display \page 438

Activate
Restrictede
Display

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to

Palette Select

Bright Color

Dark Color

Monochrome

Light Only: turns the display light off, leaving the text visible at a low intensity.

Dark text on a light
background.

Light text on a dark
background.

Bright without color

For details on each key, use key help
as described on page 40.

X-Series signal generators are shipped from the factory with default
display settings. Automated Test Environment (ATE) users may benefit
from display settings other than the default settings. When the signal
generator display is not required to be active for long periods of time,
consider using the Screen Saver Mode to extend the life of the display.

With the brightness set to minimum, the display may be too dark to see
the softkeys. If this happens, use the figure above to locate the brightness
softkey and adjust the value so that you can see the display.

Keysight EXG and MXG X-Series Signal Generators User’s Guide
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Preferences & Enabling Options
User Preferences

Power On and Preset

Pouerup Tupe

Utility > Power On/Preset “Pouer On/Preset | Last
Fower 0On >
(Preseti™ = Preset

Preset. Language,
(SCPI

User

Restore Sustem
ings toe
Default Values

Select the GPIB language desired after a preset.

) ) See also, the Programming Guide and the SCPI Command
Restores persistent settings Reference.

(those unaffected by a power
cycle*, preset, or recall)
to their factory defaults.

Available only when 8648 is either the selected preset language or
the selected remote language (see page 31).

Restore Sustem

Confirm Restore
Sus Settimgs to
Default Values

*Caution

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to
nonvolatile memory, the X-Series signal generator should always be powered down either via the instrument’s front
panel power button or the appropriate SCPI command. X-Series signal generators installed in rack systems and
powered down with the system rack power switch rather than the instrument’s front panel switch display a Error -310
due to the instrument not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.

Front Panel Knob Resolution

;":t' —— Makes the increment value of the current function the active entry.

Utility >
Instrument Adjustments . . .
The increment value and the step/knob ratio determine how much each

turn of the knob changes the active function value.

RUSINents For example, if the increment value of the active function is 10 dB and the
SEERYTED LA step/knob ratio is 50 to 1, each turn of the knob changes the active
\ function by 0.2 dB (1/50th of 10 dB).
Time,/Dater— P29¢ 29-
- 20 To change the amount for each turn of the knob, modify the increment
R o page sU. value, the step/knob ratio, or both.
0
ALE [ Exﬁcgte | Executes the ALC Modulator Bias Adjustment. When using

Bias ﬂd?ugtﬁeﬁg the ALC in open loop mode, this compensates for open loop

power drift due to temperature and humidity.

‘SCPllélorlnm'andsi | § For details on each key, use key help
Hore 1 of 2 :CALibration:ALC:MODulator:BIAS as described on page 40.
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Preferences & Enabling Options
User Preferences

Setting Time and Date
The signal generator’s firmware tracks the time and date, and uses the latest time and date as its
time/date reference point.

Changing the time or date can adversely affect the signal generator’s ability to use

time.

— based licenses, even if a time based license is not installed.

Figure 2-1
=S PN
Time Date
Time/Dater Time/Date
Utility > Off
Instrument Adjustments Ref Oscillator
Date Format
> "B ™ Oty
ALC Ex?cgte
Odu Lator i
Bigs Adjustment SR T3
Set Date
More 1 of 2

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time-based
licenses, and that you are resetting the signal generator’s time/date reference point. \When you
set a new time or date that is later than the signal generator’s current reference point, that date
becomes the new reference point. If you then set the date back, you run the risk described in the
next section.

Original time/date reference point New time/date reference point

4 o

Time

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the
reference point. If you set the time back more than a few hours, you disable the signal generator’s
ability to use time-based licenses, even if there is no license installed at the time that you set the
time back. In this case, you can re-enable the signal generator’s ability to use time-based licenses
by moving the clock forward to the original time or simply waiting that length of time.
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User Preferences

Reference Oscillator Tune

Utility > Instrument Adjustments

Adjustments
Step/Knob Ratio
50/1

Tunes the internal VCTXCO oscillator frequency.

The user value offsets the factory tuned value (the value is added to the
factory calibrated DAC value). The tune value of 0 sets the factory

Time/Dater calibrated value.
Ref Decillgtor The range; -8192 to 8192, can be set by using the front panel keypad,
nob or remote command.

Execute
ALC Modulator
Bigs Adjustment

For details on each key, use key help See also the SCPI Command Reference.
as described on page 40.

fore 1 of 2
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Upgrading Firmware

Preferences & Enabling Options
Upgrading Firmware

For information on new firmware releases, go to http://www.keysight.com/find/upgradeassistant.

Remote Operation Preferences

For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

@

NOTES

USB is also available. It is not shown in the menu because it requires no configuration.
For details on using the instrument remotely, see the Programming Guide.

Utility T/0 Confio GPIB Setup
GPIB Address
I/0 Confio GPIB Setuprf—— 13
BTty LAN Setups page 32
Displas Lan Seryicee, | page 32
Power on/, FRemote Lanouage, Select the desired language.
Freset (5CPI)

Instrument Infok

fore 1 of 2

SCPI Log/Helpw

\

i

This setting is not persistent and is cleared by performing an
instrument Preset. In most cases, it is best to use Utility > Power
On/Preset > Language for a permanent language change. See
page 33.

SCPL Log/Nelp
SCPI Looain
OfFf

Display SCPI Log

Clear SCPI Log

SCPT Hel
OFF NN

Select On to place a copy of every subsequent SCPI command
executed in the log.

Select Off to stop logging. Selecting Off does not clear the log.
Press the Clear SCPI Log softkey to clear the log.

Select On to view the associated SCPI command for a key press.

For details on each key, use key help as described on page 40.
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Configuring the LAN Interface

Manual Settings
IF Address
0.0.0.0

Subnet. Mask
0.0.0.0

Default Gatewsy
0.0.0.0

ONS Serwver

Domain Mame
p SOCO.@3ilent.com

Utility > 1/0 Config —® [ LAH Config

— LAH Setup Auto
— (DHCP/Auto-IP)

i osthame

170 Confin A-N51826-00021
GPIE Setupe Manua1

Config Tupe,

CAULO)

LAN Setupk )
Manual Configy,
page 32. Settings
LAN Services, )
SRR Advanced
Settings”™
Remote Language,
teEPm) Proceed With
Reconf iourat ion
SCPI Loo/Helpe
Y
Adv Settings
—_— Dunamic ONS
Confirm Off

Confirm Change
(Network Will
restart)

NOTES
Use a 100Base—T LAN cable to connect the
signal generator to the LAN.

Use a crossover cable to connect the signal
generator directly to a PC.

For details on using the instrument remotely,
refer to the Programming Guide and to
www.keysight.com and search on FAQs:
Hardware Configurations and Installation for the
Keysight MXG.

mokS /OMNS=50
0ff HGN

Confirm

Restore LAN
Settings toe
Default Values

Confirm Restore
LAN Settimgs to
Default Values

Values are listed in the
Programming Guide

For details on each key,

use key help as described on page 40.

Enabling LAN Services: “Browser,” “Sockets,” and “VXI-11"

Utility > 1/0 Config
LAH Services

1/0 Config FTP Server
0ff iGN
GPIE Setupe

Enable remote (browser)
access to the
instrument’s file system.

Heb Services

Heb Serwer
off

Heb Servicese
LAN Setupe

LAN Services,
Setup

Remote Language,
(SCPI)

Proceed Hith

Reconf iourat ion

SCPI Loo/Helpe

SCPI Servicessf—P

\/

SCPI Services

License Manager

Use a browser to control
[—the signal generator.

License Manager Server (On)

Server 1
Sockets SCRI aff allows updates of the
OfFf instrument licenses, disable
—— for additional instrument
0FF security.
Confirm
Confirm Chanoe
. (Instrument

For details on each key, use key help
as described on page 40.

32

Will Reboot)

For more information refer to
the Programming Guide.
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Configuring the Remote Languages

Figure 2-2

Utility > 1/0 Config

N5171B/72B/81B/82B

Select the desired Remote language.

Preferences & Enabling Options
Remote Operation Preferences

I/0 Confio Remote Language
GPIE Setuprk SCPT
LAN Setupe MN5181A ,N5182A

LAW Services
Setup® ELL28C ,ELL380

Femote Language ES2570,ES2670
(SCFIY™ ESERE

ES2L7C ,EB257C
SCPI Loo/Helpe e

fore 1 of 3

For details on each key, use key help
as described on page 40.

Remote Language

ES2L 1A ,E82LLA
EB251A ,EB25LA

ELL2%E ,ELLExE

86L3A/B/C/D
(GPIE onlu)

8BSER ,8657A /B
(GPIE onlul

8bb2A
(GPIE onlu)

fore 2 of 3 =

Remote Language

8BE3A
(GPIE onlu)

Fohde & Schuarze—

Aerof lexe

fore 3 of 3

Refer to the SCPI Command Reference.

Keysight EXG and MXG X-Series Signal Generators User’s Guide

Remote Language

L

Remote Language
SHUZ00A
SHATEZ00A
SMJ100A
SHIO

SHL

Sy

fore 1 of 2

SME100A
SHEV100A

Remote Language

3410 Series
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Preferences & Enabling Options
Remote Operation Preferences

Figure 2-3 N5173B/83B
Utility > 1/0 Config Select the desired Remote language.

I/0 Config Remote Lanouage Remote Lanouage Remote Language | Remote Lanouage

GPIE Setupk SCPT 8350 Series HPEEKHN— T
[ [ | [
LAN Setupb NS151A NS122A B3711B,837128 R - cHzEn
H ; ohde & Schiarze (GPIE onlu)
LAN Seryices, ELL2EC , ELL3EC 53731B,537328 Anritsu ME3EIEM BELLA
Remote Language, E8257D,E82670 83751B,837528 BEELA
ES2L7C ,EB257C 8340B,530418

SCPI Loa/Helpk EaSRiE PR o) BEESA/B

lore 1 of 3 lore 2 of 3 More 3 of 3

Remote Language

For details on each key, use key help as described on page 40. ’ | SR

SMJ100A

SME100A
SHEV100A

SHMF100A

Remote Language

NMG3E318
— (GPIE onlu)

NMG3E928
(GPIE onlu)
NMG3E958
(GPIE onlu)

Refer to the SCPI Command Reference. ME3E5LE
(GPIE onlu)
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Configuring the Preset Languages

Figure 2-4

Utility > Power On/Preset

N5171B/72B/81B/82B

Select the desired Remote language.

Pouer On/Preset

Poder O,
(Preset.)

Preset. Languace, |
(SCPI

Festore Sustem \
Settings toe
Default Values f' |

Preset Language

SCPI
NS181A ,M5182A
ELLZ2BC ,ELL33C
cws Eel

EB2L7C ,EB257C
ES267C

fore 1 of 3 _ |

For details on each key, use key help

as described on page 40.

Preset Language

ES2L 1A ,E82LLA
EB251A ,EB25LA

ELL2%E ,ELLExE

86L3A/B/C/D
(GPIE onlu)

8BSER ,8657A /B
(GPIE onlul

8bb2A
(GPIE onlu)

fore 2 of 3 _

Preset Language

8BE3A
(GPIE onlu)

Fohde & Schuarzy

Aerof lexk

Preset Language

SHUZ00R
SHATE200R

SMJ100A

Refer to the SCPI Command Reference.

Keysight EXG and MXG X-Series Signal Generators User’s Guide

SMI0

SHL

Sy

fore 1 of 2

Preset Language

SME100A
SHEV100A

p» Preset Language

3410 Series

Preferences & Enabling Options
Remote Operation Preferences

35



Preferences & Enabling Options
Remote Operation Preferences

Figure 2-5

Utility > Power On/Preset

N5173B/83B

Select the desired Remote language.

Pouer On/Preset

Poder O,
(Preset.)

Preset. Languace, |
(SCPI

Festore Sustem \
ettings tok
Default values ' |

\
page 28

For details on each key, use key help as described on page 40.

36

| Preset Lanouage

SCPI
NS181A ,M5182A
ELLZ2BC ,ELL33C
cws Eel

EB2L7C ,EB257C
ES267C

fore 1 of 3 — |

Preset Language

8360 Series

837118 ,83712E

837318 ,83732B

837518 ,83752E

83L0E ,8341B
(GPIE onlul

fore 2 of 3 |

Preset Language

HPEEXKMH

e

[ Preset Lanouage

8bb2A
(GPIE onlu)

Fohde & Schuarzw

8BE3A
(GPIE onlu)

Anritsu MG3E9xEr

Refer to the SCPI Command Reference.
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SBELA

8BREA/B

| Preset Language

.

SHR

SMJ100A

SME100A
SHEV100A

SHMF100A

| Preset Lanouage

—

NMG3E318
(GPIE onlu)

NMG3E928
(GPIE onlu)

NMG3E958
(GPIE onlu)

NMG3E34E
(GPIE onlu)




Preferences & Enabling Options
Enabling an Option

Enabling an Option

There are two ways to enable an option:

— Use the License Manager software utility:
1. Run the utility and follow the prompts.

2. Download the utility from www.keysight.com/find/LicenseManager and select license (.lic)
files from an external USB Flash Drive (UFD).

— Use SCPI commands, as described in the Programming Guide.

Viewing Options and Licenses

Utility > Instrument Info Options Info
Instrument Info — 5
Dimgnostic Infoe nsuggggﬂsb
; Auxiliary >
TEEAENS JAnieD » coftuare Options® fAux Softuare Licenses
Self Tests iy
Inetalled Service Software Licenses
Board Info” appear here.

Front. Panel Testse

Haveform License: 03/09/2012 1L
Have ID Days Left Description

Waveform licenses from some

Instrument options appear Signal Studio applications appear here.
here. A check mark means that
an option is enabled.

\ 03/09/2012 14:31

A

Instrument. Options ) o
Option Expiratipn Description
c Digitsl output coonectivity pith the o102 B

ooy permanent) + Digital input connectivity with the N51026

0o& permanent) + Security and removable memory card

oo9 permanent. \ + Internal solid state memory

012 permanent. \ + LO infout for phase coherencd

021 permanent \ v Upgrade BEG memory from 32 Msa to 256 HMsa

02z permanent \+ Upgrade BEG memory from 32 Msa to 512 Hsa

023 permanent  + Uparade BEG memory from 32 Msa to 1 Gsa

039 permanent  + Ewpanded license ked upgradability For details on each key, use key help
1EA permanent ¥ Hioh pouer output

as described on page 40.

03/09/2012 14:29
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Preferences & Enabling Options
Hardware Assembly Installation and Removal Softkeys

Hardware Assembly Installation and Removal Softkeys

For details on each key, use key help

Ut|[|ty > More 2 Of 2 > as described on page 40.
Service
Remove Assembluw > Assy p Confirm Removal
Prepare Confirm Removal
CPU Assembly of CPU Assembl
Install Assemblu For Remoual -
Frepare
Verify output attenuator BF ﬂsseﬁblg Heﬁgggi
Paower Yerifumsl—operation using a power For Remowal Prepare
meter at the RF Output. EBG Assembly .
For Remoual | Whetherasoftkey is
1/ IESPEQEETSA’ | available depends on
Calibrations U gEESﬁEES the model of signal
For Bemoval generator.
Tht Chan Corr — | Install Assy Confirm Install
Finalize Confirm
Enhanced Factory — CPU Assembly > Installation
Calibration Installation of CPU Assemblu
Finalize abort
Factory RF Assembly
Calibration Installation - - Ui A2
Finalize
| BEG Assemblu
Installation = Whether a softkey
Finali is available depends
Select either Enhanced Factory MU Reconbigs| ©on the model of signal
Calibration or Factory Calibration Installation | generator.
to calibrate your instrument.
The Enhanced Factory
Calibratiqn requjres a spectrum » Confirm Install |
analyzer in addition to a power —— _
meter. Poer fieter?|——® Pl Conflo
Connection
The Factory Calibration uses only Settings
& power meter. Power Meter
Channel
B

onfirm
Installatdon
of RF AsSEmoIu
Zero Sensor
Abort.
Installation
Calibrate Sensor
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Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

3  Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation,
refer to the Programming Guide.

— Presetting the Signal Generator on page 40

— Viewing Key Descriptions on page 40

— Entering and Editing Numbers and Text on page 41

— Setting Frequency and Power (Amplitude) on page 43
— Setting ALC Bandwidth Control on page 45

— Configuring a Swept Output on page 46

— Modulating the Carrier Signal on page 54

— Working with Files on page 56

— Reading Error Messages on page 68

KEYSIGHT

TECHNOLOGIES
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Basic Operation
Presetting the Signal Generator

Presetting the Signal Generator

To return the signal generator to a known state, press either Preset or User Preset.

Preset is the factory preset; User Preset is a custom preset** (see also, page 28).

To reset persistent settings (those unaffected by preset, user preset, or power cycle*),
press: Utility > Power On/Preset > Restore System Defaults.

*Caution

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to nonvolatile memory,
the instrument should always be powered down either via the instrument's front panel power button or the appropriate SCPI command.
instrument's installed in rack systems and powered down with the system rack power switch rather than the instrument's front panel
switch display a Error -310 due to the instrument not being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-9 on page 66).

Viewing Key Descriptions

."' The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key.
The help displays and the key’s normal function does not execute.
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Basic Operation
Entering and Editing Numbers and Text

Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Use the number keys and decimal point to enter numeric data.
Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

Lacal

Page Page up/down keys move tables of data up and down within the display area.
p

a

- Left/right arrow keys move the cursor horizontally.

Use the Select hardkey to choose part of an entry, as when entering alpha
Page characters. In some menus, the Select key also acts as a terminator, and is
Down equivalent to the Enter softkey.

DO E
o

OO0

To specify a negative value, enter the
negative sign either before or after
the numeric value (this key is a toggle).

Backspace moves the cursor to the left, Note: Rotating the knob increases or
deleting characters as it goes. decreases a numeric value, changes a
highlighted digit or character, or steps
through lists or items in a row.

OOo00
BN

a0

S

See also “Front Panel Knob Resolution” on page 28.
For details on each key, see page 40.

E nte ri N g Alp h a C h aracters Note: File names are limited to 25 characters.

Data entry softkeys appear in various IERAE

menus. If their meaning is not clear in Enter
context, use the help key (described on

Clear Text
page 40) to display an explanation. Use the
softkey next to the alpha table for help on S Aolnc
the table. Show mDB?FT to move the cursor
Selecting data that accepts alpha BCOEF BHEIEL Fether thar withn he.
characters, displays one of the menus NOPORS TUulik¥2 | 50 L e
shown at I’Ig ht. - Add/edit comments for saved

instrument state files (see page 62).

Use the arrow keys or knob to highlight the
desired letter, then press the Select
hardkey (or the softkey next to the alpha table). To correct errors, use Bk Sp or Clear Text.

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the
letters A through F (use the numeric keypad for other values).
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Basic Operation
Entering and Editing Numbers and Text

Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.
2. Open the table editor: Press Sweep > More > Configure List Sweep.
The signal generator displays the editor shown in the following figure.

Active Function Area Cursor
Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable)
item, either press Select, or simply enter the desired value.

List Table
Edit Item
List Hode Ualues
Po 1711 Frequency  Pouer Haveform pell
1 =1L, 00(-- CH ¢no modulation) 2.000 ms
2| ©.00000000000 GHz|-1uk.00|-- CH (no modulation) Z.000 ms Insert Row
3 B[, 00000000000 GHz —— CH (no modulation) 2.000 ms
L (. 000000000 GHz —— CH (nq modulation? /E.DDD ms
9| Bl 000000000OMINGHZ —— CH (ng modulat ion) 2.000 Delete Row
6| B.00000000000 GNz -— CH (mo modulat ion) 2.000
7 B[, 00000000000 GH —— CH (o modulation?) 2.000
8 B[, 00000000000 GHz 2.000
9| Bl.0000D0DO00OD GHz (vector models of 2.000 /ms Goto Rowe
10| & 00000000000 GHz 2.000/ ms
/ /1 Hore 1 of 2
Table Editor Name Table Items Table Editor Softkeys Indicates that
Table items are also Used to load, navigate, modify, and another menu
called data fields. store table item values. For details

Current / Total Number of Pages is available; to

on each key, use the key help:

display the
tF;]rezs tr_le (Ii-klzlp hardkey and then second menu,
e desired key. press More.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor.
4. (Optional) Display the selected item in the active function area: Press Select.
5. Modify the value:

— If the value is displayed in the active function area, use the knob, arrow keys, or numeric
keypad to modify the value.

— If the value is not displayed in the active function area, use the numeric keypad to enter the
desired value (which then appears in the active function area).

6. Terminate the entry:

— If available, press the desired units.
— If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.
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Basic Operation
Setting Frequency and Power (Amplitude)

Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

.

In Frequency mode, this menu is

<_automatically displayed when entering
a numeric value with the front panel

In Amplitude mode, this menu is
automatically displayed when entering
a numeric value with the front panel

keypad. ¢ keypad.
- O dBuVemf terminates
Frequency requency Units Anplitude Pouer Units the value as dBuV
Freg Fef Set GHz attensaLc,| Opens the electromotive force.
000 Hz Control —Atten/ALC 58 | Emfis the output
Control L
P menu. vol_tage_thh no load.
on |page 106 MHz s dgewv |\ This unit is external
only. Internal
Freq Offset KkHz representation as well
0.00 Hz dBuifemf | | a5 increment and
- decrement values are
Freq ”Ul%}gééez Hz i in dBm.
Note: dBuV, mV, and
Freq ChannelsH— | Freq Channels Leveling, Tiemf nVemf behave similarly
e — Liaial (i.e. Values are external
_ fore 1 of 2 | on Hore 1 of 3 only. Internal
representation as well
Channel Humber as increment and
i AneLitude decrement values are
Frequency ) in dBm).
, eume Amptd Ref Set
Phase Ref Set MS 0.00 dBm
Channel Band, amptd Fef This softkey sets a user determined
RdJHSBDEhasg (P-G5M Base) &' On maximum power level on the
. ra instrument that is persistent.
: Amptd Offset
Reference, Sets the current relative 0.00 de _ Available on vector
Dscillator*fpage 44 phase of the RF output Amplitude dels with BBG
signal as the zero modets with :
Improve f User FlatnessM—page 82 User Power Maxe Enables the instrument
non—tarenics relerence. to select between two
L All subsequent i power levels with a
adjustments are relative Output Blankin Alternate
justmer A | Amp1itode®] hardware marker or
to this adjustment. .
Hore 2 of 2 using an external BNC.
fore 2 of 2 ALC Bl

[ page 45

| Available on
vector models.

nables the mode to improve non-harmonics performance (low spurs mode).

Note: When this mode is enabled, the instrument switching speed and behavior of
the source’s settled signal are affected.

Poueﬁoggg’ — Pouer Opt Nodes

To display the next menu, press More. Hore 3 of 3

Enables the optimize signal-to-noise ratio state (Optimize S/N) On or Off. Opt.imize
The optimize signal-to—noise softkey changes the attenuator and alc setting to provide ”éﬁs

optimal signal-to—noise performance; it does not change the RF output power.
Caution: When the optimize signal-to-noise ratio state is enabled, some increased levels of |
harmonic distortion can occur. This increased harmonic distortion could degrade ACPR and
EVM.

Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation
type. A settings conflict error will be generated if attentuator hold or any modulation is
activated when optimize signal-to—noise is active (On).

Modifies the attenuator and ALC settings
for optimal performance. It does not
change the RF output power.

For details on each key, use key help
as described on page 40.

Refer to the SCPI Command Reference.
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Basic Operation
Setting Frequency and Power (Amplitude)

Example: Configuring a 700 MHz, =20 dBm Continuous Wave Output

1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the
front panel display areas are shown on page 9).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz.

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the
active entry area.

3. Set the amplitude to —20 dBm: Press Amptd > -20 > dBm.

The display changes to —20 dBm in the AMPLI TUDE area of the display, and the amplitude
value becomes the active entry. Amplitude remains the active function until you press another
function key.

4. Turn on the RF Output: Press RF On/Off.
The RF Output LED lights, and a 700 MHz, —20 dBm CW signal is available at the RF OUTPUT

connector.
Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

Freq > More

* Ref Oscillator
Int uses the signal generator’s internal reference oscillator.
Frequency
uses the REF IN connector to get it's Frequency Reference. Note: An error
Phase Ref Set Eut. screen is displayed if the reference is not connected or is tuned to the wrong
2 frequency.
Adjust. Phase uses the signal generator’s internal reference unless a signal is present at
0.000 rad TieF Oscillator fAuto the rear panel REF IN connector. If an external signal is present, that signal is
PR used as the reference.
ef Oscillator
Dggi'ﬂggg?b.—bl ?SHES?' BEG uses the baseband generator clock (BBG) as the reference oscillator source.
== Gecilianh Available on vector models with BBG.
ef Oscillator
nDn—har;$EDigg Ext Freq
N oo 10.0000000 HMHz
- Ref Oscillatar Range: 1 to 50 MHz
Ewt Bandlidth For guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth,
Marrow operation using frequencies below 2 MHz is not guaranteed.
fore 2 of 2

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the
external reference you are using is noisy or spurious, use the narrow bandwidth mode.
With Wide bandwidth selected, if you select a frequency less than 2 MHz, the signal
generator displays a warning message.

For details on each key, use key help as described on page 40.
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Basic Operation
Setting ALC Bandwidth Control

Figure 3-2 Using an External Reference Oscillator

MXG Close In Phase Noise @1 GHz

-4 O0E+D1
-4 50E+01 h"\ #
-5 00E+01
-5.50E+01
-6.00E+01 Y
-6.50E+01
-7.00E+D1 |
-7 50E+01 ,km i
-B.00E+D1
-B.50E+01
-9.00E+01
-9.50E+01
-1.00E+02
1.05E+02 [,
-1 10E+I2 =
-1.15E+02 kN
1 208402 [~
-1 256402
-1 30E+02
-1 356402
1.40E+02
1.45E+02
1.50E+02
1 DOE+00 1 0B+ 1.00E+02 1.00E+03 1. 00E+04 1 DOE+05 1 DOE+0B
Offset Frequency

=
[

narrow bandwidth mode,
external reference

T A

wide bandwidth mode,
external reference

dBc/Hz

Setting ALC Bandwidth Control

Figure 3-3 Amplitude Softkeys
RMPTD

Amplitude v Amplitude Amplitude

A entror ATty G S User Foer Max

ALC fmptd Ref Alternate
Dff Wi o Amp1itude®

Fouer Search Amptd Of fset aLc B —_—_—
A 0.00 dB (Auto) [~ ALC Banduidth

Enables the
ALC Transition futo — automatic
0o Power Search User Flatnesse / HBFBPBHSE ALC
ndwidth
200 Hz bandwidt

Leveling Output Blankin Power Opt mode (Auto).
Control® Off 0On mﬂ Hodgs'

fore 1 of 3 __MNore 2 of 3 | lore 3 of 3 2 kHz

20 kHz

For details on each key, use key help Refer to the SCPI Command Reference. To display the next menu, press
as described on page 40. More.
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Configuring a Swept Output

Configuring a Swept Output

The signal generator has two methods of sweeping through a set of frequency and amplitude
points:

Step sweep (page 47) provides a linear or logarithmic progression from one selected frequency,
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along
the sweep. The sweep can progress forward, backward, or manually.

List sweep (page 49) enables you to enter frequencies and amplitudes at unequal intervals, in
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list
sweep data in the file catalog (page 61).

Figure 3-4 Sweep Softkeys

mj During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

The selected sweep type determines the displayed parameter.

- - 3 € Progress Bar: Note that very fast sweeps
Selecting step sweep also displays the step spacing (Lin or Log).

can appear to sweep randomly or

backward.
AAPLITUDE Sueep/Lis
00000 vz -144.00 dBn Sese)l ™ Sucep Tiode ]
g i Of f
HEE) =)

Sueep/List Status Information Lasic % o
Skesp : an
Skeep Tupe Ssihg?g %

Manual Mode o OFfF Ametd
SHeep Direction: Up on
Sreep Repeat 1 Cont
Sweep Triooer : FreeBun
Step Points 101 Point Triooer : FreeRun .
Freq Step Size : 0.00Hz ronfiaure,— page 47
Step Duell 1 2.000msec
U nore ﬁ of 3
—Trisser Seiop ] Sweep without waiting for )
rigger Setup a trigger at each point. On vector models:
5 m Point Trigger pauses for the dwell Available Whef )
3 LT time prior to the first sweep. See Sweep Type = List
 J page 110.
Sueep/List Trioger Key
X Trigger on a remote command.
Configure, [page 49
List Sueep
Bus Apply a TTL/CMOS signal to the
Sueep Tr j_gger'* Trigger In connector.
(Free Fun EuT
i ieEsr ¥ Down sweeps from
Point Trigoer [ Sueep/List | stop to start
(Free Run:"| frequency/amplitude.
il %Eg, Skeep Direction
J bown MR Up sweeps from start
fore 1 of 2 g - to stop
Heep Retrace i
page 53 0rF frequency/amplitude.
- Periodically issue a trigger event to
Trigger Setup whatever selects it as a source.
lore 2 of 3 ; .
Timer Trigger Using timer trigger with single
sweep results in a delay prior to the
first sweep. See page 110.
Route Conmectors,| page 47
& Set Polarity
> fore 3 of 3

For details on each key, use key help as described on page 40.
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Routing Signals

Sweep > More > More > Route Connectors

Step Sweep

Basic Operation
Configuring a Swept Output

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude,
or both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep.
The sweep can progress forward, backward, or be changed manually.

Figure 3-5 Signal Routing Softkeys
Toute Connectors | Trig 1 Out BHC Trig 1 Out BHC
Foute To
Trig 1 BHCH > Hone LKI
(None )
Sueep Dut BHC
Foute Ti ;
TriSUEBBNE= Routes Step or Suesp Trig Out Snesp Run
(Sneep Trig Out) Sueep Dut )| | ist Sweep
S Source Settled Trigger 2
(Skeep Out.) Source Settled B—Routes non
Route To Step or List Pulse Si Pul:
- : ulse Sunc ulse
Bmseband BHCsS : Sweep signals
Pulse Wideo (i.e. SCPI
Trigger Out, command Pulse Video Swept. Func Done
Polarity Pulse Sunc | development.
These softkeys are Hore 1 of 2 —} - Hore 2 of 2
only available for Source Settled
th'e vector models Sueep Fun is not affected
with a BBG. e by Trig Out
Polarity Neg Routes a signal to the Trig Out (Trig 1 or Trig 2) rear panel
_ Pos softkey connectors as follows:
BE Triogers BHC <&— selection. K i .
RS T Sueep Oul BHC None: No signals are routed to Trig 1 or Trig 2 BNCs
BB TRIG 1 BMC» Sweep Trigger Out: Sweep Trigger Out signal (trigger
(Marker 21 Swept. Func Done handshake)
FELEE 1o Opens a menu for
BE TRIG 2 BHCe routing Markers 1 Source Settled: Source Settled signal
thane ) through 4lt° the Pulse Sync: Pulse Modulation Synchronization signal
rear panel
Eugﬁ?“'iegﬁg. basezand BNC Pulse Video: Pulse Modulation Video signal
(Marker 1) connectors. LXI: LXI Trigger Output
PATT ?a%eaﬁgb Sweep Run: Sweep Run signal (sweep is running)
(None) Other Trigger BNC: The signal on the other Trigger BNC
Pulse BNC: The signal on the PULSE IN BNC
Swept Func Done: Swept Function Sweep Done signal
Marker 1
Marker 2
-
Marker 3
\ Marker 4 )
For details on each key, use key help as described on page 40.
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Basic Operation

Configuring a Swept Output

Figure 3-6

y

Sueep/List

SHeep,
(Off2

Sweep Tupe
List %

Step Sueep
Freq Start
. 00000000000GHz

Freg Stop
&.00000000000GHz

Sweep Softkeys

Step Sueep

Step Dnell
2.000 msec

Step Spacing
LOG

For details on each key, use key help
as described on page 40.

Dwell Time = the time that the signal is settled and you can make
a measurement before the sweep moves to the next point.

(Point to point time is the sum of the value set for the dwell plus
processing time, switching time, and settling time.)

Step Sweep and List Sweep dwell times are set

Lin = steps equally spaced over the sweep; the output

Sweep Repeat Ametd Start LIMN Freg Step .
sinaie NREEE it s 0.00 Hz changes linearly.
Log = step spacing increases logarithmically over the
amptd Stop sweep; the output changes exponentially.
—14iy. 00 dBm LB

Sets the step size for a linear step sweep in frequency (the

Enable Atten difference between frequency points).

tonfiaure, Protection

# Points
101

Step Swesp'[— P 0ff Ml NOTE: Setting the step size will determine the number of
il 1 of 3 Nore 2 of 2 B points in the step sweep based on the current start and stop
et flore 1 of 2 » frequencies. Due to the integer number of step points, the

step size may be adjusted in order to yield a true linear
sweep between the start and stop frequencies.

Enables protection for the mechanical attenuator by automatically turning on
Atten Hold during frequency and/or power step sweeps.

This may cause unleveled RF output to occur for certain sweep configurations.
Disabling this attenuator protection will allow the sweep to optimally set both
the automatic leveling control (ALC) and output attenuation at each sweep
point.

When the attenuator protection is disabled, the step dwell time will be set to a
minimum of 50 ms as a precaution.

[:SOURce]:SWEep:ATTen:PROTection[:STATe] ON|OFF|1|0

Example: Configuring a Continuous, Linear Step Sweep

A signal that continuously sweeps from 500 to 600 MHz and from —20 to 0 dBm, with a dwell time of
500 ms at each of six equally spaced points

Output:

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step
spacing selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

Press Freq Start > 500 > MHz
Press Freq Stop > 600 > MHz
Press Amptd Start > —20 > dBm

Start frequency 500 MHz:
Stap frequency 600 MHz:
Amplitude at the beginning of the sweep, —20 dBm:
Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.
6 sweep points: Press # Points > 6 > Enter

Press More > Step Dwell > 500 >

Dwell time at each point, 500 milliseconds:
msec

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd
Off On.
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Basic Operation
Configuring a Swept Output

A continuous sweep begins, from the start frequency/amplitude to the stop

frequency/amplitude. The SWEEP annunciator displays, and sweep progress is shown in the

frequency display, the amplitude display, and the progress bar.
5. Turn the RF output on: Press RF On/Off.

The RF LED lights, and the continuous sweep is available at the RF Output connector.

List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear

ascending, descending, or random order. List sweep also enables you to copy the current step
sweep values, include a waveform in a sweep (on a vector instrument), and save list sweep data in
the file catalog (page 61). Dwell time is editable at each point. For fastest switching speeds, use list

sweep.
Figure 3-7 List Sweep Configuration Softkeys and Display
™ Sueep Hode | For details on each key, use key help
as described on page 40.
v 0ff
Sueep/List Freg
SHeep, - n
COff) -
Displays the selected ”Eﬁd
LSNEB Tope sweep type parameters B
is (see page 50) Avgilable only on vector models,
an
Sweep Repeat = Li
Sirois ﬁ only when Sweep Type = List.
page 47
Configure FREQUEHCY AAPLITUDE List Table
Step Sueep — X
6.000 000 000 00 &= -144.00 Edit. Ttem
fore 1 of 3
Sueep/List
. 1 Frequency Haveform
Conflaure,) 5 HEE| - 14k, 00[-— CH (no modulation) 2.000 ms
List Sheep £.00000000000 GHz|-144.00|-- CM (no modulation) 2.000 ms Insert Rou
£.00000000000 GHz|-1bb4.00|-- CH ¢no modulation) 2.000 ms
e TiFiEEEr £.00000000000 GHz|-144.00|-- CH (o modulation) 2.000 ms
TFree Ao * £.00000000000 BHz|-144.00|-— CH (no modulation) 2.000 ms Delete Row
6| £.00000000000 GHz|-1b4.00|-- CH ¢no modulation) 2.000 ms
. . 7| £.00000000000 GHz|-1bb4.00|-- CH ¢no modulationd 2.000 ms
Point Trigger, 8| £.00000000000 GHz|-1hb4.00 2.000 ms
(Free Run) 9| £.00000000000 GHz|-1hb4.00 2.000 ms Goto Rowk
10| 5.00000000000 GHz|-1hb4.00 2.000 ms
02/23/2012 14:19 fore 1 of 2
Each line defines the Vector models only
Hore 2 of 3 corresponding point in

the sweep. For example, T TList Table |
line 1 defines point 1.
Sueep/List Load/Storer

Sweep Direction
Doun

Sweep Retrace
Off

Route Connectors,
& Set Polarity

see page 50
T~ Preset Listh

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwe

time is the same at each point; List Sweep dwell time can be different at each point. Insert Item

Dwell Time = the time that the signal is settled and you can make a measurement before the

sweep moves to the next point. Delete Ttem
Point-to—Point Time = the sum of the value set for the dwell plus processing time, switching
time, and settling time. [uell Tupe
9 INEAE Step
Hore 2 of 2
[~~page 47

fore 3 of 3
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Basic Operation
Configuring a Swept Output

Example: Configuring a List Sweep Using Step Sweep Data

1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step
sweep configured on page 48.
2. In the SWEEP menu, change the sweep type to list:
Press SWEEP > Sweep Type List Step to highlight List.
The display shows sweep list parameters, as shown below.
[FREQUENCY N AriPLTTUDE MM Sueep/List
6.000 000 000 00 &z -144.00 den Sueee,
e
Sueep/sList Status Information L?EEBHE@E
SHeep : UF; SWeep Repeat
Prostiere : & o00000 Manual Mode o OFfF SilEE ﬁ
Sweep Direction: Up
Sweep Repeat 1 Cont
Sweep Triooer : FreeBun
Step Points c1m Point Trigger : Fresfun
Configure,
Step Ouell : 2.000meec SEEp &R
02/25/2012 12:53 fore 1 of 3
3. Open the List Sweep menu: Press More > Configure List Sweep.
4. Clear any previously set values from the menu and load the points defined in the step sweep

List Hode Ualues
Pg 1/11

into the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset.
The display updates with the values loaded from the step sweep, as shown.

Vector Models:

ANPLITUDE List Table

-144.00 8o

Presetting the list clears any
previously selected waveforms.

6.000 000 000 00 s+

Load/Stores

For information on selecting a list
Preset. List®  sweep waveform, see “Example:
Frequency — Pouer laveform Duell Editing List Sweep Points” on

1 —14k.00|-— CH ¢no modulation? 2,000 ms age 50.
2| &.00000000000 GHz|-1ub.00 2.000 ms Insert Item pag
3| 6.00000000000 GHz|-1b4.00 2.000 ms
4| 65.00000000000 GHz|-1b4.00 2.000 ms
5| 6£.00000000000 GHz|-1b4.00 2.000 ms
6| 6.00000000000 GHz|-1bb.00 2.000 ms NS R
7| 6.00000000000 GHz|-1bb.00 2.000 ms
5| £:00000000000 Gro|-iuuiDp|  aveforms are avalable | £-880 T2 oDuell Tupe
. = . . ms ist
10| £.00000000000 GH=|-1bb .00 only on vector models. .000 ms Lizt |Sise
02/23/2012 1L:37  Hore 2 of 2

. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off

On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display,
the SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

If not already on, turn the RF output on: Press RF On/Off.
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 42.

1.

50

Create the desired list sweep. This example uses the list sweep created in the previous
example.
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. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error.

. Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight
List.

. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100
ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row.

This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent
rows.

. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in
row 5, then press More > Insert Item.

This places a copy of the highlighted frequency value in row 6, shifting the original frequency
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the
power and dwell time entries do not shift down).

. Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in
row 5 is now the active parameter.

. Insert a new power value (-2.5 dBm) for point 5, and shift down the original power values for
points 5 and 6 by one row: Press Insert Item > -2.5 > dBm.

10.To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy

of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

11.For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12.Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform.
The signal generator displays the available waveforms, as shown in the following example.

FREQUEHCY ANPLITUDE Arb Uaveform
6.000 000 000 00 sz -144.00 8 o FRiEheyEET T Either select a waveform,
I D page 40
Displad Haveform,
Select Segment On Sequence On And Markers or
Po 171 BBG Hedia Points Int Hedia Seas

RAMP_TEST_LIFH 200 53 ANTENNAZH 2037152 Wavefarm
SINE TEST LT 200 53 Seoment.s®

select no modulation.

CH
(no modulationd

Goto FRowe

b. Highlight the desired waveform (in this example, SI NE_TEST) and press either the Select
hardkey or the Select Waveform softkey.
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13.As desired, repeat step 12 for the remaining points for which you want to select a waveform.
The following figure shows an example of how this might look.

FREQUEHCY AAPLITUDE List Table
6.000 000 000 00 GHz _144000 dBn Select Havefarme The empty entry is equivalent to
| choosing CW (no modulation).
—CH
List Node Ualues 0 lat ion)
Po 1711 Frequency  Pouer Due,
1| E.00000000000 GHz|-1bb,00| NEaeeeen ms
2|LL5. 00000000000 FHz| -1k .00 0.000 ms Insert Rou
3| E£.00000000000 GHz|-1ub.00 2.000 ms
L| £.00000000000 GHz|-1uk.00 2.000 ms
5|590.00000000000 MHz| -2.50 2.000 ms Delete Fou
6| E£.00000000000 GHz| -2.50 2.000 ms
7| £.00000000000 GHz|-1ub.00 2.000 ms
§| E.00000000000 GHz|-1uk.00 2.000 ms
9| E.00000000000 GHz|-1ub.00 2.000 ms Goto Rowe
10| £.00000000000 GHz|-1uh.00 2.000 ms
0272472012 11:10 Hore 1 of 2

14.Turn sweep on:
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15.1f it is not already on, turn the RF output on:
Press RF On/Off.

The SWEEEP annunciator appears on the display, indicating that the signal generator is
sweeping, and the progress bar shows the progression of the sweep.

If the instrument is in manual sweep (page 53), the active row (row 6 in the
figure above) is the selected (manual) point, and the signal generator
outputs the settings for that selection when the RF output is on.

Example: Using a Single Sweep

1. Set up either a step sweep (page 48) or a list sweep (page 50).

2. In the List/Sweep menu, set the sweep repeat to single:
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WN T annunciator appears on the display, indicating that the sweep is waiting
to be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.
4. Initiate the sweep: Press Single Sweep.
A single repetition of the configured sweep is available at the RF Output connector.

As the signal generator sweeps, the SWEEP annunciator replaces W N T on the display, and the
progress bar shows the progression of the sweep.

At the end of the sweep, there is no progress bar, and the WN T annunciator replaces SWEEP.
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Example: Manual Control of Sweep

1. Set up either a step sweep (page 48) or a list sweep (page 50).
2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.
3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.
4. Ifitis not already on, turn the RF output on: Press RF On/Off.
5. Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF
output changes to the settings in that selection.

The SWWAN annunciator . When you enter a manual point,
indicates that the sweep The currently sweeping the progress bar moves to and

o parameter stops and )
is in manual mode. displays the selected point. stops at the selected point.

The parameters of the selected sweep point (point 3
of 6 in this example) define the signal available at the
RF Output connector.

ANPLITUDE eep/List

Configure,

List Sueep

Hanual Point: 100 Sue%g Tr“iager)“,
5 fList Status Information =S [l

Sheep : Freg+Amptd (Current Point : 100/104 ) . .

Steep Tupe 1 List Skeep Speed 1 273ptsssec PDlTEP;ElESﬁGD

Frequency Points: 104 Manual Mode HE

Amplitude Points: 104 Manual Hode When you turn manual mode on, the
OFf N current sweep point becomes the

Ouell Tupe : List manual point.

Manual Point
100

0272472012 11:18 Hore 2 of 3
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Modulating the Carrier Signal
To modulate the carrier signal, you must have both

— an active modulation format
and
— modulation of the RF output enabled

Example

1. Preset the signal generator.

2. Turn on AM: Press AM > AM Off On (requires Option UNT).
You can turn on the modulation format before or after setting signal parameters.
The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating
that a modulation format is active.

3. Enable modulation of the RF output: Press the Mod On/Off key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not
modulate until you subsequently turn on a modulation format.

Annunciator indicates active AM modulation

FREQUEHCY ANPLITUDE An

6.000 000 GO0 00 sz -144.00 cen il 15
i indicates that any active
A lit LED indicates that any act
Al Path | modulation format can modulate
fAnalog Modulation Status Information Ea the carrier.
AfL FuncGenl Depth:0.1% Hfm:Sine(L00. 0Hz)
Ar2 FuncGenl Depth:0.1x Hfm:SinecL00. OHz) _ar AM f
AMLE I Input Depth:0.5v=100: aff [— ormat on
Fri FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
Fr2 FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz) A Depth
Bl FuncGenl Dev:0.000rad Wfm:Sine ko0, 0Hz) .1
2 FuncGenl Dev:0.000rad Hfm:Sine koo, 0Hz) T
LFOut  IntHonitor Ampl:0. 0004 Monitored:FuncGenl

M Source,
(Func Gen 13

| Hore 1 of 2

To turn modulation off, press the Mod On/Off key until the LED turns off.

When the Mod On/Off key is off, the carrier signal is not modulated, even
with an active modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/Off key
until the LED lights.

Seealso:  “Analog Modulation (Option UNT)” on page 159

“Pulse Modulation (Options UNW and 320)” on page 169
“I/Q Modulation” on page 245
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Simultaneous Modulation

The Keysight X-Series signal generators are capable of simultaneous
modulation. All modulation types (AM, FM, fM, Pulse, and I/Q) may be
simultaneously enabled, but there are some exceptions. Refer to Table 3-1.

Table 3-1 Simultaneous Modulation Type Combinations
AM? FM fm Pu[seb 1/Q
AM -- X X X X
FM %C - not X X
applicable
™ «C not -- X X
applicable
Pulse | x X X -- X
1/Q X X X X --

a. Linear AM and Exponential AM cannot be enabled simultaneously. Refer to
Chapter 6.

b. Pulse modulation requires Option UNW. Refer to Chapter 7.

c. FM and fM cannot be enabled simultaneously.
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Working with Files

— File Softkeys on page 57

— Viewing a List of Stored Files on page 58

— Storing a File on page 60

— Loading (Recalling) a Stored File on page 61

— Moving a File from One Media to Another on page 62
— Working with Instrument State Files on page 62

— Selecting the Default Storage Media on page 67

The signal generator recognizes several types of files, such as instrument state files, license files,
and list sweep files. Files can be stored either in the signal generator’s internal storage or on the
USB media. This section provides an overview of how to navigate the signal generator’s file menus,
and how to view, store, load, and move files.

The Keysight MXG and EXG nonvolatile internal memory is allocated according to a Microsoft
compatible file allocation table (FAT) file system. Refer to the Programming Guide.

See also: Storing, Loading, and Playing a Waveform Segment on page 189.
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File Softkeys

For details on each key, use key help as described on page 40.
File Note: Available file types depend on the installed options.

Display internal or USB Instrument operating parameters (see page 62).
Tatalon QEZ’C?: dp;r:) ‘ggeo;éz?a Catalog Tupe Sweep data from the List Mode Values table editor.
Catalog Tupe - All User flatness calibration corrections.
(Binaru)” o
5 Cataloo Tupe
Binary
Oelete Filew page 58
Catalos Tuhee
atalog Tupes " "
. . State Displays IQ Files
Py e ) . Modulat ion, | .
Deletions require Catalog Tupes Displays FSK
confirmatipn. List Files
Fename File
FIR
Delete All User Flatness Displays FIR
Einary Files® ) Files
Hore 1 of 2 | Pulse Train
Hore 1 of 2 page 437 - \Displaysalist of
Pulse Train files.
Bit. ) _
Catalog Default Storage \ D_|splays Bit
IO Ay U __lore 2 of 2 | Files
» edia
EEED (Rt If Present
page 67 Default Path
. Use Only
Securitye Internal Storage Duiggcggpzegg
Default Path Available only with USB connected
g Use Only (i.e. Without external USB connected
USE File Managerk i = ’
= UsE (2 Defal ltGEa{ﬁ / softkeys are greyed out).
Internal /USE Specifu Default
iomw » Storage Path for—————» .
S%BEEQ?FSSr{gggéEG USE Media regte Directory
lore 2 of 2 The signal generator does not

format USB media or change file
permissions. Use a computer to
perform these operations.

The display indicates when the current directory is the default storage path.

Shows the current directory For information on setting the default storage path, see page 67.

\J

5.000 000 O

Al

This key changes, depending on
the selected file. See

0 00 &Hz

Use ask

-144.00 den

Copd File tod page 62
USB(I]irectorg: /TI%6 uavefbrns) 85.LME Free Instrument

File Hame Nodified
TN

Available only when the

TOTENE LT EEWEENIE; Up Directory current dlrgctory is not the
COMAZK _SCHAN_HFM 01/11/07 128 . P
COMAZK_PILOT_LFHM 01/11/07 17:29 Delete File on ]  Requires
EDGE_BURST_HFH 01/11/07 17:29 Directory confirmation
GSM_BURST_LIFM 01/11/07 17:29

QAN1E_HFM 01/11/07 17:29 .

OPSK_HFH 01/11/07 17:29 | Create Directory

HEOMA_10PCH_LIFM 01/11/07 17:29

02/2L/2012 15:18  fore 1 of 2 | —Page 62

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the
signal generator displays the message External Media Not Detected.
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ARB File Softkeys

Waveform files and their associated marker
and header information.

Catalog Tupe frb Catalog Tupe frb Catalog Tupe
Catalon Tupee " BBG Seoments FTEE
Modulat ion Stored
Catalog Tupes® Seaments
FIR Sequence
Pulse Train Dr1oD Note: Available file types depend on the installed options.
Bit MOMOD
lore 2 of 2 HMore 1 of 2

For details on each key, use key help as described on page 40.

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to
Auto, as described on page 67.

Viewing a List of Files Stored in the Signal Generator

1. If USB media is connected, disconnect it. The signal generator’s storage media switches to
internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press File > Catalog Type > desired catalog (in this example,
All). The selected files appear in alphabetical order by file name, as shown in the following
figure.

FREQUEHCY ANPLITUDE Catalog

The selected file catalog and 6.000 000 00 00 ez -144.00 den fatalos Toney

the storage media

Delete Filew

Catalog of\All Files in Int Storage 32kB used 29.2GE free
File Hame Size Nodified

1 NENNE S Bl B 12/1L/11 1 )

2 802_11AC_1B0MHZ _2560. HFM SHULIFH 10EkE  10/28/11 13:27 Copy File
3 802 11AC_B0MHZ 2560 HFH SMylFM  53.1kE  10/26/11 13:27

g P Fa 268D 02/20/1% 18:60

6 FHFADIO_1.56 HiHKR 381N 10/30/11 19:38 Rename File
7 FHRADIO_15G MylFH 1.L43968  10/30/11 19:19

8 FHRADIO_1 GG HyHOR 173 B 10/30/11 19:38 )

9 FSKIFILE FSk 3L B 11/09/11 11:16 Delete ALL Filese
10 FSKZFILE FSk 34 B 11/09/11 11:16

0272472012 15:44 Hore 1 of 2
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Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which
can display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

— With the USB media connected, select the desired file catalog: press > Catalog Type >
desired catalog. The selected files appear in alphabetical order by file name.

Using the USB File Manager:

— With USB media connected, open the USB File Manager: press File > More >
USB File Manager.
The instrument displays the default directory on the USB Media, as shown in the following
figure. Note that when you attach USB media, the display goes directly to this menu.

FREQUEHCY ANPLITUDE USE Nedia
6.000 000 000 00 sz -144.00 e -
Copd File to,
Use the Page Up and [JSB Directory: /NXG waveforns 86.LME Free Instrument
Page Down hardkeys to scroll File Hame Tupe Size Hodified _
through the contents of the T2TONE LEH 10.0kE 01/11/07 17:29 Up Directory
directory. 2TOME_MFIH E92 B 01/11/07 17:30
COMAZK_ICHAN_LFH 1.25MB  D1/11/07 17:29 )
COMAZ2K_PILOT_LFN ELOKE 01/11/07 17:29 Delete File or,
EOGE_BORST LFH 3.3 01/11/07 17:23 Directary
GSM_BURST_FM 9.3 01/11/07 17:23
QAMLE_WFM 20K 01/11/07 17:23 )
OPSk_LFM 320kB 01711707 17:29 Create Directoru
LICOMA_10PCH_WFM 1.L7MB  D1/11/07 17:29

fore 1 of 2
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Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument
states, lists, and waveforms.

— An instrument state file contains instrument settings. For this type of file, use the Save hardkey
shown in Figure 3-8 on page 63.

— For other types of data, use the Load/Store softkey (shown below) that is available through the
menu used to create the file.

File Type Save From
List Sweep menu
State Save menu
Waveform Mode menu
User Flatness ~ Amplitude menu
User Preset User Preset menu
Pulse Train Pulse Train menu
Text Entry
Enter
Load From
Selected File CUEEF et
Load/Stores|—w
Store To, Editing Mode

Eile*—> == Feplace

Show Alpha Table
Off

[BCOEFGHIJKLN
HOPORSTUUNXYZ
u_$a8+L1

Use this menu to enter the file name,
as described on page 41.

File Length (including extension)
For details on each key, use key help as described on page 40. Internal Media: 25 characters

USB Media: 39 characters
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There are several ways to load (recall) a stored file.

Basic Operation
Working with Files

— For an instrument state file, use the Recall hardkey shown in Figure 3-8 on page 63.

— For other types of data, use the Load/Store softkey (shown below) that is available through the

menu used to create the file.

Load fStor‘eb}—b

Loading a File From USB Media

Load From
Selected File

Confirm Load

Confirm Load
From File

Store To,
File

File Type Recall From
List Sweep menu
State Save menu
Waveform Mode menu

User Flatness
User Preset
Pulse Train

Amplitude menu
User Preset menu
Pulse Train menu

To load a file from USB media, use the USB file manager shown below.

File > Catalog Type > <type> > More > USB File Manager

or
File > More > USB File Manager
or

Insert the USB media

USB Nedia

This key changes, depending
Enter Directory = on the selected file.

Copu File to
Instrument. Copy & Select User Flatness

Copy & Play Waveform

Copy & Play Sequence

Enter Directory

Recall Instrument State

Load List

Load Pulse Train

Install licenses

Oelete File or,
Directory

Create Directory

»
-

N tion (USB disconnected)

fore 1 of 2 |

File Type Extension Pressing Select with file highlighted...
List list loads list and starts sweep
State .state load instrument state
Waveform .waveform loads and plays waveform
User Flatness .uflat loads and applies user flatness
User Preset .uprst loads and executes user preset
License lic installs purchased license
Pulse Train .ptrain loads and applies pulse train
Use File Use File Use File

Load Sweep List

Recall State

Copy & Select
User Flatness
Corrections

Copy & Play
Haveform

Copy & Play
Sequence

fore 1 of 2

| B

If the signal generator does not recognize the file,

you must select how the file is to be used.

For details on each key, use key help as described on page 40.

Load Pulse Train

Load Filter

Load Multi-Tone

Load DigHod

Load Pulse Train

Load Filter

Load Multi-Tone

Load DigHod

Load

Load
Multi-Carrier
OigHod

fore 2 of 3
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

File > Catalog Type > <type> > More > USB File Manager Copy File As

or ;
File > More > USB File Manager Skeep List
or

Insert the USB Flash Drive (UFD) Instrumert. State
Selecting a waveform or
an unknown file type

displays this softkey. User Flatness

Corrections
USE fedia This key changes, BEG Memaru
] erenmngonthesebcwd Laveform®
Enter Directory file. See page 61

Copd File to,
Instrument

Internal Storage

)

Copy File to Whether a menu is available Sequence
Instrument -
Copy File to, _Hore 1 of 3 |
Instrument
Moves up one directory level
Delete File or fihe fienSe ed Topy File As | hese
i 2 Requires confirmation eTile type Is recognize
Oirectory a the “Filename.xxx copied Pulse Train SOﬁ:keyS are
to Internal Storage” is
Create Directory displayed
Filter
fore 1 of 2
Multi-Tone Setup
Catalog Type Menu
7 page 57
Set Tledia DigHod Setup
Select
Internal Filetsie
i GeRY e BEE Multi-Carrier
[T FO0 il DigHod Setup
S » LCOpy iles
Copy All Filesk > lore 2 of 3
Internal Storage
Delete ALL Files, . . itm Wt
in Current Dir Requires confirmation
USE to Copu File As

Internal Storage
I0 Definition

These
softkeys

FSK Definition

fore 2 of 2

Data Bit File

For details on each key, use key help as described on page 40.

Working with Instrument State Files

— Saving an Instrument State on page 64

— Saving a User Preset on page 64

— Recalling an Instrument State on page 64

— Recalling an Instrument State and Associated Waveform File on page 65
— Recalling an Instrument State and Associated List File on page 65

— Moving or Copying a Stored Instrument State on page 66
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When saved to the signal generator, instrument settings
(states) save to instrument state memory*. Instrument
state memory is divided into 10 sequences (0 through 9);
each sequence comprises 100 registers (00 through 99).

Figure 3-8 Save and Recall Softkeys
lSave Recall
[ . [ |
Save State Save State Recall State

SAVE
Seql1] RegCOO]

Select Reg:

(available) 00

Select Seqi

fore 1 of 2

Select Seqi

Oelete ALl
Fegs in SeqC1]

Delete ALl
Sequences

For details on each key, use key help

as described on page 40.

Table 3-2

RECALL
Seql1] ReoC--1

Select Reo:

Select Seqi

Oelete ALl
Fegs in SeqC1]

fore 1 of 2

Recall State

Delete ALl

Sequences®

Auto Recalle

The following information is not stored in a state file:

System Security Level

System Security Level Display

System Security Level State

Web Server (HTTP)

Sockets SCPI (TELNET)

Sweep lists

Pulse Train lists
Display State On/Off

Files

I/Q Calibration Data

Hostname

IP Address
Subnet Mask

Default
Gateway

Keysight EXG and MXG X-Series Signal Generators User’s Guide

*Caution

To avoid the loss of data, GPIB settings, or current user
instrument states that have not been permanently saved
to nonvolatile memory, the instrument should always be
powered down either via the instrument's front panel
power button or the appropriate SCPI command.
instrument's installed in rack systems and powered down
with the system rack power switch, rather than the
instrument's front panel switch display a Error -310 due to
the instrument not being powered down correctly.

Remoate
Language

FTP Server
Manual DHCP
VXI-11 SCPI

Delete softkeys in the Save and Recall menus enable you
to delete the contents of a specific register, or the contents
of all sequences in the state file catalog.

The signal generator requires that you confirm a deletion.

Step increment values

ARB Files
MAC

User Power
Correction
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Saving an Instrument State

1. Preset the signal generator and set the following:

- Frequency: 800 MHz - Amplitude: 0 dBm -RF:on

2. (Optional, vector models only) Associate a waveform file with these settings:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first
move it from internal or external media to BBG media, see page 189.

3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 >
Enter.

4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg.

If a waveform is currently selected, saving the instrument state also saves a pointer to the
waveform file name.

5. Add a descriptive comment to sequence 1 register 01:

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment
appears in the Saved States list when you press Recall. If the instrument state has an
associated waveform, entering the waveform name in the comment makes it easy to identify
which instrument state applies to which waveform.

Saving a User Preset

A user preset is a special type of instrument state file.
1. Preset the signal generator and set as desired.

2. Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as
containing user preset information.

You can set up several preset conditions under different names:

1. After you save a user preset, rename it to something other than USER_PRESET (see page 66).
2. Save as many user presets as you wish, renaming the USER_PRESET file each time.

3. Give the desired file the name USER_PRESET.

Recalling an Instrument State
1. Preset the signal generator.
2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored
in the registers in that sequence; RECALL Reg is the active entry.

3. Select the desired instrument state:
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If the desired state is listed in the currently selected sequence, press desired number > Enter.
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number >
Enter.

Recalling an Instrument State and Associated Waveform File
1. Ensure that the desired waveform file exists, and that it is in BBG media (page 189).
If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform
name. It does not recreate the waveform file if it was deleted, or load the file into BBG media if
it is in internal or USB media.

2. Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.
The name is displayed as the selected waveform.

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency
and/or amplitude values. Because you must load the list file from the file catalog, when you store a
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).
2. Load the desired list file:
a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key.
This is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].
4. Press Re-SAVE Seq[n] Reg[nn].

This overwrites previously saved instrument state settings with the new comment.
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Moving or Copying a Stored Instrument State

Figure 3-9 Instrument State File Catalog

l Sequence Register

FREQUEHCY

6.000 000 000 0

ANPLITUDE

-144.00 den

Catalog

0 &z

Catalog Tupe,
(State)

Delete Filew

Catalog of /State Files in Int Storage 32kB used 29.2GE free
F me Tupe Size Nodified
1 BlE B 12/1L/11 11:1k )
2 PERSISTENT STATE 2.L3kE 02/2L/12 18:06 Copy File

3 USER_PRESET STATE 601 B 02/2L4712 17:55

Fename File

Oelete All,
State Files

02/25/2012 12:15 Hore 1 of 2

The signal generator recognizes only the file named USER_PRESET as user preset information (page 64).

A user-created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same
name as an existing file. If you rename a state file to something other than a valid sequence/register

name, the file does not appear in either the Save or Recall menu.
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You can configure the signal generator to store user files to either the internal storage or to external
USB media. To automatically switch between USB media and internal storage, depending on
whether USB media is attached, select Automatically Use USB Media If Present. To avoid storing
any confidential information in the instrument, select Use Only USB Media. To avoid storing any
confidential information to USB media, select Use Only Internal Storage.

This selection is unaffected by a power cycle or preset.

ile > >
File > More Tatalon

Goto FRowe

Securitue

USE File Managere

Internal /USBE
Current Storage SelectionM
selection TUSE if present)
fore 2 of 2

[—» Default Storage

Automatically Use
USE Media 7

If Present

Use Only
Internal Storage

Use Only
USE Media

Specify Default
Storage Path fore
USE Media

This is the recommended selection. When USB media is attached to the
/front panel, it is the selected media; when USB media is not attached,
internal storage is used.

Memory in the instrument is used, and USB media is ignored.

\Media attached to the front panel USB connector is used, and no user
data is stored to internal storage.

[~~~ Select the directory on the USB media to be used for all file operations

when USB media is attached and enabled.

For details on each key, use key help as described on page 40.
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Reading Error Messages

If an error condition occurs, the signal generator reports it to both the front panel display error
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed
separately; for information on the SCPI error queue, refer to the Programming Guide.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Drops the oldest error as each new error comes in.

Viewing Entries Press: Error > View Next (or Previous) Error Page

Clearing the Queue | Press: Error > Clear Error Queue(s)

Unresolved Errors? Re-reported after queue is cleared.

When the queue is empty (every error in the queue has been read, or the queue is cleared), the
No Errors following message appears in the queue:
No Error Message(s) in Queue O0of O

a. Errors that must be resolved. For example, unlock.

Error Message Format Error Message Error Description

Error Number (May be truncated on the

N T

-222 Data out of range; value clipped to lower limt.

Indicates that the user has entered a deviation, depth, or internal
source frequency that is beyond the specific limits

__//

_
Explanation is provided in the Error Message file (see page 431)
(This is not displayed on the instrument)

The annunciator indicates an unviewed message.

new indicates a message generated
since messages were last viewed.

Modulation Status Information Error
Hod State Depth/Dev Source Rate Havefo|
Fn On 1. 0000KHz Internal 400, OHz Sine * Message number and longer description
[_Error Tnfa 7
Yiew Prewious
Error Page
View Mext
[Error_ueue 1.4 Y Error Pase
= = 1, Sett flict; Enabled modulat Flict: € )
ERBROR: -221. Settings conflict uunﬁrgméugigcggmigu meOULAtLon SOUrse . Previcys molstion 1 of L
disabled.
Clear
Error Queue(s)
Error messages appear in the lower left corner
of the display as they occur.
fe== PROTO _CODE == NOT FOR CUSTOMER [SE s O /0R/2006_10:12
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4 Optimize Performance

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

— Using the Dual Power Meter Display on page 70

— Using the USB Pass Through Commands on page 77

— Using the Power Meter Servo on page 79

— Using Flatness Correction on page 82

— Using Internal Channel Correction (N5172B/82B Only) on page 91
— Using External Leveling (N5173B/83B Only) on page 95

— Using Unleveled Operating Modes on page 102

— Using an Output Offset, Reference, or Multiplier on page 106

— Using Free Run, Step Dwell, and Timer Trigger on page 110

— Using a USB Keyboard on page 112

KEYSIGHT

TECHNOLOGIES
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Using the Dual Power Meter Display

Using the Dual Power Meter Display

The dual power meter display can be used to display the current frequency and power of either one
or two power sensors. The display outputs the current frequency and power measured by the power
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 4-2,

Figure 4-2, and Figure 4-3.

Figure 4-1

Pouer

ChA:-66.465 dBm
dBM  crpi-ugi3l dBg

28/2012 17:L43

Channe

Dual Power Meter Display with Power Sensors A and B Calibrated

Once turned on, the
power meter

[ —readings are always
visible, even if

Neter

Off
another instrument

Channel A feature is selected
setup®
Perfer Heter Heasurements P (i.e. Sweep, AM,
etc.).
Channel B
ChA (usB: myu7u0013) ChB (sck: 1u1.121.92.70) oFf
Hg%g,’: Hg%g:: This area is the main
Channel B, display for the dual
-61.40 dB -48.64 dB ] e
. m . m calibration frequency
N [~~.and current power
[ >S8.000 HHz 50.000 MHz measured. P

If channel A or

For details on each key, use key help as described on page 40.

Figure 4-2 Dual Power Meter Display Menu

Auxiliary

Fouer Meter,
Measurements™

Pouer Heter

Channel A
| Off i

ANPLITUDE

-20.00 den

FREQUEHCY

6.000 000 000 00 &+

Chanoel A,
Pouer Heter Measurements S

Channel B
| Off i

Channel B,
Setup

02/23/2012 12:23

channel B power
sensors or both are
displayed, and the
AMPTD or the FREQ
softkeys are pressed,
the large power
meter measurements
remains displayed.
After the first
connection, if the
connection is
successful, the
model number and
serial number of the
power sensor is
displayed.

Enables the power sensor on
channel A.

[—See page 71

Enables the power sensor on
channel B.

| Channel B is configured similarly to
channel A. See page 71

For details on each key, use key help

as described on page 40.
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Figure 4-3 Configuring the Power Sensor Channels
AUX Fctn > Power Meter Note: This figure illustrates channel A. Channel B is similar.
Measurements
Pouer Heter Channel A Setup rm
Chanmel A Connect ion i -
0n Settinos™ ED””BC%SBR.L%E?'—> Connection Tupe Enables the power meter

connection type: Sockets

Channel A, Channel, Power Meter LAN, VXI-11 LAN, or USB.
Setup Settings 1 IF Address
Note: The VXI-11 softkey is
Channel B Pouwer Meter used to communicate
On Ir Port remotely with a power meter

that has a GPIB connector
via LAN-GPIB gateway.

Channel B,
Setup

Zero Sensor

Calibrate Sensor

USB U2000A Series Power
Sensors do not require the
sensor to be calibrated.

The MXG/EXG use the ChA Settinos Selects the channel on the external

USB U2000A Series Power External Power | __power meter that the power sensor
Sensor’s “Internal” zero. == EnEl is connected to.

Refer to the USB U2000A

Series Power Sensor’s Charnel Frequencu | Selects the frequency that channel A has
documentation. Settinas been calibrated to.

Channel Offset | Enables a power offset in dB for

Zero Sensor and Calibrate
0.000 dB the current channel.

Sensor softkeys are
inactive during a

measurement. fveraging, | Enables averaging. Instrument
Lto3*[ default is Auto with 1024 points.
Measurement.
Units
H
Sockets LAN: Sets the
IP port to 5025 (standard)
or 5023 (telnet)
ChA Connection programming.
ED””BC%SERQ%E'?' Sets the power meter’s IP
address or LAN-GPIB
Fouer Heter gateway'’s IP address (Sockets FEMER [EEEr
IP Address LAN and VXI-11 LAN only). TF Port. |
Poner Meter™) Whether a softkey is available
IP Port | pends on
20254 Connection Type P WHI-11
ype. Dewvice Mame
gpib0,13
VXI-11 LAN: Opens a menu for
For details on each key, use key help as entering a device name for the
described on page 40. power meter being used.

Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A P-
Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and
calibrated, as required.

On the signal generator:
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1. Setup for Step Sweep. “Configuring a Swept Output” on page 46.

2.

72

Verify RF Output power is off before continuing.

Connecting the Channel A power sensor: Connect USB sensor to the signal generator. The
MXG/EXG should display a message across the bottom that reads similar to:
USB TMC488 devi ce (USB PONER SENSOR, MY47400143) connect ed

Figure 4-4 MXG/EXG Displays Connection to U2000 USB Power Sensor
FREQUEHCY

6.000 000 000 00 &z

‘USB THCL88 device (USB POUER SEHSOR.NYL7L00143) connected [ >

Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings >
Connection Type > USB Device (None) > USB PONER SENSOR ( MY47400143)

Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a
different serial number is connected to the signal generator (refer to Figure 4-5). After the
U2000 has been recognized by the signal generator, the U2000 power sensor is saved as a
softkey in the instrument and the dialog box in Figure 4-5 won’t be displayed (press DONE, if
you see this message).

Figure 4-5 Diagnostic Dialog Box for USB Sensor

| Dimgnostic Dialog

Verifu That the sensor is connected to the Power Meter
Reference or the MXG RF Out

A Running Calibration(s) baris displayed on the signal generator. Refer to Figure 4-6 on
page 73.
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FREQUEHCY

40.000 000 000 00 &z

RF_OFF

Optimize Performance
Using the Dual Power Meter Display

Running Calibration(s) Bar (Zeroing Sensor)

e —
 Zero Sensor

Pouer Heter Measurements

Running Calibration¢s)
S0% complete
I

For details on
each key, use key
help as described
on page 40.

Figure 4-7

The U2000 Series USB Power Sensor, does not require a 50 MHz

calibration. If a calibration is attempted with the U2000 Series Power

Sensors, the signal generator displays a message reading:

The U2000 series power sensor does not require a 50 M

cal i brati on. Refer to Figure 4-7 on page 73.

Diagnostic Dialog Box Displayed for U2000 Power Sensor

FREQUEHCY

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

The U2000 series power sensor does not require a 50 MHz
calibration

RF_OFF

0K

For details on
each key, use key
help as described
on page 40.

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the
instrument's display and in the upper right portion of the display under Power Meter. Refer to

Figure 4-8.

Figure 4-8

Channel A Power Sensor Displayed on MXG/EXG

| “Pauer leter .~

B

annel 8
Off

Chanoel Ay
Pouer Heter Measurements Setup
A (usB: nuL7LODIL3) eénB
Channel B,
-69.81 dBm <
For details on
50.000 MHz each key, use key
help as described
— —— on page 40.
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6. On the N1912A P-Series Power Meter (Channel B power sensor): Connect the N1912A P-
Series Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

It is recommended, but not required to use the channel B on the N1912A.
This provides continuity with the signal generator’s dual display. For this
example, the U2004A has already used up the channel A position on the
signal generator.

8. Connect the power sensor input to the 50 MHz reference of the power meter.
9. Press Channel B Setup

10.Press Connection Settings > Sockets

11.Press IP Address > IP address > Enter

The IP address of the power meter should be displayed in the ChB section
of the display.

Figure 4-9 Channel B Power Sensor with IP Address Entered
FREQUENCY [RE_OFF |/POLER NETER
ChA:-53.81 dBm
40.000 000 000 00 &Hz e
Channel ﬂ'
Pouer Heter leasurements Setup
L —
ChA cusB: MyL7001L3) Q Wil
Crenget B
-69.81 dBm
50.000 MHz For details on
each key, use key
=% PAOT0 CODE == NOT FOR CUSTOMER USE =w= 0L /0272008 15:038 help as described

on page 40.

12.Press Return > Channel Settings > External Power Meter Channel to B.

74 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Optimize Performance
Using the Dual Power Meter Display

13.0n the signal generator: Press Channel B to On and then back to Off again. This initializes the
signal generator to the external power meter.

14.Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 4-10 on page 75).

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 4-10

FREQUEHCY

50.000 MHz

40.000 000 000 00 &Hz

: Dimgnostic Dialog
Pouel

Diagnostic Dialog Box for Channel B

RF_OFF |/POUER NETER
ChA:—60.30 dEm

[: Verifu That the sensor is connected tDD %;he Fouer Meter

Feference or the MXG RF Ou

DOKE

15.Press Done

For details on
each key, use key
help as described
on page 40.

The Runni ng Cal i bration(s) baris displayed: Zeroi ng Sensor Pl ease wait....

16.After Running Calibration(s) bar disappears: Press Calibrate Sensor

Diagnostic Dialog box is displayed that prompts for verifying the connection of the power
sensor to the power meter 50 MHz reference (refer to Figure 4-11 on page 75).

Figure 4-11

FREQUEHCY

Diagnostic Dialog Box for Calibration

RF_OFF

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

Verifu That the sensor is connected to the Power Meter

Reference or the MXG RF Out

DOKE
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17.Press Done

Calibration progress bar is displayed. Refer to Figure 4-12 on page 76.

Figure 4-12 Running Calibration(s) Bar (Calibrating Sensor)

40,000 000 000 00 stz | 2000 ()

Pouer Heter Measurements

Running Calibration¢s)
S0% complete
I

For details on
each key, use key
help as described
on page 40.

18.Press Return > Channel B to On

19.The current power meter sensor reading should be displayed on the signal generator in the
ChB portion of the display and in the upper right corner of the display under Power Meter and
to the left of the Power Meter power sensor reading.

Figure 4-13 Channel B Power Sensor Displayed on MXG/EXG
FREQUEHCY LRE_OFE | /POUER METER Pouer_leter
40.000 000 000 00 GHz el Cramel &
Chanoel Ay
Pouer Heter Heasurements Setup
L~
ChA cusB: nyu7u001L3) ChB ¢stk: 1u1.121.92.70) ( Epnal B )
Ehange% B,
eLup
-61.40 dBm -48.64 dBm For detals on
each key, use key
50.000 MHz > Hz help as described
on page 40.

20.The power sensors are now ready to be connected in a measurement setup.
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Using the USB Pass Through Commands

The USB pass through SCPI commands are used remotely and or to program your system setup
and power meter sensor setup.

This section applies to the following USB power sensors:
— U2040 X-Series

— U2020 X-Series

— UB480 Series

— U2000 Series

If the power sensor is configured to return peak power, then the MXG
displays peak power (i.e., Use the : f et ch? and : nmeasur e? power sensor
SCPI commands, which returns a value based on the configuration). Refer
to the X-Series Signal Generators SCPI Command Reference.

This section contains the following:

— Table 4-1, “SCPI Pass Through Commands”

— “Procedure”

Table 4-1 SCPI Pass Through Commands
: SYSTem PMETer [ 1] | 2: PASSt hr ough <" scpi Command" >
: SYSTem PMVETer [ 1] | 2: PASSt hr ough? <"scpi Query" >
: SYSTem PMETer [ 1] | 2: PASSt hr ough: ENABl e 0] 1
: SYSTem PMETer [ 1] | 2: PASSt hr ough: ENABI e?
: SYSTem PMETer [ 1] | 2: PASSt hr ough: Tl Meout <val uel nSeconds>
: SYSTem PMETer [ 1] | 2: PASSt hr ough: Tl Meout ?

Procedure

Step Substeps Results/Notes

1. Setup equipment.

2. Enable the pass a. Enter:
through capability in i .
the MXG. : SYSTem PMETer : PAS

St hrough: ENABl e 1

3. Querytheinstrument a. Enter: The instrument should return a 1, indicating that the
and verify pass - SYSTem PVETer : PAS PSS through feature has been enabled.

through status. St hr ough: ENABI 2
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Step

Substeps

Results/Notes

4. Sending additional
SCPI commands.

If you are sending a
query, go to step 5.

Else, repeat steps 4 and
or 5 as needed.

a. Enter:

: SYSTem PMETer : PAS
St hrough " SCPI
comand”

Where "SCPI command" is any SCPI pass through
command. Refer to Table 4-1 on page 77.

5. Sending additional
SCPI queries.

If you are sending a
command, go to step 4.

Else, repeat steps 4 and
or 5as needed.

78

a. Enter:

: SYSTem PMETer : PAS
St hrough? “*| DN?”
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Figure 4-14
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The Power Meter Servo mode uses power meter readings to adjust the output power of the source,
maintaining a constant DUT output power.

The servo loop measures the output power of the DUT, compares it to the user-provided reference
power, and adjusts the output of the source to achieve the user-provided power level within the
settling error. The servo loop will abort after twenty unsuccessful attempts to achieve the
user-provided power level.

The system automatically adjusts
power level according to the power
meter reading.

Once performs the adjustment only at
the end of any transition (amplitude or
frequency change). After the
adjustment is performed and the
power error is corrected, no further
adjustments are performed until the
next transition.

N5173B/83B
only

/ Continuous performs the adjustment

as in Once mode, and continues to
adjust the power periodically if the

value differs by more than the
specified Settling Error.

Device Protect Sets the relative initial power

when leveling with the Power
Initial Pouer | Meter Servo mode. The
| 0.00 @8 | gefault of 0 dB means that the
system starts with the power
Increment | it thinks is needed (based on
100.0 % output power, offset and
reference) but this might lead
Until Delta | to power overshoots in certain
100 @B cases (especially when the
offset is not set up correctly).
This value allows to specify
an additional safe-margin to
start the measure/adjust
M EE . Bgtggk cycles lower than the target
power to protect the device
from power overshoots.
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Power Meter Servo Configuration

The following procedure is a basic configuration for using the signal generator’s Power Meter Servo
mode.

The configuration described below is one possible setup example.
Consider the limits of your DUT and use caution to protect the DUT from
being exposed to too much power.

1. Connect the equipment as shown in Figure 4-15.

Figure 4-15 Power Meter Servo Configuration

Power Sensor

DUT
I/ Directional Coupler

For details on each key,
use key help as described
on page 40.

2. Set the signal generator frequency and amplitude to the desired settings for your device.

To get the best results and reduce stress on the DUT, the amplitude offset
should be set to match the approximate gain of the device. For example, if
the DUT is an amplifier with 20 dB of gain, set the amplitude offset to 20
dB.

Press AMPTD > More > Amptd Offset, then enter a value.

3. On the signal generator, press AMPTD > Leveling Control > Power Meter Servo Configuration.

4. Press Channel A Setup and configure the power meter. Refer to Configuring the Power Sensor
Channels on page 71.

5. Press Return > Return > Settling Error. Set the Settling Error value.
6. Press Return > Return > Leveling Mode. Select the leveling mode.
Power Meter Once performs the adjustment only at the end of any transition (amplitude or

frequency change). After the adjustment is performed and the power is corrected, no further
adjustments are performed until the next transition.
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Power Meter Continuous performs the adjustment as in Once mode, and continues to adjust
the power periodically if the value differs by more than the specified Settling Error.

Once these parameters are set, the servo loop engages and levels the DUT’s output power.

Example

The following example emphasizes the importance of setting the amplitude offset, as it protects the
DUT from being exposed to too much power.

For this example, the source amplitude offset is 20 dB and the source amplitude is programmed to
25 dBm. The offset is subtracted from the programmed level, making the actual source output
power 5 dBm. If the power meter measures 24.5 dBm, for example, the output power will be
adjusted by 0.5 dBm since the power meter measurement is 0.5 dBm lower than the desired 25
dBm. The new source output power is 5.5 dBm. If the power meter then measures 24.97 dBm, no
further adjustments will be made since the measured value is within half of the settling error of 0.2
dB.

If using the continuous leveling mode, the power meter readings are monitored and the output
power of the source will be adjusted if the measurement drifts outside the specified settling error.

Continuing with this example, if the amplitude offset remained at the default of O dB, the output
power would have been 25 dBm, resulting in a power meter measurement of 40 dBm (assuming the
amplifier already went into compression). The algorithm would have reduced the source power by
15 dB, thus outputting 10 dBm and resulting in a measurement of maybe 29.5 dBm. The additional
reduction of another 4.5 dB would have lead to the same outcome as with the 20 dB amplitude
offset (source output power of 5.5 dBm). However, in-between, the DUT was stressed possibly past
its specified operating range.
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Using Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in
cables, switches, or other devices. Using an Keysight N1911A/12A, E4419A/B, or U2000 Series
power meter/sensor to calibrate the measurement system, a table of power level corrections can
automatically be created for frequencies where power level variations or losses occur. Supported
connection types to the power meter/sensor are Sockets LAN, VXI-11 LAN, USB, and GPIB via VXI-
11 LAN using a LAN-GPIB gateway (e.g. E5810A Gateway or equivalent).

A power meter with GPIB requires using the Connection Type VXI-11
softkey, as well as a LAN-GPIB gateway, to control a power meter. Refer to
the Keysight Connectivity Guide USB/LAN/GPIB Connectivity Guide
(E2094-90009), Keysight X-Series FAQs “How do | connect to the LAN?”,
and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.

If you do not have an Keysight N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may
save individual user flatness correction tables to the signal generator’s memory catalog and recall
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal
generator’s RF output (see page 86).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on
page 90 to recall a user flatness file from the memory catalog and apply it to the signal generator’s
RF output.
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Figure 4-16
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Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array
contains ten frequency correction pairs (amplitude correction values for each specified frequency),
from 500 MHz to 1 GHz.

An Keysight N1911A/12A or E4419A/B power meter and E4413A power sensor are used to
measure the RF output amplitude at the specified correction frequencies and transfer the results to
the signal generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter
and E4413A power sensor.) The signal generator reads the power level data from the power meter,
calculates the correction values, and stores the correction pairs in the user flatness correction
array.

If you do not have the required Keysight power meter, or if your power meter does not have a LAN,
GPIB, or USB interface, you can enter correction values manually.

Required Equipment

— Keysight N1911A/12A or E4419A/B power meter (a power meter is not required with the
U2000A/01A/02A/04A Power Sensor)

— Keysight E4413A E Series CW power sensor or U2000A/0TA/02A/04A Power Sensor
— GPIB, LAN, or USB interface cables, as required
— adapters and cables, as required

For operating information on a particular power meter/sensor, refer to its
operating guide.

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 85.

During the process of creating the user flatness correction array, the power
meter is remotely controlled by the signal generator.
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Connect the Equipment
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LAN, GPIB, or USB interface
cables, as required
adapters and cables, as
required

The LAN, GPIB*, and USB connections are for
convenience. If your power meter does not have
LAN, GPIB, or USB, then manually enter corrections
as described in the correction entry step in this
section.

*GPIB control of a power meter requires a LAN—
GPIB gateway and use of the connection type VXI-
11. Refer to the Keysight Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009),
Keysight X-Series FAQs “How do | connect to the
LAN?", and to the E5810A User’s Guide or
equivalent LAN/GPIB gateway device.

Power Meter
(if applicable)

Note: Keysight U2000 Series USB
Power Sensors connect directly to the
signal generator’s front panel USB
port (i.e. the power meter is not
applicable).

a. For operating information, refer to the power meter/sensor documentation.
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Basic Procedure
1. Create a user flatness array.
a. Configure the power meter/sensor
b. Connect the equipment
c. Configure the signal generator
d. Enter the user flatness correction values
2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.
Configure the U2000A/01A/02A/04A Power Sensor

1. Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect
the Equipment” on page 85.

2. Zero the power sensor using the signal generator softkeys.

Verify the signal generator RF Output power is set to the desired amplitude
before performing the power meter zero. No RF Output amplitude check is
done by the signal generator during zero.

The signal generator’s RF Output LED remains unchanged during zeroing
of the power sensor (e.g. if the RF Output LED was on prior to starting the
Zeroing of the power sensor, the LED remains on throughout the
zero/calibration). But, actually the instrument’s firmware has turned off
the RF Output’s power.

For operating information on your particular power sensor, refer to its
operation guide.

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal
generator or the front panel of the power meter.

3. Enter the power sensor calibration factors into the power meter as required.

86 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Optimize Performance
Using Flatness Correction

4. Enable the power meter’s cal factor array.

The signal generator’s RF Output LED remains unchanged during zeroing
of the power sensor (e.g. if the RF Output LED was on prior to starting the
Zeroing of the power sensor, the LED remains on throughout the
zero/calibration). But, actually the instrument’s firmware has turned off
the RF Output’s power.

For operating information on your particular power meter/sensor, refer to
its operating guide.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:

a. Preset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

Press AMPTD > More > User Flatness > Configure Power Meter > Connection Settings >
Connection Type > connection type.

ii. If connection type is USB:

1. Zero Sensor
2. Goto stepc.

else

If Sockets LAN or VXI-11 LAN: Press Power Meter IP Address > power meter’s or LAN-
GPIB gateway IP address > Enter.

If Sockets LAN: Press Power Meter IP Port > IP port > Enter.
else
If VXI-11: Press PM VXI-11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the
power meter’s documentation. Typically, this is “i nst 0” and is case sensitive for some
power meters. Refer to your power meter’s documentation, the Keysight Connectivity
Guide USB/LAN/GPIB Connectivity Guide (E2094-90009), and Keysight X-Series FAQs
“How do | connect to the LAN?”

When connecting via a LAN-GPIB gateway, enter the SICL address of the power meter.
Typically, this is “gpi b0, 13”, where “gpi b0” is the GPIB SICL interface name of the
gateway and “13” is the GPIB address of the power meter. Refer to the Keysight
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094-90009), Keysight
X-Series FAQs “How do | connect to the LAN?”, and to the E5810A User’s Guide or
equivalent, LAN/GPIB gateway device.
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c. Open the User Flatness table editor and preset the cal array:
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

d. In the Step Array menu, enter the desired flatness-corrected start and stop frequencies,
and the number of points:

Press More > Configure Step
Array >

Freq Start > 500 > MHz >
Freq Stop > 1> GHz >

# of Points > 10 > Enter

e. Populate the user flatness correction array with the step array configured in the previous
step:

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.
f. Set the output amplitude to O dBm.
g. Turn on the RF output.
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2. Connect the power meter to the RF output and enter the correction values:

Optional: Save the User Flatness Correction Data
1.
2.

3.
Enable the Flatness Correction at the RF Output

With a Power Meter Over LAN, GPIB, or USB

i. Create the correction values:
Press More > User Flatness > Do Cal.

The signal generator begins the user
flatness calibration, and displays a
progress bar.

The amplitude correction values load
automatically into the
user flatness correction array.

ii. View the stored amplitude correction
values:
Press Configure Cal Array.

The user flatness correction array title displays User Fl at ness:

Vi.

Manually

Open the User Flatness table editor and
highlight

the frequency value in row 1:

Press More > User Flatness > Configure Cal
Array.

The RF output changes to the frequency value
of
the table row containing the cursor.

. Note the value measured by the power meter.
iii. Change the sign on the delta value (e.g. the

delta value of the 0 dBm reference value (step
f), and the measured value from ii is —.34,
change the value to +.34).

. Highlight the correction value in row 1.

Press
Select > enter the delta calculated in step iii >
dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output
amplitude
based on the correction value entered.

Repeat steps ii - v until the power meter
reads 0 dBm.

vii. Highlight the frequency value in the next row.

viii.Repeat steps ii through vii for the remaining

rows.

(UNSTCRED) , without a

name, indicating that the current user flatness correction array data has not been saved to the

file catalog.

Press Load/Store > Store to File.

Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any
user flatness correction files saved to the catalog can be recalled, loaded into the correction
array, and applied to the RF output to satisfy specific RF output flatness requirements.

Press Return.

— Press Return > Flatness Off On.
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The UF annunciator appears in the AMPLI TUDE area of the display, and the correction data in the
array is applied to the RF output.

Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction
Values on page 87.

1. Preset the signal generator.
2. Recall the desired User Flatness Correction file:

a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm
Preset.

b. Press Load/Store.
c. Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Fl at ness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using Internal Channel Correction (N5172B/82B Only)

There is an internal calibration routine (Factory Calibration) that collects
correction data for both the baseband and RF magnitude and phase errors
over the entire RF frequency and power level range on any unit with
options 653, 655, 656, and 657. The internal channel correction cannot be
turned on until after the Enhanced Factory Calibration has been executed
once. See “Perform Enhanced Factory Calibration” on page 94.

The internal channel correction feature flattens the system magnitude and phase response across
the maximum bandwidth supported by the instrument (up to 160 MHz BW, depending on the
option). This performance improvement is available at any arbitrary center frequency or amplitude
level.

Correction filter generation and application is performed internally. The correction filtering occurs
in real time and is applied to live data.

There are two correction types: factory and user. The Factory Calibration optimizes the performance
at the front panel RF output connector into a precision 50 ohm load. The User Calibration can
extend this performance to a new calibration reference plane and deliver the highest signal quality
to the user’s DUT.

This feature also minimizes unwanted baseband images by flattening (and matching) the
magnitude and phase response of the I and Q channels from the signal DACs to the IQ modulator.

This calibration should be run when the ambient temperature has varied by at least +5 degrees
Celsius from the ambient temperature at which the previous calibration was run.

When this feature is off, the box will behave as it always has. When this feature is on, the internal
I/@Q path is active, the I/Q Correction Optimized Path is RF Output, and the frequency is changed by
more than 1 kHz, the firmware will calculate a channel correction filter. For List/Sweep, the
calculation will be done prior to the first sweep using the specified frequencies when either
waveform sweep is active or the baseband is on and the instrument is optimized for the internal
path. This calculation will cache corrections for up to the maximum number of cache points (256).
For list/sweep, the sweep will pause and recalculate the correction caches before running again.

In the case of arbitrary frequency switching, once the correction cache is
full (256 unique frequency points), the oldest frequency corrections will be
forgotten as new frequencies are selected.

Whenever I/Q Timing Skew, I/Q Delay, Quadrature Angle Adjustment, or
the Int Equalization Filter is adjusted, all caches are forgotten.

Additional characteristics of the internal channel correction:

— When the internal channel correction is on, arbitrary frequency switching while the baseband is
on will take up to an additional 290 ms (72 ms typical) the first time that frequency is specified.
After the first time that a frequency is selected, switching to that frequency again takes an
additional T ms.
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— If afrequency sweep is activated, then the calculation and caching will occur up front for the
first 256 unique frequencies, and all additional unique frequencies will have the characteristics
of arbitrary frequency switching.

— Ifthe I7Q Correction Optimized Path softkey is set to Ext I/Q, then only the baseband corrections
will be applied and the frequency switching will be unaffected.

— If active, the ACP Internal I/Q Channel Optimization filter and the Equalization filter, will be
convolved with the internal channel correction filter. A hamming window is applied and the
resulting filter will be truncated to 256 taps.
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internal baseband generator RF and

Correctionk:
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fore 2 of 3

Toggles on or off the application of the
internal baseband generator RF and
baseband magnitude and phase
corrections across the 160MHz
baseband bandwidth at the current RF
frequency.

When this feature is on, arbitrary
frequency switching while the
baseband is on will take up to an
additional 3.3ms (typical) to 6.8ms the
first time that frequency is specified.
After that, switching to that frequency
will take up to an additional 1.3ms.

Up to 1024 unique frequencies can be
cached before the oldest cache will be
forgotten. If a frequency sweep is
activated, then the calculation and
caching will occur up front for the first
1024 unique frequencies, and all
further unique frequencies will have
the characteristics of arbitrary
frequency switching.

If the I/Q Correction Optimized Path is
set to Ext I/Q Output then only the
baseband corrections will be applied
and the frequency switching speed will
be unaffected.

This correction will be convolved with
the ACP Internal I/Q Channel
Optimization filter and the Equalization
filter if they are active. The resulting
filter will be truncated to 256 taps.
NOTE: The Enhanced Factory
Calibration must be executed once
before the Factory correction type can
be turned on. See page 94.
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performance to the RF output
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the DUT.
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correction type can be turned on.

See Perform Enhanced
Factory Calibration.

To perform the Factory
calibration, press Utility > More
> Service > 1/Q Int Channel
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Factory Calibration. Follow the
instructions on the signal
generator display.
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Configure Internal Channel Correction

There is an internal calibration routine (Enhanced Factory Calibration) that
collects correction data for both the baseband and RF magnitude and
phase errors over the entire RF frequency and power level range on any
unit with options 653, 655, 656, and 657. The internal channel correction
cannot be turned on until after the Enhanced Factory Calibration has been
executed once.

The following is a basic configuration for using the signal generator’s internal channel correction.
Refer to Figure 4-18.

On the signal generator:

1. Set the center frequency:

Press Freq > 3 > GHz

2. Set the I/Q to internal (default):
Press 1/Q > 1/Q Source > Internal

3. Press 1/Q to On

4. Perform internal channel correction:

Press More > Int Channel Correction Off On to On

Using User Corrections

Use a USB power sensor to perform a User Channel Corrections calibration to correct the response
of the DUT/poor matching network. And, verify the EVM of the DUT with the new User Channel
Corrections calibration.

Perform Enhanced Factory Calibration

For instruments with firmware prior to B.01.10, the Enhanced Factory Calibration must be run once
before you can turn on the I/Q Internal Channel Corrections (Factory Correction Type). Optionally,
this calibration procedure can be run anytime for new calibration data.

Depending on the equipment you use, the Enhanced Factory Calibration
may take up to four hours to complete.

On the signal generator:

1. Press Utility > More > Service > I/Q Int Channel Correction Calibrations > Enhanced Factory
Calibration.

2. Follow the instructions on the signal generator display to complete the calibration.
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Using External Leveling (N5173B/83B Only)
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Sourcer
(Off2

- Leveling

Leveling Mode,
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Ext Leveling
Ametd Of fset |
16.00 dB

Fouer Meter Servo
Conf iouration

Atten Hold sets to On and grays out (inactive) with Ext Detector selection. When re—
selecting Internal, the softkey becomes active, but attenuator hold remains on. If
desired, manually set it to off.

With the Ext Detector selection, Set Atten has no effect on the output power level.
During external detector use, use the attenuator to keep the ALC power level at
approximately 0 dBm when using negative dBm power levels. See page 98.

Leveling Hode

Internal

Prr Meter Once

—

Prr Meter Cont

These settings do not
change the output power
amplitude of the signal
generator, they only let
you modify the front panel
display amplitude value so
it closely approximates the
power level measured at
the output of the
coupler/splitter. See

page 101.

fore 3 of 3

While operati

his softkey works with only the Ext Detector selection. It uses 16 dB as its zero
reference point.

Pouer Heter Servo

Fouer Meter
hannel

ElE

Settling Error
0.20 dB See page page 70.

Poner Meter,
Conf iouration

Opens a menu in which you can specify the manner in which power is set.
Power setting can be optimized for different parameters.

Select Optimize S/N to maximize the signal to noise performance in the
resulting signal.

Select Optimize Harmonics to minimize the amplitude of harmonics in the
resulting signal.

ng in external leveling mode, if either the RF or the DC

connection between the signal generator and the detector is broken,
maximum signal generator power can occur. This maximum power may
overstress a power-sensitive device under test.

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so
that it accounts for most of the power uncertainties inherent to the cabling and components in a
test setup. Refer to Figure 4-19.
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Figure 4-19 ALC Circuity
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The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT
connector based on the power level at the detector. As the RF power level at the coupler’s/power
splitter input changes, the external detector returns a compensating negative voltage. The ALC
circuit uses this negative voltage to level the RF output power by raising and lowering the signal’s
power, thus ensuring a constant power level at the point of detection (external detector). Since the
point of detection does not occur at the output of the device to which the detector is connected,
there is some power loss that is not compensated for by the external detector. For example on a
coupler, the coupled port siphons some of the signal’s energy to drive the external detector. In
addition the coupler experiences some insertion loss between the coupled port and the output.
Figure 4-21 on page 97 shows the input power versus output voltage characteristics for typical
Keysight Technologies diode detectors. Using this chart, you can determine the leveled power at
the diode detector input by measuring the external detector output voltage. For a coupler, you
must then add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values
shown in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that
the detector, coupler/power splitter are specified for the power and frequency range of interest. To
determine the signal generator’s actual power range during external leveling, see “Determining the
Signal Generator’'s Amplitude Range” on page 100.

With external leveling, the displayed amplitude value can vary significantly from the actual output
power of the coupler/power splitter to which the external detector is connected (see Figure 4-20).
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display
an accurate amplitude value. Also components between the signal generator and the external
detector can affect the output power of the coupler/power splitter. You can compensate for this
power display difference by using the

Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two
softkeys is that the Ext Leveling Amptd Offset functions only while external leveling is active. For
more information on using the external leveling offset feature, see “Adjusting the Signal Generator
Display’s Amplitude Value” on page 101.
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Figure 4-20 Power Value Differences with External Leveling
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Figure 4-21 Typical Diode Detector Response at 25° C
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Option TET Output Attenuator Behavior and Use

When using the internal detector, the Option TE1 output attenuator enables signal generator
power levels down to -130 dBm at the RF Output connector. It accomplishes this by adding
attenuation to the output signal after the ALC detection circuit. The output power value (shown in
the Anpl i t ude area of the display) is the resultant of the Set Atten and Set ALC Level values (see
page 95). With the external detector selected, the output attenuator no longer attenuates the
output signal since the feedback for the detection circuit has been moved beyond the output
attenuator. Because the attenuator no longer affects the amplitude of the output signal, the output
amplitude is determined by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet).
As stated earlier, the actual output power may vary due to the external detector and the
coupler/power splitter performance characteristics.

When the internal detector (Internal selection) is reselected, the signal
generator does not turn the attenuator hold off.

Even though the output attenuator no longer affects the output power, it is still useful to drive the
ALC circuit to its mid-power point of approximately O dBm, which is optimal for the internal leveling
circuitry and typically provides the best amplitude flatness results. This is useful with power values
of -5 dBm or less. For example, to drive the ALC to approximately mid-power with a -20 dBm
power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (-20 + 25).

If there is too much attenuation, it will drive the ALC circuit too high and
cause the signal generator to go unleveled. Ensure that you decrease the
attenuation as you increase the power level.

Configure External Leveling

Basic Setup Process
— If working with a single frequency signal, perform Steps 1 through 5.
— If working with multiple frequencies:
a. Perform Steps 1 through 4.
b. Perform a user flatness correction, see “Using Flatness Correction” on page 82.
— If working with a sweep:
a. Perform Steps 1 through 4.
b. Setup the sweep, see “Configuring a Swept Output” on page 46.
1. Setup the equipment, see “Equipment Setup” on page 99
2. Configure the carrier signal, see “Configuring the Carrier” on page 99

3. Select external leveling, see “Selecting External Leveling” on page 99.
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4. Determine the output amplitude range, see “Determining the Signal Generator’'s Amplitude
Range” on page 100

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude
Value” on page 101

Equipment Setup

Set up the equipment as shown in Figure 4-22 on page 99. Place the external detector (detector
and coupler/power splitter) as close as possible to the DUT.

Recommended Equipment
— Keysight 8474E negative detector
— Keysight 87301D directional coupler

— cables and adapters, as required

Figure 4-22 Typical External Leveling Setup using a Directional Coupler

Negative Detector

ALC INPUT
il -
l plaealeles ala el .
AERAAREAARERS RF OUTPUT Leveled Slgnal
- EL“EO ||>
Signal Generator Amplifier Coupler

Configuring the Carrier
1. Press Preset.
2. Set the carrier frequency.
3. Set the power level to 0 dBm:
— If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:
a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.
b. Press Set Atten > 0 > dB.
c. Press Set ALC Level > 0 > dBm.

Selecting External Leveling
Press AMPTD > Leveling Control > Leveling Mode > Pwr Meter Cont.
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Determining the Signal Generator’s Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency
points and there is a need to know the maximum output amplitude for each frequency point, refer
to the “Amplitude” section of the X-Series Data Sheet. Then use this procedure to determine the
maximum amplitude for each band.

With external leveling and Option TE1, the signal generator’s power range approximates that of a
standard option instrument (no Option TE1). But Option TE1 does let you use the attenuator to
drive the ALC to its mid-power point when using amplitude values less than O dBm. However
adding attenuation does decrease the upper range limit. For more information, see “Option 1E1
Output Attenuator Behavior and Use” on page 98.

1. If Option 1E1 is installed, adjust the attenuator to the desired level.

If the Option 1E1 output attenuator value is too high (approximately

355 dB), it will cause an unlevel condition to occur when the RF output is
turned on.

a. Press AMPTD > Atten/ALC Control > Atten Hold On > Set Atten.
b. Enter the attenuator value.
2. Turn on the RF output: Press RF On/Off to On
3. Set the AMPTD step increment value to one dB.
— Press AMPTD > Incr Set > 1 > dB.
4. Determine the minimum amplitude value:
a. Set the amplitude to -25 dBm.
b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.
c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range
value.

5. Determine the maximum amplitude value:
a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

— If the unleveled annunciator appeared, decrease the amplitude until the annunciator is
gone. The value where the annunciator disappears is the maximum upper range value.

— If the signal generator displays Error: 501, Attenuator hold setting over
r ange at the bottom of the display, the value showing is the maximum upper range
value.
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To remove the error message, press the down arrow key until the message is gone. The
error appears when an attempt is made to increase the amplitude beyond the maximum
value as it relates to the current attenuator setting.

Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference,
the signal generator provides two methods for configuring the displayed power value so that it
closely matches the measured value at the output of the coupler/splitter.

1. Connect and configure a measurement instrument:
a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.
b. Configure the power meter/signal analyzer for measuring the power level of the signal.
2. Adjust the signal generator’s displayed amplitude value:
— If using the Ext Leveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal
detector.

a. On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

b. While viewing the carrier amplitude value on the signal generator display, use the RPG
knob (detent knob) to adjust the offset value until the integer part of the displayed
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB.

c. Using the number keypad, make the necessary fractional adjustments to the display
amplitude value.

— If using the Amptd Offset Softkey:
a. On the signal generator, press AMPTD > More > Amptd Offset.

b. Calculate the difference between the signal generators displayed Amplitude value and
the measured value.

c. Using the numeric keypad, enter this difference as the Amptd Offset softkey value.
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Using Unleveled Operating Modes

Figure 4-23
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For details on each key, use key help as described on page 40.

ALC Off Mode

Turning ALC off deactivates the signal generator’s automatic leveling circuitry. Turning ALC off is
useful when the modulation consists of very narrow pulses that are below the pulse width
specification of the ALC or when up converting external |Q signals and the modulation consists of
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slow amplitude variations or bursts that the automatic leveling would remove or distort. When
using the internal IQ baseband generator, the best technique is to use the ALC hold marker
function vs. ALC off for the types of signals just described.

After the ALC has been turned off, power search must be executed to set
the proper output power level requested on the front panel. Power search
is executed automatically by default, but the these settings can be
overridden by using the Manual mode.

Power Search Mode

The power search mode cannot be used with bursted signals input via the
external 1Q inputs.

The MXG/EXG has three power search modes (for internal and external I/Q modulation) and four
power search references (for external I/Q modulation only). Refer to Figure 4-23 on page 102.

Power search executes a routine that temporarily activates the ALC, calibrates the power of the
current RF output, and then disconnects the ALC circuitry.

Power Search Modes (Applies to External and Internal I/Q Modulation)

— Auto — A power search is executed at each frequency or power change, and at each change to
the AM, burst, pulse, or I/Q modulation state.

— Span — When Power Search is set to Span, pressing Do Power Search executes the power
search calibration routine over a range of user-defined frequencies. The power search is stored
and used when the signal generator is tuned within a user-defined range. After the Span softkey
is pressed, select either Full or User. If User is selected, then the start and stop frequencies need
to be selected.

— Manual — When Power Search is set to Manual, pressing Do Power Search executes the power
search calibration routine for the current RF frequency and amplitude. In this mode, if there is a
change in RF frequency or amplitude, you will need to press Do Power Search again.

Power Search References (Only applies to Internal I/Q Modulation)

The four Power Search References control the power search function. These four references select
the reference voltage used while the RF signal is being I/Q modulated. (Power search references are

not used for analog modulation: FM, fM, or pulse modulation.)

If the power search reference has the incorrect RMS voltage, the output
power will be incorrect. Refer to Figure 4-24, "Calculating the Output
Power Error for a Single Waveform Sample Point" and Figure 4-25,
“Calculating the RMS Voltage of the Waveform.”

A successful power search is dependent on a valid power search reference.
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— Fixed - Reference level is 0.5 Vrms.

This reference functions with internal, external IQ and bursted signals. This is the instrument’s
default setting.

— RMS - User provided reference level 0-1.414 VVrms placed in the Waveform Header. Refer to
“Saving a Waveform’s Settings & Parameters” on page 197.

This reference functions with internal IQ and bursted signals.
— Manual - User provided reference level 0-1.414 Vrms.

This reference functions with internal, external IQ and bursted signals.
— Modulated - Uses the I/Q modulation signal as the reference level.

This reference functions with internal or external 1Q. It is not functional with bursted signals or a
signal with varying Vrms.

Figure 4-24 Calculating the Output Power Error for a Single Waveform Sample Point

The Output Power Error= 20 x log10((V1)/(V2))

Where:
V1 is the actual waveform RMS voltage

V2 is the entered RMS voltage

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired. If the RMS
voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

Figure 4-25 Calculating the RMS Voltage of the Waveform

i
1
RMS value for the waveform = ;2 + qz .
n n N
n=1

The signal generator can calculate the RMS value automatically.if more

than two contiguous |Q data points are zero, the signal generator

calculation ignores those zero points. Also, because the RMS calculation,

that is done by the signal generator, is slow and may not be appropriate for N =4 of Samples
your application, it is recommended that the user calculate and enter in

their measured RMS value for the waveform file.

SCPI Commands:

[:SOURce]:RADio:ARB:HEADER:RMS <'file_name">,<val>|UNSPecified
[:SOURce]:RADio:ARB:HEADER:RMS? <"file_name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the Documentation
CD that came with this instrument.

The RMS and MANUAL references are the most powerful selections. The user provides the reference
level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the
RMS/MANUAL reference level is set, the power search runs independent of the current Vrms value
of the waveform.

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a calculated
rms value of 1 and can be measured using SINE_TEST_WFM.
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The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not
require the IQ signal to be present.

The MXG/EXG reference voltage is designed to operate between 0.1 Vrms
to 1 Vrms nominally, but it can overrange to 1.414 Vrms. (The RMS can
overrange to 1.414, if the constant values are loaded manually and all “1”s
are entered for the | and Q values.) See also “Saving a Waveform’s Settings
& Parameters” on page 197.

The minimum reference level that results in a successful power search is
dependent on RF Frequency, RF Amplitude, and Temperature. An
MXG/EXG power search using a reference level of 0.1 Vrms for 0 dBm at 1
GHz may fail.

Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:

The I/Q modulation enabled On.

The RF output enabled On.

The Automatic Leveling Circuitry deactivated (Off).
The RF Blanking set to On.

This function prevents power spikes during the power search (refer to “Using the RF Blanking
Marker Function” on page 214.)

When using summing for the internal Arb and the external I/Q, all four power reference modes
are available (e.g. Fixed, RMS, Manual, and Modulated).

When using the external IQ inputs, use the MANUAL reference mode, and make sure the
external I/Q signal is present when executing a power search. If the external I/Q signal is not
present, the power search will fail.

Example: Automatic Power Search

1. Preset the signal generator.
2. Set the desired frequency.

3.
4
5

Set the desired amplitude.

. Turn the RF output on.

. Deactivate the signal generator’s automatic :

Press AMPTD > ALC Off On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument
change that automatically initiates a power search.
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When set to Auto, power search automatically executes when a significant instrument setting
changes. The Do Power Search feature enables you to decide when to execute a power search to
compensate for changes, such as temperature drift or a change in the external input.

Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset
(positive or negative) from the entered value.

RF Output = entered value - offset value

Displayed Value = output frequency + offset value

To set an offset:

— Frequency: Press Freq > Freq Offset > offset value > frequency unit.

— Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Indicates that an offset is on

FREQUENCY ®
6.000 000 001 00 &z | -143.00 den ‘

Examples
Example | Example | Example
Parameter 1 42 43 Comments
Entered (and displayed) 300MHz | 300MHz | 2GHz The entered value must be positive.
Value:
Offset: 50 MHz —50MHz | -1 GHz An offset value can be positive or negative.
Output Frequency: 250MHz | 350MHz | 3GH, | /e sSignal generator alerts you ifthe
output frequency or amplitude is out of range.

When using the signal generator as a local oscillator (LO), you can use the offset to display the
frequency of interest, as illustrated below:
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Antenna tuned to 1321 MHz

RF Amplifier Mixer Filter IF Amplifier

IF Output
IF =321 MHz 321_MHZ_>
T Output Frequency = 1000 MHz
Selected Offset Slgnal Generator Display
321 MHz 1321 MHz (Antenna
_679 MHz Frequency)

Signal Generator
(local oscillator) 321 MHz (IF Output)

&

Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset
(positive or negative) by the entered value from a chosen reference value.

RF Output = reference value + entered value
To set a reference:
1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level”
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.

Indicates that a reference is on

FREQUEHCY REF ANPLITUDE REF

0.00 = | -144.00

Examples
Example | Example | Example

Parameter #1 4 43 Comments
Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.
Entered (and displayed) 2 MHz -2 MHz -1 GHz The entered value can be positive or negative.
Value:
Output Frequency: 57 MHz 48 MHz 1GHz The §|gnal generator alerts you if the output frequency or

amplitude is out of range.
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To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the

steps above.

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple
(positive or negative) of the output value.

Displayed Value = multiplier value “output frequency

Output Frequency = displayed value , multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency.

The display equals the output frequency times the multiplier value.

Indicates that a frequency multiplier is on

600.000 000 00 mz -144.00 den Frea Ref Set
HN:GU&UOUUUOOUMHZ Incr: 100.00000kHz Weg?
Freq Offset

0.00 Hz

Freg Multiplier
£32.000 %

Freq Channelse

02/25/2012 17:03 Hore 1 of 2

Examples
Example | Example | Example
Parameter 1 4 43 Comments
Frequency Multiplier: 3 -3 4 The multiplier range can be set from:
+0.001 to +1000
-1000 to -0.001
Entered (and displayed) 600 MHz | —600 8 GHz
Value: MHz
Output Frequency: 200MHz | 200MHz | 2 GHy The signal generator alerts you if the output frequency is
out of range.
108 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Optimize Performance
Using the Frequency and Phase Reference Softkeys

When using the signal generator as the input to a system, you can set the frequency multiplier so
that the signal generator displays the output of the system, as illustrated below using a doubler:

Signal Generator Doubler

| t=2GH Output = 4 GHz Selected Entered/Displayed  Signal Generator
npu GHz xp [UPUEIETE Multiplier ~ Frequency Output
2 4 GHz 2 GHz

When measuring mixers, the frequency multiplier and frequency offset are often used together. In
the upconverter example below, the multiplier is set to

-1 and the offset is set to 3 GHz so that the signal generator displays fgf.

Mixer

fre = 2200 2400 MHz ( E i ) fi = 3000 MHz

T fLo = 800 — 600 MHz

Selected Selected Entered/Displayed — Signal Generator
Multiplier Offset Frequency Output (fLo)
(fre)

Signal Generator -1 3000 MHz 2200 MHz 800 MHz
(local oscillator) -1 3000 MHz 2400 MHz 600 MHz

Using the Frequency and Phase Reference Softkeys

The MXG/EXG can be set to have either a user-determined frequency or phase reference.

Figure 4-26 Frequency Reference and Frequency Offset Softkeys
FREQUEHCY ANPLITUDE Frequency

600.000 000 00 mz -144.00 den Frea Ref Set

Freq: 600000 000 00 MHZ Incr: 100.00000kHz Fres EﬁF

Freq Offset

0.00 Hz

Freg Multiplier
1.000 =

Freq Channelse

02/25/2012 17:04 Hore 1 of 2
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Using Free Run, Step Dwell, and Timer Trigger

Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 4-27 on page 111) the signal generator waits for the signal
to settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In
addition, the time to complete the entire sweep can vary. There is always a minimum value of Step
Dwell for each frequency point. The minimum Step Dwell timing for any point is fixed at a value of
100 us. The time between frequency points is the sum of the settling time, plus the Step Dwell time.
The settling time is dependent on frequency, amplitude, band crossings, and other factors, so the
time between frequency points can vary.

Timer Trigger instead of Free Run (Figure 4-27 on page 111) the signal generator generates
equally spaced triggers, and it moves to the next point at each trigger. This has the advantage that
the time between points is consistent and the overall sweep time is consistent. But, if the trigger is
too fast, the signal may not have time to settle before jJumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the
point to point time is consistent, use Free Run and Set Dwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point
can vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the
signal generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms,
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers.
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Figure 4-27 Free Run, Set Dwell, and Timer Trigger Softkeys
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LOG

LIN Freq Step
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Markersm

N5173B/83B only
Enable Atten
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Off

fore 2 of 2
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Conf igure >
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(Free Fun Trioger Key

Point Trigger |

(Free Rurm™ \/ Bus
| EXT,

‘ (Trigger 1)

INT
N e (Pulse Sunc)®

fore 2 of 3 Hore !‘ of 2

Trigger Setup

Timer Trigger

For details on each key, use key help as described on see page 40.

Use Step Dwell with Free Run when additional measurement wait time is
desired after settling.

If the signal is to be settled for a minimum specific time at each point and it is
not important if the point to point time is consistent, use Step Dwell and Free
Run time.

If the signal’s point to point time requires
consistency but the specific settling time
at each point can vary, then use the
Timer Trigger. Avoid using too fast of a
sweep which does not allow the signal
generator to settle.
If the signal needs to be settled for a
specific minimum time and consistent
point to point time is required, then you
should set the Timer Trigger to be the
sum of the switching time (900 us (Option
Timer Trioger UNZ) or 5 ms (Standard)) plus the
. . q minimum settled time that is needed to
»-|Iria T”{‘?EDEB%QE make the measurement.

Example: If you need the signal to remain

settled for 3 ms, and you have Option

UNZ which settles in 0.9 ms, then set the

time trigger to the sum which is 3.9 ms.
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Using a USB Keyboard

You can use a USB keyboard to remotely control the RF output state, the modulation state, and to
select a memory sequence and register.

The register selection, RF output state, and modulation state are affected by power cycle or preset,
but the USB keyboard control state and the sequence selection are not.

To avoid the loss of data, GPIB settings, or current user instrument states
that have not been permanently saved to nonvolatile memory, the signal
generator should always be powered down either via the instrument’s
front panel power button or the appropriate SCPI command. Signal
generators installed in rack systems and powered down with the system
rack power switch rather than the instrument’s front panel switch display a
Error -310 due to the instrument not being powered down correctly.

Recal USB Keyboard Key Signal Generator Function
- Delete, Enter RF On/Off
Insert Mod On/Off
Home, Right Arrow Next Sequence
" THecall State | End, Left Arrow Previous Sequence )
Page Up, Up Arrow, + Recall Next State Register
Seqri] Hgggﬂ';'j Page Down, Down Arrow, — Recall Previous State Register
Select Reo:
Deletes every register in every sequence.
Select Seq: .
1 NOTE: You cannot recover the registers after
deleting them.
I — FREQUEHCY AAPLITUDE Auto Recall
elete
: »
Regs in Seat 1] 600.000 000 00 mz  -144.00 den Next. SED
fore 1 _of 2 -]
RECALL Reg: —— Prev SEQ
— T e SEQ—REG MOD RF
Mewxt. REG
Oelete AL
Sequences
Prev REG
Auto Recallyf———» E— —
USE Keuboard
Control
an

Turning the USB keyboard control off disables the USB
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on page 40.
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User’s Guide

5 Avionics VOR/ILS (Option 302)

This chapter describes the avionics softkeys used by Keysight N6171B/72B
EXG and N5181B/82B MXG X-Series signal generators with Option 302
Avionics License during either VOR [VHF Omnidirectional Ranging] or ILS
[Instrument Landing System] aircraft navigation receiver test. Avionics is a term
used to describe the electronic instrumentation on aircraft.

Before using the information in this chapter, you should be familiar with the
basic operation of the signal generator. If you are not comfortable with
functions such as setting the power level and frequency, refer to Chapter 3,
“Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

Use the Aux Fctn [Auxiliary Functions] key to access the Avionics softkeys.

Figure 5-1 Avionics Softkeys
[ Amiliary ]
| Homaarenerts”
Ruionicslr—,w
| wat—Using VOR [VHF Omnidirectional Range] Softkeys on page 114
1s Lacarizem—USING ILS Localizer Softkeys on page 129
1s s1ide s1oreef——USING ILS Glide Slope Softkeys on page 141
narker seaco|——USING ILS Marker Beacon Softkeys on page 153
KEYSIGHT

TECHNOLOGIES
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Using VOR [VHF Omnidirectional Range] Softkeys

Figure 5-2

The purpose of the VOR system is to provide directional information for aircraft
in flight. VOR ground based transmitter stations are strategically located to
provide complete coverage for air traffic. Each VOR ground based transmitter
station radiates a carrier in the range from 108.00 to 117.95 MHz, which is
modulated in a way that provides aircraft bearing information relative to the
VOR ground based transmitter location.

The VOR radiated electromagnetic signal consists of the sum of two antenna's
signals radiating at the same RF carrier frequency:

— The first antenna signal is from a non-directional antenna radiating a carrier
that is AM modulated by a signal that varies from 9480 Hz to 10440 Hz and
back 30 times per second.

— The second antenna signal is from a horizontal dipole which rotates at a
rate of 30 revolutions per second.The dipole produces a figure-eight
pattern. The RF voltages are opposite in polarity on front and back side of
the dipole pattern. Since the RF on one side is in phase with the RF radiated
from the non-directional antenna, a cardioid field pattern, which rotates at
30 Hz is formed. The signal received by the aircraft is an RF carrier with
amplitude varying at 30 Hz which is caused by the rotating cardioid pattern.
The carrier is also amplitude modulated by the 9960 Hz frequency
modulated sub-carrier. The 30 Hz FM signal provides the phase reference
and the 30 Hz AM caused by the cardioid pattern provides the variable
phase signal.

By demodulating the transmitted VOR signal, an aircraft receiver can compare
the phases of the two 30 Hz signals (REF Freqg vs VAR Freq) to determine the
compass bearing to a VOR station. By tuning to two or more VOR stations and
recording each bearing angle, pilots can determine their exact location on an
air chart by triangulation. A VOR Bearing Angle is the phase difference
between the 30 Hz reference signal (REF Freq) and the 30 Hz variable phase
signal (VAR Freq). The 30 Hz reference signal (REF Freq) is transmitted from
the ground-based stationary VOR transmitter while the 30 Hz variable phase
signal (VAR Freq) is transmitted from the VOR signal that is rotating at 30 Hz
clockwise.

VOR Transmitter Antenna Pattern

30 Hz Rotating 30 Hz
Signal Detected
—~— Reference
1 v Signal
I
I
| 30 Hz
} ~— Detected
\ I Bearing v Bearing
Q \ = Information Signal
30 Hz Fixed
Omnidirectional Signal VOR Signal Seen at Aircraft Receiver

VOR Antenna Pattern
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When using an X-Series signal generator with Option 302 Avionics License to
simulate VOR signals, the 30 Hz reference signal (REF Freq) is placed on a
sub-carrier of 9960 Hz (SubCarrier Freqg) using frequency modulation with a
peak deviation set to 480 Hz (REF Deviation). This frequency modulated
sub-carrier is then amplitude modulated onto one of the VOR carriers (108.00
to 117.95 MHz). This makes the reference signal essentially an FM/AM

multiplex signal.

Figure 5-3
—
VOR [ode

VOR Softkeys

(OFF)* UOR NODE

; - Sets a Carrier Frequency by selecting an Index from 1 to 160.
Carrier Fred | (Default: index is 1 and corrésponds to 108.00 MHz)
1

Bear ingl UOR Bearing
- Sets the Bearing angle
0.00"322 | FROM the VOR station VAR
REF /VAR»—UOR REF /UAR/SubC - Sets the frequency of .
REF /VAR _Fi the reference signal and 1] t 1 Sets the Bearing
29 | variable phase signal drection | - - i
COM/ID 30. z p 9 To direction as either SLErEr
- Sets the amount of Fhron\} SII’RTO .
REF Devistion | FM deviation the 30 Hz the station _ ;
—fore L of 2 | LB0.0 Hz | reference signal applies SRR A
on the sub-carrier
VAR_Deeth | sets AM depth of the
‘=~ " | variable phase signal
SubCarrier Freq | - Sets the frequency of
9.98000kHZ | the sub-carrier

SubCarrier Depth | - Sets the AM depth of
30.0 % | the sub-carrier as it

modulates the main carrier

- Turns off all
VOR modulation;
VOR carrier remains on.

- Turns on all

VOR modulation
and VOR carrier

- Turns on the VOR
carrier and variable
phase signal

- Turns on only the
sub-carrier

- Turns on the sub-carrier
modulated with the
reference signal

When testing a VOR system, the following VOR parameters can be set:

VOR Menu Parameters Default State
VOR Mode OFF
Carrier Freq Index 1 108.00 MHz
Bearing menu Angle 0.00 Deg
Direction From
REF/VAR menu REF/VAR Freq 30.00 Hz
REF Deviation 480.0 Hz
VAR Depth 30.0%
SubCarrier Freq 9.96000 kHz
SubCarrier Depth 30.0%

COM/ID menu?

a. Forinformation on the COM/ID menu,
refer to “Using COM/ID Softkeys” on page 124.
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To set the VOR mode that produces a full or partial VOR signal

1. Press Aux Fctn > Avionics > VOR

2. Press VOR Mode
(Default selection is OFF.)

3. Select either: OFF | NORM | VAR | Sub-carrier | Sub-carrier+FM

— Selecting OFF turns off all VOR modulation. When set to OFF, all VOR mode
parameter settings are turned off, but the selected VOR carrier is still
present on the RF Output connector. To turn off this VOR carrier, set
RF Off/On to Off.

— Selecting NORM turns on all VOR signals so that a standard VOR signal is
generated with a default VOR Bearing of zero degrees.

— Selecting VAR turns on the main VOR carrier and the 30 Hz variable phase
signal (VAR Freq); suppressed the Sub-carrier.

— Selecting Sub-carrier turns on the Sub-carrier without the 30 Hz reference
signal (REF Freq); suppresses the main VOR carrier.

— Selecting Sub-carrier+FM turns on the Sub-carrier and the 30 Hz reference
signal (REF Freq); suppresses the main VOR carrier.

To set the VOR carrier frequency

116

1. Press Aux Fctn > Avionics > VOR

2. Press Carrier Freq Index
(Default value is 1 and corresponds to 108.00 MHz.)

3. Select a value from 1 to 160 and press Enter.

The index value that is entered sets the VOR carrier frequency to one of the
standard defined corresponding values and produces a VOR carrier.

VOR carrier frequencies range from 108.00 to 117.95 MHz and can be set by
selecting index values from 1 to 160.

ILS Localizer frequencies range from 108.10 to 111.95 MHz, which overlaps the
VOR carrier frequency range, and can be set by selecting index values from 1
to 40. (For information, see: “To set the ILS Localizer carrier frequency” on
page 132.)

Because VOR carrier frequencies and ILS Localizer carrier frequencies have a
frequency range that overlaps, only frequencies where the 100 kHz digit is even
(tenths of a megacycle count is even) are used as VOR carrier frequencies.

The default VOR carrier frequency Index is 1 and corresponds to 108.00 MHz.

VOR Carrier Frequencies (MHz) ~ Carrier Freq Index =1 to 160
1t032 33 to 64 65 to 96 970128 1290 160
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108.00
108.05
108.20
108.25
108.40
108.45
108.60
108.65
108.80
108.85
109.00
109.05
109.20
109.25
109.40
109.45
109.60
109.65
109.80
109.85
110.00
110.05
110.20
110.25
110.40
110.45
110.60
110.65
110.80
110.85
111.00
111.05
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To set the VOR bearing angle between the VAR signal and the
REF signal

1. Press Aux Fctn > Avionics > VOR

2. Press Bearing

3. Press Angle
(Default value is 0.00 deg.)

4. Select a <value> from O to 360 deg and press Enter.

By demodulating the transmitted VOR signal, an aircraft receiver can compare
the phases of the two 30 Hz signals (REF Freq vs VAR Freq) to determine the
compass bearing to a VOR station. By tuning to two or more VOR stations and
recording each bearing angle, pilots can determine their exact location on an

air chart by triangulation.

A VOR Bearing Angle is the phase difference between the 30 Hz reference

signal (REF Freq) and the 30 Hz variable phase signal (VAR Freq).

The 30 Hz reference signal (REF Freq) is transmitted from the ground-based
stationary VOR transmitter while the 30 Hz variable phase signal (VAR Freq) is

transmitted from the VOR signal that is rotating at 30 Hz clockwise.

Figure 5-4 VOR Transmitter Antenna Pattern

30 Hz Fixed
Omnidirectional Signal VOR Signal Seen at Aircraft Receiver

VOR Antenna Pattern
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To set the VOR bearing direction as From or To

1. Press Aux Fctn > Avionics > VOR
2. Press Bearing

3. Press Direction
(Default selection is From.)

4. Select either From | To

From - In the From convention, the VOR transmitter beacon is made the
reference point and the Bearing Angle is between local magnetic-North and
the beacon-to-aircraft radial line (RL).

To - In the To convention, the aircraft is made the reference point and the
Bearing Angle is between local magnetic-North and the aircraft-to-beacon
radial line (RL).

RL(To) = 180° - RL(From)

To set the frequency of the reference signal (REF Freq) and the
variable phase signal (VAR Freq)

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press REF/VAR Freq
(Default value is 30 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 10 to 60 Hz.

Enter a value in Hz to set the frequency of the reference signal (REF Freq) and
the variable phase signal (VAR Freq).

To set the amount of FM deviation that the 30 Hz reference signal
(REF Freq) applies on the sub-carrier

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press REF Deviation
(Default value is 480 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 1 kHz.

Enter a value in Hz to set the amount of FM Deviation that the 30 Hz reference
signal (REF Freq) applies on the sub-carrier.

The 30 Hz reference signal (REF Freq) is placed on a sub-carrier of 9960 Hz
(SubCarrier Freq) using frequency modulation with a peak deviation set to
480 Hz (REF Deviation). This frequency modulated sub-carrier is then
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amplitude modulated onto one of the VOR carriers (108.00 to 117.95 MHz).
This makes the reference signal essentially an FM/AM multiplex signal.

To set the AM depth of the variable phase signal (VAR Freq)

1. Press Aux Fctn > Avionics > VOR
2. Press REF/VAR

3. Press VAR Depth
(Default value is 30%.)

4. Select a value from 0 to 49.9% and press Enter.

Enter a value in percentage to set the AM depth of the variable phase signal
(VAR Freq).

To set the frequency of the sub-carrier signal (SubCarrier Freq)
This process sets the frequency of the sub-carrier for a VOR signal.
1. Press Aux Fctn > Avionics > VOR
2. Press REF/VAR

3. Press SubCarrier Freq
(Default value is 9960 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 20 kHz.

The 30 Hz reference signal (REF Freq) is placed on a sub-carrier of 9960 Hz
(SubCarrier Freq) using frequency modulation with a peak deviation set to
480 Hz (REF Deviation). This frequency modulated sub-carrier is then
amplitude modulated onto a VOR carrier (108.00 to 117.95 MHz). This makes
the reference signal essentially an FM/AM multiplex signal.

To set the sub-carrier AM depth that modulates the VOR carrier

—

. Press Aux Fctn > Avionics > VOR
. Press REF/VAR

w N

. Press SubCarrier Depth
(Default value is 30%.)

4. Select a value from 0 to 49.9% and press Enter.

Enter a value in percentage to set the Sub-carrier AM depth as it modulates
the main carrier of a VOR signal.

Sub-carrier AM depth is typically 30%, but can range from O to 49.9%.
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To set or return the VOR subsystem parameters to a default state

This process returns the VOR system parameters to a set of default state
conditions.

1. Press Aux Fctn > Avionics > VOR
2. Press More 1 of 2
3. Press Recall Default Settings

VOR Menu Parameters Default State
VOR Mode OFF
Carrier Freq Index 1 108.00 MHz
Bearing menu Angle 0.00 Deg
Direction From
REF/VAR menu REF/VAR Freq 30.00 Hz
REF Deviation 480.0 Hz
VAR Depth 30.0%
SubCarrier Freq 9.96000 kHz
SubCarrier Depth 30.0%

COM/ID menu®

a. Forinformation on the COM/ID menu,
refer to “Using COM/ID Softkeys” on page 124.

Example of Setting All VOR Parameters

1. Press Preset to place the signal generator in a known preset state.
2. Set the VOR carrier frequency.
a. Press Aux Fctn > Avionics > VOR

b. Press Carrier Freq Index
(Default value is 1 and corresponds to 108.00 MHz
carrier frequency.)

c. (Optional) Select a value from 1 to 160 and press Enter
to change to a different carrier frequency.

3. Set the VOR bearing angle between the VAR signal and the REF signal.
a. Press Bearing

b. Press Angle
(Default value is 0.00 deg.)

c. (Optional) Select a value from 0 to 360 deg and press Enter.
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4. Set the VOR bearing direction as From or To.

a.

b.

Press Direction
(Default selection is From.)

(Optional) Select either From | To

5. Set the frequency of the reference signal (REF Freq)
and variable phase signal (VAR Freq).

a.
b.

C.

d.

Press Return
Press REF/VAR

Press REF/VAR Freq
(Default value is 30 Hz.)

(Optional) Select a <value> from 10 to 60 Hz.

6. Set the amount of FM deviation that the 30 Hz reference signal (REF Freq)
applies on the sub-carrier.

a.

b.

Press REF Deviation
(Default value is 480 Hz.)

(Optional) Select a <value> from 0 Hz to 1 kHz.

7. Set the AM depth of the variable phase signal (VAR Freq).

a.

b.

Press VAR Depth
(Default value is 30%.)

(Optional) Select a <value> from 0 to 49.9% and press Enter.

8. Set the frequency of the sub-carrier signal.

a.

b.

Press SubCarrier Freq
(Default value is 9960 Hz.)

(Optional) Select a <value> from 0 Hz to 20 kHz.

9. Set the sub-carrier AM depth that modulates the VOR carrier.

a.

b.

Press SubCarrier Depth
(Default value is 30%.)

(Optional) Select a <value> from 0 to 49.9% and press Enter.

10.Set the VOR mode to produce a full VOR signal.

a.

b.

C.

122

Press Aux Fctn > Avionics > VOR

Press VOR Mode
(Default selection is OFF.)

Select NORM to turn on all VOR signals so that a standard VOR
signal is generated with a default VOR Bearing of zero degrees.
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11.Set modulation to on.

a. Press MOD On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is on).

12.Set a desired RF power level.

a. Press Amptd
(Default power level is around -144 dBm, and depends on the signal
generator model being used, so the signal may be very low and hard
to find if you do not specify a high enough power level.)

b. Select a value from -20 dBm to -40 dBm.
13.Set RF output to on.

a. Press RF On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is off).

14.Verify that all settings are as expected on the signal generator display.
a. Press Aux Fctn > Avionics > VOR

b. Review the settings under
VOR Status Information
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Using COM/ID Softkeys

The purpose of COM/ID commands are to set parameters related to
airport communication identification codes. (This code may also be referred to
as an, “airport call-sign”.)

During VOR and ILS testing, a COM/ID code can be transmitted as a three
letter Morse-code signal of 1.02000 kHz and is placed on the carrier; this
COM/ID code is used to identify the ground-based transmitting station.

Fach COM/ID code (airport identification code) must correspond to one of the
International Air Transport Association (IATA) codes.

IATA owns, controls, and has a copyright to the complete list of airport
identification codes; STS is the airport identification code that refers to the
Sonoma County Airport in Santa Rosa, CA, USA.

Figure 5-5 COM/ID Softkeys
NMarker Beacon
Marker Beacon,
(Off)
Carrier Freq
Index
i ————— Con/Io
Marker Freg COoM/I0 - Turns off all
400.00 Hz El‘n COM/ID signals
- Sets either Code or Tone
il 5o Eo 1= | as the COMIID type
» COM/I0 Code - Sets a 3-character
(i STS | airport ID Code enclosed
Hore 1 of 2 in single or double-quotes
Frequency - Sets the COM/ID tone
1.02000kHz | modulating frequency
Depth - Sets the COM/ID tone
10.0 % amplitude modulation depth
. 0,
T (Range: 0 to 49.9%)

When testing a VOR [VHF Omnidirectional Ranging]
or ILS [Instrument Landing System],
the following COM/ID parameters can be set:

COM/ID Menu Parameters Default State
COM/ID Off/On Off
COM/ID Code/Type Code
COM/ID Code STS
Frequency 1.02000 kHz
Depth 10.0%
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To set the COM/ID on or off
This process toggles COM/ID Off (0) or On (1).
1. Press Aux Fctn > Avionics > VOR

2. Press COM/ID
(Default is COM/ID Off.)

3. Select either COM/ID Off | COM/ID On

When COM/ID is set to Off, all COM/ID functions are turned off and must be
set to On before any of the other COM/ID parameters have an effect.

To set the COM/ID type between Code or Tone

1. Press Aux Fctn > Avionics > VOR
2. Press COM/ID

3. Press COM/ID Type

4. Select either Code | Tone

Code - When set to Code, the signal generator plays the code associated with
the COM/ID Code setting.

— To change the COM/ID Code setting, see “To set the COM/ID 3-character
code (airport identification code)” on page 125

Tone - When set to Tone, the COM/ID Code setting is disabled and the signal
generator plays a continuous tone based on the COM/ID Frequency setting.

— To change the COM/ID Tone setting, see “To set the COM/ID tone/code
modulating frequency” on page 126

To set the COM/ID 3-character code (airport identification code)

—

. Press Aux Fctn > Avionics > VOR
. Press COM/ID

. Press COM/ID Code
(Default 3-character code is STS.)

w N

4, Select a 3-character code and select Enter.

Enter a valid COM/ID code (airport identification code) by typing a 3-character
code (for example, STS).

This value sets the airport communication identification code to be played by
the COM/ID generator. (This value/code may also be referred to as an,
“airport call-sign”.)

The COM/ID code is transmitted as a three letter-code signal of 1.02000 kHz
and is placed on the VOR carrier; this COM/ID code is used to identify the VOR
ground-based transmitting station.
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Fach COM/ID code (airport identification code) must correspond to one of the
International Air Transport Association (IATA) codes.

IATA owns, controls, and has a copyright to the complete list of airport
identification codes; STS is the airport identification code that refers to the
Sonoma County Airport in Santa Rosa, CA, USA.

To find a valid COM/ID code (airport communication identification code) for a
particular area, refer to the following websites:

Airline Coding Directory (http://www.iata.org)

AirNav (http://www.airnav.com)

To set the COM/ID tone/code modulating frequency

1. Press Aux Fctn > Avionics > VOR
2. Press COM/ID

3. Press Frequency
(Default value is 1.02000 kHz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 20 kHz.

Enter a value in Hz to set the frequency of the COM/ID tone
modulating frequency.

To set the COM/ID tone AM depth

1. Press Aux Fctn > Avionics > VOR
2. Press COM/ID

3. Press Depth
(Default value is 10%.)

4. Select a value from 0 to 49.9% and press Enter.

Enter a value in percentage to set the COM/ID tone AM depth.
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To set or return the COM/ID parameters to a default state

1. Press Aux Fctn > Avionics > VOR
2. Press COM/ID

3.

4. Press Recall Default Settings

Press More 1 of 2

Selecting these softkeys returns the COM/ID parameters to a set of default
state conditions.

COM/ID Menu Parameters Default State
COM/ID Off/On Off
COM/ID Code/Type Code
COM/ID Code STS
Frequency 1.02000 kHz
Depth 10.0%

Example of Setting All COM/ID Parameters

1.

Press Preset to place the signal generator in a known preset state.

2. Set the COM/ID type to Code.

a. Press Aux Fctn > Avionics > VOR
b. Press COM/ID

c. Press COM/ID Type
(Default setting is Code.)

d. Select Code

3. Set the COM/ID 3-character code (airport identification code).

a. Press COM/ID Code
(Default 3-character code is STS.)

b. (Optional) Select a 3-character code and select Enter.

To find a valid COM/ID code (airport communication identification
code) for a particular area, refer to the following websites:

Airline Coding Directory (http://www.iata.org)

AirNav (http://www.airnav.com)

4. Set the COM/ID tone/code modulating frequency.

a. Press Frequency
(Default value is 1.02000 kHz.)
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b. (Optional) Select a <value> from 0 Hz to 20 kHz.
5. Set the COM/ID tone AM depth.

a. Press Depth
(Default value is 10%.)

b. (Optional) Select a <value> from 0 to 49.9% and press Enter.

6. Set the COM/ID mode to on.

a. Press COM/ID
(Default is COM/ID Off.)

b. Select COM/ID On

7. Set modulation to on.

a. Press MOD On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is on).

8. Set a desired RF power level.

a. Press Amptd
(Default value is around -144 dBm, and depends on the signal
generator model being used, so the signal may be very low and hard
to find if you do not specify a high enough power level.)

b. Select a value from -20 dBm to -40 dBm.
9. Set RF output to on.

a. Press RF On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is off).

10.Verify that all settings are as expected on the signal generator display.
a. Press Aux Fctn > Avionics > VOR

b. Review the settings on the right-side of the display.
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Using ILS Localizer Softkeys

An ILS [Instrument Landing System] is a navigation system, used by aircraft to
obtain guidance to a runway (performing a “runway approach” while
attempting to land the aircraft) and includes the following three functions
operating in tandem (working together):

— ILS Localizer - ensures that the lateral/horizontal left-right approach of an
aircraft is aligned with the center of a runway

— ILS Glide Slope - ensures that the vertical descent path of an aircraft is
aligned to the proper descent path (~ 3 degrees downwards slope) of a
runway

— ILS Marker Beacons - ensures the proper distance from a runway; the
distances are based on the Outer, Middle, and Inner ILS Marker Beacons

The purpose of the ILS Localizer is to provide signals that indicate whether an
aircraft is left, right, or in-line with the glide path to a runway and enables a
pilot to adjust the aircraft left or right correctly during landing. This
lateral/horizontal correction is performed using two AM signals with an AM
depth of 20%, operating at a carrier frequency range between 108.10 to
111.95 MHz.

For an aircraft on approach, using the ILS Localizer to land on a runway, the
left signal is modulated at a frequency of 90 Hz AM by default and the right
signal is modulated at a frequency of 150 Hz AM by default.

The primary mechanism which makes it possible for a pilot to obtain guidance
to a runway is the aircraft receiver's ability to detect the “Difference in Depth of
Modulation (DDM)” between this 90 Hz and 150 Hz amplitude modulation.
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Figure 5-6 ILS Localizer: 108.10 MHz w/ 90 Hz AM (Left), 150 Hz AM (Right) @ 20%

150 Hz AM @ 20% Depth

Runway

90 Hz AM @ 20% Depth
Figure 5-7 ILS Glide Slope: 334.70 MHz w/ 90 Hz AM (Up), 150 Hz AM (Down) @ 40%

n

40% DeP"

g0 vz A = In-line
4% 0P
150 Hz R
Runway
Figure 5-8 ILS Marker Beacons: 75 MHz, Inner 3000 Hz, Middle 1300 Hz, Outer 400 Hz
75 MHz @ 75 MHz @ 75 WMHz @

13000 Hz | 11300 Hz | | 400 Hz |

3500 Feet
4 ‘ 5 Mies ‘

Runway Inner Marker  Middle Marker Outer Marker
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ILS Localizer Softkeys

Carrier Freq
Index

- Sets a Carrier Frequency by selecting an Index from 1 to 40.
(Default: Index is 1 and corresponds to 108.10 MHz)

——
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DOH /SO

COH/IOw

— LOC DDA/SDA

Flu
Right

Hore 1 of 2

DO
0.0000
OO LA
0.0 uA

oo =

0.00 =

S0
Lo.o =

When testing an ILS [Instrument Landing System],
the following ILS Localizer parameters can be set:

1 LOC Left/Rioht
Left Freduency
50.00 Hz
-Sets DDM Polarity [
Left | Right | In-line Riaht Freauencu
150.00 Hz
- Sets DDM (Difference i
in Depth of Modulation) LBF”HIQBFDE“?SS

- Sets DDM in uA

- Sets DDM in %.
DDM of 1% is
equivalent to 0.001

- Sets the Sum of
Depth of Modulation

ILS Localizer Menu
ILS LOC Mode
Carrier Freq Index

Left/Right menu

DDM/SDM menu

COM/ID menu?

a. Forinformation on the COM/ID menu,

- Sets Left Frequency
- Sets Right Frequency

- Sets the Phase of the
Right signal relative to
the Left signal

Parameters

1

Left Frequency
Right Frequency
Left/Right Phase
Fly Left/Right
DDM

DDM uA

DDM%

SDM

P ————
1 ILS LOG NODE

Suppress Right

- Turns off the Left (90 Hz)
orr | and Right (150 Hz)

ILS Localizer signals

- Turns on the Left (90 Hz)
and Right (150 Hz)

ILS Localizer signals

- Turns off the Left (90 Hz)
ILS Localizer signal

MORM

Suppress Left

- Turns off the Right (150 Hz)
ILS Localizer signal

Default State
OFF

108.10 MHz
90 Hz

150 Hz
0.00 deg
None
0.0000

0.0 uA
0.00%
40.0%

refer to “Using COM/ID Softkeys” on page 124.

To set the ILS Localizer mode to produce a full or partial signal

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press ILS LOC Mode
(Default selection is OFF.)
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3. Select either: OFF | NORM | Suppress Left | Suppress Right

These softkeys allow selection of a complete or partial ILS Localizer signal and
can set the ILS Localizer Mode to one of the following:

— Selecting OFF turns off both the Left (90 Hz) and the Right (150 Hz)
ILS Localizer signals. When set to OFF, all ILS Localizer mode parameter
settings are turned off, but the selected ILS Localizer carrier is still present
on the RF Output connector. To turn off this ILS Localizer carrier, set
RF Off/On to Off.

— Selecting NORM turns on both the Left (90 Hz) and the Right (150 Hz)
ILS Localizer signals.

— Selecting Suppress Left turns off the Left (930 Hz) ILS Localizer signal.
— Selecting Suppress Right turns off the Right (150 Hz) ILS Localizer signal.

To set the ILS Localizer carrier frequency

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press Carrier Freq Index
(Default value is 1 and corresponds to 108.10 MHz.)

3. Select a value from 1 to 40 (108.10 to 111.95 MHz) and press Enter.

These softkeys set a carrier index between 1 and 40.
Each index corresponds to a standard defined ILS Localizer carrier channel in
the range from 108.10 to 111.95 MHz.

There are forty channels that are allocated to the ILS Localizer in the range
from 108.10 to 111.95 MHz; each ILS Localizer carrier has a corresponding ILS
Glide Slope carrier frequency in the range from 329.15 to 335.00 MHz.

The default ILS Localizer carrier frequency Index is 1 and corresponds to
108.10 MHz.

ILS Localizer and Corresponding ILS Glide Slope
Carrier Frequencies (MHz)

ILS Localizer  ILS Glide ILS Localizer  ILS Glide

(MHz) Index  Slope (MHz) Slope

1-20 (MHz) Index | Index21-40  (MHz) Index
1-20 21-40

1=108.10 1=334.70 21=110.10 21=334.40
2=108.15 2=334.55 22=110.15 22=334.25
3=108.30 3=334.10 23=110.30 23=335.00
4=108.35 4=333.95 24=110.35 24=334.85
5=108.50 5=329.90 25=110.50 25=329.60
6=108.55 6=329.75 26=110.55 26=329.45
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7=108.70 7=330.50 27=110.70 27=330.20
8=108.75 8=330.35 28=110.75 28=330.05
9=108.90 9=329.30 29=110.90 29=330.80
10=108.95 10=329.15 30=110.95 30=330.65
11=109.10 11=331.40 31=111.10 31=331.70
12=109.15 12=331.25 32=111.15 32=331.55
13=109.30 13=332.00 33=111.30 33=332.30
14=109.35 14=331.85 34=111.35 34=332.15
15=109.50 15=332.60 35=111.50 35=332.90
16=109.55 16=332.45 36=111.55 36=332.75
17=109.70 17=333.20 37=111.70 37=333.50
18=109.75 18=333.05 38=111.75 38=333.35
19=109.90 19=333.80 39=111.90 39=331.10
20=109.95 20=333.65 40=111.95 40=330.95

To set the ILS Localizer left frequency

1. Press Aux Fctn > Avionics > ILS Localizer
2. Press Left/Right

3. Press Left Frequency
(Default value is 90 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 6 MHz.
These softkeys set the frequency of the Left ILS Localizer signal.

To set the ILS Localizer right frequency

1. Press Aux Fctn > Avionics > ILS Localizer
2. Press Left/Right

3. Press Right Frequency
(Default value is 150 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.
These softkeys set the frequency of the Right ILS Localizer signal.
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To set the ILS Localizer phase of the right signal relative to the left

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press Left/Right Phase
(Default value is 0.00 deg.)

3. Select a value from 0.00 deg to 360 deg and press Enter.

These softkeys set the phase of the right (150 Hz) ILS Localizer signal relative
to the left (90 Hz) ILS Localizer signal.

To set the ILS Localizer DDM polarity to fly left or fly right

134

1. Press Aux Fctn > Avionics > ILS Localizer
2. Press DDM/SDM

3. Press Fly Left | Right
(Default selection is Left.)

4. Select either Left | Right

These softkeys set the “Difference in Depth of Modulation” (DDM)
polarity of the ILS Localizer signal to either:
LEFT = positive | RIGHT = negative

The ILS Localizer provides signals that indicate whether an aircraft is Left,
Right, or in-line with the glide path to the runway and enables a pilot to adjust
the aircraft Left or Right correctly during landing. This lateral/horizontal
correction is performed using two AM carriers with an AM depth of 20%,
operating at a carrier frequency range between 108.10 - 111.95 MHz.

For an aircraft on approach, the left signal is modulated at a frequency of 90 Hz
by default, and the right signal is modulated at a frequency of 150 Hz by
default. When an aircraft is in-line with the glide path to the runway, the
amplitude of the 90 Hz and 150 Hz sine-wave signals are equal. Left or right of
this glide path, the amplitudes are different.The difference in amplitude can
determine the relative position of an aircraft from this theoretical glide path.

The primary mechanism which makes it possible for a pilot to obtain guidance
to a runway is the aircraft receiver's ability to detect the “Difference in Depth of
Modulation (DDM)” between the 90 Hz modulation and the

150 Hz modulation.

DDM is defined to be the “percentage modulation depth of the larger signal”
minus the “percentage modulation depth of the smaller signal”,
divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

When this formula yields a negative DDM value, the right signal at 150 Hz is
stronger; this is indicating that the aircraft is to the Right of the ILS Localizer
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centerline signal and would have to Fly “Left” to bring the DDM value back to
zero so that the aircraft is back in-line with the centerline of the runway.

Figure 5-10 ILS Localizer @ 108.10 MHz w/ Aircraft In-Line, Fly Left, Fly Right

150 Hz AM @ 20% Depth

= -l_'- In-line

Runway

90 Hz AM @ 20% Depth

150 Hz AM @ 20% Depth

A, FlyLeft

' to correct

Runway

90 Hz AM @ 20% Depth

150 Hz AM @ 20% Depth

N Fly Right
to correct

<
Hnwey 90 Hz AM @ 20% Depth '

Example:

To correct if the left signal at 90 Hz is stronger at 0.2 DDM, the
aircraft would have to be pointed Right with a DDM of 0.2.

The following steps of key presses demonstrate the correction for Right:
1. Aux Fctn > Avionics.
2. ILS Localizer > DDM/SDM > Fly Left Right to Right highlighted.
3. DDM > 0.2 > Enter.
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Example:

To correct if the right signal at 150 Hz is stronger at -0.2 DDM,
the aircraft would have to be pointed Left with a DDM of -0.2

The following steps of key presses demonstrate the correction for Left:
1. Aux Fctn > Avionics.
2. ILS Localizer > DDM/SDM > Fly Left Right to Left highlighted.
3. DDM > -0.2 > Enter.

To set the ILS Localizer DDM value

This process sets a value for the Difference in Depth of Modulation (DDM).
1. Press Aux Fctn > Avionics > ILS Localizer
2. Press DDM/SDM

3. Press DDM
(Default value is 0.0000.)

4. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (-0.40 to 0.40)
for most applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is
available. The following demonstrates the limits of DDM’s range:

(-SDM/100) to (SDM/100)
As SDM’s value increases or decrease, so does DDM’s range.

DDM is defined to be the “percentage modulation depth of the larger signal”
minus the “percentage modulation depth of the smaller signal”,
divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

The primary mechanism which makes it possible for a pilot to obtain guidance
to a runway is the aircraft receiver's ability to detect the DDM between the 90
Hz and 150 Hz amplitude modulation.

To set the ILS Localizer DDM value in micro-amps (UA)

136

This process sets a value for the difference in depth of modulation (DDM)
in HA.

1. Press Aux Fctn > Avionics > ILS Localizer.
2. Press DDM/SDM.
3. Press DDM uA
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4. Enter avalue that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range for most
applications.

If SDM is set to 99%, then the full range (-958.1 to 958.1 uA) of DDM uA is
available. The following demonstrates the limits of DDM uA’s range:

((-SDM/100)*(150/.155)) to ((SDM/100)*(150/.155))
As SDM'’s value increases or decrease, so does the range.

The DDM uA default value is 0.0 uA.

To set the ILS Localizer DDM value as a percentage (%)

This process sets a value for the difference in depth of modulation (DDM)
in %. DDM can be expressed either in terms of percentage (%) or as a
modulation index. A DDM of 1% is equivalent to 0.01 DDM.

—

. Press Aux Fctn > Avionics > ILS Localizer
. Press DDM/SDM

. Press DDM%
(Default value is 0.00%.)

w N

4. Enter a value within the range of the current SDM value.

Typically the SDM default value provides sufficient range (-40% to 40%)
for most applications.

If SDM is set to 99%, then the full range (-99% to 99%) of DDM is
available. The following demonstrates the limits of DDM’s range:

(-SDM) to (SDM)

As SDM'’s value increases or decrease, so does DDM’s range.

To set the ILS Localizer SDM value
This process sets the sum of depth of modulation (SDM):
1. Press Aux Fctn > Avionics > ILS Localizer
2. Press DDM/SDM
3. Press SDM
(Default value is 40.00%.)
4. Select a value from 0 to 99% and press Enter.
The SDM range is defined by the following equation:
SDM = [AM(90 Hz) + AM(150 Hz)] / 100:
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To set or return the ILS Localizer parameters to a default state

138

This process returns the ILS Localizer parameters to a set of default state

conditions.

1. Press Aux Fctn > Avionics > ILS Localizer
2. Press More 1 of 2

3. Press Recall Default Settings

The following table lists the default values:

ILS Localizer Menu  Parameters
ILS LOC Mode
Carrier Freq Index 1
Left/Right menu Left Frequency
Right Frequency
Left/Right Phase
DDM/SDM menu Fly Left/Right
DDM
DDM uA
DDM%
SDM

COM/ID menu®

a. For information on the COM/ID menu,

Default State
OFF

108.1 MHz
90 Hz

150 Hz
0.00 deg
Left
0.0000
0.0 uA
0.00%
40.0%

refer to “Using COM/ID Softkeys” on page 124.
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Example of Setting All ILS Localizer Parameters

—

. Press Preset to place the signal generator in a known preset state.

N

. Set the ILS Localizer carrier frequency.
a. Press Aux Fctn > Avionics > ILS Localizer

b. Press Carrier Freq Index
(Default value is 1 and corresponds to 108.10 MHz
carrier frequency.)

c. (Optional) Select a value from 1 to 40 and press Enter
to change to a different carrier frequency.

3. Set the ILS Localizer left frequency.
a. Press Left/Right

b. Press Left Frequency
(Default value is 90 Hz.)

c. (Optional) Select a <value> from 0 Hz to 6 MHz.
4. Set the ILS Localizer right frequency.

a. Press Right Frequency
(Default value is 150 Hz.)

b. (Optional) Select a <value> from 0 Hz to 10 MHz.
5. Set the ILS Localizer phase of the right signal relative to the left.

a. Press Left/Right Phase
(Default value is 0.00 deg.)

b. (Optional) Select a <value> from 0.00 deg to 360 deg and press
Enter.

6. Set the ILS Localizer DDM polarity to fly left or fly right.
a. Press Return
b. Press DDM/SDM

c. Press Fly Left | Right
(Default selection is Left.)

d. (Optional) Select either Left | Right
7. Set the ILS Localizer DDM value.

a. Press DDM
(Default value is 0.0000)

b. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (-0.40 to
0.40) for most applications.
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If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is
available. The following demonstrates the limits of DDM’s range:

(-SDM/100) to (SDM/100)
As SDM'’s value increases or decrease, so does DDM’s range.
8. Set the ILS Localizer SDM value.

a. Press SDM
(Default value is 40.00%.)

b. (Optional) Select a <value> from 0 to 99% and press Enter.
9. Set the ILS Localizer mode.

a. Press ILS LOC Mode
(Default selection is OFF.)

b. Select NORM to turn on both the Left (90 Hz) and the Right (150 Hz)
ILS Localizer signals.

10.Set the modulation to on.

a. Press MOD On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is on).

11.Set a desired RF power level.

a. Press Amptd
(Default power level is around -144 dBm, and depends on the signal
generator model being used, so the signal may be very low and hard
to find if you do not specify a high enough power level.)

b. Select a value from -20 dBm to -40 dBm.
12.Set the RF output to on

a. Press RF On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is off).

13.Verify that all settings are as expected on the signal generator display.
a. Press Aux Fctn > Avionics > ILS Localizer

b. Review the settings under
ILS-LOC Status Information
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Using ILS Glide Slope Softkeys

An ILS [Instrument Landing System] is a navigation system, used by aircraft to
obtain guidance to a runway (performing a “runway approach” while
attempting to land the aircraft) and includes the following three functions
operating in tandem (working together):

— ILS Localizer - ensures that the lateral/horizontal left-right approach of an
aircraft is aligned with the center of a runway

— ILS Glide Slope - ensures that the vertical descent path of an aircraft is
aligned to the proper descent path (~ 3 degrees downwards slope) of a
runway

— ILS Marker Beacons - ensures the proper distance from a runway; the
distances are based on the Outer, Middle, and Inner ILS Marker Beacons

The purpose of the ILS Glide Slope is to provide signals that indicate whether
an aircraft is above, below, or in-line with the glide path to a runway and
enables a pilot to adjust the aircraft up or down correctly during landing. This
Is the same type of information as provided by the ILS Localizer, but for the
vertical reference rather than the lateral/horizontal reference; the same
modulation and antenna techniques are used. This vertical correction is
performed using two AM signals with an AM depth of 40%, operating at a
carrier frequency range between 329.90 to 334.70 MHz.

For an aircraft on approach, using the ILS Glide Slope to land on a runway, the
upper signal is modulated at a frequency of 90 Hz AM by default, and the
lower signal is modulated at a frequency of 150 Hz AM by default.

The primary mechanism which makes it possible for a pilot to obtain guidance
to a runway is the aircraft receiver's ability to detect the “Difference in Depth of
Modulation (DDM)” between this 90 Hz and 150 Hz amplitude modulation.
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Figure 5-11 ILS Localizer: 108.10 MHz w/ 90 Hz AM (Left), 150 Hz AM (Right) @ 20%

150 Hz AM @ 20% Depth

Runway

90 Hz AM @ 20% Depth
Figure 5-12 ILS Glide Slope: 334.70 MHz w/ 90 Hz AM (Up), 150 Hz AM (Down) @ 40%
n
40% DeP"
g0 ¥z AM = In-line
n
40% D°P*
~go vz AV
Runway
Figure 5-13 ILS Marker Beacons: 75 MHz, Inner 3000 Hz, Middle 1300 Hz, Outer 400 Hz
75 MHz @ 75 MHz @ 75 WMHz @

13000 Hz | 11300 Hz | | 400 Hz |

3500 Feet
4 ‘ 5 Mies ‘

Runway Inner Marker  Middle Marker Outer Marker
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ILS Glide Slope Softkeys

ILS GS Mode,
(OFF)”™

l - Sets a Carrier Frequency by selecting an Index from 1 to 40.

Carrier Fre:

Indeﬂ (Default: Index is 1 and corresponds to 334.70 MHz)
1

Up /DOHN®-

DOM /SO —' GS DDn/Son

Con/IoN| |

More 1 of 2

Fly
=8 Cokn

DOl
0.0000

O0H uA
0.0 uA

00K
0.00 7

S0K
a0.0 %

- Sets DDM Polarity
Up | Down | In-line

- Sets DDM (Difference
in Depth of Modulation)

- Sets DDM in uA

- Sets DDM in %.
DDM of 1% is
equivalent to 0.001
- Sets the Sum of
Depth of Modulation

GS Up/Doun
Up Frequency
90.00 Hz

Doun Fregquency
150.00 Hz

Up/Down Phase
0.00 deg

- Sets the Frequency of
the Up signal

- Sets the Frequency of
the Down signal

- Sets the Phase of the
Down signal relative to
the Up signal

1 ILS GS HODE

- Turns off the Up (90 Hz)
and Down (150 Hz)

| L ILS Glide Slope signals
- Turns on the Up (90 Hz)
wopn | and Down (150 Hz)

Suppress Up

ILS Glide Slope signals

- Turns off the Up (90 Hz)
ILS Glide Slope signal

When testing an ILS [Instrument Landing System],

the following ILS Glide Slope parameters can be set:

ILS Glide Slope Menu

ILS GS Mode
Carrier Freq Index

Up/Down menu

DDM/SDM menu

COM/ID menu?

Parameters

1

Up Frequency
Down Frequency
Up/Down Phase
Fly Up/Down
DDM

DDM uA

DDM%

SDM

a. For information on the COM/ID menu,
refer to “Using COM/ID Softkeys” on page 124.
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Suppress Down

Default State
OFF

334.70 MHz
90 Hz

150 Hz
0.00 deg
Up

0.0000

0.0 uA
0.00%
80.0%
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To set the ILS Glide Slope mode to produce a full or partial signal

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press ILS GS Mode
(Default selection is OFF.)

3. Select either: OFF | NORM | Suppress Up | Suppress Down

These softkeys allow selection of a complete or partial ILS Glide Slope signal
and can set the ILS Glide Slope Mode to one of the following:

— Selecting OFF turns off all ILS Glide Slope signals. When set to OFF, all
ILS Glide Slope mode parameter settings are turned off, but the selected
ILS Glide Slope carrier is still present on the RF Output connector. To turn
off this ILS Glide Slope carrier, set RF Off/On to Off.

— Selecting NORM turns on both Up (90 Hz) and Down (150 Hz) ILS Glide
Slope signals.

— Selecting Suppress Up turns off the Up (90 Hz) ILS Glide Slope signal.

— Selecting Suppress Down turns off the Down (150 Hz) ILS Glide Slope
signal.

To set the ILS Glide Slope carrier frequency
1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press Carrier Freq Index
(Default value is 1 and corresponds to 334.70 MHz.)

3. Select a value from 1 to 40 (see table) and press Enter.

There are forty channels that are allocated to the ILS Localizer in the range
from 108.10 to 111.95 MHz; each ILS Localizer carrier has a corresponding ILS
Glide Slope carrier frequency in the range from 329.15 to 335.00 MHz,

The default ILS Glide Slope carrier frequency Index is T and corresponds to
334.70 MHz.

ILS Localizer and Corresponding ILS Glide Slope
Carrier Frequencies (MHz)

ILS Localizer LS Glide ILS Localizer LS Glide
Index 1-20 Slope Index 21-40  Slope
Index 1-20 Index 21-40

1=108.10 1=334.70 21=110.10 21=334.40
2=108.15 2=334.55 22=110.15 22=334.25
3=108.30 3=334.10 23=110.30 23=335.00
4=108.35 4=333.95 24=110.35 24=334.85
5=108.50 5=329.90 25=110.50 25=329.60
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To set the ILS Glide Slope up frequency
This process sets the ILS Glide Slope up frequency.
1.
2.
3.

4,

6=108.55

7=108.70

8=108.75

9=108.90

10=108.95
11=109.10
12=109.15
13=109.30
14=109.35
15=109.50
16=109.55
17=109.70
18=109.75
19=109.90
20=109.95

6=329.75

7=330.50

8=330.35

9=329.30

10=329.15
11=331.40
12=331.25
13=332.00
14=331.85
15=332.60
16=332.45
17=333.20
18=333.05
19=333.80
20=333.65

Press Aux Fctn > Avionics > ILS Glide Slope

Press Up/Down

Press Up Frequency
(Default value is 90 Hz.)

26=110.55
27=110.70
28=110.75
29=110.90
30=110.95
31=111.10
32=111.15
33=111.30
34=111.35
35=111.50
36=111.55
37=111.70
38=111.75
39=111.90
40=111.95

Select a value in Hz | kHz | MHz | GHz from 0 Hz to 6 MHz.

To set the ILS Glide Slope down frequency

This process sets the ILS Glide Slope down frequency.
1.
2.
3.
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Press Aux Fctn > Avionics > ILS Glide Slope

Press Up/Down

Press Down Frequency
(Default value is 150 Hz.)

Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

26=329.45
27=330.20
28=330.05
29=330.80
30=330.65
31=331.70
32=331.55
33=332.30
34=332.15
35=332.90
36=332.75
37=333.50
38=333.35
39=331.10
40=330.95
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To set the ILS Glide Slope phase of the down signal relative to the up

This process sets the phase of the Down (150 Hz) ILS Glide Slope signal
relative to the Up (90 Hz) ILS Glide Slope signal.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press Up/Down Phase
(Default value is 0.00 deg.)

3. Select a value from 0.00 deg to 360 deg and press Enter.

To set the ILS Glide Slope DDM polarity to fly up or fly down
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1. Press Aux Fctn > Avionics > ILS Glide Slope
2. Press DDM/SDM

3. Press Fly Up | Down
(Default selection is Up.)

4. Select either Up | Down

The ILS Glide Slope enables a pilot to adjust the aircraft up or down correctly
during landing.

The ILS Glide Slope provides signals that indicate whether an aircraft is above,
below, or in-line with the glide path to the runway and enables a pilot to adjust
the aircraft Up or Down correctly during landing.

This is the same type of information as provided by the ILS Localizer, but for
the vertical reference rather than the lateral/horizontal reference; the same
modulation and antenna techniques are used.

This vertical adjustment is performed using two AM signals with an AM depth
of 40% operating at a carrier frequency range between 329.90 to 334.70 MHz.

For aircraft approach, the upper signal is modulated at a frequency of 90 Hz
AM by default, and the lower signal is modulated at a frequency of 150 Hz AM
by default.

The primary mechanism which makes it possible for a pilot to obtain guidance
to a runway is the aircraft receiver's ability to detect the “Difference in Depth of
Modulation (DDM)” between the 90 Hz and the 150 Hz amplitude modulation.

DDM is defined to be the “percentage modulation depth of the larger signal”
minus the “percentage modulation depth of the smaller signal”,
divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

When this formula yields a positive DDM value, the upper signal at 90 Hz is
stronger; this is indicating that the aircraft is Above the ILS Glide Slope
centerline signal and would have to Fly “Down” to bring the DDM value back to
zero so that the aircraft is back in-line with the centerline of the runway.
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Figure 5-15 ILS Glide Slope @ 334.70 MHz w/ Aircraft In-Line, Fly Down, Fly Up
oz AM o 0P = In-line
4ot DePt
150 Hz P
Runway
 Fly Down

to correct

Runway

, FlyUp
=" to correct

Runway

Example:

To correct if the upper tone at 90 Hz is stronger at 0.4 DDM, the aircraft
would have to fly Down with a DDM of 0.4.

The following steps of key presses demonstrate the fly Down correction:
1. Aux Fctn > Avionics.
2. ILS Glide Slope > DDM/SDM > Fly Up Down to Down highlighted.
3. DDM > 0.4 > Enter.

Example:

To correct if the upper tone at 150 Hz is stronger at -0.4 DDM, the aircraft
would have to fly Up with a DDM of -0.4.

The following steps of key presses demonstrate the fly Up correction:

1. Aux Fctn > Avionics.

2. ILS Glide Slope > DDM/SDM > Fly Up Down to Up highlighted.
3. DDM > -0.4 > Enter.
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To set the ILS Glide Slope DDM value
This process sets a value for the “Difference in Depth of Modulation” (DDM).

1.
2.
3.

Press Aux Fctn > Avionics > ILS Glide Slope
Press DDM/SDM

Press DDM
(Default value is 0.0000.)

Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (-0.80 to 0.80)
for most applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is
available. The following demonstrates the limits of DDM’s range:

(-SDM/100) to (SDM/100)

As SDM'’s value increases or decrease, so does DDM’s range.

The primary mechanism which makes it possible for a pilot to obtain guidance
to a runway is the aircraft receiver's ability to detect the “Difference in Depth of
Modulation (DDM)” between this 90 Hz and 150 Hz amplitude modulation.

DDM is defined to be the “percentage modulation depth of the larger signal”
minus the “percentage modulation depth of the smaller signal”,
divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

To set the ILS Glide Slope DDM value in micro-amps (UA)

148

This process sets a value for the difference in depth of modulation (DDM)
expressed in PA.

W N -

4,

Press Aux Fctn > Avionics > ILS Glide Slope
Press DDM/SDM

Press DDM uA
(Default value is 0.0 pA.)

Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range for most
applications.

If SDM is set to 99%, then the full range (-846.6 to 846.6 pA) of DDM uA is
available. The following demonstrates the limits of DDM uA’s range:

((-SDM/100)*(150/.175)) to ((SDM/100)*(150/.175))

As SDM’s value increases or decrease, so does the range.
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To set the ILS Glide Slope DDM value in percentage (%)

This process sets a value for the difference in depth of modulation (DDM)
in %. DDM can be expressed either in terms of percentage (%) or as a
modulation index. A DDM of 1% is equivalent to 0.01 DDM.

—

. Press Aux Fctn > Avionics > ILS Glide Slope
. Press DDM/SDM

. Press DDM%
(Default value is 0.00%.)

w N

4. Enter a value within the range of the current SDM value.

Typically the SDM default value provides sufficient range (-80% to 80%)
for most applications.

If SDM is set to 99%, then the full range (-99% to 99%) of DDM is
available. The following demonstrates the limits of DDM’s range:

(-SDM) to (SDM)

As SDM'’s value increases or decrease, so does DDM’s range.

To set the ILS Glide Slope SDM value
This process sets the sum of depth of modulation (SDM):
1. Press Aux Fctn > Avionics > ILS Glide Slope
2. Press DDM/SDM
3. Press SDM

4. Select a value from 0 to 99% and press Enter.
(Default value is 80%.)

The SDM value is calculated using the following equation:
SDM = [AM(90 Hz) + AM(150 Hz)] / 100
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To set or return the ILS Glide Slope parameters to a default state

150

This process returns the ILS Glide Slope parameters
to a set of default state conditions.

1. Press Aux Fctn > Avionics > ILS Glide Slope
2. Press More 1 of 2
3. Press Recall Default Settings

ILS Glide Slope Menu Parameters Default State
ILS GS Mode OFF
Carrier Freq Index 1 334.70 MHz
Up/Down menu Up Frequency 90 Hz
Down Frequency 150 Hz
Up/Down Phase 0.00 deg
DDM/SDM menu Fly Up/Down Up
DDM 0.0000
DDM uA 0.0uA
DDM% 0.00%
SDM 80.0%

COM/ID menu?

a. For information on the COM/ID menu,
refer to “Using COM/ID Softkeys” on page 124.
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Example of Setting All ILS Glide Slope Parameters

N =

Press Preset to place the signal generator in a known preset state.
Set the ILS Glide Slope carrier frequency.
a. Press Aux Fctn > Avionics > ILS Glide Slope

b. Press Carrier Freq Index
(Default value is 1 and corresponds to 334.70 MHz.)

c. (Optional) Select a <value> from 1 to 40 and press Enter to change
to a different carrier frequency.)

Set the ILS Glide Slope up frequency.
a. Press Up/Down

b. Press Up Frequency
(Default value is 90 Hz.)

c. (Optional) Select a <value> from 0 Hz to 6 MHz.
Set the ILS Glide Slope down frequency.

a. Press Down Frequency
(Default value is 150 Hz.)

b. (Optional) Select a <value> from 0 Hz to 10 MHz.
Set the ILS Glide Slope phase of the down signal relative to the up.

a. Press Up/Down Phase
(Default value is 0.00 deg.)

b. (Optional) Select a <value> from 0.00 deg to 360 deg and press
Enter.

Set the ILS Glide Slope DDM polarity to fly up or fly down.
a. Press Return
b. Press DDM/SDM

c. Press Fly Up | Down
(Default selection is Up.)

d. (Optional) Select either Up | Down
Set the ILS Glide Slope DDM value.

a. Press DDM
(Default value is 0.0000.)

Keysight EXG and MXG X-Series Signal Generators User’s Guide 157



Avionics VOR/ILS (Option 302)
Using ILS Glide Slope Softkeys

b. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (-0.80 to
0.80) for most applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is
available. The following demonstrates the limits of DDM’s range:

(-SDM/100) to (SDM/100)
As SDM'’s value increases or decrease, so does DDM’s range.
8. Set the ILS Glide Slope SDM value.

a. Press SDM
(Default value is 80%.)

b. (Optional) Select a <value> from 0 to 99% and press Enter.
9. Set the ILS Glide Slope mode.

a. Press ILS GS Mode
(Default selection is OFF.)

b. Select NORM to turn on both the Up (90 Hz) and Down (150 Hz)
ILS Glide Slope signals.

10.Set the modulation to on.

a. Press MOD On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is on).

11.Set a desired RF power level.

a. Press Amptd
(Default power level is around -144 dBm, and depends on the signal
generator model being used, so the signal may be very low and hard
to find if you do not specify a high enough power level.)

b. Select a value from -20 dBm to -40 dBm.
12.Set the RF output to on.

a. Press RF On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is off).

13.Verify that all settings are as expected on the signal generator display.
a. Press Aux Fctn > Avionics > ILS Glide Slope

b. Review the settings under
ILS-GS Status Information
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Using ILS Marker Beacon Softkeys

Figure 5-16

Narker Beacon

Marker Beacon
(OffFI"

An ILS [Instrument Landing System] is a navigation system, used by aircraft to
obtain guidance to a runway (performing a “runway approach”) and includes
the following three functions operating in tandem (working together):

— ILS Localizer - ensures that the lateral/horizontal left-right approach of an
aircraft is aligned with the center of a runway

— ILS Glide Slope - ensures that the vertical descent path of an aircraft is
aligned to the proper descent path (~ 3 degrees downwards slope) of a
runway

— ILS Marker Beacons - ensures the proper distance from a runway; the
distances are based on the Outer, Middle, and Inner ILS Marker Beacons

Marker Beacons are used to alert a pilot that an action is needed, such as
checking the aircraft altitude. Marker Beacon information is presented to pilots
by audio and visual information. The ILS Localizer may contain present
information on the Outer, Middle, and Inner ILS Marker Beacons. All ILS Marker
Beacons are broadcast at 75 MHz and are located at specific intervals along an
ILS approach. Each ILS Marker Beacon is identified by specific audio as well as
visual characteristics.

ILS Marker Beacon Code Color Sound
Outer Marker L Blue 400 Hz

two dashes per second
Middle Marker e Amber 1300 Hz

alternating dot and dash
Inner Marker e White 3000 Hz

dots only

ILS Marker Beacon Softkeys

NMarker Beacon

Carrier Freq
Index
17

Marker Freg
400.00 Hz
Harker Depth
95.0 /4

COM/ID»

fore 1 of 2

- Sets a Carrier Frequency by selecting an Index from 1 to 33.
(Default: Index is 17 and corresponds to 75.000 MHz)

- Sets the selected Marker Beacon, different from nominal:
Inner=3000 Hz, Middle=1300 Hz, Outer=400 Hz
(Range: 0 Hz to 10 MHz)

- Sets the amplitude modulation depth
on the Marker Beacon Carrier.
(Range: 0 to 99%)
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Off

Inner

Niddle

Outer

- Turns off all
Marker Beacon signals

- Turns on and simulates

the Inner Marker Beacon

(3000 Hz modulation)

- Turns on and simulates

the Middle Marker Beacon
(1300 Hz modulation)

- Turns on and simulates

the Outer Marker Beacon
(400 Hz modulation)
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When testing an ILS [Instrument Landing System], the following ILS Marker
Beacon parameters can be set:

ILS Marker Beacon Menu  Parameters Default State
Marker Beacon mode Off

Carrier Freq Index 17 75.0 MHz
Marker Freq 400 Hz Outer

Marker Depth 95.0% Up

COM/ID menu?

a. For information on the COM/ID menu,
refer to “Using COM/ID Softkeys” on page 124.

To set the ILS Marker Beacon mode to off, inner, middle, or outer
This process selects a Marker Beacon Mode and can be one of the following:
1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Marker Beacon
(Default selection is Off.)

3. Select either: Off | Inner | Middle | Outer
— Selecting Off turns off all Marker Beacon signals. When set to Off, all

Marker Beacon parameter settings are turned off.

Setting the mode back to OFF, after selecting one of the other modes
(either: Inner | Middle | Outer) does not turn off the Marker Beacon carrier, specified by
Carrier Freq Index, it is still present on the RF Output of the signal generator.

To turn off this ILS Marker Beacon carrier, set RF Off/On to Off.

— Selecting Inner turns on and simulates the Inner Marker Beacon (nominal
3000 Hz modulation) signal.

— Selecting Middle turns on and simulates the Middle Marker Beacon
(nominal 1300 Hz modulation) signal.

— Selecting Outer turns on and simulates the Outer Marker Beacon (nominal
400 Hz modulation) signal.

To set the ILS Marker Beacon carrier frequency

This process sets the carrier frequency for the three Marker Beacons:
Inner, Middle, and Outer.

1. Press Aux Fctn > Avionics > Marker Beacon
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2. Press Carrier Freq Index
(Default value is 17 and corresponds to 75.000 MHz.)

3. Select a value from 1 to 33 and press Enter.

The default ILS Marker Beacon carrier frequency Index is 17 and corresponds
to 75.000 MHz.

ILS Marker Beacon Carrier Frequencies (Index =1 to 33)

1=74.600 12=74.875 23=75.150
2=74.625 13=74.900 24=75.175
3=74.650 14=74.925 25=75.200
4=74.675 15=74.950 26=75.225
5=74.700 16=74.975 27=75.250
6=74.725 17=75.000 28=75.275
7=74.750 18=75.025 29=75.300
8=74.775 19=75.050 30=75.325
9=74.800 20=75.075 31=75.350
10=74.825 21=75.100 32=75.375
11=74.850 22=75.125 33=75.400

To set the ILS Marker Beacon AM depth

This process sets the AM depth on the Marker Beacon carrier.
1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Marker Depth
(Default value is 95%.)

3. Select a value from 0 to 99.9% and press Enter.

To set the ILS Marker Beacon inner marker frequency
This process sets the frequency for the Inner Marker Beacon.
1. Press Aux Fctn > Avionics > Marker Beacon
2. Press Marker Beacon

3. Press Inner

4

. Press Marker Freq
(Default value is 3000 Hz.)

5. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.
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To set the ILS Marker Beacon middle marker frequency

This process sets the frequency for the Middle Marker Beacon.

1. Press Aux Fctn > Avionics > Marker Beacon
2. Press Marker Beacon

3.
4

Press Middle

. Press Marker Freq

(Default value is 1300 Hz.)
Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

To set the ILS Marker Beacon outer marker frequency

This process sets the frequency for the Outer Marker Beacon.

1. Press Aux Fctn > Avionics > Marker Beacon
2. Press Marker Beacon

3.
4

Press Outer

. Press Marker Freq

(Default value is 400 Hz.)
Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

To set or return the ILS Marker Beacon parameters to a default state
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This process returns the ILS Marker Beacon parameters to a set of default state
conditions.

1.
2.

Press Aux Fctn > Avionics > Marker Beacon

Press More 1 of 2

3. Press Recall Default Settings

ILS Marker Beacon Menu Parameters Default State
Marker Beacon mode Off

Carrier Freq Index 17 75.0 MHz
Marker Freq 400 Hz Outer

Marker Depth 95.0% Up

COM/ID menu?@

a. For information on the COM/ID menu,
refer to “Using COM/ID Softkeys” on page 124.
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Example of Setting All ILS Marker Beacon Parameters

1.
2.

Press Preset to place the signal generator in a known preset state.
Set the ILS Marker Beacon mode to inner, middle, or outer mode.
a. Press Aux Fctn > Avionics > Marker Beacon

b. Press Marker Beacon
(Default selection is Off.)

c. Select either: Inner | Middle | Outer

Set the ILS Marker Beacon carrier frequency.

a. Press Carrier Freq Index
(Default value is 17 and corresponds to 75.000 MHz.)

b. (Optional) Select a <value> from 1 to 33 and press Enter to change
to a different carrier frequency.

Set the ILS Marker Beacon AM depth.

a. Press Marker Depth
(Default value is 95%.)

b. (Optional) Select a value from 0 to 99.9% and press Enter.

(Optional, if Inner was selected in step 2 above.)
Set the ILS Marker Beacon inner marker frequency.

a. Press Marker Beacon
b. Press Inner

c. Press Marker Freq
(Default value is 3000 Hz.)

d. (Optional) Select a value from 0 Hz to 10 MHz.

(Optional, if Middle was selected in step 2 above.)
Set the ILS Marker Beacon middle marker frequency.

a. Press Marker Beacon
b. Press Middle

c. Press Marker Freq
(Default value is 1300 Hz.)

d. (Optional) Select a <value> from 0 Hz to 10 MHz.

(Optional, if Outer was selected in step 2 above.)
Set the ILS Marker Beacon outer marker frequency.

a. Press Marker Beacon

b. Press Outer
(Default value is 400 Hz.)
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c. Press Marker Freq
d. (Optional) Select a <value> from 0 Hz to 10 MHz.

8. Set the modulation to on.

a. Press MOD On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is on).

9. Set a desired RF power level.

a. Press Amptd
(Default power level is around -144 dBm, and depends on the signal
generator model being used, so the signal may be very low and hard
to find if you do not specify a high enough power level.)

b. Select a value from -20 dBm to -40 dBm.
10.Set the RF output to on.

a. Press RF On and verify that the front panel LED is illuminated,
indicating that it is on.
(Default is off).

11.Verify that all settings are as expected on the signal generator display.
a. Press Aux Fctn > Avionics > Marker Beacon

b. Review the settings under
Marker Beacon Status Information
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6  Analog Modulation (Option UNT)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

— Using an Internal Modulation Source on page 162

— Using an External Modulation Source on page 163

— Removing an External Source DC Offset on page 163
— Using Wideband AM on page 164

— Configuring the LF Output (Option 303) on page 165

KEYSIGHT

TECHNOLOGIES
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Analog Modulation Waveforms

The signal generator can modulate the RF carrier with four types of analog modulation: amplitude,
frequency, phase, and pulse. For pulse modulation information, refer to Chapter 7, “Pulse
Modulation (Options UNW and 320)”, on page 169.

Available internal waveforms include:

Sine sine wave with adjustable amplitude and frequency

Triangle triangle wave with adjustable amplitude and frequency
Square square wave with adjustable amplitude and frequency

Pos Ramp positive going ramp with adjustable amplitude and frequency
Neg Ramp negative going ramp with adjustable amplitude and frequency

Analog Modulation Sources

The signal generator provides the following internal and external modulation input sources. Internal
modulation sources generate the five waveforms listed above unless noted otherwise.

Ext1 & Ext2 an externally applied signal is used as the modulation input. Connect the signal to
the EXT 1 or EXT 2 connector on the rear panel of the instrument.

Func Gen 1 sine wave from the internal function generator. Instruments with Option 303 have
additional waveform choices listed above.

Func Gen 2 Func Gen 2 has the same capability as Func Gen 1. Available on instruments with
Option 3083.

Dual Func Gen dual waveforms with individually adjustable frequencies and a percent-of-
peak-amplitude setting for the second tone. Available on instruments with Option
303.

Swept Func Gen swept waveforms with adjustable start and stop frequencies, sweep time, and
sweep trigger settings. Available on instruments with Option 3083.

Noise Gen 1 & 2 noise with adjustable amplitude generated as a peak-to-peak value (RMS value is
approximately 80% of the displayed value). Uniform and Gaussian distribution is
available. Available on instruments with Option 303.
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Figure 6-1 Analog Modulation Softkeys
AM | {FMJ |
Al FH/DH Fri/on
Al Tupe | Fr1 Wl FH
LT ? High Bl
Al Path FI1 Path P11 Fath
2 UWB 2 2
1 FH Ll
on on on
A Depth | FM Dev |—— o Dev |
0.1 % page 162 1.0000 KAz page 162 0.000 rad [—Page 162
A Source FM Source M Source
(Func Gen 13* (Func Gen 131" (Func Gen 13*
fore 1 of 2 —J Hore 1 of 2 —1 fore 1 of 2 —1
;11 FHA®A FH/on
Setup AN Sourcer Setup FM Sourcer Setup @M Sourcer
A Depth Couple FM Dev Couple M Dev Couple
on an on
A Hode
Morma 1
Hore 2 of 2 Hore 2 of 2 Hore 2 of 2

For details on each key, use key help
as described on page 40.
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Using an Internal Modulation Source

1. Preset the signal generator.
2. Set the carrier (RF) frequency.
3. Set the RF amplitude.

4. Configure the modulation:

AM M OM
a. Press AM a. Press FM/®M a. Press FM/®M > FM/OM
b. Setthe AM type (Linear or Exponential): | b. Set the deviation: (®M is highlighted)
AM Type to highlight desired type. FM Dev > value > b. Set the BW (normal or high):
c. Set the AM Mode (Normal or Deep). frequency unit FM ®M to highlight desired
Default is Deep. To select Normal c. Set the rate: type
enable More to highlight desired More > Setup FM ¢. Set the deviation:
type. Source > FM Rate > ®M Dev > value > pi rad
d. Set the AM Depth: ~ AM Depth > value > frequency unit d. Set the rate:
value > unit More > Setup ®M
e. Set the rate: Source > ®M Rate >
More > Setup AM Source > value > frequency unit
AM Rate > value > frequency unit
5. Turn on the modulation:
AM FM OM
AM Off On softkey to On FM Off On softkey to On ®M Off On softkey to On

The appropriate modulation annunciator displays, indicating that you enabled modulation.
6. Turn on the RF output.
The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”
on page 425.

See also “Modulating the Carrier Signal” on page 54.
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Using an External Modulation Source

Fii/7on —> FIl Source Fi/en Fi/on Setup Extl
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fore 1 of 2 _Morelof2 = > florel of 2 Hore 2 of 2
" |

Rear panel inputs are described on page 12
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AM, FM or ®M inputs

Removing an External Source DC Offset

To eliminate an offset in an externally applied FM or ®M signal, perform an external DC calibration
(Ext DC Cal).

1. Set up and turn on the desired modulation.
2. Press FM/®M > FM Source > Ext1 or Ext2 > More > Setup FM Source.
3.

Ensure that Ext Coupling is set to DC.
- If not, press Ext Coupling DC AC until DC is highlighted.

4, Press Ext DC Cal.

This begins the calibration.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal,
and the applied DC level becomes the new zero reference point. When you disconnect the DC
signal, perform the calibration again to reset the carrier to the correct zero reference.
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Using an External Modulation Source

Using Wideband AM

Wideband AM uses the | input of the I/Q modulation system. When the wideband AM is turned on,
the I/Q is turned on and the I/Q source is set to external. If the I/Q is turned off or the I/Q source is
set to internal, then the wideband AM turns off.

For frequencies between 9 kHz and b MHz, Wideband AM turns off.

Figure 6-2 Wideband AM Softkey Menu

AM > AM Path 1 2 WB

l

FREQUEHCY ANPLITUDE An

6.000 000 000 00 &z -144.00 cen
[An] [L/0]

Enables and disables the
wideband AM feature.

AN Path ,
. = B Note: If the I/Q is turned off or
Analog Modulation Status InF.orma_twn _— 1z the 1/Q sourceQis setto
arl FuncGenl Depth:0. 1z Hgm gigg EESS : Sﬂgg an internal, then the wideband
AMUB I Tnput Depth:0.5U=100% OFf AM turns off.

FH1 Extz OC Dewv:1.0000kHz Imp:50 Ohm

Fr2 FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
$MIHEN  Extl DC Dev:0.000rad Imp:50 Ohm
PHM2HEN  FuncGenl Dev:0.000rad Hfm:Sine koo, 0Hz)

LFOut  IntHonitor Ampl:0. 0004 onitored:FuncGenl

For details on each key, use key help
as described on page 40.
02/25/2012 1L:25

When the Wideband AM is enabled, these fields are active.

Setting the Wideband AM

1. Set up and enable the desired modulation type.
2. Press AM > AM Path 1 2 WB to WB.
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Configuring the LF Output (Option 303)

Configuring the LF Output (Option 303)

The signal generator has a low frequency (LF) output. The LF output’s source can be switched
between an internal modulation source or an internal function generator.

Using internal modulation (Int Monitor) as the LF output source, the LF output provides a replica of
the signal from the internal source that is being used to modulate the RF output. The specific
modulation parameters for this signal are configured through the AM, FM, or ®M menus. The
internal source (AM, FM, or ®M) must be configured for the LF Out to provide a signal.

Using function generator as the LF output source, the function generator section of the internal
modulation source drives the LF output directly. Frequency and waveform are configured from the
LF output menu, not through the AM, FM, or ®M menus. You can select the waveform shape from
the following choices:

Available internal waveforms include:

Sine sine wave with adjustable amplitude and frequency

Triangle triangle wave with adjustable amplitude and frequency
Square square wave with adjustable amplitude and frequency

Pos Ramp positive going ramp with adjustable amplitude and frequency
Neg Ramp negative going ramp with adjustable amplitude and frequency
Pulse pulse with adjustable period and width

LF Out Modulation Sources

The signal generator provides the following modulation input sources. Internal modulation sources
generate the five waveforms listed above unless noted otherwise.

Int Monitor uses AM, FM or ®M settings.
Func Gen 1 waveforms from the internal function generator
Func Gen 2 waveforms from the internal function generator

Dual Func Gen dual waveforms with individually adjustable frequencies and a percent-of-
peak-amplitude setting for the second tone. Available on instruments with Option
308.

Swept Func Gen swept waveforms with adjustable start and stop frequencies, sweep time, and
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2 noise with adjustable amplitude generated as a peak-to-peak value (RMS value is
approximately 80% of the displayed value). Uniform and Gaussian distribution is
available. Available on instruments with Option 303.
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DC selects a DC voltage level as the LF output BNC source.

The LF Out Off On softkey controls the operating state of the LF output. However when the LF
output source selection is Int Monitor, you have three ways of controlling the output. You can
use the modulation source (AM, FM, or ®M) on/off key, the LF output on/off key, or the Mod
On/Off softkey.

The RF On/Off hardkey does not apply to the LF OUTPUT connector.

Configuring the LF Output with an Internal Modulation Source
In this example, the internal FM is the LF output source. See Figure 6-3 on page 167.

Internal modulation (Int Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source
1. Press Preset.

2. Press the FM/®M hardkey.

3. Press FM Dev > 75 > kHz.

4. Press More > Setup FM Source > FM Rate > 10 > kHz.

5. Press Return > Return > FM Off On.

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FMannunciator is
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output
1. Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > V.

3. Press LF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is
frequency modulated using the Int Monitor source selection (default source).
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Figure 6-3 Configure the LF Out Source with FM
FM and LF annunciators indicate Frequency Modulation is the LF Out source
FREQUEHCY RE_OFF
6.000 000 000 00 &=
Amptd: 3000 V Incr: 500.0my
Analog Modulation Status Information
Arl FuncGenl Depth:0. 1 Hfm:Sine ko0, 0Hz)
A2 FuncGenl Depth:0. 12 Hfm:Sine koo, 0Hz)
AHUE I Input Depth:0.Sy=100:
FH1 FuncGenl Dev:75. 0000kHz Hfm:5Sine(10.0000kHz)
unciGen ev: 1. 0000kHz Hfm:Sinethod. OoHz)
1 FuncGenl Dens:0.000rad Hfm: Sine(LO0.0Hz)
LFOut  IntHAonitor Ampl :3. 000V Monitored :FuncGenl e .
FM as the LF Out Source
04 /07 /2012 15:16

LF Out using the Int Monitor source (default selection). For details on each key, use key help

Configuring the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source
1. Press Preset.
2. Press the LF Out hardkey.

3. Press LF Out Source > Func Gen 1.

Configuring the Waveform

1. Press Setup LF Out Source > LF Out Waveform > Sine.
2. Press LF Out Freq > 500 > Hz.

3. Press Return.

This returns you to the top LF Output menu.

Configuring the Low Frequency Output
1. Press LF Out Amplitude > 3 > V.

This sets the LF output amplitude to 3 V.
2. Press LF Out Off On.

Figure 6-4 on page 168 shows that the LF output is now transmitting a signal using the function
generator that is providing a 3 V sine waveform.
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Figure 6-4 LF Out Status Display

LF Out annunciator

FREQUEHCY

6.000 000 000 00 &+
it Frea: D00.0 Hz Incr: 500.0Hz
Analog Modulation Status Information
Arl FuncGenl Depth:0. 1 Hfm:Sine ko0, 0Hz)
A2 FuncGenl Depth:0. 12 Hfm:Sine koo, 0Hz)
AMLE I Input Depth:0.5v=100%
Fri FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
Fr2 FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
1 FuncGenl Dens:0.000rad Hfm: Sine(LO0.0Hz)
LFOut  FuncGenl Ampl :3. 000V Hfm:Sine(500.0Hz)

/07 /5012 15201 For details on each key, use key help

g as described on page 40.
LF Out configuration
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Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

7 Pulse Modulation (Options UNW and 320)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

Option UNW with Option 320 provides the pulse train generation support.
— Pulse Characteristics on page 171

— The Basic Procedure on page 173

— Example on page 174

— Pulse Train (Options UNW and 320) on page 175
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Pulse Modulation (Options UNW and 320)

Figure 7-1

Pulse Softkeys

Pulse Source
Pulse | Square
| Pulse Source
) Free-Run Gated
Note: Pulse Period age 173
Pulse and Pulse Width are
not available when Tricgered page 173 Ext Pulse
Uéﬁe Pulse Train is selected
N as the Pulse Source.
Vi Adiustable i
Pulse Source, - Ooublet Pulse Train | _page 175
(Free-Run 7 >
e I .
7 Fules Farian / Trigger Doublet
\ 400 usec / fore 1 of 2
Pulze Delay Trig 1 Out BHC Trig 1 Out BHC
0.00000000 sec /
o — — — Hone L¥I
Pulse Hidth
2.00 usec
———— These softkeys are Sweep Trig Out = Sweep Fun
fore 1 of 2 only available when Low = settled "
the Pulse—Source is Latency from the external
set to Adjustable Source Settled pulse input to the pulse Tricger 2
Pulse Dpublet. sync output = 50-60 ns.
Width Period
. . Pulse Sunc 50 ns >50ns Pulse
Determines how the signal generator 20 ns <50 ns
responds to an external pulse signal.
Normal = high state. TTL signal Pulse Wideo Swept. Func Done
Invert = low state.
Hore 1 of 2 > Hore 2 of 2
See also, page 13 and
page 15 Trig 2 ODut BHC Trig 2 ODut BHC
Ext Polarity \
eai=0 Irert —— Mone LKI
Route( Connectors ) \
Route Connectors,] Route To
& Set Polaritu > Trig (ﬁoﬁgg* Sueep Trig Out Sweep Aun \
LI 2L 0l 2 . Hou%eeﬁg Select the\signal
rig M .
(Sueep Trig OUL) SEMES BEEEIEE frigger 1 m,ﬂ ;[:?)r?gg:tor
Available on vector Foute To 7
instruments with Su?gaeggtuﬁggy Pulse Sunc Fulse e 4
BBG. ~
Foute To .
Baseband EMCs Pulse Yideo Swept. Func Done Ve
Trigg?r D.gt, lore 1 of 2 —1—®_ lore 2 of 2
moaritd Sueep OuL BAC
/s
L
Sueep Out /
Y V4

Trigger Polarity

For details on each key, use key help
as described on page 40.

170

Source Settled

Trigoer Out 1
Polarit
MNeg

Trigoer Out 2
Folari

Pulse Wideo

Neg Pulse Sunc

Sweep Run

Hore 1 of 2—

Sueep Dut BHC

Swept. Func Done
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Pulse Characteristics

Pulse Modulation (Options UNW and 320)
Pulse Characteristics

When using very narrow pulses that are below the signal generator’s ALC
pulse width specification, or leveled pulses with an unusually long duty
cycle, it is often useful to turn ALC off (see page 102).

Pulse Sour . Uses Trigger Event?
o Type Period? Width & Delay® g?
Internal free run pulse train with Determmed %)
Square o user defined — —
50% duty cycle.
rate.
Free Run Internal free run pulse train User Defined User Defined —
(default)
Triggered Internal pulse train — User Defined ?
User Defined:
First pulse is relative to the
) ) . rising edge of trigger signal.
Adjustable Two internal pulse trains for each L _ _ ”
Doublet trigger event. Secoln.d pulse is rel_atwe to f
the rising edge of first pulse.
See Figure 7-2 on
page 172
The first pulse follows the
trigger signal.
Trigger Tv_vo internal pulse trains for each . Second pulse s user defined 2
Doublet trigger event.
See Figure 7-3 on
page 172
Gated Internal gated pulse train — User Defined ?
External External pulse signal at the rear . . L
panel Pulse connector
Pulse Train | Internal pulse train User Defined: ?
User Defined

See Figure 7-4 on
page 175

a. All delays, widths, and periods have a resolution of 10 ns.
b. Asignal at the rear panel pulse connector must be held high for at least 20 ns to trigger an
internally generated pulse.
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Pulse Characteristics

Rear panel inputs are described on page 12

External pulse input

o ® oee . - .
csseee -
st

1w
T

Figure 7-2 Adjustable Doublet
External
Trigger :
RF Output X PU[S X PulS ; —

'<—— Delay —»~'<—— Width —

The delay of the first pulse is measured from :
the leading edge of the external trigger signal.

Puls Puls
‘«—Dely —————————>-'€—— width ——»;

The delay of the second pulse is measured from
the leading edge of the first pulse.

Figure 7-3 Trigger Doublet
External
Trigger
RF Output —

' ' '
. Puls . Puls :
14— Delay —+—— Width ——

The first pulse follows the The delay of the second pulse is measured from

external trigger signal. the leading edge of the external trigger signal.
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Pulse Modulation (Options UNW and 320)
The Basic Procedure

The Basic Procedure

1. Preset the signal generator.
2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4. Configure the modulation:
a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

Square | FreeRun | Triggered | Adjustable Doublet | Trigger Doublet Gated Pulse External
(default) Train?
Pulse — — — — — — —
Rate
— Pulse — — — Pulse — —
Period Period
— Pulse Pulse Pulse Delay Pulse Delay — Pulse —
Delay Delay Delay
— Pulse Pulse Pulse Width Pulse Width Pulse — —
Width Width Width
— — — Pulse 2 Delay — — — —
— — — Pulse 2 Width — — — —
- - - - - - Pulse On® -
- - - - - - Pulse Off° -

a. Requires Option 320.

b. Up to 2047 pulse cycles (elements) composed of both Pulse On and Pulse Off can be user
defined.

5. Turn on the modulation: Pulse Off On softkey to On.
The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.
The RF output LED lights, indicating that the signal is transmitting from the RF output connector.
See also, “Modulating the Carrier Signal” on page 54.
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Example

Example
The following example uses the factory preset pulse source and delay.

Output: A2 GHz, 0 dBm carrier modulated by a 24 ps pulse that has a period of 100 ps.

Preset the signal generator.
Set the frequency to 2 GHz.
Set the amplitude to 0 dBm.
Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

o a r w N =

Turn on both the pulse modulation and the RF output.
The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”
on page 425.
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Pulse Train (Options UNW and 320)

Pulse Train (Options UNW and 320)

The Option 320 Pulse Train feature enables the specification of up to 2047 independent pulse
cycles, each of which has an “On Time”, during which the RF output is measurable at the RF output
connector, and an "Off Time", during which the RF output is attenuated. Each pulse cycle is similar
in function to other X-Series signal generator Pulse modes—the Pulse Train feature has up to 2047
cycles, instead of only a maximum of two (with Doublets). There are also repeat counts available for
each pulse. These repetitions count against the total count of 2047 cycles.

The instrument can import pulse trains from a .csv (comma separated values) file or some other
common ASCII format. It can also export to ASCII/CSV files as well. Export allows specification of
the decimal separator and a column separator. The import allows specification of the decimal

separator (to allow for ","), but the column separator is auto-detected. Refer to “Pulse Train Menu
Softkeys” on page 175 and “Display Pulse Train Menu Softkeys” on page 177.

Figure 7-4 Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train For details on each key, use key help as
described on page 40.

—» Train Trigger

Free-Run
FREQUEHCY RE_OFF
Fulse Triooered
6.000 000 000 00 &z -
PULSE
Pulse Source, Gated
Aodulation Status Information (Pulse Train)
fMod  State Depth/Be0 Source  Rate  Hayeform Free-Run continuously plays
the pulse train, ignoring all
triggers.
Pulse Oelay Triggered runs the pulse
Pulse  On iggered Train 0.00000000  sec train (after waiting the Pulse
Delay) each time an external
: : trigger is supplied to the
¥
SR, (A UreH PULSE BNC, the Trigger
ZE/0L/2010 16:73 | Tore 1 of 2 Immediately softkey is
pressed, or the Trigger SCPI

command is sent.
Gated runs the pulse train
while an external trigger is

Display area indicates Pulse Train is the current pulse
source.

Biise supplied (level triggered) to
Trigoer the PULSE BNC connector.
Trigger Immediately causes Immediately The state of the GATEd
the pulse train to run once. trigger is detected only when

the playback is transitioning
to or in idle. This means that,
once started, playback is
always completed, even if
the GATE trigger changes to
the inactive state.

Ext Polarity
Invert

Route Connectors,
& Set Polarity

fore 2 of 2

SCPI Commands:

[:SOURce]:PULM:INTernal: TRAIn:TRIGger FRUN|{TRIGgered}|GATEd
[:SOURCce]:PULM:INTernal: TRAiIn: TRIGger:IMMediate

Refer to the SCPI Command Reference.
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Edit Pulse Train Menu Softkeys

For details on each key, use key help as described on page 40.

Figure 7-5

These softkeys provide
ease of use in changing
the pulse cycle settings
in the plte train.

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train

FREQUENCY ANPLITUDE Pulse Train Goto Hou
6.000 000 000 00 &= -144.00 cen Edit Ttem - Enter
Pulse Train Insert Row B0 UeD (e
Delete Fou Goto Middle Row
2. 000 us 2.000 us Goto Rowe Goto Bottom Row

‘..I‘\“M‘rf

— e
Load/Store

Display
Pulse Train® page 177

fore 1 of 2

Og/06/2012 17:33

\J

This column
displays the repeat
times for each

Th\s column
displays the off
times for each

This Jolumn indicates the Thisxolumn
row of a each pulse train displays the on
cycle. times for each

Note: When the cycles pulse cycl(_e pulse cycle pulse cyclg Imeart, /Export §
(elements) are repeated, (element) in the (element) in the (element) in the
the row numbers are pulse train. pulse train. pulse train.

skipped in the displayed
count for the number of
pulse cycles repeated.
Example: For the pulse
train displayed above, in
row 2, the 3 us On Time
and 2 us Off Time pulse
cycle is repeated twice.
But, only row 2 is
displayed for that pulse
cycle (i.e. row 3 is not
displayed).

Inzert Item

/

page 178 Oelete Item

Delete ALl Row

fore 2 of 2

SCPI Commands: SCPI Commands (continued):

[:SOURce]:PULM:INTernal: TRAIn:LIST:PRESet
[:SOURce]:PULM:INTernal: TRAin:OFFTime <20ns - 42sec>
[:SOURce]:PULM:INTernal: TRAIn:OFFTime?
[:SOURce]:PULM:INTernal: TRAin:OFFTime:POINts?
[:SOURce]:PULM:INTernal: TRAin:ONTime <20ns - 42sec>
[:SOURce]:PULM:INTernal: TRAin:ONTime?
[:SOURce]:PULM:INTernal: TRAin:ONTime:POINts?
[:SOURce]:PULM:INTernal: TRAIn:REPetition <1-2047>
[:SOURce]:PULM:INTernal: TRAin:REPetition?
[:SOURce]:PULM:INTernal: TRAin:REPetition:POINts?

Refer to the SCPI Command Reference.

176

:MEMory:CATalog:PTRain?

:MEMory:DELete:PTRain

:MEMory:EXPort[:ASCii]:PTRain <"filename">
:MEMory:EXPort[:ASCii]:SEParator:COLumn
TAB|SEMicolon|{COMMa}|SPACe
:MEMory:EXPort[:ASCii]:SEParator:COLumn?
:MEMory:EXPort[:ASCii]:SEParator:DECimal {DOT}|COMMa
:MEMory:EXPort[:ASCii]:SEParator:DECimal?
:MEMory:IMPort[:ASCii]:PTRain <"filename">
:MEMory:IMPort[:ASCii]:SEParator:DECimal {DOT}|COMMa
:MEMory:IMPort[:ASCii]:SEParator:DECimal?
:MMEMory:LOAD:PTRain <"filename">
:MMEMory:STORe:PTRain <"filename">
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Figure 7-6

Pulse Modulation (Options UNW and 320)

Display Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > Display Pulse Train

FREQUEHCY

RF_OFF

6.000 000 000 00 &+

PULSE

Tine offset:  2.00 USEC

Pulse Train

[T TN o oL

2.00us %

10. 00ufed7div 39._00usec

Train Display
Time Offset
2.00
usec 1

Zoom In
Zoom Out
Zoom In Max

Zoom Out. Max

Pulse Train (Options UNW and 320)

This softkey shifts the time
offset from the left hand side
of the display to the one
specified. Increments and
decrements are 1/20th of
the visible pulse train.

Use these softkeys to optimize
the view of the different
characteristics of the pulse
train.

AN
03/07/2012 11:4LL
N \Z/ \
This value cag be These are‘the division markers currently N
adjusted with th, set at 10.00 us/div for the currently N
Time Offset softkey. displayed view. Use the zoom softkeys
\ to change the time/div value. N
N AN
N AN
N\
FREQUEHCY RE_OFF
6.000 000 000 00 &z
PULSE
time oerset: 2,00 USEC
Pulse Train
L L
~Oblsec ' 10. 00usec/div 39. 00jisec
|- —
| 2nd and 3rd | |<— 5th, 6th, and 7th —#]| |
| pulse cycles | pulse cycles
(elements) or > (elements) or rows = » |
1 rows 2 and 3. |- " ;
o o 4th pulse cycle Final pulse cycle
This is the initial

pulse cycle (row 1)

(element) or row 4.

note that the On
Time portion of this
pulse is not showing

due to the
2 us offset.

(element) in the
displayed pulse
train above. 8th
pulse cycle or row.

For details on each key, use key help as described on page 40.
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Pulse Train (Options UNW and 320)

Figure 7-7 Pulse Train: Import From Selected File Softkeys

For details on each key, use key help as described on page 40.
Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

FREQUEHCY RF_OFF Pulse Train
6.000 000 000 00 &+ ( Losgsstores}——page 60
PULSE
Import /Exportk
Pulse Train ) ) meart /Exp
1 203051$ grguglg Repeatl, These softkeys delete
2 3.000 us 2.000 us ] Insert Item individual On Time or Off
L 2.000 us 2.000 us 1 Time elements as well as the
9 3.000 us 2.000 us 3 Repeat cycle counts.
8 2,000 us 2.000 us 1 Delete Item
9 _______________________
Deleting all Pulse Cycle rows
| t: t
Delets ALL Rouse| — — _(cirfmﬁqlz) must be
03/07/2012 11:54 HMore 2 of 2
Confirm Import
From File
FREQUEHCY RF_OFF Import/Export
6.000 000 000 00 &z Imeert, From o
d Selected File A
PULSE
Export To,l
Catalog of Binaru Files in Int Storace %2776 Used _LEGTE fres File page 179
File Hame Tupe Size Hodified
1 DISPLAY.EMP EIMARY 76918 22/03/06 22:36 .
2 DORMVIPH.LIC BINARY 524 22/09/06 22:36 Delete File
o EILOR 925656 22/03/06 22:36
I CC  [L 0510 [F /
I 55 0O4/05/10 08:L3 ¥ age 179
6 PTRATNZ.CSY EINARY 15 OL/05/10 09:08 buto hon Pag
7 HHAPINFO.HHL, BIMARY 296 22/09/06 22:37
Import Decimal
Separator
IEA Comma |- Selects whether the decimal point
/ 0L /05 /20 2 Iﬁw isa"." ora"," during import of
—

CSV/ASCII files.

This value is persistent across
This file’s data structure uses decimals in the numbers preset/recall and power cycles.
and so requires the Import Decimal Separator to be set to

Dot. SCPI Commands:
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal DOT|COMMa
:MEMory:IMPort[:ASCii]:SEParato

r:DECimal?
KF_OFF
6.000 000 000 00 &+
PULSE
Note: Column
separated values are Pulse Train i _
au?o-detected by the On_Time Off Time Repeat
instrument. 1| N HTEN 1.000 us 2 | After confirming import of the file
g ;888 Hg %888 ﬂg g the new file’s pulse train values
8 - e || == are displayed.

Pulse train imported as CSU
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Figure 7-8 Pulse Train: Export to Fi

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

l

Pulse Modulation (Options UNW and 320)
Pulse Train (Options UNW and 320)

le Softkeys

Note: Files can be FTP'd to the BIN (Binary) folder in the instrument, or a USB
stick can be used to download the files to the instrument. Refer to page 61.

FREQUENCY RE_OFF Tnport/EXport
6.000 000 000 00 &k . meert, From
PULSE
Export Toll
Catalog of Binaru Files in Int Storaoe 32.6MB used  LESME free File
File Hame Tupe Size Nodified
1 DISPLAY.EMP EINARY 76918 22/09/06 22:36 )
2 DORMYIPM.LIC EINARY 524 136 Delste Filey
3 LAUNCHUS.EXE EINARY 9256596
L PTRAIN.CSY EINARY |55
Ll FTRATN. THT  INARY o 1
6 HHPINFO. ML ETNARY Boto Fou

Import Decimal

Separator
Dot MR

0L /05

2010 D5:LE

Hore 1 FF 2 \

Import/Export > Column Separator
Export. Column Selects whether the Selects whether the column
SeDar“atDr)“b decimal point is a *.” Comma Zep_arator |sat?bH C A lorS?:
or “, “" during export luring e_xporto t e SVA 1
Export Decimal of the CSV/ASCII _ files. This value is persistent
SBDEEEI}SP —files._ This value is Semicolon gc;nl)jss preset/recall and power
persistent across yoes. .
preset/recall and SCPI Commands:
power cycles. Tab :MEMory:EXPort[:ASCii]:SEParato
SCPI Commands: r:CoLumn
:MEMory:EXPort[:AS TAB|SEMicolon|COMMa|SPACe
Cii]:SEParator:DECi Space :MEMory:EXPort[:ASCii]:SEParato
mal DOT|COMMa r:.CoLumn?
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal?
\
FREQUEHCY RE_OFF Text Entry
6.000 000 000 00 &z Enter
PULSE
Export to: pTRHINTXTI Clear Text
Cataloo of Binary Files in Int Storage 32.6MB used LESME free
File Hame Tupe Size Hodified
1 DOISPLAY.BMP BINARY 7318 22/09/06 22:36 Editing Mode
2 [ORMVIPH.LIC BINARY 524 22/039/06 22:36 Ml Feplace
LAUNCHUZ, EHE BIMNARY 925696 22/09/06 22:36
T T o

04 /05,10
e

55
T CC  0OL/05/10 Show Alpha Table
296 22/09/06 Off
ABCDEFGHIJKLN
HOPORSTUMUEYZ
w_t4u+l1]

Note: Since there is already a file named PTRAIN.CSV the new
filename should be different, to avoid overwriting the original
PTRAIN.CSYV file.

[} 05‘2010 02:50

page 178

Goto Rou

Enter

Goto Top Row

Goto Middle Row

Goto Bottom Row
———— ‘r/'

The Export to File softkey menu,
writes out a CSV/ASCI| file to the
BINARY directory. You may supply
your own extender as part of the
filename.

Example:

MEM:EXP:PTR "myfile.csv".
SCPI Command:
:MEMory:EXPort[:ASCii]:PTRAIn
<"filename">

Use the text editor keys to
rename the file to be exported
to the BIN (Binary) folder.

For details on each key, use key help as described on page 40.
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8  Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting power level and frequency, refer
to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in that

chapter.

See also “Adding Real-Time Noise to a Dual ARB Waveform” on page 342.
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I/7Q Modulation

|/Q Modulation

The following factors contribute to the error vector magnitude:

— Differences in amplitude, phase, and delay between the | and Q channels

— DC offsets

The I/Q menu provides adjustments and calibration to compensate for some of the differences in
the I'and Q signals or to add impairments. See I/Q Modulation on page 245 for additional

information.

See also “Modulating the Carrier Signal” on page 54.

Figure 8-1 I/Q Display and Softkeys

Iya This panel displays the current status and settings

This panel displays the external

1/Q signal routing. adjustments are off.

FREQUEHCY ANPLITUDE

6.000 000 000 002 -144.00 dn

I/0 Routing & Optipization I/0 adjustments:/ OFf

[Ex1 N = ¥ 0T |

0L4/09/2012 11:00

1/0

I/0 Adjustments, |
(Off2

Man  Meas

fore 1 of 2

of the I/Q adjustments. Grey text indicates I/Q

oF¢ Nl

I/0 CalibrationM— Sets the dc Ext In I/0 Adj
offset External Input
Ext Input Level I Offset
500 my rms 0.0000

L

I/0 adijustments
I/0 Adjustments
0n

External Input
Adjustments

External Input

External Input
I/0 Gain Balance
0.000 de

Quadrature

1/0

Anole Adjustment

Ext In I/0 Atten
9.53 dB

Marual Offsets the phase of the Q signal relative to the
phase of the | signal. The quadrature adjustment
key is in units of degrees. This adjustment is not

Toggles between DC, User, and Full IQ calibration types.

DC: Calibrates I/Q offset, gain and quadrature error for a single
frequency at the current signal generator settings.

This calibration requires that the 1/Q be on, the optimized path be set to
RF Out, and the source be set to the internal baseband generator.
Changing any instrument setting except for 1/Q adjustments after
performing a DC calibration voids the DC calibration and causes the
signal generator to revert to the factory supplied calibration data.

User: Calibrates 1/Q offset, gain, and quadrature error for all signal
generator settings over a range of frequencies that you define.

Full: Calibrates I/Q offset, gain, and quadrature error for all settings

over the full frequency range of the signal generator.

For details on each key, use key help
as described on page 40.

Y

calibrated.

Starts the I/Q calibration routine for the

I/0 Calibration

Execute Cal

Calibration Tupe
— DC User li!llf&

Rewvert to
Default Cal
Settings

The following table shows common uses for the adjustments.

selected frequency range. (Use the
Callibration Type softkey to select the
—frequency range.) You can abort the
calibration by pressing the Abort Cal
softkey or the Local Cancel/(Esc)
hardkey. If you abort the calibration, the
previous calibration data is restored.

This calibration should be run when the
ambient temperature has varied by at
least +/-5 degrees Celsius from the
ambient temperature at which the
previous calibration was run.

Table 8-1 I/Q Adjustments Uses
I/Q Adjustment Effect Impairment
Offset Carrier Feedthrough dc offset
182
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Table 8-1 I/Q Adjustments Uses
I/Q Adjustment Effect Impairment
EVM error phase skew
Quadrature Angle
I/Q Images I/Q path delay

Configuring the Front Panel Inputs

[/Q Modulation

The MXG/EXG accepts externally supplied analog | and Q signals through the front panel I Input

and @ Input for modulating onto the carrier.

1. Connect | and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel

Overview” on page 5.

a. Connect an analog | signal to the signal generator’s front panel | Input.

b. Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Turn on the I/Q modulator: Press I/Q Off On to On.
3. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

4. Make adjustments to the 1/Q signals (page 182) as needed.
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I/7Q Modulation

184 Keysight EXG and MXG X-Series Signal Generators User’s Guide



9

Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

Basic Digital Operation (Option 653/655/656/657)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting power level and frequency, refer
to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in that
chapter.

The features described in this chapter are available only in vector signal generators with Option 653
or 655 (N5172B) or Option 656 or 657 (N5182B).

Waveform File Basics on page 187

Storing, Loading, and Playing a Waveform Segment on page 189
Waveform Sequences on page 192

Saving a Waveform’s Settings & Parameters on page 197
Using Waveform Markers on page 203

Triggering a Waveform on page 219

Clipping a Waveform on page 226

Scaling a Waveform on page 235

Setting the Baseband Frequency Offset on page 241

I/Q Modulation on page 245

I/Q Adjustments on page 249

I/Q Calibration on page 250

Using the Equalization Filter on page 252

Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter on
page 254

Modifying a FIR Filter Using the FIR Table Editor on page 260
Setting the Real-Time Modulation Filter on page 263
Multiple Baseband Generator Synchronization on page 265

Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator
Synchronization on page 271
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— Waveform Licensing on page 276

See Also:
— Adding Real-Time Noise to a Dual ARB Waveform on page 342
— Real-Time Phase Noise Impairment on page 350

— Multitone and Two-Tone Waveforms (Option 430) on page 411
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Waveform File Basics
There are two types of waveform files:
— A segment is a waveform file that you download to the signal generator.
For information on creating and downloading waveform files, refer to the Programming Guide.

— A sequence is a file you create in the signal generator that contains pointers to one or more
waveform files (segments, other sequences, or both).

For information on creating sequences, see page 192.

Signal Generator Memory
The signal generator has two types of memory:

— Volatile memory, baseband generator (BBG) media, where waveform files are played from or
edited.

— Non-volatile memory, either internal (int) or external (USB) media, where waveform files are
stored.

Dual ARB Player

The MXG/EXG’s ARB Waveform File Cache is limited (see the Data Sheet).
Consequently, once the file cache limit has been reached, the waveform
switching speed is much slower for additional files loaded into the volatile
waveform memory (BBG).

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player
also provides markers (page 203), triggering (page 219), clipping (page 226), and scaling

(page 235) capabilities.

Most procedures in this section start from the Dual ARB menu, shown below.
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Figure 9-1 Dual ARB Softkeys
™ fArb Setup | If you set the ARB sample clock when the dual ARB
Arb R —— k__is off, the new setting is applied when the dual ARB
b oample Lloc player is turned on; this setting survives toggling
SEB LR L= the Dual ARB player off and on.
[Mode \ B
Heal—TirreSREGN'_ page 342
— avefar— Page 189 e
\/ Real-Time, age 235
HodnTatien s frb Setups . F11ESE Noise Sstup pag
Oual AREM— Trigger Tupe RS ?B%ﬁ”? )— page 235
(EDEtlnuausib
BRE Custom e 65 page 219 Modulator Atten
Modulation” B.00 dE
Manuzal WENEEE
. fore 1 of 2
F‘Bal‘Tr%lﬂ'g Euﬁtﬂm. Hore 1 of 2 These softkeys are
EaiEEE only available in the Dual
ARB'’s Arb Setup
Real-Time menu.
ApPplications Arb Setup
e
; requency e
Multitonew 0.000 bs "
age
Hore 1 of 2 \/ pag
Arb
Haveform,

Sequences®[——Page 192 - page 244

Haveform, ;
ISHEI Multi-BBG Sunc
Utilities ?S%LFJ?; |—» page 265

Marker ;
ilities® Real-Time

Note: This is second of UsllteEs Modulat ion F%é%?r;b ——» page 265
two Arb menus. Headar

Utilities®

| page 197 fore 2 of 2

—page 276
Available on ) Nore 2 of 2
vector models with TRiETER
opt 2xx. rb Markers

Marker Polaritue TFA Utilities

page 203 Plat,l  nage 226

Marker Routinge CCOF®

Scale Haveform
Set. Markerse Data®[— Page 235

{2 S

Foute Tool
Baseband BHCs® page 47

For details on each key, use key help
as described on page 40.
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Storing, Loading, and Playing a Waveform Segment

Storing, Loading, and Playing a Waveform Segment

he MXG/EXG’s ARB Waveform File Cache is limited to 128 files.
Consequently, once the 128 file cache limit has been reached, the
waveform switching speed will be much slower for additional files loaded
into the volatile waveform memory (BBG).

Before using this information, you should be familiar with the signal generator’s file menus. If you
are not, refer to “Working with Files” on page 56 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 192.

The signal generator has two types of waveform media: non-volatile (internal or USB), and volatile
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 9-2 Waveform Segment Softkeys
Arb Tlaveform Note: When a sequence is selected, this key name
Mode page 203 ——changes to Show Waveform Sequence Contents.
Arb Select Havefarm
AFE (=hONE=) Arb Seoments
an
L Display Waveform, Stare Arb Seoments
Hodulation Hode And Markers
uagg%g%, » Rename Seament
L Load Segment
=il (RS Eggﬁ;ﬂ{g From Int Media
AFE Cust Arb Setupk Lomd ALL Goto FRowe
ustom oz
Modulat ion® From Int Media Text Entry
Trioger Tupe
Real-Time Custom (EDEtinuausib Enter
- ree Run
Hodulat ion® Goto Roue Delete Seamentk
Real-Time, SDB letg gélp Clear Text
: ! egments On
ApPplications fore 1 of 2 e D i o
it.ing Mode
ore 10 — =AMl Feplace
HMult itonek @
Hore 1 of 2 These keys change to indicate the default media. Shiok ﬂlDB\EICFT
For information on selecting the default media, At
see page 67.
pag MBCDEFGHIJKLN
HOPORSTUVHXEYZ
For details on each key, use key hel Use the arrow keys or knob to
9 v hew highlight a letter or character. —————# eI

as described on page 40.

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence.
Cycling power or rebooting the signal generator deletes the files in BBG media.

Each time the instrument powers up, two factory-supplied segments are
automatically created in BBG media: RAMP_TEST_WFMand
SI NE_TEST_WFM

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Load, then use the arrow keys to highlight the desired waveform
segment.
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If there is already a copy of this segment in the currently selected media and you do not want
to overwrite it, rename the waveform segment before you load it (refer to the previous
procedure).

Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press
Load All From currently selected Media.

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media
(page 67). If you have not downloaded a waveform segment, either refer to the Programming
Guide, or use one of the factory-supplied segments.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.
2. Press Load Store to highlight Store.

3.
4

. Optionally, rename the segment.

Using the arrow keys, highlight the waveform segment you want to store.

If there is already a copy of this segment in the currently selected media and you do not want
to overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.

b. Enter a name for the waveform segment.

c. Press Enter > More.

d. Highlight the waveform segment that was renamed.

5. Press Store Segment to currently selected Media.

Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press
Store All to currently selected Media.

Playing a Waveform Segment

1. Press Mode > Dual ARB > Select Waveform.

2. In the Segrrent on BBG Medi a column, highlight the waveform segment you want to play.
3.

4. Set ARB Off On to On.

Press Select Waveform.

This plays the selected waveform segment. Both the |1 / Qand ARB annunciators turn on, and
the waveform modulates the RF carrier.
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Annunciators display with active waveform (ARB On)

Arb
ARE
0ff N

Select,
Haveform

ARB On

|5I!ll!l:tl!l:| uaveflflr‘m: .anl:RFInP_TESTJan | T Seuen
Filter: Off

. Trigger Tupe

Current waveform selection (Cont.inuous ,»

Trig Tupe: Continuous (Free Run) ArES [fmY

Pouer Search Reference: RMS
ALGM: Off Fhase Moise: Off
03/03/2012 19:17 Hore 1 of 2

5. Configure the RF Output:
Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector.
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Waveform Sequences

Figure 9-3 Waveform Sequence Softkeys
Sequence name
Mode > To display this softkey, select a waveform sequence.
Dual ARB ) g
frb Uaveform / I]Inl.l“rslturage s 29}263”319:"99 e Shouing SEQ:SIHE+RANP
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Salect And Markerg*——»
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Waveform, Sequence contents
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_— fore 1 of 2
arker _—
Utilities® ‘ see page 215
Ut_Te?c_ler“' Confirm Delete Arb Sequences
ilities
Confirm Delete
Hore 2 of 2 Goto FRowe

For details on each key, use key help
as described on page 40.

A waveform sequence is a file that contains pointers to one or more waveform segments or other
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or
other sequences, or both thereby eliminating the need to stop waveform playback just to select
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the
sequence; you must also store the individual segments or they are lost when you turn off or reboot
the signal generator. If the segments are located in internal/external media, you must load them
into BBG media prior to selecting a waveform sequence (see page 189). If you attempt to play a
sequence without the segments loaded into BBG media, the signal generator reports: ERROR

629, File format invalid.Ifthis happensand the segments are not stored in internal/external
media, you must recreate the segments using the same file names that the sequence points to
before you can play the sequence.

Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other
sequences (nested sequences). The signal generator lets you set the number of times the segments
and nested sequences repeat during play back. But there is a difference between repeating a
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segment versus repeating a nested sequence. Each segment can repeat up to 65,535 times, but no
matter how many times a segment repeats, it counts as a single segment. However each repetition
of a nested sequence counts as additional segments.

——Segment 1
Sequence A — } 2 segments
L Segment 2
Waveform 11 segments
Sequence __Sequence AN\ , Segments
Sequence B repeated 4x 9 segments
L——Segment 3

The maximum number of times that a nested sequence can repeat is based on the number of
segments in the nested sequence and the remaining number of allowed segments (1,024). For
example, with a sequence that contains 24 segments and one nested sequence with 4 segments,
the nested sequence is limited to 250 repetitions:

24 + (4 7250) = 1,024 maximum number of segments per sequence
Even though there is a limiting factor on the maximum number of times that a nested sequence can
repeat, each segment within the nested sequence can repeat up to 65,535 times.
Example

Use the following procedure to create and store a waveform sequence using one repetition each of
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on
loading waveform segments into BBG media, see page 189.

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence
> Insert Waveform.

b. Highlight the desired waveform segment and press Insert.
2. Select the second segment:
a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting
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3. Name and store the waveform sequence to the Seq file catalog:
a. Press More > Name and Store.
b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 194 and “Setting Marker Points in a
Waveform Segment” on page 210.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey
1. Press Mode > Dual ARB > More > Waveform Sequences.
2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey
1. Press Mode > Dual ARB > Select Waveform.
2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

— change the number of times each segment or nested sequence plays

— delete segments or nested sequences from the sequence

— add segments or nested sequences to the sequence

— toggle markers on and off (described on page 215)

— save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

If you edit and resave a segment used in a sequence, the sequence does
not automatically update the RMS value in its header. You must select and
update the sequence header information (page 197).

Use the following steps to edit a sequence that has two different segments so that the first
segment repeats 100 times and the second segment repeats 200 times, then save the changes.
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Assumption: A waveform sequence that has two different segments has been created and stored
(see previous example on page 193).

1.

Select the sequence:
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence >
Edit Selected Waveform Sequence.

Change the first segment so that it repeats 100 times:
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry.

Change the repetition for the selected entry to 200:
Press Edit Repetitions > 200 > Enter.

Save the changes made in the previous steps:
Press More > Name and Store > Enter.

To save the changes as a new sequence:

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RAMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence.

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 192.

To play a waveform segment individually or as part of a waveform
sequence, the segment must reside in BBG media. See also, “Loading a
Waveform Segment into BBG Media” on page 189.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RAMP200) from the Sequence
On column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Sel ect ed Wavef orm
SEQ S| NE100+RAMP200).
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ARB
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Filter: Off

Trig Tupe: Continuous (Free Run)

Pouer Search Reference: RMS
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Annunciators display with active waveform (ARB On)

Arb
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0ff N

Select,
Haveform
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Arb Setupk
Trigoer Tupe

ree Fun)

Fhase Moise: Off
03/0L/2012 15:36 Hore 1 of 2

2. Generate the waveform:
Press ARB Off On to On.

This plays the selected waveform sequence. During the waveform sequence generation, both
the I / Qand ARB annunciators turn on, and the waveform modulates the RF carrier.

3. Configure the RF output:

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector.
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Saving a Waveform’s Settings & Parameters

This section describes how to edit and save a file header. When you download only a waveform file
(I/Q data, which the signal generator treats as a waveform segment), the signal generator
automatically generates a file header and a marker file with the same name as the waveform file.
Initially the file header has no signal generator settings saved to it, and the marker file consists of
all zeros. For a given waveform, you can save signal generator settings and parameters in its file
header and marker settings in its marker file (page 203); when you load a stored waveform file into
BBG media, the file header and marker file settings automatically apply to the signal generator so
that the dual ARB player sets up the same way each time the waveform file plays.

Figure 9-4 Header Utilities Softkeys
Mode > Dual ARB > - Edit Header
More > Edit feader
. _— Enter
Header Utilities Edit Header
i Enter
Edit.
Descript.ion*[—— page 200 Unspecified
Edit, Unspecified
RHS Calculate
Edit AHGN A
RMS Owverride”
Header File
Clear Header Stored
Edit. Header — et T Seaments
Save Setup
To Header Select Header Sequence
For details on each key, Hore 1 of 2 Salect
use key help - DifferentH—m
as described on Header (ngtgégﬁe%g?y_» BBG Seaments
page 40.

When you create a waveform sequence (as described on page 192), the signal generator
automatically creates a waveform sequence header that takes priority over the individual waveform
segment headers. During a waveform sequence playback, the segment headers are ignored, except
to verify that all required options are installed. Storing a waveform sequence also stores its file
header.

Some of the current signal generator settings shown in the file header appear as part of the softkey
labels, and others appear in the dual ARB summary display, shown in the following example.
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ARB

FREQUEHCY

6.000 000 000 00 &+

Selected laveform: UFM1:RAMP_TEST_UFN
frt Sample Clock: 200.000000000HHz
Filter: Off

All settings in this menu can be stored
to thefile header
(Table 9-1 on page 198 lists all

AAPLITUDE settings stored in a file header)

0.00 den

Arb Setup

Softkey label,
Arb Sample Clock file header
200, 000000000MH=z setting
off
Real-Time ALGN,
Setup
eI T The Runtime

Fhase Moise Setup

Trig Tupe: Continuous (Free Run)

Pouer Search Reference: Fixed
AUGH: Off

Scaling softkey is
only available under
the Dual ARB menu.

Funt.ime Scaling A
70.00 X

Phaze Moise: Off

03/04/2012 16:01 Modulator Atten

ARB summary, file
header settings

Table 9-1
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Hore 1 of 2 Softkey labels
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Arb Setup
see page 241 Basaband
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0.000 Hz
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Setupk
(Off2

Feal-Time
Modulat ion F%é%erb

fore 2 of 2

File Header Entries

A description entered for the header, such as a the waveform’s function (saved/edited with the
Edit Description softkey, see Figure 9-4 on page 197).

The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown
in “Dual ARB Softkeys” on page 188).

The Runtime scaling value is applied in real-time while the waveform is playing. This setting can be
changed only for files playing in the dual ARB player (see page 238).

When the modulator attenuation setting (see page 188) is set to Auto, this value is used to calculate
the 1/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562.

Marker polarity can be positive or negative (described on page 215).

Which marker, if any, implements the ALC hold function (described on page 205), which holds the
ALC at its current level when the marker signal is low. All waveforms generated in the signal
generator have a marker on the first sample paint. To see the results from the three routing
selections, you may need to select a range of sample (marker) points (see “Setting Marker
Points in a Waveform Segment” on page 210).

Which marker, if any, implements the RF blanking function (described on page 214) when the
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold
Routing for the same marker when you are using the RF Blank Routing function. When the marker
signal goes high, RF blanking discontinues.

The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 9-1 on
page 188).

The baseband frequency offset, in Hz (see page 241).
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Table 9-1 File Header Entries
AWGN: State Indicated whether real-time noise is on (1) or off (0) (see page 341).
AWGN: C/N Ratio Carrier to noise ration, in dB (see page 346).
AWGN: Carrier BW Bandwidth over which the noise power is integrated, in Hz (see page 346).
AWGN: Noise BW Bandwidth of the noise, in Hz (see page 346).
AWGN: Carrier RMS The carrier RMS across the carrier bandwidth (see page 346).
Phase Noise State Indicated whether phase noise is on (1) or off (0) (see page 350).
Phase Noise F1 The start frequency for the level mid-frequency characteristics (see page 350).
Phase Noise F2 The end frequency for the level mid-frequency characteristics (see page 350).
Phase Noise Lmid The amplitude for the level mid-frequency characteristics (see page 350).
Modulation Filter The real-time modulation filter type selected (see page 263).
Over-Range Protect Indicated whether DAC Over-Range Protection is on (1) or off (0) (see page 354).
Unique Waveform Id 0=no Id; once an Id is assigned, it cannot be changed.
License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and

Licenses” on page 37

Can be Read Out Indicates whether the waveform can be queried through SCP! or FTP.

Viewing and Modifying Header Information
The following example uses the factory-supplied waveform file RAMP_TEST_WFM
1. From BBG media, select the waveform RAMP_TEST WM
a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On column, highlight the waveform RAMP_TEST_WM
c. Press Select Waveform.
2. Open the Header Utilities menu:
Press More > Header Utilities

The Figure 9-5 shows the default file header for the factory-supplied waveform
RAMP_TEST_WFM The Header Fi el d column lists the file header parameters; use the Page
Down key to see them all.

The Saved Header Setti ngs column shows that most of the settings are Unspeci fi ed.
Unspecified means that there is no setting saved for that particular parameter.

The Qurrent Inst. Settings column shows the current signal generator settings. In this
example, these are the settings that you will save to the file header.
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Figure 9-5

If a setting is unspecified in the file header, the signal generator uses its
current value for that setting when you select and play the waveform.

Example File Header

Mode > Dual ARB > More > Header Utilities

FREQUEHCY

6.000 000 000 00 &+

The name of the waveform file.

Edit The description can be up to
Description®} 32—-characters.

0.00 den

Edit

3. Save the information in the Curr ent

»
File Header Information :WHFM:RRHP_TESTJIFH - : RMS™]  Opens a menu for manually
Header Field Save Current Inst. Settings defining the carrier RMS value
Description Ramp (I down, @ up) HHSESR HL_JEN' | to use for calculating the
wertide WVGN: i i
Sample Rate Unspeci fied 200, 000000000MHz pve cart) er RiBvaluein
Funt.ime Scaling 78.78 % N 79.79 % € Header Feld.
0.51L852207 M/A Clear Header 4—r
Marker 1 Polarity A Unspecified Fos hsasgésr g;;a\fd
Marker 2 Polaritu T Unspecified Fos : 9
Marker 3 Polarity | Unspecified Pos Save setup | ©ntries to default
Marker L Polarity | Unspecified Pos To Header settings
ALC Hold Routing Unspecified Mone
03/04 /2012 16:01 fore 1 of 2 -
Edit. Header
Default header settings Current signal generator settings Enter

To calculate the RMS waveform voltage:
Press Calculate
Then refer to Header Field information.

Note: For greater accuracy, if the waveform has long rise/fall times, a DC
offset, or noise* already added to the waveform (for a bursted signal), it Calculate
is recommended that the Edit RMS and Edit AWGN RMS Override

Unspecified

softkeys are used for the best measurement accuracy.

*Option 403 Real-time AWGN does not affect the Header Field RMS
value. But, noise added to the waveform prior to downloading and
playing in the signal generator does affect the Header Field RMS value.

Press Save Setup To Header.

Inst. Settings column to the file header:

Both the Saved Header Setti ngs columnandthe Qurrent Inst. Settings column now
display the same values; the Saved Header Setti ngs column lists the settings saved in the
file header.

4. Edit and Update Settings

a. Return to the ARB Setup menu:

Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the
file header. Figure 9-1 on page 188 shows the ARB Setup softkeys used in the following

steps.

b. Set the ARB sample clock to 5 MHz:
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%:
Press Waveform Runtime Scaling > 60 > %.

d. Return to the Header Utilities menu:
Press Return > More > Header Utilities.

200
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As shown in the following figure, the Qurrent I nst. Settings column now reflects the
changes to the current signal generator setup, but the saved header values have not

changed.

FREQUEHCY

Header Fie
Description

Sample Rate
Funt.ime Scaling

Marker 1 Polarity
Marker 2 Polarity
Marker 3 Polarity
Marker L Polarity
ALC Hold Routing

6.000 000 000 00 &+

File Heade{dInFormatéon: HFH1 :RANP_TEST_UFN

aved Header Settings
Rame (I down, O up)

78,78 %

ANPLITUDE

0.00 den

Current Inst. Settings

0. 5ILEEZZ0T
Fos

Fos

Fos

Fos

Mone

Fos
Fos
Fos
Fos
Mone

03/04/2012 16:17

Edit. Header
Edit,
Description

Edit.

RS

Edit AMGM,
RMS Override
Clear Header

Save Setup
To Header

fore 1 of 2

e. Save the current settings to the file header:
Press the Save Setup To Header softkey.

Values differ between
| the two columns

The settings from the Qurrent I nst. Settings column now appear in the Saved
Header Settings column. This saves the new current instrument settings to the file

header.

If you change any of the signal generator settings listed in the file header after you select the
waveform file, the changed setting(s) appear in the file header's Qurrent Inst. Settings
column and are used instead of the saved header settings. To reapply the saved header settings,
reselect the waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 199, you can view and edit a waveform’s header information after you select
the waveform; you can also edit waveform header information without selecting a waveform, or for
another waveform than the one that is currently selected.

1. Access the file header utilities menu:
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was
last selected. The following figure shows an example of the factory-supplied waveforms in

BBG media.
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Active catalog Active media

6.000 000 000 0O &+
Catalo? eoF gl?g Seoment Files) in(BBG

LIFM1

ANPLITUDE Header File

Active waveform catalog
Select Header

0.00 den

Catalog Tupep)
UKE used 3.87GB free  \.BBG Seaments)
Size NModified

1 EEREREE Y] S00 B O3/0412 1L:EL
2 SINE_TEST_LFM 800 B 03/04/12 1L:BL

03/04/2012 16:20

\i

Header File

Type: Catalogs that enable you to

WFM1 = Volatile Segment Segﬁgggg view files in the active media.

NVWFM = Non-Volatile Segment For details on selecting the

SEQ = Sequence active media, see page 58.
Sequence

BBG Seoments

Files in BBG media —

For details on each key, use key help
as described on page 40.

2. If the desired catalog is not displayed, select it.
3. Highlight the desired waveform file and press Select Header.
The signal generator displays the file header for the selected waveform file.

4. To edit the header, press More, and proceed as described in Step 4 on page 200 (Viewing and
Modifying Header Information section).
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Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform
segment. \WWhen the signal generator encounters an enabled marker, an auxiliary signal is routed to
a rear panel event output that corresponds to the marker number.

— Event 1 is available at both the EVENT 1 BNC connector (see page 15), and a pin on the
AUXILIARY 1/0 connector (see page 17).

— Event 2 is available at the TRIG 1 & TRIG 2 connectors (see page 13), and a pin on the
AUXILIARY 1/0 connector (see page 17).

— Events 3 and 4 are available at pins on the AUXILIARY 1/0 connector (see page 17).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer
to “Using Waveform Markers” on page 203 for details.

When you download a waveform file that does not have a marker file associated with it, the signal
generator creates a marker file without any marker points. Factory-supplied segments
(RAMP_TEST_WMand SI NE_TEST_WM have a marker point on the first sample for all four
markers.

The following procedures demonstrate how to use markers while working in the dual ARB player.
These procedures also discuss two types of points: a marker point and a sample point. A marker
point is a point at which a given marker is set on a waveform; you can set one or more marker
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:
Clearing Marker Points from a Waveform Segment on page 209
Setting Marker Points in a Waveform Segment on page 210

Controlling Markers in a Waveform Sequence on page 215

This section also provides the following information:

— Waveform Marker Concepts on page 204

— Accessing Marker Utilities on page 208

— Viewing Waveform Segment Markers on page 209
— Viewing a Marker Pulse on page 212

— Using the RF Blanking Marker Function on page 214
— Setting Marker Polarity on page 215
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment.
You can set each marker’s polarity and marker points (on a single sample point or over a range of
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

R Positive 48 EVENT N
Marker

N _I_ Marker N
Bit N

it ~|_|— RF Blank Off On
Set Marker Marker /O Marker N

Blanks RF when

\j

_ i N i !

On Off Polarity egative | Markeris Low
When the signal generator encounters an enabled marker (described on page 215), an : RF Blank Only: includes ALC Hold
auxiliary output signal is generated and routed to the rear panel. :

) ’ . / Marker N

Event 1 is available at the EVENT 1 BNC connector (see page 15), and at a pin on the (g » Holds ALC when
AUXILIARY 1/O connector (see page 17). Marker is Low
Events 2 through 4 are available at pins on the AUXILIARY I/O connector Marker N

ALC Hold Off On

Marker Signal Response

The signal generator aligns the marker signals with the | and Q signals at the baseband generator.
However some settings such as amplitude, filters, and so forth within the RF output path can create
delays between the marker EVENT output signal and the modulated RF output. When using the
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency,
and if needed, reset the marker point positions, include delay (page 249), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker
file associated with it causes the signal generator to automatically create a marker file, but does
not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG
media (see “Loading a Waveform Segment into BBG Media” on page 189).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator,
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the
marker polarities or routing (RF Blanking and ALC Hold) and save the information to the file header
(page 197).

When you use a waveform that does not have marker routings and polarity
settings stored in the file header, and the previously played waveform used
RF Blanking, ensure that you set RF Blanking to None. Failure to do so can
result in no RF output or a distorted waveform.
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either
before or after you set marker points (page 210), setting a marker function before setting marker
points may cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods,
burst ramps, or when the increased dynamic range encountered with RF blanking (page 214) is not
desired.

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output
signal (the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.

Negative The signal is sampled during the off marker points.

Because it can affect the waveform’s output amplitude, do not use the ALC
hold for longer than 100 ms. For longer time intervals, refer to “Power
Search Mode” on page 103.

Markers set to account for marker

. ."- -

:1 response relative to RF output
RF OUTPUT | : >>
==l
Mark > H
. .al ker J == :
Positive < 100 ms .

Max ALC hold time

Incorrect ALC sampling can create a sudden unleveled condition that may
create a spike in the RF output, potentially damaging a DUT or connected
instrument. To prevent this condition, ensure that you set markers to let
the ALC sample over an amplitude that accounts for the higher power
levels encountered within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the
waveform’s area of highest amplitude. Note that the
marker is set well before the waveform’s area of lowest
amplitude. This takes into account any response
difference between the marker and the waveform signal.

Here the ALC samples during the on marker points
o “

()
Example of Incorrect Use
Waveform: 1022 points
Marker range: 110-1022

Marker polarity: Positive

The ALC samples the waveform when the marker
signal goes high, and uses the average of the
sampled waveform to set the ALC circuitry.

Marker

This example shows a marker set to sample the low s o i Vs
part of the same waveform, which sets the ALC Marker ]
modulator circuitry for that level; this usually results /

in an unleveled condition for the signal generator bulse Unieveled
when it encounters the high amplitude of the pulse.
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Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative
This figure shows that a negative polarity marker goes s

low during the marker on points; the marker signal goes  pilaak el etiaatite! Bhangiil oL S ilihe
high during the off points. The ALC samples the

waveform during the off marker points. Sample range begins on first point of signal

Sampling both on and off time sets the modulator

circuitry incorrectly for higher signal levels. Note the -
increased amplitude at the beginning of the pulse.

Marker Marker

Negative range set between signal and
off time
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Accessing

Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Note: This is the Marker Routinge-

second Arb m

page 47

— Route Ta,

Arb Harkers

For details on each key, use key help
as described on page 40.

Harker Polarity

Marker 1 Polarit
Heg IEEEH

Marker Polaritupf———9 The settings in these menus

Marker ENESl% - can be stored to the file

enu.

Set Markersk

Easeband BNCs

Arb Harkers
Marker
EH: 34

Set Marker On
First Point

Set. Marker On,|
Range 0Of Points

Set. Marker Off

header, see page 197.
Marker 3 Polarit
Heg IEEEH

Marker L Polarit fMkr To ALC Hold
Heg IEEEH

/ Mkr To Pulse

/

* Hone

Marker Range
First Mkr Poin%

Last Mkr Point
200

# Skipped Pointg

F————® Applu To Haveform

\)

Range 0Of Points

Displad Haveform,)
And Markers®]

The display below shows the |

FREQU

Narker Routing

Pulse/RF Blank,

/ (Mone)™ Marker 1
> -

ALC Hold,
Nome P Marker 2

- Alternate
Marker Range Amplitudek Marker 3

(None )

First Mkr Poin%

_ Marker L

Last Mkr Point
200

Apply To Hawveform

and Q components of the waveform, and the

marker points set in a factory—supplied segment.

EHCY

6.000 000 000 00 &+

ARB uauefur‘m And Markers
UFNL :RANP_TEST_WFTI

ANPLITUDE

-144.00 den

First sample point
shown on display

Sample Poin%

These softkeys change
the range of waveform
sample points shown

Zoom In

FLm=\o A

Zoom Out. on the marker display.

Each press of the
Zoom In Hax softkey changes the
sample range by
approximately a factor
Zoom Out Max of two

Marker points
on first /
sample point

Sample Point

28
03/05/2012 12:12

208

Keysight EXG and MXG X-Series Signal Generators User’s Guide



Basic Digital Operation (Option 653/655/656/657)
Using Waveform Markers

Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a
segment (this example uses the factory-supplied segment, SI NE_TEST_WFM.

1. In the second Arb menu (page 208), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SI NE_TEST_WFM.
3. Press Display Waveform and Markers > Zoom in Max.

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set points, view the segment

(page 209) and remove any unwanted points. With all markers cleared, the level of the event output
signal is OV. To clear marker points on a segment, the segment must reside in BBG media

(page 189).

Clearing All Marker Points

1. In the second Arb menu (page 208), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SI NE_TEST_WFM).

3. Highlight the desired marker number: Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected segment:
a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of
the waveform. The factory-supplied waveform (SI NE_TEST_WFM contains 200 samples. To
clear all set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10-20. This
makes it easy to see the affected marker points. The same process applies whether the existing
points are set over a range or as a single point (page 210)!

1. In the second Arb menu (page 208), press Marker Utilities > Set Markers, then select Marker
1.

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.
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3. Set the last marker point in the range that you want off to a value less than or equal to the
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this
example, 17):

Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

Arb Waveform And Markers
UFN1:SIHE_TEST_WFNI

This turns off all marker points for the
active marker within the range set in
Steps 2 and 3, as shown at right.

FWM= 89 H

How to view markers is described on
page 209.

1 Sample Point 28

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 209, but set both the first
and last marker point to the value of the point you want to clear. For example, if you want to clear a
marker on point b, set both the first and last value to b.

Setting Marker Points in a Waveform Segment
To set marker points on a segment, the segment must reside in BBG media (page 189).

When you set marker points, they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set marker points within a segment,
view the segment (page 209) and remove any unwanted points (page 209).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 208), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment.
3. Select the desired marker number: Press Marker 1 2 3 4
4. Set the first sample point in the range (in this example, 10):
Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends
on sample point 20, as shown in the following figure.
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Arb Waveform And Markers
UFN1:STHE_TEST_UFNI

FwMe O H

1 Sample Point 28

How to view markers is described on page 209

Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 208), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment.

3. Select the desired marker number:
Press Marker 1 2 3 4.

4. Press Set Marker On First Point.
This sets a marker on the first point in the segment for the marker number selected in Step 3.
On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 210, but set both
the first and last marker point to the value of the point you want to set. For example, if you want to
set a marker on point b, set both the first and last value to b.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped
points) between each marker. You must set the spacing before you apply the marker settings; you
cannot apply skipped points to a previously set range of points.

The skipped points value is limited to the size of the range of points.

Remove any existing marker points (page 204).
In the second Arb menu (page 208), press Marker Utilities > Set Markers.

Highlight the desired waveform segment.

A\

Select the desired marker number:
Press Marker 1 2 3 4.

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than
or equal to the number of points in the waveform, and greater than or equal to the first marker
point, in this example, 25):

Press Last Mkr Point > 25 > Enter.
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7. Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on every Arb Uavarorn And Miarkers
other point (one sample point is skipped) HF :STHETESTAFD
within the marker point range, as shown at
right.

FwMe O H

How to view markers is described on
page 209.

1 Sample Point 28

One application of the skipped point feature is the creation of a clock signal as the EVENT output.

Viewing a Marker Pulse

When a waveform plays (page 195), you can detect a set and enabled marker’s pulse at the rear
panel event connector/Aux I/0 pin that corresponds to that marker number. This example
demonstrates how to view a marker pulse generated by a waveform segment that has at least one
marker point set (page 210). The process is the same for a waveform sequence.

This example uses the factory-supplied segment, SI NE_TEST_WMin the dual ARB Player.
Factory-supplied segments have a marker point on the first sample point for all four markers, as
shown.

Arb Waveform And Markers
Marker points on UFN1:SIHE_TEST_UFN
first sample point of I

waveform segment

-

1 Sample Point 28

FLrde

How to view markers is described on page 209

In the first Arb menu (page 188), press Select Waveform.
Highlight the SI NE_TEST_WFMsegment and press Select Waveform.
Press ARB Off On to On.

Connect the signal generator’s rear panel Q QUT output to the oscilloscope’s channel 1 input.

a r wnh =

Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope’s channel 2
input.
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When marker 1 is present, the Keysight MXG/EXG outputs a signal through EVENT 1 as shown
in the following example.

QouT

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the
Marker Utilities menu) either before or after setting the marker points (page 210), setting a marker
function before you set marker points may change the RF output. RF Blanking includes ALC hold
(described on page 205, note Caution regarding unleveled power). The signal generator blanks the
RF output when the marker signal goes low. This example is a continuation of the previous example,
Viewing a Marker Pulse.

1. Using the factory-supplied segment SI NE_TEST_WM set Marker 1 across points 1-180
(page 210).

2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:
In the second Arb menu (page 208), press Marker Utilities > Marker Routing > Pulse/RF
Blank > Marker 1.

Marker Polarity = Positive

When marker polarity is positive (the default
setting), the RF output is blanked during the off
marker points.

| | || [ || || |
N 1
I v

S . N : L =~3.3V

e ov

il Marker Polarity = Negative

I When marker polarity is negative, the

RF output is blanked during the on marker
points

T

ov

Point 1 180 200
|<«—Segment—— |
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Setting Marker Polarity
Setting a negative marker polarity inverts the marker signal.
1. In second Arb menu (page 208), press Marker Utilities > Marker Polarity.
2. For each marker, set the marker polarity as desired.
— The default marker polarity is positive.

— Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 204.

As shown on page 214:
Positive Polarity: On marker points are high (=3.3V).
Negative Polarity: On marker points are low (OV).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed
to the rear panel EVENT output (described in “Rear Panel Overview (N5171B, N5172B, N5181B, &
N5182B)” on page 12) corresponding to that marker number. For a waveform sequence, you
enable or disable markers on a segment-by-segment basis; this enables you to output markers for
some segments in a sequence, but not for others. Unless you change the sequence marker settings
or cycle the power, the marker setting for the last segment edited in the sequence applies to all
segments in the next sequence that you build. For information on building a waveform sequence,
see “Creating a Sequence” on page 192.
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Figure 9-6
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Show Haveform
Sequence Contents
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For details on each key, use key help

as described on page 40.
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s
markers independently. You can enable or disable the markers either at the time of creating the
sequence or after the sequence has been created and stored. If the sequence has already been
stored, you must store the sequence again after making any changes. Enabling a marker that has
no marker points has no effect on the auxiliary outputs. To set marker points on a segment, see
“Setting Marker Points in a Waveform Segment” on page 210. This example assumes that a
waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 189).
2. From the second Arb menu, press Waveform Sequences.
3. Highlight the desired waveform sequence.
4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.
5. Toggle the markers:
a. Highlight the first waveform segment.

b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker
4,

An entry in the Mr column (see figure below) indicates that the marker is enabled for that
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.
6. Press Return > More > Name and Store.

7. Either rename the sequence using the text entry keys (see page 190) or just press Enter to
save the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence
file.

The following figure shows a sequence built using one of the factory-supplied waveform segments;
a factory-supplied segment has a marker point on the first sample for all four markers. In this
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and
markers 3 and 4 are enabled for the third segment.

P e e e

Seament. On Sequence On (UNSTORED) SIHE+RANP
Pa 1/1 BEG Hedia Int Nedia Po 1/1 Haveform Reps Hkr Sequence marker column
RAMP_TEST_MFT ANTENNAZH WFFL s SINE_TES T_WFH 1
STHE_TEST_UIFN SINE+RAIP LIFM1:SINE_TEST_MFH 2 Toggle Marker 3 )
SINE100+RAMPZO0 LFH1:STNE_TEST HFH This entry shows that markers
3 and 4 are enabled for this

segment.

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.
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Using the EVENT Output Signal as an Instrument Trigger

For details on each key, use key help as described on page 40.

One of the uses for the EVENT output o

signal (marker signal) is to trigger a [ ) The setings in this menu
measurement instrument. You can set v ——— header, see page 197.

up the markers to start the fiodulat on Hode o

measurement at the beginning of the Dual AREY— g o e

waveform, at any single point in the e Custon ooty P———— Sample
waveform, or on multiple points in the Hadu It fon” e
waveform. To optimize the use of the Real-Tine cucton, Ao SSCLRM B Resl-Tine Ao,

EVENT signal for measurements, you _ e e FelTim

may also need to adjust the sample pEpLTEAL 16me e B> Priase Noise Sstup

rate. The location of the sample rate setting is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to +4 ns on the rising and falling edge. This jitter
can be minimized in either of two ways.

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N
can be represented exactly on the display.
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on.

If the result cannot be represented exactly on the display, jitter will be present.
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8
ns. For example: A 200 point waveform with a marker on the first point and a sample clock of 50
MHz provides a marker every 4 us. Because 4 ps is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample
rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of
the original waveform with a sample rate change, you will have to also recalculate the sample
values. The following figures illustrate the marker signal jitter and its affect on the waveform.

EVENT output signal exhibits jitter Waveform appears to exhibit jitter when The jitter is gone with
due to a non-optimal sample rate triggered using EVENT signal with jitter. an optimal sample rate

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal
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Triggering a Waveform

Figure 9-7 Triggering Softkeys
Mode > Dual ARB Arb
ARE
| Off [l

Select
Haveform

Arb Setupk

Trioger Tupe
(Cont.inuous ,M——page 220
Free Run.

| page 221

fore 1 of 2

For details on each key, use key help
as described on page 40.

Triggers control data transmission by controlling when the signal generator transmits the
modulating signal. You can configure trigger settings so that data transmission occurs once (Single
mode), continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment
Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another,
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is
because the signal generator sets the | and Q signals to zero volts prior to the first trigger event. To
maintain the carrier signal at the RF output, create a data pattern with the initial | and Q voltages
set to values other than zero.

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF
output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator. This
ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a trigger.
When that trigger is received, the Arb begins playing the waveform and the modulated RF carrier
exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:
— Type determines the behavior of the waveform when it plays (see Trigger Type on page 220).

— Source determines how the signal generator receives the trigger that starts the modulating
waveform playing (see Trigger Source on page 221).
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered.

Mode > TContinuous Hode | Immediately triggers and plays the waveform; triggers
Dual ARB > received while the waveform is playing are ignored.
Trigger ype  —qrh Trigger ] Free Run
Cont inuousk > i i ived:
TiriEEEr & fum Plays the Wav_eform whe_n a trigger is received;
subsequent triggers are ignored.
Single
(Restart on Trig)"” Fiesat & Fun
Segment. Advancer Plays the waveform when a trigger is received; subsequent
triggers restart the waveform.
Gateds Ignores an early trigger
A segment in a sequence plays received while a
once, ignoring the repetition \J waveform is playing.
setting, after which the dual ARB Single Mode
player stops and waits for a A v tri ived
(FFVECERT T - trigger before advancing to the Mo Retrigger w?ui?ea;yw;\gggr:ﬁﬁs e
Active Low —V next segment. The next segment playing waits until the
Sen advance Mode then plays to completion. e Tofe. current waveform
) . . . . completes, then plays
Act.ive High Single If a trigger is received while a the waveform once
segment is playing, the segment . more
plays to completion. The dual Restart on Trig )
Cont inuous ARB player then advances to the An early trigger received
next segment and p_Iays that while the waveform is
segment to completion. playing immediately

The waveform stops during the inactive
state of the trigger source, and plays
during the active state.

restarts the waveform.

A segment in a sequence plays continuously until the waveform receives another trigger.

If a trigger is received while a segment is playing, the segment plays to completion. The
dual ARB player then advances to the next segment and plays that segment continuously.

For details on each key, use key help
as described on page 40.

The example above shows Dual ARB Mode, but trigger functionality is
similar for other modulation modes. Available trigger types vary
depending on the modulation mode selected.

— Continuous mode repeats the waveform until you turn the signal off or select a different
waveform, trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

— Single mode plays the waveform once.

In Single No Retrigger, do not use Continuous Reset & Run mode due to
the variable latency of this setup.

No Retrigger: If a trigger is received early it will be ignored. The gap in your playback is
dependent on the trigger period, after which time the RF will start up again where it is expected.

Buffered Trigger: An early trigger will cause the waveform to play to the end and then start
again. The RF will not be aligned with this early trigger.

Restart on Trigger: The ARB will reset itself and trigger again but there will some gap in the
playback while this is occurring. It will reset itself for every trigger it receives.
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— Segment Advance mode plays a segment in a sequence only if triggered. The trigger source
controls segment-to-segment playing (see Example: Segment Advance Triggering on page
222). Atrigger received during the last segment loops play to the first segment in the sequence.

— Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and
stops playing the waveform in response to an externally applied gating signal. See Example:
Gated Triggering on page 223.

Trigger Source

Mode >
Dual ARB >
Trigger Source

'

Arb Trigger

»

»  Arb Trioger

Trigger Source,
(Ext)

Trigger Keu

Patt Thia TH TN »"Ext Trio &
a rig In - * Ext Trig Source
Neg = the signal generator = -
responds during the trigger signal Patt Trig 1 Patt Trig In BNC connector Bus
Ewt Folarity low state BHC Sourcer (see page 16)
Pos 4 : (Patt Trig)
Pos = the signal generator Patt Trig 2
Ext. Delay responds dugring ?he trigger signal (BB ?ﬁggggﬁrg?' Aux /0 connector Ext
on high state. (see page 17)

Key inactive until Ext
Delay is enabled On.

For details on each key, use key help
as described on page 40.

External Trigger Polarity

— In Continuous, Single, and Segment Advance modes, use the Ext Polarity softkey to set the
external trigger polarity.

— In Gated mode, the Active Low and Active High softkeys (page 220) determine the external
trigger polarity.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform
sequence. This type of triggering ignores the repetition value (page 194). For example if a segment
has repetition value of 50 and you select Single as the segment advance triggering mode, the
segment still plays only once. The following example uses a waveform sequence that has two
segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on
page 192.

1.
2.

Preset the signal generator.

Configure the RF output:

— Set the desired frequency.

— Set the desired amplitude.

— Turn on the RF output.

Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.
c. Press Select Waveform.

Set the triggering as follows:

— Trigger Type: continuous Segment Advance
Press Trigger Type > Segment Advance > Continuous.

— Trigger source: Trigger hardkey
Press Trigger Source > Trigger Key.

Generate the waveform sequence:
Press ARB Off On until On highlights.

(Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure
the oscilloscope so that you can see the signal.

. Trigger the first waveform segment to begin playing continuously:

Press the Trigger hardkey.

Trigger the second segment:
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next
segment to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering
Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear panel PAT TRIG IN
connector, as shown in the following figure. This connection is applicable to all external
triggering methods. The optional oscilloscope connection enables you to see the effect that
the trigger signal has on the RF output.

Function Generator
A A—
)

pooooooog o
Oooooooog @

&...

Signal Generator ( PAT TRIG Oscilloscope

L N NG
0 EEEE — D
” o %Eﬂn 9 ee =IO‘I ‘

o aoc 090

Channel 1 Channel 2

C— Y PV

2. Preset the signal generator.
3. Configure the RF output:
— Set the desired frequency.
— Set the desired amplitude.
— Turn on the RF output.
4. Select a waveform for playback (sequence or segment):
a. Press Mode > Dual ARB > Select Waveform.
b. In the Segnent (On or Sequence On column, highlight a waveform.
c. Press Select Waveform.
5. Set the triggering as follows:

— Trigger type: Gated
Press Trigger Type > Gated.

— Active state: Low
Press Active Low.

— Trigger source: External
Press Trigger Source > Ext.

— Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.

7. On the function generator, configure a TTL signal for the external gating trigger.
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8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external
triggering signal. You will see the waveform modulating the output during the gate active
periods (low in this example).

The following figure shows an example display.

Modulating Waveform RF Output

N
N e

]

Externally Applied Gating Signal
Gate Active = Low

224 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Basic Digital Operation (Option 653/655/656/657)
Triggering a Waveform

Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel

BNC connector
N
AT TRIG FUNCTION

- GENERATOR
— — —

1 [ — —
Booooooooaoo [
Coooooooo0o0 =®
E==] ooooooos ©

o @ @e O Dooooooog g

SIGNAL GENERATOR OUTPUT

1. Connect the signal generator to the function generator as shown above.
2. Configure the RF output:

— Set the desired frequency.
— Set the desired amplitude.
— Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segrment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform:
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

d. External Trigger Polarity: positive
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms
Press More > Ext Delay until On highlights
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

— Waveform: 0.1 Hz square wave
— Output Level: 3.5V to 5V.
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Clipping a Waveform

Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting
in spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping
function enables you to reduce high power peaks by clipping the | and Q data to a selected
percentage of its highest peak, thereby reducing spectral regrowth.

— How Power Peaks Develop on page 227

— How Peaks Cause Spectral Regrowth on page 229

— How Clipping Reduces Peak-to-Average Power on page 230
— Configuring Circular Clipping on page 233

— Configuring Rectangular Clipping on page 234

Figure 9-8 Clipping Softkeys
Arb
Mode > Dual ARB > More —p» T TFN Utilities
Sequences —_—
Eég%, Arb Clipping
Haveform, Clipping Tupe
S H— 2
UsllteEs Scale Waveform WEEXIA lI_El” 191
Data®
Ut 113C5ee> tue 1l
Clipping,| g T
(II+3al*
 Header,
Utilities Available only when
clipping type = Il, |Q|
For details on each key, use key help _llore 2 of 2 |
as described on page 40. Apply To Hawveform
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks
develop as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an
unusually high power peak (positive or negative) occurs in the summed waveform.

Because the high and low states of the bits in channel waveforms are random and generally result
in a canceling effect, high power peaks occur infrequently with multiple channel summing.

I I I I I I I Multiple Channelsto be

Summed Into One Tor Q

o ("

|

Summed lor Q Waveform

- - -
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Combining the | and Q Waveforms

When the | and Q waveforms combine in the I/Q modulator to create an RF waveform, the
magnitude of the RF envelope is HIZ+QZ, where the squaring of | and Q always results in a positive
value.

As shown in the following figure, simultaneous positive and negative peaks in the  and Q
waveforms do not cancel each other, but combine to create an even greater peak.

4V
| _|_
[ and Q Waveforms
to be Combined
Q a— Q
RY 1
——— —+— i I
[ | 4 1
|
-+ 566V 4V
1
4 1
566V |
Resultant Baseband TV T
Waveform Determined Vector Representation
by A 12 02
yNT*Q of High Peak
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How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high peak-
to—average power ratio, as illustrated in the following figure.

———————————————— Peak Power

Average Power

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that
develops on each side of the carrier (similar to sidebands) and extends into the adjacent frequency
bands (see the following figure). Clipping provides a solution to this problem by reducing the peak-
to—average power ratio.

Spectral
Regrowth

1
1
1
1
|
1
1

RF Signal Adjacent Band
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How Clipping Reduces Peak-to-Average Power

You can reduce peak-to-average power, and consequently spectral regrowth, by clipping the
waveform. Clipping limits waveform power peaks by clipping the | and Q data to a selected
percentage of its highest peak. The Signal Generator provides two methods of clipping:

— Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 9-9, the clipping level is constant for all phases of the vector and appears as
a circle in the vector representation.

— Rectangular clipping is independently applied the | and Q data.

As shown in Figure 9-10 on page 231, the clipping level is different for | and Q, and appears as
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that
reduces spectral regrowth but does not compromise the integrity of the signal. The two
complementary cumulative distribution plots in Figure 9-11 on page 232 show the reduction in
peak-to-average power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is
clipped). The peaks can often be clipped without substantially interfering with the rest of the
waveform. In many cases, data that might otherwise be lost in the clipping process is retained
because of the error correction inherent in the coded systems. If you apply excessive clipping,
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that
reduces spectral regrowth while retaining needed data.

Figure 9-9 Circular Clipping
Peak Power Without Clipping _- -~ -
/ (Clipping Setto 100%) \/ , — .~
_____-._T __________ ,/ 1 \\
/ \

1 \

\ I
1 I L] | | 1 1 | 1 I
453V L 1 \ 1 o

\ 4 KV
Clipped Baseband Waveform ~ ’

. e - ™

Vector Representation
of Clipped Peak

230 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Basic Digital Operation (Option 653/655/656/657)
Clipping a Waveform

Figure 9-10 Rectangular Clipping

Q
T
P N—
r______b___l
______________ | P
Clipped | Waveform : :
L I 3v 1. 1
I 1 Ll 'l |I
o
|
c - :
I ¥ |

Vector Representation

of Clipped | & Q Peak
Q ; g a) || Clipping Setto 100% (No Clipping)
2V
¥ o b) |l| Clipping Setto 75% of Greatest Peak

c) |Q| Clipping Set to 100% (No Clipping)

—_— = e mme— = = = = — = - d) |Q| Clipping Set to 50% of Greatest Peak
Clipped Q Waveform
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Figure 9-11 Reduction of Peak-to-Average Power
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Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak-to-average
power ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped
equally). For more information about circular clipping, refer to “How Clipping Reduces Peak-to-

Average Power” on page 230.

Clipping is non-reversible and cumulative. Save a copy of the waveform
file before you apply clipping.

Copy a Waveform File

1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.
2. Highlight the waveform RAMP_TEST_WM

3.

4. Name the copy (in this example, the name is MY_TEST_Cl RC) and press Enter.

Press Copy File.

Apply Circular Clipping to the Copied Waveform File

1.

Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform
Utilities.

2. In the list of files, highlight the copied file (in this example, M¥_TEST_O RQ).

3. Create the CCDF plot: Press Plot CCDF.

4. Observe the shape and pOSitiOﬂ of the Example waveform curve before clipping
waveform’s curve (the dark line in the . CONMPLEMENTARY CUNULAYIVE DISTRIBUTION
example at right). 2,507 o B 100 UAUEFORN:_T¥/TEST_CTRC

. . . 107 3.90d8 | B 10%

5. Activate circular clipping: Press Return > 0o -0 g 1
Clipping > Clipping Type until [I+jQ| oy i L O
highlights. ¥ 0.001%

0 PEAK/AUG_dB 10.0

6. Set circular clipping to 80%:

Press Clip [1+jQ| To > 80 > %.

7. Apply 80% clipping to the | and Q data: Press Apply to Waveform.

8. Create the CCDF plOt (See the example Example waveform curve after circular clipping
at right): Press Plot CCDF. /

. COMPLENENTARY CUMULATIVE DISTRIGUTION

9. Observe the waveform’s curve after u5.002  0ds | B 1007 N

S PR B 10%

clipping. 01% o EE I

. . 0.017 ----dB | I .17

Note the reduction in peak-to-average Uiy dE % 0. 01%
power relative to the previous plot. ¥ 0.001% Lo B o TE
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Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the | and Q data
independently. For more information about rectangular clipping, refer to “How Clipping Reduces

Peak-to-Average Power” on page 230.

Clipping is non-reversible and cumulative. Save a copy of the waveform
file before you apply clipping.
Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.
2. Highlight the waveform RAMP_TEST_WM
3. Press Copy File.
4. Name the copy (in this example, the name is MY¥_TEST_REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform
Utilities.

2. In the list of files, highlight the copied file (in this example, M\¥_TEST REC).
3. Create the CCDF plot: Press Plot CCDF.

4, Observe the shape and pOSitiOﬂ of the Example waveform curve before clipping
waveform’s curve (the dark line in the ) CONPLERENTARG CUTULATIVE QISTRIGUT 0
example at right). w2502 o B 1002 : Iy

. . 10z 3.90a8 | B 10z

5. Activate rectangular clipping: Press il = B 1z

Return > Clipping > Clipping Type until | o%0i == L 01

. . Peak  L.7 dB % 0.01%

1,|Q| highlights. ¥ 0.001%
0 PEAK/AUG_dB 10.0

6. Set 80% clipping for the | data: Press
Clip |I| To > 80 > %.

7. Set 40% clipping for the @ data: Press Clip |Q| To > 40 > %.
8. Apply the rectangular clipping to the waveform: Press Apply to Waveform.

9. Create the CCDF pl.Ot (See the example Example waveform curve after rectangular
at right): Press Plot CCDF. clipping
10.0bserve the waveform’s curve after 0,507 v lB muf”"PLE"E"Lﬂﬁ” G ok _pg oeuT IO
Cllpplng' 107 —-——- dB g 10%
17 --——dB | A .
. 0.1 --——- dB | B i
Note the reduction in peak-to-average Q017 8 |1 gy
power relative to the previous plot. Peak 2.7 dB i 0-01%
0-001 5 PEAK/AUG_dB 10.0
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Scaling a Waveform

The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which
may create a DAC over-range error condition. This chapter describes how DAC over-range errors
occur and how you can use waveform scaling to eliminate these errors.

— How DAC Over-Range Errors Occur on page 236

— How Scaling Eliminates DAC Over-Range Errors on page 237

— Keysight MXG/EXG waveform scaling on page 238 and page 239:
— Waveform runtime scaling to scale a currently-playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a non-
playing waveform file in BBG media

Figure 9-12 Scaling Softkeys

Mode The settings in this menu can
be stored to the file header,
see page 197.

Arb
Todniation Hode ARE Arb Setu
Hodulation Mode GEE on P
Arb Sample Clock
Oual AREK—> A 200.000000000MH=
Waweform®
ARE Custom, Real-Time ALGN,
Modulation Setup
Arb Setupkf—B
Real-Time Custom, Real-Time,
Modulat ion Trigger Tupe Fhase Moise Setup
(Cont inuous ,»
- Free Run) g - . .
prﬁgéﬂérnrg Runt. ime ?Baéé”g <4 \Waveform Runtime Scaling, see page 238.
Hodulatog Egtgg
Multitonew o
fore 1 of 2 Marual
fore 1 of 2 v fore 1 of 2
Arb
Sggﬁg;ggg’ Waveform Scaling, see page 239.
Haveform, —
Utilities®|—®= WFM Utilities Arb Scaling
Plot Scaling
Marker CCOF* E
Utilities® AL &
Scale Haveform
Header, Data®
Utilities
Clipring,
T30
fore 2 of 2
Apply To Hawveform
For details on each key, use key help

as described on page 40.
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How DAC Over-Range Errors Occur

The signal generator uses an interpolator
filter when it converts digital | and Q INTERPOLATED SAMPLES
baseband waveforms to analog
waveforms. Because the clock rate of the
interpolator is four times that of the
baseband clock, the interpolator
calculates sample points between the
incoming baseband samples and smooths
the waveform as shown in the figure at
the right.

BASEBAND SAMPLES

The interpolation filters in the DACs
overshoot the baseband waveform. If a OVER-RANGE SAMPLES CANNOT
baseband waveform has a fast-rising BE INTERPOLATED CORRECTLY
edge, the interpolator filter’s overshoot
becomes a component of the interpolated
baseband waveform. This response
causes a ripple or ringing effect at the
peak of the rising edge. If this ripple
overshoots the upper limit of the DAC
range, the interpolator calculates
erroneous sample points and is unable to
replicate the true form of the ripple (see
the figure at the right). As a result, the
signal generator reports a DAC over-
range error.

Y

DAC RANGE

Z

BASEBAND SAMPLES
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Scaling reduces the amplitude of the baseband
waveform while maintaining its basic shape and
characteristics, such as peak-to-average power
ratio. If the fast-rising baseband waveform is
scaled enough to allow an adequate margin for
the interpolator filter overshoot, the interpolator
filter can calculate sample points that include the
ripple effect and eliminate the over-range error
(see the figure at the right).

Although scaling maintains the basic shape of the
waveform, excessive scaling can compromise
waveform integrity. For example, if the bit
resolution becomes too low the waveform
becomes corrupted with quantization noise. To
achieve maximum accuracy and optimize
dynamic range, scale the waveform no more than
is required to remove the DAC over-range error.
Optimum scaling varies with waveform content.

Basic Digital Operation (Option 653/655/656/657)

Scaling a Waveform

How Scaling Eliminates DAC Over-Range Errors

SAMPLES WITHIN DAC RANGE
INTERPOLATED CORRECTLY

L
rd

DAC RANGE

ﬁ"

AN

BASEBAND SAMPLES

<
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Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You
can apply runtime scaling to either a segment or sequence, and set the scaling value either while
the ARB is on or off. This type of scaling is well suited for eliminating DAC over-range errors.
Runtime scaling adjustments are not cumulative; the scaling value is applied to the original
amplitude of the waveform file. There are two ways to save the runtime scaling setting: by using the
save function (page 64) and by saving the setting to the file header (page 199). Saving to the file
header saves the value with the waveform file, saving with the Save function stores the value as the
current instrument setting.

Use this example to learn how to scale the currently selected waveform.
1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB Off On until On highlights.
3. Set the Waveform Runtime Scaling value:

a. Press ARB Setup > Waveform Runtime Scaling.

b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is
no single value that is optimal for all waveforms. To achieve the maximum dynamic range,
use the largest scaling value that does not result in a DAC over-range error.

c. Press Return.
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Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform
data and only applies to waveform segments stored in BBG media. You scale the waveform either
up or down as a percentage of the DAC full scale (100%). If you scale your waveforms using this
method, you may also need to change the waveform runtime scaling value to accommodate this
scaling.

When you scale, the signal generator permanently modifies the waveform file’'s sample values so
that they conform to the desired scaling value. When you initiate scaling, the signal generator
performs the following actions:

— locates the waveform file’s absolute peak sample value

— determines its current percentage of full scale

— calculates the ratio of the desired scale value to the determined absolute peak sample scale
value

— multiplies each sample in the waveform file by this ratio

Peak sample
DAC full scale 100%
. .‘../. ................ \\.\ ...... 85% of full scale—Prescaling
e = Samples o N
R RN
- . .4 = = - 60% of full scale—Post scaling
AL : L R
et e
o : e +
¥ . e :
. o : L ]
Pl .t Original ramp waveform : P ' Scaled ramp waveform

Scaled sample value = scaling ratio x prescale sample val
Scaling ratio = desired scale val / current scale val
=60/85
=0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data
occurs almost every time you reduce or increase the scaling value, and causes quantization errors.
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor.
You lose data when either the signal generator rounds fractional data down or the scaling value is
derived using the results from a power of two. This means that scaling a waveform in half (power of

two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not
correctable and may cause waveform distortion. It is always best to make a copy of the original file
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses
the factory-supplied waveform RAMP_TEST_WFM it is the same for any waveform file.

Copy a Waveform File

1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile
Segments.

2. Highlight the waveform RAMP_TEST_WM
3. Press Copy File.
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4. Name the copy (this example uses the name MY_TEST_SCAL) and press Enter.

Apply Scaling to the Copied Waveform File

This type of scaling is non-reversible. Any data lost in the scaling
operation cannot be restored. Save a copy of the waveform file before
scaling.
1. Open the DUAL ARB Waveform Utilities menu:
Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example,
MY_TEST_SCAL).

3. Set and apply a scaling value (in this example 70% scaling is applied):
Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.
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Setting the Baseband Frequency Offset

The baseband frequency offset specifies a value to shift the baseband frequency up to +50 MHz
within the BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband
generator option. While the following figure shows how to access the control using the Dual ARB
player, the location of the Baseband Frequency Offset softkey within each ARB format, through the
ARB Setup softkey, is the same as for the Dual ARB player.

When the Baseband Frequency Offset is non-zero, the hardware rotator accumulates phase-shift
of the baseband signal. This residual phase remains even after the offset value is returned to zero.
To remove this phase accumulation, either restart the personality or select the Baseband
Frequency Offset Phase Reset softkey. This softkey will grey out whenever the phase, due to the
frequency offset, is zero. In addition, while there is a non-zero residual phase present in the signal,
the DAC Over-Range Protection feature will automatically ensure that the reduced internal scaling
is applied. This reduced scaling will be removed when both the frequency offset is returned to zero
and the phase is reset.

Figure 9-13 Baseband Frequency Offset Softkey for the Dual ARB Player
Mode The settings in this menu can
be stored to the file header,
_-J see page 197.
V Arb
NModulation Hode ARE
o Arb Setup
Arb Sample Clock
DU FRED Seloct 200. 8000000001 Hz
Waweform®
ARE Custom, Feal-Ti ALGH
Modulat ion® =2 meSetup" page 342
Arb Setupk——~m
Feal-Time Custom, Feal-Time
Madulation” Trigger Tupe Phase Noise Setup| page 342
(Cont inuous ,» ets the Baseband
g Free Run . . Frequency Offset value
Feal-Time Funt Scal quency :
Applications L 1M ?Ba_luén% 1 page 235 entered in the signal to

baseband.

. Modulator Atten
Multitoner Hore 1 of 2 5.00 dB

—ore 2 of £ | CRLtG | Arb Setup lears the phase
il 1 of 2 Manal M Baseband accumulation and so zeros
SEam Hore 1 of 2 Frequency Offset the phase shift. Causes a
D00 i sudden phase shift

discontinuity of the
baseband signal.

il

| page 243
For details on each key, use key help FLE I=EIETE gHBCL aqe 265
as described on page 40. (Off) pag
Hodulat im FiLter
odulation Filterw
(GFF) page 265
fore 2 of 2

Common uses for the offset feature include:

— offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
— sum the baseband signal with external | and Q inputs to create a multicarrier signal
— use the signal generator’s I/Q signal as an IF
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Changing the baseband frequency offset may cause a DAC over range
condition that generates error 628, Baseband Generator DAC over

r ange. The signal generator incorporates an automatic scaling feature to
minimize this occurrence. For more information, see “DAC Over-Range
Conditions and Scaling” on page 243.

The baseband frequency offset value is one of the file header parameters (page 197), which means
you can store this value with the waveform. When you select a waveform with a stored frequency
offset value, the signal generator changes the current value to match the stored file header value. If
there is no stored baseband offset frequency value for the current waveform, the signal generator
uses the last set frequency offset value.

You can also use the Save function (page 64) to store this value as part of the signal generator
setup. When you Recall a setup stored with the Save function, the baseband frequency offset value
becomes the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the
factory supplied waveform, SI NE_TEST_WMavailable in the Dual ARB Player. To view the output
for this example, connect the RF OUTPUT of the signal generator to the input of a spectrum
analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segnent On BBG Medi a column, select SI NE_TEST WM
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.
3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press Mode > Dual Arb > ARB Setup > More > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the
following figures.
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Modulated carrier with 0 Hz Modulated carrier with 20 MHz

baseband frequency offset baseband frequency offset Modulated RF signal

,

LO/carrier feedthrough

AR g MWMMM’WWMNNWN\MJN\WMNMMWM i

Spectrum analyzer set to a span of 100 MHz

DAC Over-Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a
DAC over-range condition, which causes the Keysight MXG/EXG to generate an error. To minimize
this condition with the frequency offset feature, the Keysight MXG/EXG incorporates an automatic
DAC over-range protection feature that scales down the I/Q data by 7/square root of 2 when the
offset is something other than zero. Because it can scale the data by more than what is actually
need, it typically decreases the dynamic range of the waveform. This is especially noticeable when
using a constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over-range feature can be turned off. When on, it is active
for the Dual ARB signal only when the offset is something other than O Hz. The control for the Dual
ARB DAC over-range protection feature is located in the key path as shown in Figure 9-14.
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Figure 9-14

Mode —>= NModulation Hode

Oual ARER

ARE Custom,
Modulation

Real-Time Custom,
Modulation

Feal-Time
Applicat ions

Multitonew

fore 1 of 2

For details on each key, use key help
as described on page 40.

Arb
ARE
on

Select,
Haveform

Arb Setupk

Trigoer Tupe
(Cont inuous ,»
Free Run.

fore 1 of 2

—

Arb Setup
Arb Sample Clock
200. 000000000MHz
Real-Time ALGN,
Setup

Feal-Time
Fhase Moise Setup

Funt.ime Scaling
70.00 X
Modulator Atten

.00 dB
Hanual
fore 1 of 2

Arb Setup

Easeband
Freguency Offset
0.000 Hz

CHra)

Multi-BBG Sunc

Setupb—page 265

(0ff)

Feal-Time
Modulation Filtere
(Off2

fore 2 of 2

Dual ARB DAC Over-Range Protection Softkey Location

When the DAC over—range protection is off,

[<€——=liminate over—range conditions by

decreasing the scaling value (see “Setting
Waveform Runtime Scaling” on
page 238).

Default setting is On. Available only
when Phase Noise or AWGN are on
(see page 349), or when the
baseband frequency offset is set to a
value other than zero.

Turn off when you want to manually
control scaling while using the
baseband frequency offset feature.
Manually adjust the scaling using the
Waveform Runtime Scaling softkey
above.

Enables or disables the automatic
internal scaling used to keep DAC
over-range errors from occuring with
the Phase Noise, AWGN and
Frequency Offset features. This
automatic scaling can be excessive
(particularly for a constant amplitude
signal) and thus reduce the dynamic
range more than is necessary.
When the protection is disabled, no
automatic scaling occurs, so the
Runtime Scaling feature must be
used to adjust for the highest scaling
value that does not cause DAC
overranges.

Since the over-range protection
works with only three features, this
key grays out until one of the three
features is active even when the
protection is on.

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over-range

conditions.
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I/Q Modulation
The following factors contribute to the error vector magnitude:
— Differences in amplitude, phase, and delay between the | and Q channels

— DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides
adjustments and calibrations to compensate for differences in the | and Q signals.

See also, “Modulating the Carrier Signal” on page 54.
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Figure 9-15

This panel displays the current
settings for the 1/Q signal routing
and 1/Q correction optimized path.

FREQUEHCY

6.000 020 000 00 &=

zation

I/0:

I/0 Routing & Dptip

[Ex1 N = ¥ 0T |

B Optimized Path

Off

I/Q Display and Softkeys

I/0 Source

This panel displays the current status and settings
of the I/Q adjustments. Use the Page Up and
Page Down keys to scroll through these
parameters. Grey indicates an inactive (off)
adjustment.

Internal

External

ANPLITUDE 1/0

Sy

.00 den

1/
an

I/0 Sourcey
(Externall

I/0 Correction
Optimized PathF
(RF Output)

These selections are
reflected in the

1/Q Routing &
Optimization graphic.

I deustr{gl;%?’__page 249

I/0 CalibrationM— page 250

\J

03/09/2012 18:04 Hore 1 of 3

I/0 Dptimization

RF Output

Ext I/0 Output

optimization values to all paths, which impairs the

1/0 h
Int Phase | Inverts an internally generated Q signal, so that the | component lags the
Folarity Q component by 90 degrees.
Invert
1«—Used only with internally generated, bursted modulation
Burstlgﬁe formats. Enables/disables the RF burst modulator.
Int. Equalizat.ion Fe——Opens the internal I/Q Equalization Filter which can be used
Filtere to correct and/or impair the RF and External I/Q outputs for
(Off) the internal I/Q source. ) ) o
Optimize Int I/0 lg——Selects between optimizing the internal I/Q channel for EVM (in channel Bach path requires different optimization values;
Chanmel For when you select a path, you are selecting the
[a) performance) at the expense of ACP (out of channel performance) or unique optimization values required by that path
optimizing for ACP at the expense of EVM. The signal generator applies the selected )
Iggrgggggg% l@—, EVM is an 80% nyquist filter (100Mhz wide) with a wide transition band.
N When an equalization filter is active, this filter is not active. unselected paths
Hore 2 of 3 ACP is also an 80% nyquist filter (100Mhz wide), but the transition band ’
is very narrow, thus reducing images for wide-band signals. This filter will
be convolved with the active equalization filter and the Int Channel
Correction filter (if it is on), the result of which will be truncated to the
1/0 center 256 taps.
Ext Input Level SCPI Commands:
_ SO0 md rms [:SOURce]:DM:INTernal:CHANnel:OPTimization EVM|ACP
Man  Meas [:SOURce]:DM:INTernal:CHANnel:OPTimization?
Toggles on or off the application of the internal baseband generator RF, and baseband magnitude and
Ewt In I/ Gtten phase corrections across the 160MHz baseband bandwidth at the current RF frequency.
9.53 dB When this feature is on, arbitrary frequency switching while the baseband is on will take up to an
Manuial additional 3.3ms (typical) to 6.8ms the first time that frequency is specified. After that, switching to
that frequency will take up to an additional 1.3ms.
Up to 1024 unique frequencies can be cached before the oldest cache will be forgotten. If a frequency
sweep is activated, then the calculation and caching will occur up front for the first 1024 unique

For details on each key, use key help
as described on page 40.
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frequencies, and all further unique frequencies will have the characteristics of arbitrary frequency
switching.

If the I/Q Correction Optimized Path is set to Ext I/Q Output, then only the baseband corrections will be
applied and the frequency switching speed will be unaffected.

This correction will be convolved with the ACP Internal I/Q Channel Optimization filter and the
Equalization filter if they are active. The resulting filter will be truncated to 256 taps.

SCPI Commands:

[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0
[:SOURce]:DM:INTernal:CHANnel: CORRection[:STATe]?

Keysight EXG and MXG X-Series Signal Generators User’s Guide



Basic Digital Operation (Option 653/655/656/657)
I/Q Modulation

Using the Rear Panel | and Q Outputs

The rear panel | and Q connectors only output a signal while using the
internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated | and
Q signals to the rear panel | and Q connectors. These output signals are post DAC, so they are in
analog form. You can use these rear panel | and Q signals to:

— drive a system’s transmitter stage
— testindividual analog | and Q components such as an I/Q modulator
— route the | and Q signals into another signal generator

The factory default setting routes the internally generated | and @ signals to the I/Q modulator and
the rear panel | and Q output connectors. However to optimize (apply calibration factors) the rear
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform

1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path

1. Connect cables from the rear panel | and @ connectors to either a DUT or another signal
generator.

When you turn the ARB on, the signal generator automatically outputs the | and Q signals to
the rear panel connectors. You can use the rear panel | and Q signals as | and Q inputs to
another signal generator. The MXG/EXG has front panel connectors, | Input and Q Input, for
this purpose.

2. Press 1/Q > 1/Q Correction Optimized Path > Ext I/Q Output.

When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized T/0
I
Off lﬂﬁ
I/0 Routing & Optimization
e
nLerna
EE GEM | » I/0 0UT
I/0 Correction
Optimized Patbe
EXT IN FF_OUT RF @R
I/0 Adjustments,
B Optimized Path T70 Optimization ] '
Rear panel I/Q path optimized i UERUE [BIEAERD
1/0 Routing & Optimization 3
£C 9 a Ext I/0 Output
BE GEM I/0 ouT -

B Optimized Path
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Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog | and Q signals through the front panel |
Input and Q Input. You can use the external signals as the modulating source, or sum the external
signals with the internal baseband generator signals.

1. Connect | and Q signals to the front panel connectors.
a. Connect an analog | signal to the signal generator’s front panel | Input.
b. Connect an analog Q signal to the signal generator’s front panel Q Input.
2. Set the signal generator to recognize the front panel input signals:
— To Modulate onto the Carrier

Press I/Q > I/Q Source > External.

Signal generator display: both paths are calibrated LA D & WU

when the 1/Q Correction Optimized Path is set to

Ext I/Q Output (See page 247) [ B8 5En {10 ]

[T N f————{ FF w1 |
Note: when the optimized path is set to RF, only the

RF Out path is calibrated. [ Optimized Path

— To Sum and Modulate onto the Carrier
Press 1/Q > 1/Q Source > Sum.
To select and play a waveform for the BB GEN path, see page 190.

I/0 Routing & Optimization
Signal generator display: both RF paths are calibrated

when the 1/Q Correction Optimized Path is set to
RF Output (see page 247) BB GEN —L 1/0 00T
EXT IN —— RF aUT

B Optimized Path

Notice that only the internal BBG (BB GEN) routes | and Q signals to the rear panel | and Q
outputs.

3. If you are using only the external | and Q signals (no summing), turn on the 1/Q modulator:
Press 1/Q Off On to On.

4. Configure the RF output:
a. Set the carrier frequency.
b. Set the carrier amplitude.

c. Turn the RF output on.
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I/Q Adjustments

Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

Adjusts the | signal amplitude relative to the Q
signal amplitude. Use this as an internal
impairment, or to compensate for differences in
signal path loss that occur due to path irregularities  the ARB. See page 200.
in the external | and Q output cabling.

1/Q > 1/Q Adjustments

IUYAOuns Enentis This feature allows adjustment of the absolute phase of the internal I/Q channel by

rotating both | and Q, thus adjusting the relative phase of the RF carrier. For option

The DC offset values are calibrated relative to
the RMS waveform voltage being played out of

BB I/0 Adj
I Offsed
0.000 ¥

0 Offset
0.000 &

I/0 Adjustments I/0 Gain
on 012, this is the only way to adjust the RF phase for a unit with an external LO. — B lance
0.000 dB
Internal Baseband
) . — Quadrature
Adjustments \ fngle Adjustment
0.00 deg
External Input o Ext In I/0 AdJ | i
R p Ext In I/0 Adj Offsets the phase of the Q signal \ 1/0 Phase
External Input relative to the phase of the I signal. a 0.00 dea
I Offse The baseband quadrature
External Output fore 1 of 2

adjustment key is calibrated in units

Adjustments "
of degrees. The external input

External Input

Offset quadrature adjustment is not
oo calibrated.
If%x&er_‘naé %nput The function provided by this key is
- ain_Balance not the same as the function
Ext Out I/0 Adj 0.000 d& /provided by the I/Q Skew key.
Quadrature
‘_ Anole ﬂdjustrrgn%

Common_HMode
IKH Of feet Eange
ine

bandwidth signals.
Common Mode

The 1/Q Attenuator softkey affects the 1/Q signal to the

IS%BEESEE RF Output and the External I/Q Outputs. the | and Q signals. The different signal paths
= traveled by the | and Q signals result in time delay
DlEFﬁFT;ggE This softkey is active when the 1/Q optimized path is set differences that show up as an EVM error in large
o.oooo W to Ext I/Q Output and a digital modulation personality bandwidth modulated signals.
. is on. This attenuation is also adjustable using the Mod Adding an equal and opposite time delay (skew) in
DlEFﬁF?ggE Attenuator key located in the Arb Setup menus in each the I/Q signals during baseband generation
0.0000° Y personality. This adjustment is not affected by the I/Q ~ eliminates the time delay error, correcting for any

Adjustments On/Off key.

baseband generator.
When Auto mode is selected, the signal generator
automatically optimizes I/Q attenuation for the current
conditions. When the Manual mode is selected, 1/Q
Attenuation is the active function. The value you enter
sets the attenuation level of the I/Q signal.

SCPI Commands (Refer to the commands for each

personality):
[:SOURCce]:RADio:<personality>:1Q:MODulation:ATTen

Offsets are typically used to either reduce carrier leakage, or to create an impairment that simulates carrier leakage.

Common Mode 1/Q Offset Range

This changes the adjustment range of the Common Mode 1/Q Offset from Coarse (Default) to fine or vice versa. The Coarse
range corresponds to the default value of + 2.5V. The Fine range corresponds to a value of £ 100 mV.

Common Mode I/Q Offset

This adjusts the DC offset of both | and Q signals simultaneously.

Diff Mode | Offset

This adjusts the DC offset level of the | and I-bar output signal. | and I-bar cannot be adjusted independently.

Diff Mode Q Offset

This adjusts the DC offset level of the | and I-bar output signal. | and I-bar cannot be adjusted independently.
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Note: The I/Q signal will be
scaled down by 0.7071 for all
phase offsets except 0. Use
-360 or +360, if it is desirable
to maintain a constant power
level with the ALC off while
adjusting the 1/Q phase.

Skew is typically used either to create
impairments, or to reduce error vectors on large

Provides a relative time delay correction between

delays in signals that are generated in the internal

BB I/0 Adj

I/0 Skew
0. 000000000000

Available only when a SEeC
waveform is playing.

I/0 Delay
0. 000000000000
SBC

Changes the absolute phase of
both the I and Q signals with
respect to triggers and markers.
Positive values add delay and
negative values advance the
signals. This value affects both
the baseband signal modulated
onto the RF and the external
output signals (I and Q). This
setting cannot be used with
constant envelope modulation
and it does not affect external |
and Q inputs.
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I/Q Calibration
Table 9-2 I/Q Adjustments Uses
I/Q Adjustment Effect Impairment
Offset Carrier feedthrough dc offset
EVM error phase skew
Quadrature Angle
I/Q images I/Q path delay
high sample rate phase
/0 Skew EVM error skew or I/Q path delay
I/Q Gain Balance I/Q amplitude difference | 1/Q gain ratio
I/Q Phase I/Q phase rotation RF phase adjustment

The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any

latency between the EVENT output signals (marker signals) and the RF output.

1/Q Calibration

Use the I/Q calibration for I and @ signal corrections. What aspects of the | and @ signal is corrected

depends on whether the signal is internally or externally generated.

Correction Internal | and Q External | and Q
Offset X X

Gain Balance X X
Quadrature X X
Error

When you perform an I/Q calibration, that calibration data takes precedence over the factory-
supplied calibration data. The calibration routines improve performance that may degrade over
time or due to temperature changes. An I/Q calibration should be run when the ambient
temperature has varied by at least +5 degrees Celsius from the ambient temperature at which the
previous calibration was run.

— The user I/Q calibration is persistent (i.e. Pressing instrument preset or cycling power does not
remove the user I/Q calibration from memory).

— Ifthe start and stop frequencies are set to the same value, then the calibration will be performed
exactly at that frequency and the data will be persisted in the bounding calibration array
elements.
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1/Q > 1/Q Calibration I/0 Calibration
Execute Cal
Calibration Tupe
OC User li!llf&
Available only when
Calibration type = User
Rewvert to
Default Cal
Settings
Deletes any user—generated
calibration data and restores
the factory—supplied
calibration data.
Note
A DC calibration requires the following settings:
*1/Q: On

» Optimized Path: RF Output
* Source: Internal

For details on each key, use key help
as described on page 40.

Basic Digital Operation (Option 653/655/656/657)
I/Q Calibration

DC optimizes the 1/Q performance for the current
instrument settings, and typically completes in several
seconds. Changing any instrument setting after performing
a DC calibration voids the DC calibration and causes the
signal generator to revert to the user calibration data (or
factory-supplied calibration data, if no user calibration data
exists)

User provides a quicker calibration when a full calibration
is not required. You can limit the calibration by specifying
the calibration start and stop frequencies.

When you limit the calibration to less than the instrument’s
full frequency range, the factory—supplied calibration data
is used for the rest of the range. If the start and stop
frequencies are set to the same value, then the calibration
will be performed exactly at that frequency and the data will
be persisted in the bounding calibration array elements.
Information is retained through a preset or power cycle*.
Full takes approximately a minute, executing
measurements over the instrument’s entire frequency
range.

Information is retained through a preset or power cycle*.
*Caution:

To avoid the loss of data, GPIB settings, or current user
instrument states that have not been permanently saved to
non-volatile memory, the signal generator should always be
powered down either via the Instrument’s front panel power
button or the appropriate SCPI command. Signal
generators installed in rack systems and powered down
with the system rack power switch rather than the
instrument’s front panel switch display an Error -310 due to
the instrument not being powered down correctly.
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Using the Equalization Filter

An equalization FIR file can be created externally, uploaded via SCPI, and subsequently selected
from the file system (refer to “Working with Files” on page 56). For information related to
downloading FIR file coefficients, refer to the Programming Guide. For information regarding
working with FIR file coefficients manually, refer to “Modifying a FIR Filter Using the FIR Table
Editor” on page 260.

This filter can be used to correct and/or impair the RF and External I/Q outputs for the internal 1/Q
source. This filter will be convolved with the ACP Internal I/Q Channel Optimization filter if that filter
is selected, the result of which will be truncated to the center 256 taps. The equalization filter
operates at 200 MHz, so all equalization filters must be resampled to 200 MHz prior to selection, if
they are sampled at some other rate.

The MXG/EXG supports equalization filters—either Complex or Real—that are programmable FIR
filters with two inputs (I, Q) and two outputs (I, Q) per sample. This 256-tap filter has two modes of
operation:

The maximum number of taps is 256 (with 2 coefficients per tap for a
complex filter) for equalization filters. The minimum number of taps is 2.

Equalization filters can also be referred to as predistortion filters or
correction filters.

Type of Filter ~ Description

Real The I'and Q samples are independently filtered by a single set of real coefficients.

Complex The samples are treated as complex (I +jQ) and convolved with the filter coefficients which are
specified as (I +jQ) in the time domain.

The equalization filter can be turned on and off.

252 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Figure 9-16

1/Q > More

1/0

Int Phase
Polarity
Invert

Burst_Envelope
| Of ]

Int Equalization
Filtere
(Off2

Optimize Int I/0
Channel For
ACP
Int Channel
Correction
an

fore 2 of 3

Note:

™~

Basic Digital Operation (Option 653/655/656/657)
Using the Equalization Filter

Int Equalization Filter Softkeys

Int Eq Filter

Int Equalization
Filter
L Of+ ]

Select Filter,
(s=MOME= )

Oefine,
User FIR

page 246

Use the FIR Table editor to view the filter’s coefficients.

Refer to page 260.

For more information on the SCPI commands,
refer to the SCPI Command Reference.

For details on each key, use key help
as described on page 40.

Enables the internal
—— equalization filter.

Opens a file catalog of FIR filters to select as the equalization filter. Equalization filters are
typically complex and must have an oversample ratio of 1. The filter must not have more than

—— 256 taps (512 coefficients for a complex filter). The equalization filter operates at 200 MHz, so
all equalization filters must be resampled to 200 MHz prior to being placed in the signal
generator.

page 255

SCPI commands:

Equalization filter state: :SOURce]:DM:INTernal:EQUalization:FILTer:STATe { OFF } |
ON [:SOURce]:DM:INTernal:EQUalization:FILTer:STATe?

Equalization filter selection:

[: SOURce] : DM | NTer nal : EQUal i zati on: FI LTer: SELect "fi | ename"
[: SOURce] : DM | NTer nal : EQUal i zat i on: FI LTer : SELect ?

To add a real filter to the file system:

:MEMory:DATA:FIR “filename", [REAL,] osr, coeffl [,coeff2 [..., coeffN]]
:MEMory:DATA:FIR? “filename"

To add complex filter to the file system:

:MEMory:DATA:FIR "“filename", COMPIex, osr, hiIRe0, hQImO [, hiIRel, hQIm1 ...,
hiReN, hQImN]]

:MEMory:DATA:FIR? "filename"

To add I/Q symbol data to the file system:

:MEMory:DATA “WFM1:filename", <blockdata>

Keysight EXG and MXG X-Series Signal Generators User’s Guide 253



Basic Digital Operation (Option 653/655/656/657)
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

Using Finite Impulse Response (FIR) Filters in the Dual ARB
Real-Time Modulation Filter

Finite Impulse Response filters can be used to compress single carrier I/Q waveforms down to just
the I/Q constellation points and then define the transitions similar to the modulation filter in Arb
Custom (refer to “Using Finite Impulse Response (FIR) Filters with Custom Modulation” on

page 394). The key difference for dual ARB real-time modulation is that a filter is applied as the
waveform plays, rather than in the waveform data itself.

Figure 9-17 Filter Menu

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter >
Enables or disables the Modulation Filter. This filter is typically applied to an Arb Waveform
containing just the 1/Q symbol decision points. The Modulation Filter then effectively
defines the transitions between the symbol decision points. This means that the filter must
have an oversample ratio of 2 or more. When this feature is active, the Sample Clock Rate

is acuye Symbol Rate. Also, the filter must be real (refer to page 263). Filter Select

Root Huquist

Filters

Select 4 .
(Root. Wuguist) Muguist
Detine) Available only when the
User FIR \ Gaussian
Filter Alpha Opens the 1IS-95
0.500 IS-S5k[—filter selection

page 255 Filter @lpha
0.500 menu.

This softkey changes, depending

Optimize FIR For |- — — —— —— —— — ——
ACF on the selected filter—type.

User FIRk —page 260
fore 1 of 3

Filter BOT
0.500

Festore Default
Filter

page 252
Available only when the filter
selected = Gaussian

Filter Select

HCOMA

Fectangle

EDGE

EDGE Wide

EDGE HSR

fore 2 of 3

Filter Select

APCO 25 CLFM

For details on each key, use key help as described on page 40.
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Creating a User-Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FI R Val ues table editor to create and store an 8—symbol, windowed
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press Preset.

2. Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Select > Nyquist.
3. Press Define User FIR.

4. Press More 1 of 2 > Delete All Rows > Confirm Delete of All Rows.

This will initialize the table editor as shown in Figure 9-18.

Figure 9-18 Creating a User-Defined FIR Filter Using the FIR Filter Table Editor

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter >

. ! For details on each key, use key help as described on page 40.
Define User FIR > More 1 of 2 > Delete All Rows > Confirm Delete of

All Rows
- Opens a menu that
FREQUEHCY RF_OFF User Filter enables you to select
6 000 000 000 00 GHz and load a saved file
e e I
Load Default
4 2
FIR Values VErSaATe. L, Length In Sutbols: O FIR page 260
Coeff. Real Value Imaginary Ualue
| ] — ;
0 - Delete ALL Rousk Adds a column for specifying the
e imaginary coefficients of the filter.*
\\ —— (All of the imaginary coefficients
; T will be 0 initially.) If the Convert to
=Rl PRSP Complex Filter softkey has been
selected the Convert to Real Filter
Display Filtere softkey becomes available.
Caution: Selecting the Convert to
g e fore 2 of 2 Real Filter softkey removes the
Imaginary Values column and the
imaginary values are lost.
D1
Active only when:
FIR filter coefficient table
has minimum of two
values visible.
Note:

Modulation filters must be real and have an oversample ratio (OSR) of 2 or greater.
Equalization filers are typically complex and must have an oversample ratio (OSR) of 1.

Entering the Coefficient Values
1. Press the Return softkey to get to the first page of the table editor.
2. Use the cursor to highlight the Val ue field for coefficient 0.

3. Use the numeric keypad to type the first value (—~0.000076) from Table 4. As you press the
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you
can correct it using the backspace key.)
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been

entered.
Table 9-3

Coefficient Value

—0.000076

1 —0.001747

—0.005744

—0.004424

0.007745

0.029610

0.043940

~N| OO o ] W

0.025852

Coefficient Value

8 —0.035667
9 —-0.116753
10 —0.157348
1 —0.088484
12 0.123414
13 0.442748
14 0.767329
15 0.972149

Duplicating the First 16 Coefficients

Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in
reverse order. The signal generator provides a mirror table function that automatically duplicates

the existing coefficient values in the reve

rse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and

the first of these coefficients (numbe

Figure 9-19
FIR table coefficient values, FREQUEHCY AAPLITUDE User Filter
may be from the factory
default values or entered by 6.000 000 000 00 GHz _144.00 dBm Insert Row
the user.
. Oelete Rou
F[I:R |leli?lues =il CEN Oversample Ratio: 4, Lenoth In Sumbols: 2
oeff. eal Ualue
“10 -0.15736800 >
1 —0.038L8400 Goto Roue
12 0. 12341400
| 13 O.LLZ7LE00 | J
1 0. 76732900 Mi Tabl
I 0.97214300 | trror fahse
17 0. 7e732500 i
\ 18 R T BEERERIRIE [REE
A8 0.1230100
0371472012 2L: 28 Hore 1 of 2

r 16) highlights, as shown in Figure 9-19 on page 256.

For details on each key, use key help as described on page 40.

256

Use the Goto Row menu
to move around and
make changes to the FIR
Values coefficient table.
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Setting the Oversample Ratio

Modulation filters are real and have an oversample ratio (OSR) of two or
greater.

Equalization filters are typically complex and must have an OSR of one
(refer to “Using the Equalization Filter” on page 252 and to “Setting the
Real-Time Modulation Filter” on page 263).

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range
from 1 through 32; the maximum number of taps allowed by the table editor is 1024.

The actual limits on OSR, number of coefficients, and number of symbols depends on the feature
with which the FIR is used. Refer to Table 9-4.

Table 9-4
Filter Type Oversampling Ratio | Number of Taps | Symbols/Coefficients
(OSR) (Maximum) (Maximum)
Equalization® | ' 256 -
ARB Custom | 22 -- 512/1024
Modulation®
Dual ARB >7 -- 32/1024
Real-Time
Modulation®

a. When I/Q timing skew, I/Q delay, or the ACP internal I/Q channel
optimization features are active, the effective number of taps for the
equalization filter are reduced.

b. The filter may be sampled to a higher or lower OSR.

c. The filter will be decimated to a 16 or lower OSR depending on the
symbol rate.

For modulation filters, if the oversample ratio is different from the internal, optimally selected one,
then the filter is automatically resampled to an optimal oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and
frequency dimensions.

1. Press More 1 of 2 > Display Filter > Display FFT (fast Fourier transform).
Refer to Figure 9-20 on page 258.
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Figure 9-20
FREQUEHCY AAPLITUDE
6.000 000 000 00 sz -144.00 e
I
FFT
1]
d
B
For details on each key, use key
help as described on page 40. =100 5 Sumbol Rate 2
0371472012 1h:10
2. Press Return.
3. Press Display Impulse Response.
Refer to Figure 9-21.
Figure 9-21
FREQUEHCY AAPLITUDE

6.000 000 000 00 &z -144.00 cen

Real Impulse Response A
1 Length In Sumbols: 8 Oversample Ratio: L

For details on each key, use key
help as described on page 40.

-0-5 g Coefficient

i
037142012 1h: 1L

4. Press Return to return to the menu keys.

Storing the Filter to Memory

Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of
memory available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 189, name and
store this file as FI R_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional file
names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The amount
of memory used is also displayed. The number of files that can be saved depends on the size of the
files and the amount of memory used. Refer to Figure 9-22.

258 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Figure 9-22

FREQUEHCY

1 FIR1
2 NEE
3 NEWFIRZ

6.000 000 000 00 &+

Catalog of FIR Files in Int Storage
File Hame T
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ANPLITUDE

-144.00 den

36kB used 29.2GE free
Size Nodified
268 B 02/20/12 16:50
265 B 0371012 1h:10
268 B 03713712 17:07

0371472012 14:15

List. Load/5tore

Load From
Selected File

Store To,
File

Delete Filew
These keys manage the table

of DMOD files in internal

Goto Fowe|| Storage

Catalog display>\R files that have
been previously saved by the user.

For details on each key, use key help as described on page 40.

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new

filter design.
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Modifying a FIR Filter Using the FIR Table Editor

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You
can load the FIR table editor with coefficient values from user-defined FIR files stored in non-
volatile memory or from one of the default FIR filters. Then you can modify the values and store the

new files.

Loading the Default Gaussian FIR File

Figure 9-23

Modulation Filter

Loading the Default Gaussian FIR File

Mode > Dual ARB > Arb Setup > More > Real-Time

Filters
Modulation Filter
| Of+ ]
Select,
(Root. Wuguist)

Oefine,
User FIR

Filter Alpha
0.350

Optimize FIR For
ACP

1. Press Preset.

User Filter

Inzert Row
Delete Row
Goto FRowe

Mirror Table

Oversample HatiE

fore 1 of 2

—

For details on each key, use key help as described on page 40.

User Filter

Load/Storek

Lomd Default,

FIR
Oelete ALl Rowse

Convert To
Complex Filter

Display Filterw

fore 2 of 2

Load Def FIR

Foot. Muguiste

Mugquiste

Gaussiank

Fectangler

These softkeys select a
window function
(apodization function) for
a filter.

Default Filter

Gaussian BbT

Generate

Filter BOT
0.300
Filter Sgnbolg

Hindou,
(None )

Hone
Hamming
Hann

Kaiserek

2. Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define User FIR >
More > Load Default FIR > Gaussian.

3. Press Filter BbT > 0.300 > Enter.

4. Press Filter Symbols > 8 > Enter.

5. Press Generate.

6. Press Display Filter > Display Impulse Response (refer to Figure 9-24).

260

The actual oversample ratio during modulation is automatically selected
by the instrument. A value between 4 and 16 is chosen dependent on the
symbol rate, the number of bits per symbol of the modulation type, and
the number of symbols.
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Figure 9-24

FREQUEHCY ANPLITUDE

6.000 000 000 00 &z -144.00 cen

Real Impulse Response A
1.2 Lenath In Sumbols: 8 Oversample Ratio: L

For details on each key, use key

help as described on page 40. <0 Coefficient

LR =g - TR —

0371372012 17:00

7. Press Return.

Modifying the Coefficients

1. Using the front panel arrow keys, highlight coefficient 15.
2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 9-25

FREQUEHCY ANPLITUDE

6.000 000 000 00 &z -144.00 cen

Real Impulse Response A
1.5 Lenath In Sumbols: 8 Oversample Ratio: L

For details on each key, use key

help as described on page 40. =0.5 Coefficient

LR =g - TR —

31
0371372012 17:02

Refer to Figure 9-25. The graphic display can provide a useful troubleshooting tool (in this
case, it indicates that a coefficient value is missing, resulting in an improper Gaussian
response).

4. Press Return.
5. Highlight coefficient 15.

6. Press 1 > Enter.

Keysight EXG and MXG X-Series Signal Generators User’s Guide 261



Basic Digital Operation (Option 653/655/656/657)
Modifying a FIR Filter Using the FIR Table Editor

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).
1. Press Return > Return > Load/Store > Store To File.

2. Name the file NEWFIR2.

3. Press Enter.

The contents of the current FIR table editor are stored to a file in non-volatile memory and the
catalog of FIR files is updated to show the new file.
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Setting the Real-Time Modulation Filter

The real-time modulation filter effectively compresses a single carrier I/Q waveform down to just
the I/Q constellation points and then controls the transitions similar to the modulation filter in Arb
Custom modulation. The key difference is that this filter is applied as the waveform plays, rather
than in the waveform data itself. The real-time modulation filter is only available for Dual ARB

waveforms.

When the real-time modulation filter is on, the sample clock rate acts as the symbol rate. The
sample clock rate must be set to one half of the sample rate for the real-time Arb modulation filter

feature to be turned on. The sample rate is determined by the Option 65x baseband generator.

Because the Arb format only supports rectangular I/Q data for defining the
symbol decision points, constant envelope modulation, which should be
specified as magnitude and phase, are not supported. (Examples of
constant envelope modulation are MSK and FSK.)

The carrier frequency must be the same for all frequencies used (i.e. only
single carrier applications work with arb real-time modulation filters).

Figure 9-26 Real-Time Modulation Filter Softkeys for the Dual ARB Player
Mode > Dual ARB > Arb The settings in this menu
Setup > More can be stored to the file

header, see page 197. —>
Arb Setun Filters 2| > /F‘ﬂter Select\ 158
and

Easeb X .
Modulation Filter i
FrequencH.%ESﬁg UfF Ei Root. Hyquist 15-95 W/EQ

lect.

Se 5
> (Root NugList)” MU SiE I5-95 Mod

Define 5
User FIR® ERUESIE 15-95 Mad W/E
Multi-BBG Sunc .
Setupk Filter Elggg 15-ac) |
Feal-Time i
i i S Optimize FIR For
Modulation F%é%?r)“b ACp User FIR page 254
fore 2 of 2 ore I o B

. ~~These are the available
Ler Selec // real-time modulation filters that
can be applied to a waveform.

Filter Select Y
» D
APCO 25 CLFH

L3
\

HCOMA

Fectangle

EDGE

EDGE Wide

For details on each key, use key help EDGE HSR
as described on page 40. .

Common uses for the real-time modulation feature include:

— Where the single carrier rectangular ideal I/Q symbol decision points are known and are to have

an over-sampled filter applied.
— Where greater effective MXG/EXG memory size is required.
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— When you have a low rate waveform that could benefit from a higher OSR that does not make
the waveform longer.

The real-time modulation filter setup is one of the file header parameters (page 197), which means
you can store this setup with the waveform. When you select a waveform with a stored modulation
filter setup, the signal generator changes the current setup to match the stored file header setup. If
there is no stored modulation filter setup for the current waveform, the signal generator uses the
last set modulation filter setup.

You can also use the Save function (page 64) to store this value as part of the signal generator
setup. When you Recall a setup stored with the Save function, the modulation filter value becomes
the current instrument setting value, disregarding the stored file header value.

Use the following steps to apply a real-time modulation filter to the current waveform loaded into
volatile memory. This example uses the factory supplied waveform, SI NE_TEST_WMavailable in
the Dual ARB Player. To view the output for this example, connect the RF OUTPUT of the signal
generator to the input of a spectrum analyzer.

The following setup assumes you have completed the setup in “Setting the
Baseband Frequency Offset” on page 241 for creating a modulated RF
signal that is offset from the carrier frequency by 20 MHz.

1. Configure the modulation filter:

Press Mode > Dual ARB > Arb setup > More > Real-Time Modulation Filter > Select > Root
Nyquist

2. Press Filter Alpha > .4 > Enter.

The modulated RF signal now has a real-time modulation filter of type root nyquist, with a
filter alpha of 0.400.
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Multiple Baseband Generator Synchronization

Available in the Dual ARB menu, this feature lets you set up a master/slave system of up to sixteen
Keysight MXG/EXGs so that the baseband generators (BBG) synchronize the playing of waveforms.
The system count includes one Keysight MXG/EXG to function as the master (see “Equipment
Setup” on page 268).

The MXG/EXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common
external LO signal to create phase coherent system. Refer to “Understanding Option 012 (LO
In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization” on page 271
and the Data Sheet.

Figure 9-27 Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger
Softkeys and Menu Location

Note: The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this
process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 266.

Mode NModulation Hode Arb Setup Arb Setup
FEb Arb Sample Clock Baseband
UL (IR see page 189 | 200.0000000GTTHz Freauency Difset
ARE Custom Y Real-Time ALGN,
Modulation Setup
Arb
Real-Time Custom, ARE Real-Time,
Hodulat ion on Fhaze Moise Setup
Real-Time, Select,| Runtime Scaling Multi-BEG_Sunc
Applications Havefarm 70.00 7 ?g%g?’i
X Modulator Atten Feal-Time
Multitonew Arb Setupb————® B.00 dB i i »
ManLal Modulat ion F%é%er“
Hore 1 of 2 Trioger Tupe Hore 1 of 2 +—»  Hore 2 of 2
| (Cont inuous , M
219 Free Run) \ see page 266
see page BBG sync automatically changes the trigger type to Trigger and Run if
— the current setting is Free Run or Gated. If desired, manually set
/ differently on either the master or slaves, or both either before or after
Greys out for slave instruments. —llore 1 of 2 | configuring the BBG sync setup parameters.
Remains active for the master
instrument. Free Run and Gated are unavailable choices while using BBG sync.
Master default settings. If Slave default settings. These Nhote: Ase“.'”g C‘;”:'C‘ o e
desired, change these settings are not accessible w len att it'Te"O the master/slave
settings after designating the after selecting an instrument se ect|.on, the following trigger setting(s)
instrument as the master as a slave. is true:
Master
« Free Run or Gated trigger type
Slave
T arb Trioger | T Arb Trigoer | + Free Run or Gated trigger type
« Ext Polarity Neg trigger source
Trigger Source, Trigger Source,
(Ext) (Ext)
Ext Source, Ext Source
(Patt Trig In 13 (Patt Trig In 13"
Exagégg ExtNggl% -€—Neg is the factory default setting.
The slave selection changes it to
Pos. If desired, manually change to
eéﬂg eéﬂg Pos prior to selecting as a slave.

For details on each key, use key help
as described on page 40.
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Figure 9-28
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Shows after pressing Listen for Sync
* In Sync

Note: Press before pressing Sync
Slaves on the master instrument.

Shows after pressing Sync Slaves on the master

For details on each key, use key help
as described on page 40.

Understanding the Master/Slave System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform
generation capability of up to 16 signal generators to within a characteristic value of + 8 ns
between the master and the last slave. This minor amount of delay (+ 8 ns) can be reduced further
to picosecond resolution by using the I/Q Delay softkey located in the I/Q menu. To reduce the
delay, check and adjust the BBG signal alignment for each signal generator in the system. For more
information on adjusting the delay, see “I/Q Adjustments” on page 249.
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The delay value includes compensation for cables that have less than 1 ns of propagation delay
between the EVENT 1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is
an Keysight BNC cable, part number 10502A. The use of cables with greater propagation delay may
not allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the master signal generator sends a one-time event pulse that
propagates through and to each slave in the system. Prior to this event, each slave must recognize
that it is waiting for this event pulse, which occurs during the system configuration (see
“Configuring the Setup” on page 268). In order to properly send the synchronization pulse, the
trigger source and the Dual ARB Player for each signal generator must be turned off.

The master/slave setup does not incorporate a feedback system between the slaves and the signal
generator selected as the master. After synchronization, if changes occur to the Multi-BBG Sync
Setup menu or a signal generator is added to the system, the master does not automatically
resynchronize the setup. This may cause the signal generators in the system to incorrectly report
their statusas I n Sync.

The system can also misinterpret other signals as the synchronization pulse, which results in an
incorrect I n Sync status. These types of signals include a continuous trigger or an active Marker
routed to the EVENT 1 connector. Improperly connected rear panel cables can also create a false
status.

You must resynchronize the entire system after making any change in one or all of the Multi-BBG
Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status
of a signal generator. Changes to parameters that are outside of the Multi-BBG Sync Setup menu
such as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have
no effect on the system synchronization. To resynchronize a system, see “Making Changes to the
Multiple Synchronization Setup and Resynchronizing the Master/Slave System” on page 270.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 265) for each
signal generator. For signal generators selected as slaves, you can only modify the trigger type
(with restrictions). The trigger source is fixed and set to receive a trigger through the rear panel PAT
TRIG connector. On the master, you can change both the trigger type (with restrictions) and the
trigger source. The trigger source provides three options for triggering the waveforms: external
trigger, front panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature
changes the trigger settings to what is shown on page 265. When this change occurs, the Keysight
MXG/EXG generates a settings conflict error to alert you to the changes. To avoid the error
generation, appropriately configure the trigger settings prior to selecting a signal generator as the
master or slave.

The system trigger propagates in the same manner as the synchronization pulse initiated by the
master (see System Synchronization). So if it is not turned off during changes to the
synchronization parameters, it can cause a false I n Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization
feature is turned off. To play waveforms after disabling the feature, you must either set the trigger
type to Free Run or provide a trigger to start the waveform play back.
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Equipment Setup

Figure 9-29 Multiple Baseband Synchronization Setup

Note: To minimize synchronization delay, the Keysight BNC cable 10502A is the
recommended cable for the rear panel daisy chain connections (see page 266).
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Configuring the Setup

Set the Common Parameters
Perform the following steps on all signal generators:
1. Set the frequency of the carrier signal.
2. Set the power level of the carrier signal.
3. Select the desired waveform (see page 189).
Do not turn the Dual ARB on.
4. Except for triggering, set the desired waveform parameters such as markers and sample clock.

The baseband synchronization feature limits the trigger selections for both the master and
slaves. If the current trigger settings include unsupported BBG synchronization parameters,
the Keysight MXG/EXG generates a settings conflict error and changes the trigger settings. To
avoid the settings conflict error, manually set the trigger parameters as shown on page 265
prior to setting the multiple BBG synchronization parameters.

5. Turn on the RF Output.

Set the BBG Synchronization Master Parameters

1. Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-Bbg Sync Type
> Master.

2. Set the number of slaves using the Number of Slaves softkey.

3. If desired, modify the trigger parameters (see page 265).
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The master signal generator allows the modifications of both the trigger type and the trigger
source.

a. Return to the Dual ARB menu (see page 265).
b. Set the desired trigger type and source.
c. Return to the Multi-BBG Sync Setup menu.

Set the BBG Synchronization Slave Parameters

1. Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-BBG Sync Type
> Slave.

2. Set the number of Slaves using the Number of Slaves softkey.
3. Set the slave position that the signal generator occupies.
There can be up to fifteen slaves in a system.

4. Press the Listen for Sync softkey and verify that Vi ti ng for Sync appears in the St at us
area of the display.

5. If desired, select a different trigger type parameter:
a. Return to the Dual ARB menu (see page 265).
b. Set the desired trigger type.
c. Return to the Multi-BBG Sync Setup menu.

6. Repeat for each slave signal generator in the system.

Synchronize the System

Perform this procedure only after setting the parameters for both the master and slave signal
generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple
Synchronization Setup and Resynchronizing the Master/Slave System” on page 270.

1. On the master, press the Sync Slaves softkey.
All of the signal generators in the master/slave system must be
resynchronized when any changes are made to the master/slave settings

or with the addition of a slave instrument, even if | n Sync appears after
pressing the Listen for Sync softkey on the slave instruments.

2. On the front panel displays, ensure that all of the signal generators show | n Sync as the
St at us.

Trigger and Play the Waveform
1. On all Keysight signal generators, press Mode > Dual ARB > ARB Off On to On.

2. Start the trigger signal going to the master signal generator.
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Making Changes to the Multiple Synchronization Setup
and Resynchronizing the Master/Slave System

If any changes are made to the master/slave parameters or a signal generator (slave unit) is added
to the system, the system must be resynchronized even if | n Sync appears in the St at us portion
of the display.

1.

Turn off the trigger source. If using the Trigger key, there is nothing to turn off.

If the trigger source is on and provides a continuous pulse stream, it may cause the signal
generators to incorrectly display | n Sync as the status after pressing the Listen for Sync
softkey.

On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.

If a signal generator(s) has the Dual ARB on during changes, signal generators further in the
chain may incorrectly display | n Sync after pressing the Listen for Sync softkey.

3. On each of the signal generators, press ARB Setup > More > Multi-BBG Sync Setup.

Make the changes in the Multi-BBG Sync Setup menu.
Qut O Sync appears as the status message.
On each of the slave signal generators, press Listen for Sync.

Ensure that all of the slaves’ St at us show Wi ting for Sync. If I n Sync shows as the
status, perform the following steps:

a. Check that the PATT TRIG to EVENT 1 cables are properly connected on the rear panel.
A disconnected cable can cause a false | n Sync status.
b. If the cables are connected, perform steps 1 and 2.

c. Press Listen for Sync and ensure that Vi ti ng for Sync appears as the status.

On the master signal generator, press Sync Slaves.

8. Verify that I n Sync appears as the status on all master/slave signal generators.

Perform the process “Trigger and Play the Waveform” on page 269.
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Understanding Option 012 (LO In/Out for Phase Coherency)
with Multiple Baseband Generator Synchronization

NOTE This section assumes that the previous section on Multiple Baseband
Generator Synchronization has been read and understood. If not, refer to

“Multiple Baseband Generator Synchronization” on page 265 before
continuing.

The MXG/EXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common
external LO signal to create a phase coherent system (refer also, to “Multiple Baseband Generator
Synchronization” on page 265).

RF phase coherency may not be needed for general STC/MIMO receiver testing, since a MIMO
receiver perceives any phase differences between the sources as part of the channel conditions and
correct for them. But, RF phase coherency might be desirable for certain applications such as R&D
on beamforming systems.

Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

The Keysight BNC cable, part number 10502A, is the recommended cable for the standard multi-
BBG synchronization setup, and is recommended for Option 012 too (see also Figure 9-29 on
page 268). Additionally, for the 2x2, 3x3, and 4x4 MIMO connections from the LO IN and LO OUT to
the splitter, additional cables are required (refer to Table , Figure 9-30 on page 273, and Figure
9-31 on page 274).

NOTE Keysight recommends the LO Output be covered when not in use.

When the LO In/Out jumper cable is removed and the instrument is in Dual
ARB mode, the instrument is unleveled and the instrument displays an
Unlevel error message.

All test equipment requires a 12 hour warm-up period to ensure accurate
performance.

The phase coherent configuration requires the following:

— The recommended LO input drive level should be in the O to 6 dBm range.

NOTE The 0 to 6 dBm LO input drive level ensures the instruments will operate
over the full frequency and over the full 0 to 55 ambient temperature
range®.

a. LO input power requirements vary with temperature; power <0 dBm may work at 20-30 degree
ambient temperature conditions. Refer to the Data Sheet.

— The I/Q calibration and the self-test must be performed with the LO In/Out jumper cable in

place. Where the I/Q calibration cannot be run, the baseband offset can be manually adjusted
to minimize the I/Q offsets.
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— The phase coherency feature only applies to the Dual ARB modulation mode.

— All cables from the splitter output to the instrument inputs should be of equal lengths.

Table 9-5 Option 012 (LO In/Out for Phase Coherency) Equipment

MIMO Configuration

Part?

Cable Length

Notes

2x2

n/a

11636A

As required

n/a

SMA flexible cables are connected from
the power splitter outputs to the LO
inputs on the rear panel of both the
master and the slave MXG/EXGs. Refer
to Figure 9-30 on page 273.

Power Divider, DC to 18 GHz. Refer to
www.keysight.com.

3x3

n/a

PS3-20-
4517128

As required

n/a

SMA flexible cables are connected from
the power splitter outputs to the LO
inputs on the rear panel of the slave
MXG/EXGs. Refer to Figure 9-31 on
page 274.

3-Way Pulser Microwave Corp., 3-Way
Wilkinson Dividers

4x4

n/a

PS4-16-
452/10S

As required

n/a

The SMA flexible cables are connected
to the power splitter output to the LO
inputs on the rear panel of the slave
MXG/EXGs. Refer to Figure 9-31 on
page 274.

4-Way Pulser Microwave Corp., 4-Way
Wilkinson Dividers

All

10502A

22.86 c¢cm (9 inches)

Refer to Figure 9-30 on page 273 and
Figure 9-31 on page 274. See also
“Multiple Baseband Generator
Synchronization” on page 265.

a. On all of the MIMO configurations, the same length of SMA flexible cables are connected
from the splitter output to the inputs on the master and slave instruments. Refer to Figure
9-30 on page 273 and to Figure 9-31 on page 274.
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2x2 MIMO (LO In/Out for Phase Coherency) Configuration

For the 2x2 MIMO (LO In/Out for phase coherency) setup, the LO from the master MXG/EXG can be
run through a power splitter and used as the LO input to both the master and the slave signal
generators. No external source is required.

To generate phase coherent signals for a 2x2 MIMO configuration, the master MXG LO OUT is
connected via a power splitter to the slave LO IN. The LO OUT provides a sufficient amplitude LO
signal when connected directly, to drive the Slave MXG/EXG(s), thus providing phase coherency for
the RF output signals. In this example, we show two MXG signal generators with Option 012
connected for a phase coherent 2x2 MIMO solution. Refer to Figure 9-30.

Figure 9-30 2x2 MIMO (LO In/Out for Phase Coherency) Equipment Setup
mgfszromion Mz IW

RF Output

A0 MHz QUT

A——— GFIB/LAN
REF IN

[ Far TRIE ()

g

oo — ]
RF Output

Signal Studio Software

M7E15B or NYE17E

Slave

MES182 Option 012

Note:

To optimize the phase coherence, the same length SMA flexible cable is recommended
for the output of the 2-way splitter connections to the LO IN of the signal generator

3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Configurations

For a 3x3 and 4x4 MIMO (LO In/Out for phase coherency) setups, an additional analog source is
needed to provide the higher LO power required by the power splitter and the additional
instruments.

Splitting the LO output four ways causes too much loss to drive the LO input of the N5172B/82Bs in
the system. Also, there is no amplitude adjustment to the LO output of the N5172B/82B. To
generate phase coherent signals for 3x3 and 4x4 configurations with the MXG/EXG, an external
Master LO is needed to provide a sufficient amplitude LO input signal to the vector MXG/EXGs
(refer to Figure 9-31 on page 274).

m The Master LO is not controlled by any of the Signal Studio software, but
must be set manually—via the RF frequency settings on the master signal

generator—by the user to the desired frequency and amplitude.
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Figure 9-31 3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Equipment Setup
Note:

A SMA flexible cable is recommended for the input to the 4-way splitter connections
to the LO IN and LO OUT of the instruments with Option 012 (see page 271).
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Real-Time Applications

The Keysight X-Series signal generators provide access to several real-time applications for signal
creation.

Figure 9-32 Real-Time Applications Softkeys
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For details on each key, use key help as described on page 40.
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Waveform Licensing

Waveform licensing enables you to license waveforms that you generate and download from any
Signal Studio application for unlimited playback in a signal generator. Each licensing option
(221-229) allows you to permanently license up to five waveforms or (250-259) allows you to
permanently license up to 50 waveforms of your choice (i.e. Waveform Option 22x or Option 25x are
perpetual fixed waveform licenses).

Waveforms licensed with Options 221-229 or Options 250-259 cannot be exchanged for different
waveforms. Once a waveform is licensed, that license is permanent and cannot be revoked or
replaced. Option 22x and 25x waveform licenses are signal generator specific (i.e. signal generator
serial number specific). If a licensed Option 22x or Option 25x waveform file is transferred to
another signal generator, the file must be licensed by a separate Option 22x or Option 25bx that is in
the other signal generator before it can be played.

To redeem Option 22x or Option 25x, refer to the N5182B-2xx Entitlement Certificate that comes
with the N5182B-2xx order. For more information on extracting and downloading waveform files,
refer to the Programming Guide.

Understanding Waveform Licensing

Use any N76xxB Signal Studio software to build and download waveforms to the signal generator.
Each Option 22x provides 5 available slots and Option 25x license provides 50 available slots, where
you can add and play waveforms for a trial period of 48 hours per slot. During this time, you can
replace the waveform any number of times until you are satisfied with it. After the trial period
expires, the waveform in the slot is no longer playable until the slot is locked for permanent
playback; however, you can replace the waveform in the slot with another waveform of your choice
before locking the slot.

To license additional waveforms that exceed the number permitted by an Option 22x or Option 25,
you must purchase another Option 22x or Option 25x that you do not already own. For example, if
you already own Option 250, purchase Option 251 to add an additional 50 slots. Adding all options,
250-259, provides a maximum of 500 slots. Adding all options, 221-229, provides a maximum of 45
slots. (Repurchasing the same option for the same signal generator, gives you no additional
Waveform licenses.)

Installing an Option N5182-22x or Option N5182B-25x

Load a Waveform License, Option N5182-22x or Option N5182B-25, into the signal generator
using License Manager or a USB media. For more information on loading the Waveform License,
refer to the N5182B-2xx Entitlement Certificate included with your order.

Licensing a Signal Generator Waveform

Create and download a waveform into the signal generator using any of the N76xxB Signal Studio
software. Refer to your Signal Studio software help if you need assistance using the application.

Refer to page 281 for steps in adding the waveform to a license slot for a 48-hour trial period.
During the trial period, the waveform can be played and replaced any number of times. When the
trial time expires, the slot can no longer be used for playback until the slot is locked for permanent
playback capability.
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Waveform Licensing Softkeys Overview

Figure 9-33
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Waveform Licensing Softkeys
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Filename
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Add Waveform
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Available Slot
Replace Waveform,
In Slot

Clear Haveform
From Slot
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In Slot
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Note: When Waveform Licensing is first accessed, all slots appear as Available. For
licensing status descriptions after waveforms have been added to a slot, refer to Table
9-6 on page 279.

M

Refer to the SCPI Command Reference for
related license commands.

For details on each key, use key help
as described on page 40.
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Note: Waveforms licensed with Option 2xx cannot be exchanged for other waveforms. Once a waveform is
locked into a license slot, that license is permanent and cannot be revoked or replaced.

This softkey is only available if there is an Option 2xx license installed on the instrument.
__Pressing this softkey displays the licensing status and associated filename for each slot and accesses the
waveform licensing menu selections.

This softkey allows you to add a
waveform that you select to the
first available slot. Refer to
page 278.

This softkey allows you to replace
a waveform in the selected slot.
Refer to page 279.

This softkey clears the waveform
from the selected slot.

This softkey allows you to lock a
waveform into a slot. After the
trial period has expired, the
waveform must be locked in
order to be able to play the
waveform. Refer to page 279.

This softkey allows you to select
a specific slot where you want to
add, replace, or clear a
waveform. You can also select a
slot by using the front panel
arrow keys or by scrolling to the
slot. Refer to page 278.
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Figure 9-34 Waveform Licensing Softkeys
Mode > Dual ARB > More > Note: Waveforms licensed with Option 2xx cannot be “exchanged”. Once a slot is locked,
Waveform Licensing > Add that license for the waveform in the locked slot is permanent and cannot be revoked or
Waveform to First Available Slot replaced.
or

Mode > Dual ARB > More >
Waveform Licensing > Replace
Waveform in S‘ot

The softkey is greyed out, if a
waveform is already licensed or does
not require licensing.

FREQUEHCY RF_OFF Add To Slot
GHz
6.000 000 000 00 Aad Haveformt 15 select a waveform, use
the arrow keys to highlight
Catal?gtgr%gg' [ the waveform and then
Cataloo of Stored Seoment Files in Int Storage Licenses Used: 1/50 Segments) press Add Waveform.
Haveform Status
& 11AC _16R0MH LHFH
202_11AC_BS0MHZ _2560 . HFM
FHMRADIO_1_SG Haveform License Mot Regquired
S_ANTEMMAZM Haveform License Mot Regquired
0371572012 14:58 v

Refer to the SCPI Command
Reference for related License
The waveform to be added or replaced can be selected from BBG memory, internal storage, or a USB device. Commands.

FREQUEHCY

RF_OFF Catalog Tupe

This softkey displays a catalog

Stored of the waveform segments
Seament.s stored in the Int Storage or
USB Media.

6.000 000 000 00 &+

. . . EBG Seaments
Catalog of Stored Seoment Files 1&1{11, Storage Licenses Used: 1/50
atus

This softkey displays a catalo
Haveform A g

of the waveforms stored in the
11AC 160 LLFM BBG memon
802_11AC_B0MHZ_2560). WFH Y-
FHMRADIO_1_SG Haveform License Mot Regquired
S_ANTEMMAZM Haveform License Mot Regquired

0371572012 14:55

For details on each key, use key help as described on page 40.
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Figure 9-35 Waveform Licensing Softkeys

Mode > Dual ARB > More > Waveform Licensing
> Lock Waveform in Slot

Lock In Slot

Confirm

Locking Wavefarm Refer to Step 4 on page 282.

Mode > Dual ARB > More >
Waveform Licensing > Goto Slot

Refer to the SCPI Command Reference for
related license commands.

Goto Slot

Enter

Goto First Slot |—Press this softkey to go to the first slot.

guaﬁg'{s?eFéES% —Press this softkey to go to the first slot whose status is available.

Press this softkey after entering a specific slot number using the front panel numeric pad.

Waveform Licensing

Press this softkey to confirm that you want to lock the waveform into the slot for permanent
licensing. If the waveform has not been saved to internal storage, a warning message appears.

This softkey is displayed if the waveform is not found in the internal storage memory of the
signal generator. Press this softkey to store the waveform into the Internal Storage and to
activate the Confirm Locking Waveform softkey. Refer to Step 4 on page 282.

Goto Last Slot f—Press this softkey to go to the last slot. The number of slots depends on the number of licensing

options installed on the instrument.

Mode > Dual ARB > More > Waveform
Licensing > More > More

FREQUEHCY CRE OFF | WFH Licensino Press this softkey to play the
0 RE_OFF | waveform in the highlighted
6.000 000 000 00 GHz Play Waweform |  Slot
Press this softkey to locate
Locate Haveform j
- - - - in Memary*—the waveform in memory that
gfgfform é{gf{.'g‘"g T Licenses Used: 2/50 was added to this slot
1 Remaining Trial Time Lb:20 regardless of the name. If the
2 [Wils (2715 /2012 J search returms no results, the
:13l Auaiiabil original waveform has been
'vallable deleted from memory and
g Eggﬂggig cannot be found.
7 Available
8 Available
9 Available
10 Available
0371572012 16:28 fore 2 of 2
For details on each key,
use key help as described
on page 40.
Table 9-6 Waveform Licensing Slot Status Messages
Status Column Meaning Notes

The slot has never had a waveform
added to it.

Available

50 slots are initially available for
each Option 25x.

5 slots are initially available for each
Option 22x.

Keysight EXG and MXG X-Series Signal Generators User’s Guide

279



Basic Digital Operation (Option 653/655/656/657)
Waveform Licensing

Table 9-6

280

Waveform Licensing Slot Status Messages

Status Column

Meaning

Notes

Locked MM/DD/YY

The slotis locked and can no longer
be modified.

The waveform in this slot is licensed
to this signal generator for
unlimited playback.

Remaining Trial Time HH:MM

The slotis in a trial period that is
available for 48 hours that begins
when a waveform is added.

During the trial period, the
waveform in this slot can be played,
cleared, or replaced with another
waveform.

Lock Required

The trial period for the slot has
expired but the slot has not been
locked.

The slot can be cleared or replaced
with a different waveform but the
waveform cannot be played until
the slot is locked. A trial period is
no longer available.

Keysight EXG and MXG X-Series Signal Generators User’s Guide
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Example: Licensing a Signal Studio Waveform
The following steps add a waveform file to a license slot and lock the slot for permanent playback.
1. Press Mode > Dual ARB > More > Waveform Utilities > Waveform Licensing

The signal generator displays a catalog of files labeled: Cat al og of BBG Segnment Files in
BBG Menory.

2. Use the arrow keys to highlight and select the file to be licensed.

3. Press Add Waveform to add the selected waveform to the first available slot.

Figure 9-36 Add Waveform
Mode > Dual ARB > More > Waveform Licensing> St at us area for the waveform
Add Waveform to First Available Slot N7602B-WFM1 is empty and the
Add Waveform softkey is active,
indicating the waveform is
licensable.
FREQUEHCY ANPLITUDE Add To Slot

935.200 000 00 = | -10.00 /aen Pat avetorn

Cakalog Tupege— page 278

Cataloo of BEG Seoment Files in BBG Memory Cicenses [sedig/o00) — “BEG| Seaments)
LUaveform TS

RAMP_TEST_LIFHM TCerse Mot Reqoired

SINE_TEST_HFM License Not Reguired

The selected waveform is
add Haveform added to the first

. To Firste available slot. The trial
Available Slot time for the slot begins as

soon as the waveform is
Replace N?Hegurm. added.

Haveform Licensing ) Licenges Used: (/500 Lot During the 48 hour trial
|§ll]t Status Filename period, the waveform can

1 Locked 11/03/2002 TO-SCOMAD 7 Clear Laveform

2 Lock Reguired TD-SCOMAL From Slot be P'aVEdb aﬂdfrt'_aplaCEd

3 Locked 12/02/2002 TEST_10 any number of imes.

L Lock Required TEST_1 Y Wht_en the trle_ll time

5 Remaining Trial Time LG: TEST_21 Lock. H?Ueggrrtﬂ, expires, the licensing

6 Femaining Trial Time L7:33 WTEOZE-LIFH1 n i status of the slot changes

; Eggﬂggig to Lock Required after

9 Available Goto Sloth which the waveform can
no longer be played until
the slot is locked.

%M»‘./,
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4. License the waveform:
a. Press Lock Waveform in Slot.
A warning is displayed: *** Wavef orm Lock Wérning!!! ***_If necessary, verify you
have selected the correct waveform you want for licensing by pressing Return.

Figure 9-37 Waveform Lock Warning

FREQUEHCY RF_OFF Lock In Slot

6.000 000 000 00 s+ Locking HEwarorm

4% Waveform Lock Warning!l || s

Once a waveform is locked it will use up an
avallable license slot and it can not be un-locked.
Be sure that wou want to lock this waveform.

AMMMJ

b. Press Confirm Locking Waveform.
The licensing status of the slot will be changed to Locked MM/DD/YY.

c. If the waveform has not been previously backed up in internal storage, a warning is
displayed: *** Wavef orm Backup Required!!! ***,

d. Make a backup copy of this waveform on a USB media or a computer before pressing
Backup Waveform to Int Storage. (If the waveform is lost or deleted on the signal
generator, it cannot be recovered).

Figure 9-38 Backup Waveform To Int Storage softkey

The Confirm Locking Waveform
softkey remains inactive until the
waveform is stored in internal storage.

FREQUEHCY ANPLITUDE Lock In Slot

935.200 000 OII] mz| -10.00 o ("o

ARB A

dCkUP HEVE 0

To Int Storace
aveforp Backup Required! | | # ?‘

Press this softkey to store the waveform
into the internal storage and to activate the
Confirm Locking Waveform softkey.

It is important that you make a backup copy of any waveforms that you are
licensing. Do not store the backup copy on the signal generator. If all copies of
the waveforms are deleted or lost, there is no way to recover the waveform or
reassign the license. Refer to “Working with Files” on page 56.
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Waveform Licensing Warning Messages

Figure 9-39

FREQUEHCY

RF_OFF

6.000 000 000 00 &z

+*xx% Waveform Lock Warningl | | %%

Once a waveform is locked it Will use up an
available license slot and it can not be un-locked.
Be sure that uou wWant to lock this waweform.

Inmportant! Keep a backup copy of the waveform elseuhere
in raca unil daloto A1l files in Tnt Stnraoo.

FREQUEHCY ANPLITUDE

935.20000000 mz | _-10.00_cen

Lock In Slot

Confirm
Locking Haweform

*xx Wavef orm Backup Required! I | #xx

laveform backup reguired. The waveform can not be
licensed until it is copied to non-volatile memory.

You must back up the waveform to non-volatile memory
FREQUENCY ANPLITUDE

6.000 000 000 00 &= -144.00 _de

Lock In Slot

Backup Hawveform
To Int Storage

Lock In Slot

%% WaveformBackup Failed! | | %%

Laveform backup failed. The waveform could not be
copied to non—volatile memory. There may not be
enough free memory.

You nust free enough non-volatile memory to copy
the waveform before you can license it.

: FREQUENCY RE_OFF

6.000 000 000 00 &2

Lock In Slot

k% WaveformFile is Missing! | | k%

The waveform file in the selected slot is no longer
in instrument memory.

You must either clear or replace the waveform for
this slot or load the missing file into instrument
memory before you can license it.

Keysight EXG and MXG X-Series Signal Generators User’s Guide

Waveform Licensing

This standard warning is
displayed every time a
waveform is selected to be
locked. This notification
indicates that one of the
available “license slots” is
about to be used from
Option 2xx.

ALWAYS make backup
copies of waveforms in a
separate non-volatile
memory in case a file is
deleted or lost from the
instrument’s internal
storage.

This warning is displayed
when an attempt is made
to lock a waveform that
has not been saved to
internal storage or USB
media (i.e. waveforms
cannot be locked unless
they have been stored to
non-volatile memory).
Press the Backup
Waveform To Int Storage
softkey.

This warning is displayed
when there is insufficient
memory or other problems
with the internal storage,
or USB media (non—
volatile memory) and the
waveform could not be
saved to non-volatile
memory.

This warning is displayed
when the waveform file
cannot be found in BBG or
internal storage. You must
ensure that the waveform
still resides in the
instrument before you can
lock it.
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Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

10 Digital Signal Interface Module (Option 003/004)

This chapter provides information on the N5102A Baseband Studio Digital Signal Interface Module.
These features are available only in N5172B/82B Vector Signal Generators with Options 003/004
and 653/655/656/657. The following list shows the topics covered in this chapter:

— Clock Timing on page 286
— Data Types on page 299

— Connecting the Clock Source and the Device Under Test on page 297

Operating the N5102A Module in Output Mode on page 300
Operating the N5102A Module in Input Mode on page 310

KEYSIGHT

TECHNOLOGIES
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Clock Timing

This section describes how clocking for the digital data is provided. Clock timing information and
diagrams are supplied for the different port configurations (serial, parallel, or parallel interleaved
data transmission) and phase and skew settings. All settings for the interface module are available
on the signal generator user interface (Ul).

Clock and Sample Rates

A sample is a group of bits where the size of the sample is set using the Word Size softkey. The
clock is the signal that tells when the bits of a sample are valid (in a non-transition state). The clock
and sample rates are displayed in the first-level and data setup softkey menus. The clock rate and
sample rate are usually the same. They will differ when serial mode is selected, or when there are
multiple clocks per sample.

Figure 10-1 Data Setup Menu for a Parallel Port Configuration
FREQUEHCY AMPLITUDE Data Setup
6.000 000 000 00 ez -144.00 cen | opece
N
£ —> Clock | | [ :
§ 155 1 pata Y e HelE Bite
2155 0 pata Y y
I/ Data Bit Alignment Clock Rate: 100.000 MHz
0123045678 3101112131415 | Sarple Rate: 100.000 MHz Mumeric Format,
O \\‘ESEW‘”E”‘?”U
01/31/2013 14: 10N flore 1 of 3

AN

Least significant bit

Most significant bit

Clock and sample rates

The N5T02A module clock rate is set using the Clock Rate softkey and has a range of 1 kHz to
400 MHz. The sample rate is automatically calculated and has a range of 1 kHz to 200 MHz. These
ranges can be smaller depending on logic type, data parameters, and clock configuration.

Maximum Clock Rates

The N5T02A module maximum clock rate is dependent on the logic and signal type. Table 10-1 and
Table 10-2 show the warranted rates and the maximum clock rates for the various logic and signal
types. Notice that LVDS in the output mode using an IF signal is the only logic type where the
warranted and maximum rates are the same.

Table 10-1 Warranted Parallel Output Level Clock Rates and Maximum Clock Rates
Warranted Level Clock Rates Maximum Clock Rates (typical)
Logic Type
IQ Signal Type IF Signal Type1 1Q Signal Type IF Signal Type
LVTTL and CMOS 100 MHz 100 MHz 150 MHz 150 MHz
LVDS 200 MHz 400 MHz 400 MHz 400 MHz
286 Keysight EXG and MXG X-Series Signal Generators User’s Guide
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1. The IF signal type is not available for a serial port configuration.

Table 10-2 Warranted Parallel Input Level Clock Rates and Maximum Clock Rates

Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVTTL and CMOS 100 MHz 150 MHz

LvDS 200 MHz 200 MHz

The levels will degrade above the warranted level clock rates, but they may still be usable.

Serial Port Configuration Clock Rates

For a serial port configuration, the lower clock rate limit is determined by the word size (word size
and sample size are synonymous), while the maximum clock rate limit remains constant at 150 MHz
for LVTTL and CMOS logic types, and 400 MHz for an LVDS logic type.

The reverse is true for the sample rate. The lower sample (word) rate value of 1 kHz remains while
the upper limit of the sample rate varies with the word size. For example, a five-bit sample for an
LVTTL or CMOS logic type yields the following values in serial mode:

— Clock rate of 5 kHz through 150 MHz

— Sample rate of 1 kHz through 30 MHz
Refer to Table 10-3 and Table 10-4, for the serial clock rates.

Table 10-3 Output Serial Clock Rates
Logic Type Minimum Rate Maximum Rate
LVDS 1 x (word size) kHz 400 MHz
LVTTL and CMQS 1 x (word size) kHz 150 MHz
Table 10-4 Input Serial Clock Rates
Logic Type Data Type Minimum Rate Maximum Rate
LVDS Samples 1 x (word size) kHz 400
Pre-FIR 1 x (word size) kHz the smaller of: 50" x (word size) MHz
Samples or
400 MHz
LVTTL and CMOS N/A 1 x (word size) kHz 150 MHz

1. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples.
Refer to “Input Mode” on page 299 for more information.
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Parallel and Parallel Interleaved Port Configuration Clock Rates

Parallel and parallel interleaved port configurations have other limiting factors for the clock and
sample rates:

— logic type
— Clocks per sample selection
— 1Q or IF digital signal type

Clocks per sample (clocks/sample) is the ratio of the clock to sample rate. For an IQ signal type, the
sample rate is reduced by the clocks per sample value when the value is greater than one. For an IF
signal or an input signal, clocks per sample is always set to one. Refer to Table 10-5 for the Output
mode parallel and parallel interleaved port configuration clock rates.

Table 10-5 Output Parallel and Parallel Interleaved Clock Rates
Logic Type | Signal Type | Minimum Rate Maximum Rate
LVDS 1Q 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz
Z(r)O MHz
IF 4 kHz 400 MHz
Other IQ 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz
%O MHz
IF 4 kHz 150 MHz

For Input mode, the maximum clock rate is limited by the following factors:
— sample size

— data type

Refer to Table 10-6 for the Input mode parallel and parallel interleaved port configuration clock
rates.

Table 10-6 Input Parallel and Parallel Interleaved Clock Rates
Logic Type Data Type Minimum Rate Maximum Rate
N/A Samples 1 kHz 200 MHz
Pre-FIR Samples 1 kHz 100 MHz

Clock Source

The clock signal for the N5102A module is provided in one of three ways through the following
selections:
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— Internal: generated internally in the interface module (requires an external reference)
— External: generated externally through the Ext Clock In connector
— Device: generated externally through the Device Interface connector

The clock source is selected using the N5T02A module Ul on the signal generator, see Figure 10-2.

Figure 10-2 Clock Source Selection

External and Device
Clock Setup selection:

Set to match the clock rate
1DD.DDDgéBBEDHﬁﬁ§ D of the applied clock signal
internal selection: Set the
internal clock rate.

NS102A ;
Lato Clock Source > CITIG ERTIHER
(Internal)®
ouT External
Freq Ref Internal
FPhase/Sken Clock Out. Reference

Freguency
10. 000000000 MHz Device

FREQUEHCY ANPLITUDE

-144.00 den

6.000 000 000 00 &+

Clock/Data Timing
Clock 1 | ElDCLEDPEgg?,
Data
02/06/2013 14:51 fore 1 of 2

Internal

Internal clock source
selection: Set the frequency of
the applied reference signal.

When you select a clock source, you must let the N5T02A module know the frequency of the clock
signal using the Clock Rate softkey. In the internal clock source mode, use this softkey to set the
internal clock rate. For device and external clock sources, this softkey must reflect the frequency of
the applied clock signal.

When the clock source is Internal, a frequency reference must be applied to the Freq Ref connector.
The frequency of this applied signal needs to be specified using the Reference Frequency softkey,
unless the current setting matches that of the applied signal.

The selected clock source provides the interface module output clock signal at the Clock Out and
the Device Interface connectors.

Common Frequency Reference

The clocking flexibility of the digital signal interface module allows the setting of arbitrary clock
rates for the device under test. In general, the clock rate inside the signal generator will be different
from the interface module clock rate, so the interface module performs a rate conversion. An
important aspect of this conversion is to have accurate clock rate information to avoid losing data.
The module relies on relative clock accuracy, instead of absolute accuracy, that must be ensured by
using a single frequency reference for all clock rates involved in the test setup. This can be
implemented in various ways (see the five drawings in Figure 10-3 on page 290), but whatever way
it is implemented, the clock inside the signal generator must have the same base frequency
reference as the clock used by the device under test.

Signal Generator Frequency Reference Connections

When a frequency reference is connected to the signal generator, it is applied the REF In rear panel
connector.

Keysight EXG and MXG X-Series Signal Generators User’s Guide 289



Digital Signal Interface Module (Option 003/004)
Clock Timing

Figure 10-3 Frequency Reference Setup Diagrams for the N5102A Module Clock Signal

Internally Generated Clock

Data

Signal Generator Data__ | N5102A Module DUT

Clock

Y Y

10 MHz QUT

A
Freq Ref
10 MHz Frequency Reference

Device (DUT) Supplied Clock

Data
Signal Generator Dala | N5102A Module Clock DUT

Y

10 MHz QUT

A

A

10 MHz Frequency Reference

............ | 1 Data
: Signal Generator |—DB2ata o] NS5102A Module | Clock

DUT

Yy

Ext Clk In

10 MHz Frequency Reference

External Clock

1-100 MHz Frequency Reference

NOTE: Use only one of the two signal generator frequency reference inputs.

Externally Supplied Clock

Data
Signal Generator Dala | N5102A Module Clock

DUT

Yy

10 MHz OUT

Ext Clk In

10 MHz F Refi
ZIIogrency ToeTonee P External Clock

BB GEN REF IN | Data
. . Data
Signal Generator »| NS5102A Module Clock

DUT

\ A 4

= J

. Ext Clk In

10 MHz Frequency Reference

1-100 MHz Frequency Reference | External Clock

NOTE: Use only one of the two signal generator frequency reference inputs.
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Clock Timing for Parallel Data

Some components require multiple clocks during a single sample period. (A sample period consists
of an | and Q sample). For parallel data transmissions, you can select one, two, or four clocks per
sample. For clocks per sample greater than one, the | and Q samples are held constant to
accommodate the additional clock periods. This reduces the sample rate relative to the clock rate
by a factor equal to the clocks per sample selection. For example, when four is selected, the sample
rate is reduced by a factor of four (sample rate to clock rate ratio). Figure 10-4 demonstrates the
clock timing for each clocks per sample selection. For input mode, the clocks per sample setting is
always one.

Figure 10-4 Clock Sample Timing for Parallel Port Configuration

1 Clock Per Sample

1 Sample Period Clock and sample rates are the same

| 1 Clock | | | | |

| |

Clock | | | | | |

¥ 0 o W o X 0o X 0
| ) \| f |, )

X ¥ X }4 A ;
| sample i ! j ! | ! T ! | ! ((
4 bits per word }Tf 2 »i 2 T 2 i< 2 T 2 ((
W3 ) S ¢ 3 3 3 X

| | | | | |
D D D G o K

! 1 )3 1 I 1 b 1 by 1 )
Q sample ;+' A ! f f' K
4 bits per word s 2 1. 2 hit 2 X 2 ) 2 K
) T - - G-I ¢ 3 K

| | | | | |
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2 Clocks Per Sample
Sample rate decreases by a factor of two
1 Sample Period
I 2 Clocks I I
| |
Clock | | | | | | | | |
b 0 b 0 hS 0
| sample x 1 s 1 b 1
4 bits per word b4 2 | 2 } 2
b 3 b4 3 k¢ 3
| | |
M 0 s 0 ) 0
! { |
Q sample T ! ) ! T !
4 bits per word b 2 3F 2 f 2
) 3 I 3 f 3
I I I

4 Clocks Per Sample
Sample rate decreases by a factor of four

1 Sample Period

: 4 Clocks !
| > |
Clock | | | | | | | | |

b 0 h¢ 0
b 1 b4 1

| sample J |
4 bits per word A 2 \ 2
f:Jr: 3 I 3

| |
X 0 f—
Q sample A 1 1 !
4 bits per word ks 2 b 2
x 3 A 3

[ [
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Clock Timing for Parallel Interleaved Data

The N5T02A module provides the capability to interleave the digital | and Q samples. There are two
choices for interleaving:

— 1Q, where the | sample is transmitted first

— QI, where the Q sample is transmitted first

When parallel interleaved is selected, all samples are transmitted on the | data lines. This effectively
transmits the same number of samples during a sample period on half the number of data lines as
compared to non-interleaved samples. (A sample period consists of an | and Q sample.) Clocks per
sample is still a valid parameter for parallel interleaved transmissions and creates a reduction in the
sample rate relative to the clock rate. The clocks per sample selection is the ratio of the reduction.
Figure 10-5 shows each of the clocks per sample selections, for a parallel |IQ interleaved port
configuration, using a word sized of four bits and the clock timing relative to the | and @ samples.
For a parallel QI interleaved port configuration, just reverse the | and Q sample positions. For input
mode, the clocks per sample setting is always one.

Figure 10-5 Clock Timing for a Parallel IQ Interleaved Port Configuration

1 Clock Per Sample

The | sample is transmitted on one clock transition and the Q sample is transmitted on the
other transition; the sample and clock rates are the same.

1 Sample Period

| 1Clock | | | | |
™ | | | |
clock [ || I I B N
o o | o fo jojo i 0 0 J%:ﬁ o [ o]
jl' [ | 101 ;f: 101 : 1 1 : 101 1[
}iZXZ'['Z’f_Z'{(Z}z?’{ZZ2>2¥2)r:
,'3.K3;3=1.3i'<3¥313=3 3¥3;-|f:]
| | | | | |
| sample Q sample

4 bits per word 4 bits per word
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2 Clocks Per Sample

The | sample is transmitted for one clock period and the Q sample is transmitted during the second
clock period; the sample rate decreases by a factor of two.

1 Sample Period

I 2 Clocks I |
|<—>| |
Clock | | | | I | | | I |
} G D G D S R G R S
) S P ¥ 1 ¥ 1 hi 1 P
2 2} 2 2 2k
| | |

| sample Q sample
4 bits per word 4 bits per word

4 Clocks Per Sample

The | sample is transmitted for the first two clock periods and the Q sample is transmitted during the second two
clock periods; the sample rate is decreased by a factor of four.

1 Sample Period

! 4 Clocks
| |
co | L[ L L 1 I

f:lf 0 X 0 | 0
:?1:1 1 X 1 L 1
X 2 2 I
X 3 X 3 I—
"

| sample Q sample

4 bits per word 4 bits per word

Clock Timing for Serial Data

Figure 10-6 shows the clock timing for a serial port configuration. Notice that the serial
transmission includes frame pulses that mark the beginning of each sample where the clock
delineates the beginning of each bit. For serial transmission, the clock and the bit rates are the
same, but the sample rate varies depending on the number of bits per word that are entered using
the Word Size softkey. The number of bits per word is the same as the number of bits per sample.
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Figure 10-6 Clock Timing for a Serial Port Configuration
| |
|- 1 Sample |
Frame Marker | |
coc || [ ] S e
Data Bits ;1 0 by 1 bt 2 X 3 :‘r:\' 0
|

4 bits per word

Clock Timing for Phase and Skew Adjustments

The N5102A module provides phase and skew adjustments for the clock relative to the data and
can be used to align the clock with the valid portion of the data. The phase has a 90 degree
resolution (0, 90, 180, and 270 degree selections) for clock rates from 10 to 200 MHz and a 180
degree resolution (0 and 180 degree selections) for clock rates below 10 MHz and greater than 200
MHz.

The skew is displayed in nanoseconds with a maximum range of +5 ns using a maximum of £127
discrete steps. Both the skew range and the number of discrete steps are variable with a
dependency on the clock rate. The skew range decreases as the clock rate is increased and
increases as the clock rate is decreased. The maximum skew range is reached at a clock rate of
approximately 99 MHz and is maintained down to a clock rate of 25 MHz. For clock rates below 25
MHz, the skew adjustment is unavailable.

A discrete step is calculated using the following formula:

1
256 x Clock Rate

The number of discrete steps required to reach the maximum skew range decreases at lower
frequencies. For example, at a clock rate of 50 MHz, 127 steps would exceed the maximum skew
range of £5 ns, so the actual number of discrete steps would be less than 127.

Figure 10-7 is an example of a phase and skew adjustment and shows the original clock and its
phase position relative to the data after each adjustment. Notice that the skew adjustment adds to
the phase setting.
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Figure 10-7 Clock Phase and Skew Adjustments
90 degree phase adjustment
— - Clock skew adjustment
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Connecting the Clock Source and the Device Under Test

As shown in Figure 10-3 on page 290, there are numerous ways to provide a common frequency
reference to the system components (signal generator, N5102A module, and the device under test).
Figure 10-8 shows an example setup where the signal generator supplies the common frequency

reference and the N5T02A module is providing the clock to the device.

The Device Interface connector on the interface module communicates

using high speed digital data. Use ESD precautions to eliminate potential

damage when making connections.

Figure 10-8 Example Setup using the Signal Generator 10 MHz Frequency Reference

Signal generator 10 MHz Out

Common Freq Ref cable

Freqg Ref connector
Device under test
Break-out board

Device interface connection User furnished ribbon cable(s) connect
between the device and break-out board.
The clock to the device is in the ribbon

cable.
NOTE You must disconnect the digital bus cable and the digital module while
downloading firmware to the signal generator.

1. Refer to the five setup diagrams in Figure 10-3 on page 290 and connect the frequency
reference cable according to the clock source.

2. If an external clock source is used, connect the external clock signal to the Ext Clock In
connector on the interface module.
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3. Select the break-out board that has the output connector suited for the application.

If the Device Interface mating connector is used with the device under test,
refer to Figure 10-8 for the device interface connection and connect the
device to the N5102A module. Then proceed to “Operating the N5102A
Module in Output Mode” on page 300 or “Operating the N5102A Module in
Input Mode” on page 310.

4. Refer to Figure 10-8. Connect the break-out board to the Device Interface connector on the
N5102A module.

5. Connect the device to the break-out board.
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Data Types

The following block diagram indicates where in the signal generation process the data is injected
for input mode or tapped for output mode.

Output Mode

Pre-FIR

Samples Samples
A A
Signal Generator
FIR RF
Data 1,Q
Generator [, ™ Filtering & A » DACs » Modllﬁ%tor >
A .
Resampling
Pre-FIR Samples
Samples
Input Mode

Output Mode

When using an ARB format with no real-time modulation filter, the data type is always Samples and
no filtering is applied to the data samples. The samples are sent to the digital module at the ARB
sample clock rate and resampled.

For real-time formats or Dual ARB with a real-time modulation filter, choosing Samples as the data
type will send filtered samples to the digital module at the module’s clock rate. Selecting Pre-FIR
Samples, sends unfiltered but potentially resampled samples to the module at the module’s clock
rate.

Input Mode

When the data type is Samples, the data samples coming through the digital module are injected at
a point that bypasses the filtering process.

If Pre-FIR Samples is selected, the data samples are injected before the filtering process.

The Filter softkey accesses a menu that enables you to set the desired filtering parameters.
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Operating the N5102A Module in Output Mode

This section shows how to set the parameters for the N5T02A module using the signal generator Ul
in the output direction. Each procedure contains a figure that shows the softkey menu structure for
the interface module function being performed.

Setting up the Signal Generator Baseband Data

The digital signal interface module receives data from a baseband source and outputs a digital 1Q
or digital IF signal relative to the selected logic type. Because a signal generator provides the
baseband data, the first procedure in operating the interface module is configuring the signal
generator using one of the real-time or ARB modulation formats, or playing back a stored file using
the Dual ARB player. For information on configuring the signal generator, refer to Chapter 9, “Basic
Digital Operation (Option 653/655/656/657)”, on page 185.

1. Preset the signal generator.
2. Select the modulation format (GSM, Custom, and so forth) and set the desired parameters.

3. Turn-on the modulation format.

Accessing the N5T02A Module User Interface

Figure 10-9 shows the Auxiliary menu that is accessed by pressing the Aux Fctn key on the front
panel of the signal generator.

Figure 10-9 First-Level Softkey Menu

Aux

FREQUEHCY CHANCORR ANPLITUDE Auxiliary

6.000 000 000 00 &z -144.00 den Pover rister,
hd hd Measurements
ALC OFF

EDigit?l E_lgs Select either PXB or N5102A

Onnech Ll connectivity.

P R The default selection is N5102A.

N51026 Interfacer Press here to access the N5102A
menu.
03/27/2013 17:03
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Press N5102A Interface to access the Ul (first-level softkey menu shown in Figure 10-10) that is
used to configure the digital signal interface module. Notice the graphic in the signal generator
display, showing a setup where the N5102A module is generating its own internal clock signal. This
graphic changes to reflect the current clock source selection.

Figure 10-10

N5102A Interface Menu

Internal clock going to the DUT

6.000 000 000 00 &z -144.00 cen

Clock .
— Port Config,
Signal Generator NE10ZA — =— OUT (Parallell
Ho102A
Freq. Re Data Setupk Dimgnost icsk

Clock Rate: 100.000 MHz
Sample Rate: 100.000 MHz

01/29/2013 15:51

H5102A

KNS 102A
TN On

Logic Tupe,
(3.3 CHOS)

Clock Setupe

fore 1 of 2 —

Line is grayed out until the N5102A module interface is turned on

Choosing the Logic Type and Port Configuration

Figure 10-11 Logic and Port Configuration Softkey Menus
FREQUENCY ANPLITUDE N5102A
- N5 1020
6.000 000 000 00 &= -144.00 cen 02
Logic T Logic Tuype
(G-3y oibsy
YOS
. ———EAQEE——é Part Config,|
Signal Generator NS10Z — —— OUT (Parallell
LYTTL
Freq. Ref Data Setupr
Clock Rate: 100.000 MHz 3.3V cHos
Sample Rate: 100.000 MHz Clock Setupk
01/25/2013 15:51  More 1 of 2 23 T
1.8\ CHOS

1. Refer to Figure 10-11. Press the Logic Type softkey.
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From this menu, choose a logic type.

Changing the logic type can increase or decrease the signal voltage level
going to the device under test. To avoid damaging the device and/or the
N5102A module, ensure that both are capable of handling the voltage
change.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey
selection appears requesting confirmation.

3. Refer to Figure 10-11. Press the Port Config softkey.
In this menu, select either a serial, parallel, or parallel interleaved data transmission.
Within the data and clock setup softkey menus, some softkeys function

relative to the current configuration. Softkeys that are grayed out are not
available for the current setup.

4. Select the port configuration for the device.

Selecting the Output Direction

Press Data Setup > Direction Input Output to Output and press Return.
If Option 003 is the only option installed, the direction softkey will be
unavailable and the mode will always be output. With both Option 003

(output mode) and Option 004 (input mode) installed, the default direction
is output.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory
names are generally not mentioned. For example, the Word Size softkey.

1. Refer to Figure 10-12. Press the Data Setup softkey.
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Figure 10-12 Data Setup Menu Location

FREQUEHCY AAPLITUDE Hol02a
- MNE102A
6.000 000 000 00 &=z -144.00 aen %
———
Logic Tupe,
(3.3 CHOS)
- Clock Port Config,
Signal Generator NE10ZA — =— OUT (Parallell
Freq. Ref Data Setupr -g—Accesses the Data Setup menu

Clock Rate: 100.000 MHz

Sample Rate: 100.000 MHz Clock Setupk

01/29/2013 15:51 Hore 1 of 2

This softkey menu accesses the various parameters that govern the data received by the
device under test. The status area of the display shows the number of data lines used for both
I and @ along with the clock position relative to the data. When the port configuration is
parallel or parallel interleaved, the number of data lines indicated is equivalent to the word
(sample) size. When the port configuration is serial, the display will show that only one | and
one @ data line is being used along with the frame marker that delineates the beginning of a
sample. Figure 10-13 shows the data setup menu structure.
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Figure 10-13 Data Setup Softkey Menu with Parallel Port Configuration

Inactive for ARB formats

2.

FREQUEHCY AAPLITUDE Data Setup
6.000 000 000 00 ez -144.00 @n . s
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01/31/2013 1L:10 Hore 1 of 3 | 2°s Complement
Data Setup Offset Binary
Inactive for a serial port > Signal Tupe
configuration 1F

Eit Order
M5B
Data Setup
i MNegate I Data
Data MNegationk——>® o

Spap I0 Megate [ Data
TN 0n on

Output. Markere

Gain/0f fset
fore 2 of 3 I Gain
100.00 =
Data Setup 0 Gain
. 100.00 =
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Heg IEEEH
ity
Available only whilein = ___g. Gain, Offset ) )
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0 Offset
o 0.00 %
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If a real-time modulation format or the real-time modulation filter feature in Dual ARB is being
used, press the Data Type softkey.

In this menu, select whether the real-time baseband data from the signal generator is either
filtered (Samples) or unfiltered (Pre-FIR Samples). The selection is dependent on the test
needs. The Samples selection provides FIR filtered baseband samples according to the
communication standard of the active modulation format. This is the preset selection and the
one most commonly used. However if the device being tested already incorporates FIR filters,
the Pre-FIR Samples selection should be used to avoid double filtering.

3. Select the data type that is appropriate for the test.

Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2’s complement
allows both positive and negative data values. Use the Offset Binary selection when
components cannot process negative values.
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5. Select the numeric format required for the test.
6. Press the More (1 of 2) softkey.

From this softkey menu, select the bit order, swap | and Q, select the polarity of the
transmitted data, and access menus that provide data negation, scaling, gain, offset, and 1Q
rotation adjustments.

7. Press the Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the
affected sample by expressing it in the two's complement form, multiplying it by negative one,
and converting the sample back to the selected numeric format. This can be done for |
samples, Q samples, or both.

The choice to use negation is dependent on the device being tested and how it needs to
receive the data.

8. Press the Gain, Offset & Scaling softkey.
Use the softkeys in this menu for the following functions:
— reduce sample values for both | and Q using the Scaling softkey

— increase or decrease the sample values independently for | and Q using the | Gain and Q
Gain softkeys

— compensate for or add a DC offset using the | Offset and Q Offset softkeys
— rotate the data on the IQ plane using the Rotation softkey
9. Make any required scaling, gain, offset, or rotation adjustments to properly test the device.

10.Press Return > Return to return to the first-level softkey menu.

Configuring the Clock Signal
1. Refer to Figure 10-14. Press the Clock Setup softkey.

Figure 10-14 Clock Setup Menu Location

FREQUEHCY ANPLITUDE H5102A
- MNE102A
6.000 000 000 00 &=z -144.00 aen %
———
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Clock Rate: 100.000 MHz
Sample Riate: 100,000 MHz ek SEED Accesses the

< Clock Setup Menu

01/29/2013 15:51 Hore 1 of 2
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From this softkey menu, set all of the clock parameters that synchronize the clocks between
the N5102A module and the signal generator. You can also change the clock signal phase so
the clock occurs during the valid portion of the data. Figure 10-15 shows the clock setup
menu.

Figure 10-15 Clock Setup Softkey Menu for a Parallel Port Configuration

Inactive for a serial port configuration and the IF signal type

Clocks/Sample
Clock Setup
-144.00 den Clock Rate
* 0. 000000000 MHz —

6.000 000 000 00 &+

A Clock Sour“ce'_
(Internall
ouT
Freg Ref Internal
Source = SEHEL P Clock Out Reference | Clock Source
1D 000000000 HHz EeftErmal
Clock/Data T1m1ng

Clock ElocTDPgas?,___

Data

Device

02286,/2013 14:51 Hore 1 of 2
Internal
Clock Setup

Clock Skew
0.000 nsec . Clock Phase

Elock Polarlt 0 deg

Active for only the Internal clock source selection 90 deg
Inactive for clock rates below 25 MHz

180 deg

270 deg

Inactive for clock rates below
10 MHz and above 200 MHz

The top graphic on the display shows the current clock source that provides the output clock
signal at the Clock Out and Device Interface connectors. The graphic changes to reflect the
clock source selection discussed later in this procedure. The bottom graphic shows the clock
position relative to the data. The displayed clock signal will change to reflect the following:

— clocks per sample selection

clock phase choice

clock skew adjustment

clock polarity selection

If the device or external clock does not match the frequency, one of the following error
messages will appear on the signal generator:

805 Di gital nodul e output FIFO overflowerror; There are nore
sanmpl es being produced than can be consuned at the
current clock rate. Verify that the digital nodul e clock
is set up properly.
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This error is reported when the output FIFO is overflowing in

the digital module. This error can be generated if an external clock
or its reference is not set up properly, or if the internal VCO is
unlocked.

806 Di gi tal nodul e out put FIFO underflow error; There are not
enough sanpl es bei ng produced for the current clock rate.
Verify that the digital nodule clock is set up properly.

This error is reported when the output FIFO is underflowing in the digital
module. This error can be generated if an external clock or its reference is not
set up properly, or if the internal VCO is unlocked.

2. If the port configuration is parallel or parallel interleaved, using an |IQ signal type, press the
Clocks Per Sample softkey.

Notice that multiple clocks per sample can be selected. Some DACs require the ability to clock
multiple times for each sample; having a clocks per sample value greater than one reduces the
rate by a factor equal to the selected number of clocks per sample. The sample rate is viewed
on the first-level and Data Setup softkey menus.

3. Select the clocks per sample value to fit the test.
4. Press the Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display
in the signal generator clock setup menu will change to reflect the current clock source. This
will be indicated by a change in the graphic.

5. Select the clock source.
If External or Device is Selected

Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal.

The clock phase and clock skew may need to be adjusted any time the
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew
Adjustments” on page 295.

For the External selection, the signal is supplied by an external clock source and applied to the
Ext Clock In connector. For the Device selection, the clock signal is supplied through the
Device Interface connector, generally by the device under test.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock
signal. The reference frequency signal must be applied to the Freq Ref connector on the digital
module.

a. Press the Reference Frequency softkey and enter the frequency of the externally applied
frequency reference.
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b. Press the Clock Rate softkey and enter the appropriate clock rate.

Table 10-7 provides a quick view of the settings and connections associated with each clock
source selection.

Table 10-7 Clock Source Settings and Connectors
Clock Softkeys N5102A Module Connection
Source
Reference | clock Rate' Freq Ext Clock | Device
Frequency Ref In Interface
External | l
Device l l
Internal? l l l

1. For the Internal selection, this sets the internal clock rate. For the External
and Device selections, this tells the interface module the rate of the
applied clock signal.

2. There should be no clock signal applied to the Ext Clock In connector.

6. Press the Clock Phase softkey.

From the menu that appears, you can adjust the phase of the clock relative to the data in 90
degree increments. The selections provide a coarse adjustment for positioning the clock on the
valid portion of the data. Selecting 180 degrees is the same as selecting a negative clock
polarity.

The 90 degree and 270 degree selections are not available when the clock rate is set below 10
MHz or above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rate is set
below 10 MHz or above 200 MHz, the phase will change to 0 degrees or 180 degrees,
respectively.

The clock phase and clock skew may need to be adjusted any time the
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew
Adjustments” on page 295.

7. Enter the required phase adjustment.
8. Press the Return softkey to return to the clock setup menu.
9. Press the Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is
a phase adjustment using increments of time. This enables greater skew adjustment capability
at higher clock rates. For clock rates below 25 MHz, this softkey is inactive.

The skew has discrete values with a range that is dependent on the clock rate. Refer to “Clock
Timing for Phase and Skew Adjustments” on page 295 for more information on skew settings.

10.Enter the skew adjustment that best positions the clock with the valid portion of the data.
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11.Press the Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock
transition. This has the same affect as selecting the 180 degree phase adjustment.

12.Make the clock polarity selection that is required for the device being tested.
13.Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu graphic. For
example, if the device is the new clock source, the graphic will show that the frequency
reference is now connected to the DUT and the DUT has an input clock line going to the
N5102A module.

Generating Digital Data
Press the N5102A Off On softkey to On.

Digital data is now being transferred through the N5102A module to the device. The green status
light should be blinking. This indicates that the data lines are active. If the status light is solidly
illuminated (not blinking), all the data lines are inactive. The status light comes on and stays on
(blinking or solid) after the first time the N5102A module is turned on (N5102A Off On to On). The
status light will stay on until the module is disconnected from its power supply.

The interface module can only be turned on while a modulation format is active. If the modulation
format is turned off while the module is on, the module will turn off and an error will be reported.

If changes are made to the baseband data parameters, it is recommended
that you first disable the digital output (N5102A Off On softkey to Off) to
avoid exposing your device and the N5102A module to the signal
variations that may occur during the parameter changes.
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Operating the N5102A Module in Input Mode

This section shows how to set the parameters for the N5T02A module using the signal generator Ul
in the input direction. Each procedure contains a figure that shows the softkey menu structure for
the interface module function being performed.

Refer to “Connecting the Clock Source and the Device Under Test” on page 297 and configure the
test setup.

Accessing the N5T02A Module User Interface

Figure 10-16 shows the Auxiliary menu that is accessed by pressing the Aux Fctn key on the front
panel of the signal generator.

Figure 10-16 First-Level Softkey Menu

Aux
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Press here to access the N5102A
menu.

W5102A Interfacew

03/27/2013 17:03

All parameters for the N5102A module are set with softkeys on the signal generator.

Press N5102A Interface to access the Ul (first-level softkey menu shown in Figure 10-17) that is
used to configure the digital signal interface module. Notice the graphic in the signal generator
display, showing a setup where the N5T02A module is generating its own internal clock signal. This
graphic changes to reflect the current clock source selection.

Figure 10-17 N5102A Interface Menu
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Selecting the Input Direction

If both Option 003 (output mode) and Option 004 (input mode) are installed, you must select the
input direction.

Press Data Setup > Direction Input Output to Input and press Return.

Choosing the Logic Type and Port Configuration

If only Option 004 is installed, the direction softkey will be unavailable and
the mode will always be input.

Figure 10-18 Logic and Port Configuration Softkey Menus
FREQUENCY AMPLITUDE H5102A Logic Tupe
- NS102A LYDS
6.000 000 000 00 &= -144.00 cen 02
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.  Clock Port. Config, 3.3V Cnos
Signal Generator NS10Z — —— OUT (Parallell
2.5 CHOS
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Port Config
Logic Tuype
Parallel
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Serial
551

Far I0 Intrlud
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1. Refer to Figure 10-18. Press the Logic Type softkey.

From this menu, choose a logic type.

Changing the logic type can increase or decrease the signal voltage level.
To avoid damaging the device and/or the N5102A module, ensure that
both are capable of handling the voltage change.
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2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey
selection appears asking for confirmation.

3. Refer to Figure 10-18. Press the Port Config softkey.

In this menu, select either a serial, parallel, or parallel interleaved data transmission.

Within the data and clock setup softkey menus, some softkeys function
relative to the current configuration. Softkeys that are grayed out are not
available for the current setup. Refer to the help text to determine which
parameter is causing the softkey to be unavailable. Press the Help hardkey
on the signal generator front panel and then the softkey that is
unavailable.

4. Select the port configuration for the device being tested.

Configuring the Clock Signal

1. Refer to Figure 10-19. Press the Clock Setup softkey.

Figure 10-19 Clock Setup Menu Location
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From this softkey menu, set all of the clock parameters that synchronize the data between the
N5102A module and the device. From this menu, the clock signal phase can be changed so the
clock occurs during the valid portion of the data. Figure 10-20 shows the clock setup menu.

If the device or external clock does not match the frequency, one of the following error
messages will appear on the signal generator:

803 Di gital nmodul e i nput FIFO overflow error; There are nore
sanpl es bei ng produced than can be consuned at the
current clock rate. Verify that the digital nodul e cl ock
is set up properly.

This error is reported when the digital module clock setup is not
synchronized with the rate the samples are entering the digital
module. Verify that the input clock rate matches the specified
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clock rate under the clock setup menu.

804 Di gital nodul e i nput FI FO underflow error; There are not
enough sanpl es bei ng produced for the current clock rate.
Verify that the digital nodule clock is set up properly.

This error is reported when the digital module clock setup is not
synchronized with the rate the samples are entering the digital
module. Verify that the input clock rate matches the specified

clock rate under the clock setup menu.

Figure 10-20 Clock Setup Softkey Menu for a Parallel Port Configuration

Inactive for Input mode
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81885 Skew
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Active for only the Internal clock source selection Clock Phase
Clock Polarlt
Inactive for clock rates below 25 MHz NBQ 0 deg
90 deg

180 deg
270 deg
Inactive for clock rates below /
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The top graphic on the display shows the current clock source that provides the output clock
signal at the Clock Out and Device Interface connectors. The graphic changes to reflect the
clock source selection discussed later in this procedure. The bottom graphic shows the clock
edges relative to the data. The displayed clock signal will change to reflect the following:

— clock phase choice
— clock skew adjustment
— clock polarity selection

2. Press the Clock Source softkey.
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From this menu, select the clock signal source. With each selection, the clock routing display
in the signal generator clock setup menu will change to reflect the current clock source. This
will be indicated by a change in the graphic.

3. Select the clock source.
If External or Device is Selected

Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal.

The clock phase and clock skew may need to be adjusted any time the
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew
Adjustments” on page 295.

For the External selection, the signal is supplied by an external clock source and applied to the
Ext Clock In connector. For the Device selection, the clock signal is supplied through the
Device Interface connector, generally by the device being tested.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock
signal. The reference frequency signal must be applied to the Freq Ref connector on the digital
module.

a. Press the Reference Frequency softkey and enter the frequency of the externally applied
frequency reference.

b. Press the Clock Rate softkey and enter the appropriate clock rate.

Table 10-8 provides a quick view of the settings and connections associated with each clock
source selection.
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Table 10-8 Clock Source Settings and Connectors
Clock Softkeys N5102A Module Connection
Source
Reference | Clock Rate' Freq Ext Clock | Device
Frequency Ref In Interface
External l L
Device l l
Internal? L l l

1. For the Internal selection, this sets the internal clock rate. For the External
and Device selections, this tells the interface module the rate of the
applied clock signal.

2. There should be no clock signal applied to the Ext Clock In connector
when Internal is being used.

. Press the Clock Phase softkey.

From the menu that appears, the phase of the clock relative to the data can be changed in 90
degree increments. The selections provide a coarse adjustment for positioning the clock on the
valid portion of the data. Selecting 180 degrees is the same as selecting a negative clock
polarity.

The 90 degree and 270 degree selections are not available when the clock rate is set below 10
MHz or above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rate is set
below 10 MHz or above 200 MHz, the phase will change to 0 degrees or 180 degrees,
respectively.

The clock phase and clock skew may need to be adjusted any time the
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew
Adjustments” on page 295.

5. Enter the required phase adjustment.

. Press the Return softkey to return to the clock setup menu.
. Press the Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is
a phase adjustment using increments of time. This enables greater skew adjustment capability
at higher clock rates. For clock rates below 25 MHz, this softkey is inactive.

The skew has discrete values with a range that is dependent on the clock rate. Refer to “Clock
Timing for Phase and Skew Adjustments” on page 295 for more information on skew settings.

. Enter the skew adjustment that best positions the clock with the valid portion of the data.
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9. Press the Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock
transition. This has the same affect as selecting the 180 degree phase adjustment.

10.Make the clock polarity selection that is required for the device being tested.

11.Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu graphic. For
example, if the device is the new clock source, you will see that the frequency reference is now
connected to the DUT and the DUT has an input clock line going to the N5102A module.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory
names are generally not mentioned. For example, the Word Size softkey.

1. Refer to Figure 10-21. Press the Data Setup softkey.

Figure 10-21
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Data Setup Menu Location

H5102A

KNS 102A
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Logic Tupe,
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Data Setupk|<e—— Accesses the Data Setup
Menu

01/29/2013 15:51 Hore 1 of 2

This softkey menu accesses the various parameters that govern the data received by the signal
generator. The status area of the display shows the number of data lines used for both | and Q
along with the clock position relative to the data. Figure 10-22 shows the data setup menu

structure.
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Figure 10-22 Data Setup Softkey Menu with Parallel Port Configuration
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2. Press the Data Type softkey.

In this menu, select the data type to be either filtered (Samples) or unfiltered (Pre-FIR
Samples). The selection is dependent on the test needs and the device under test. However if
the device being tested already incorporates FIR filters, the Pre-FIR Samples selection should
be used to avoid double filtering. Refer to “Data Types” on page 299, for more information.

3. Select the data type that is appropriate for the test needs.

4. Press the Numeric Format softkey.
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From this menu, select how the binary values are represented. Selecting 2’s complement
allows both positive and negative data values. Use the Offset Binary selection when
components cannot process negative values.

5. Select the numeric format required for the test.
6. Press the More (1 of 2) softkey.

From this softkey menu, select the bit order, swap | and Q, the polarity of the data, and access
menus that provides data negation, scaling, and filtering parameters.

7. Press the Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the
affected sample by expressing it in the two's complement form, multiplying it by negative one,
and converting the sample back to the selected numeric format. This can be done for |
samples, Q samples, or both.

The choice to use negation is dependent on the device being tested.

8. To access I/Q scaling and filter parameters, press Return > N5102A Off On to On. This will
invoke the real time Custom format in the signal generator’s baseband generator. This is
needed to set the filter parameters when Pre-FIR Samples is selected as the data type.

9. Press the Baseband Setup softkey.

Use this softkey menu to adjust the I/Q scaling and access filter parameters. If the selected
data type is Samples, the Filter softkey is grayed out (inactive). For more information on
user-defined filtering, refer to the “Using Finite Impulse Response (FIR) Filters in the Dual ARB
Real-Time Modulation Filter” on page 254 and “Modifying a FIR Filter Using the FIR Table
Editor” on page 260.

Digital Data
If the N5102A digital module is not on, press Return > Return > N5102A Off On to On.

Digital data is now being transferred through the N5T02A module to the signal generator. The
green status light should be blinking. This indicates that the data lines are active. If the status light
is solidly illuminated (not blinking), all the data lines are inactive. The status light comes on and
stays on (blinking or solid) after the first time the N5102A module is turned on (N5102A Off On to
On). The status light will stay on until the module is disconnected from its power supply.

If changes are made to the baseband data parameters, it is recommended
that you first disable the digital input (N5102A Off On softkey to Off) to
avoid exposing the device and the N5102A module to the signal variations
that may occur during the parameter changes.
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11 Baseband Operating Mode—Primary, BERT, or N5T02A

Figure 11-1

Auxiliary

Power Meter,
Heasurements

Avionicse

Baseband
Operat.ing Modew
(Primary)

— Operating fode |

Baseband Operating Mode is available on all Keysight N5172B EXG and N5182B MXG
X-Series signal generators that have installed firmware version B.01.70 or later.

This chapter describes the Baseband Operating Mode feature used by
Keysight N5172B EXG and N5182B MXG X-Series signal generators.

The Baseband Operating Mode can be one of three different ARB FPGA
images; each ARB FPGA image changes the supported features available while
in the selected mode.

The selected Baseband Operating Mode is a persistent instrument setting and
its value is maintained through power cycles, Preset, or *RST.

The default Baseband Operating Mode is set to Primary and can only be
changed when one or more of the following options are installed.
(BERT and/or N5102A will appear grayed-out if they are not available.)

— Internal Bit Error Rate Analyzer (BERT), Option UN7
— Digital Output Connectivity with the N5T102A, Option 003 or 004 or both.

Baseband Operating Mode Softkeys

erimry — 10 Set the Baseband Operating Mode to Primary on page 322
eerr— 10 set the Baseband Operating Mode to BERT on page 320
w10za+— 10 Set the Baseband Operating Mode to N5102A on page 321
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To set the Baseband Operating Mode to BERT

In this mode, all installed and licensed signal generator features as well as all
BERT features are fully supported, but N5T102A features are not available.

Figure 11-2 Changing to the BERT Baseband Operating Mode
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1. Press Aux Fctn.

2. Press Baseband Operating Mode.
(Default selection is Primary.)

3. Press BERT. (Press the Return key to cancel the change.)

Changing the Baseband Operating Mode selection will cause all files in
volatile waveform memory to be lost. Backup any files you want to keep before
confirming the change.

See “Working with Files” on page 56.

4. After reading the above caution and taking any needed actions,
press Confirm Change to BERT Operating Mode or Return to cancel.

This confirmation selects the BERT ARB FPGA image.

All BERT features are fully supported, but N5102A is not available in this
mode. The BERT ARB FPGA image contains all functionality and features
from the B.01.65 PXB Input FPGA image. For backwards compatibility,
selecting the BERT Baseband Operating Mode sets the I/Q Digital Bus
Connectivity to PXB.
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To set the Baseband Operating Mode to N5102A

In this mode, all installed and licensed signal generator features as well as all
N5102A features are fully supported, but BERT features are not available.

Figure 11-3 Changing to the N5102A Baseband Operating Mode
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1. Press Aux Fctn.

2. Press Baseband Operating Mode.
(Default selection is Primary, but image above shows changing from BERT.)

3. Press N5102A. (Press the Return key to cancel the change.)

Changing the Baseband Operating Mode selection will cause all files in the
volatile waveform memory to be lost. Backup any files you want to keep before
confirming the change.

See “Working with Files” on page 56.

4. After reading the above caution and taking any needed actions,
press Confirm Change to N5102A Operating Mode or Return to cancel.

This confirmation selects the N5102A ARB FPGA image. All N5102A
features are fully supported, but BERT is not available in this N5102A
Baseband Operating Mode. For backwards compatibility, selecting the
N5102A Baseband Operating Mode sets the I/Q Digital Bus Connectivity to
N5T02A.
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To set the Baseband Operating Mode to Primary

In this mode, all installed and licensed signal generator features are fully
supported, but BERT and N5102A features are not available.

Figure 11-4 Changing to the Primary Baseband Operating Mode
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both the BERT and N5102A annunciators, indicating that the
Primary Baseband Operating Mode is currently selected. NS102A

Annunciators for BERT or N5102A are only displayed when
the Baseband Operating Mode is not set to Primary.
(For more information on annunciators, see page 9.)

1. Press Aux Fctn.
2. Press Baseband Operating Mode.

3. Press Primary. (Press the Return key to cancel the change.)

Changing the Baseband Operating Mode selection will cause all files in the
volatile waveform memory to be lost. Backup any files you want to keep before
confirming the change.

See “Working with Files” on page 56.

4. After reading the above caution and taking any needed actions,
press Confirm Change to Primary Operating Mode or Return to cancel.

This confirmation selects the PXB Input ARB FPGA image. All signal
generator features are available in this mode except BERT and N5102A
functionality. For backwards compatibility, selecting the Primary Baseband
Operating Mode sets the I/Q Digital Bus Connectivity to PXB.
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12 BERT (Option UN7)

The bit error rate test (BERT) capability allows you to perform bit error rate (BER) analysis on digital
communications equipment. This enables functional and parametric testing of receivers and
components including sensitivity and selectivity.

This feature is available in X-Series vector signal generators (N5172B and N5182B).
The following options are recommended:

— Option 653 or 655 (N5172B) -- Internal Baseband Generator

— Option 656 or 657 (N5182B) -- Internal Baseband Generator

— Option 431 -- Custom Digital Modulation
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Bit Error Rate Tester-Option UN7/

The bit error rate test (BERT) capability allows you to perform bit error rate (BER) analysis on digital
communications equipment. This enables functional and parametric testing of receivers and
components including sensitivity and selectivity.

Block Diagram

When measuring BER, a clock signal that corresponds to the unit under test (UUT) output data
must be input to the BER CLK IN connector. If the clock is not available from the UUT, use the DATA
CLK OUT signal from the X-Series baseband modulator. Refer to Figure 12-16 for information
about these connections.

Figure 12-1
signal generator
Framed/unframed
RF signal
RF signal | RF OUTPUT -~ with PRBS R uuT
source L ®; P (digital
demodulator)
3
Demodulated
Baseband DATA CLK OUT > Demoduitec
modulator DATA OUT _'_%
- PATTERN TRIG
Bit BER CLK IN
it-error-
rate tester |« BER DATA IN Level
UN7 < CLK GATE IN matching

Clock Gate Function

When you use the clock gate function, the clock signal to the BER CLK IN (rear panel BB TRIG 1)
connector is valid only when the clock gate signal to the BER GATE IN connector is ON.

Press the Clock Gate Off On softkey to toggle the clock gate function off and on.The Clock Gate
Polarity Neg Pos softkey sets the input polarity of the clock gate signal supplied to the rear panel
BER GATE IN connector. When you select Pos (positive), the clock signal is valid when the clock
gate signal is high; when you select Neg (negative), the clock signal is valid when the clock gate
signal is low.

The following figure shows an example of the clock gate signal.
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Figure 12-2

Clock Gate Signal to
the BER GATE IN:  _|

i IULIL

Data Signal to
the BER DATA IN:

i T

A B

— When the Clock Gate Off On softkey is set to Off:

The clock signal in both “A” and “B” parts is effective and no gate function is required. Therefore,
the bit error rate is measured using the clock and data signal in both “A” and “B” parts.

— When the Clock Gate Off On softkey is set to On, and the Clock Gate Polarity Neg Pos softkey
is set to Pos:

The clock signal in “A” part is effective. Therefore, the bit error rate is measured using the clock
and data signals in “A” part.

— When the Clock Gate Off On softkey is set to On, and the Clock Gate Polarity Neg Pos softkey
is set to Neg:

The clock signal in “B” part is effective. Therefore, the bit error rate is measured using the clock
and data signals in “B” part.

Clock/Gate Delay Function

This function enables you to restore the timing relationship between the clock/gate timing as it
passes through the unit under test (UUT) and the packet data.

The shifted clock signal is emitted from pin 17 of the AUX I/0 rear panel connector. When you use
the clock delay function, the clock signal to the BER CLK IN connector is delayed by the clock delay
function. When you use the gate delay function with the clock gate function, the clock signal is
gated by the gate signal which is delayed by the gate delay function.

To see the signal flow using the clock and gate functions, refer to Figure 12-3.
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Figure 12-3
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Clock Delay Function

In this example, the clock delay function is off. Figure 12-4 shows the input of the internal error
detector of UN7 through AUX I/0 and indicates that the data is delayed from the clock.

Figure 12-4

CH1

CH2

CH1: BER TEST OUT (pin 17 of AUX I/0 connector)
CH2: BER MEAS END (pin 15 of AUX I/0 connector)

In this example, the clock delay function is on. The rising edge of the clock was delayed by 200 ns
and was adjusted to the center of the data. Figure 12-5 indicates the result of the using the clock
delay function.

Figure 12-5

CH1

CH2
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Gate Delay Function in the Clock Mode
To use this function, the clock must be set to continuous mode.

In this example, the clock is used to delay the gate function. The clock of the internal error detector
was gated by the gate signal which is delayed by two clocks. Figure 12-6 shows that CHO and CH
are the input of the clock and data from the rear panel input connectors of UN7. CH2 is the gated
clock through the AUX I/O connector.

Figure 12-6

CHO

CH1

CH2

CHO: BER CLK IN (rear panel BNC connector labeled BB TRIG 1)
CH1: BER GATE IN (rear panel BNC connector labeled BB TRIG 2)
CH2: BER TEST OUT (pin 17 of AUX I/O connector)
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This section describes the operating principles of the triggering function for Option UN7. To see the
signal flow of the triggering function refer to Figure 12-7.

Figure 12-7
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In this example, the triggering sequence is where you have an incoming data clock and data bit
sequences, the trigger is active, and the BERT measurement begins. Refer to Figure 12-8.

Figure 12-8
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RefData |  eeeeeeeed [ L e
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In this example, synchronization occurs after receiving a trigger.

The reference data is generated by stored data bits. If the BERT measurement accepts data bits
immediately after receiving a trigger, set the trigger delay to On and the trigger delay count to a
value corresponding to the data format. For PN9 set the delay to 9. Refer to Figure 12-9.

Figure 12-9
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In this example, the triggering sequence is where the trigger delay is active with a cycle count.

The reference data is generated by stored data bits. If the BERT measurement accepts data bits
immediately after receiving a trigger, set the trigger delay to On and the trigger delay count to a
value corresponding to the data format. For PN9 set the delay to 9. If the cycle count is set to more
than 1, it is not necessary to store data bits and no unnecessary delay occurs. Refer to Figure 12-10
and “Repeat Measurements” on page 332.

Figure 12-10
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Trigger Delay

Data Processing

Data Rates

Data rates up to 90 MHz are supported for BERT analysis on unframed or framed PN sequences.
Note that the BERT analyzer supports only continuous PN sequences.

Synchronization

Immediately after the trigger event, the DSP for the BERT measurement tries to establish
synchronization using the first incoming bit stream.

If the Bit Delay Off On softkey is set to On, the number of bits specified by the Delayed Bits are
ignored. The synchronization checking is repeated using an error-free bit string, lengthened by the
Delayed Bits, until synchronization is established.

When the BERT Resync Off On softkey is set to On, the BERT measurements will automatically be
restarted if the intermediate BERT measurement result exceeds the value specified by the BERT
Resync Limits.

Special Pattern Ignore Function

The special pattern ignore function is especially useful when performing BERT analysis on radios
that generate consecutive 0’s or 1’s data for traffic channels when they fail to detect the Unique
Word or lose synchronization. If 160 or more consecutive incoming data bits are either 1’s or O’s,
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and the Spcl Pattern Ignore Off On softkey is set to On, then all of the consecutive O’s or 1’s are
ignored. Select either O’s or 1’s as the data to ignore by using the Spcl Pattern 0’s 1’s softkey. The
following figure shows an example of the special pattern ignore function.

Figure 12-11 Pattern Ignore Function Example
‘ 160 bits of consceutive 1's ‘

0100&1111 ...... 111111111111110100

Data to be ignored

spignore

The 160 or more ignored bits can be anywhere in the PN sequence. The signal generator ignores
these bits as error, but they are counted in the PN sequence bit count.

Pass/Fail Judgement

There are two pass/fail judgement update modes: cycle end and fail hold. With cycle end selected,
either pass or fail judgement is made for the results of each measurement cycle. With fail hold
selected, the fail judgement is retained whenever a failure occurs during one loop of BERT repeat
measurements. Fail hold mode allows you to determine when a failure occurs at least once during
an entire cycle of measurements.

Repeat Measurements

When the Cycle Count softkey is set to more than 1, the synchronization performed before the start
of each measurement is only executed the first time; then it keeps track of the clock signal and the
PRBS generation for the incoming data. This function can reduce the total time for BERT
measurements. Also, once synchronization is established, it is retained even if the BERT
measurement result degrades. You may wish to adjust the signal level to find a specific BERT value.
However, once synchronization is lost in a repeat sequence, it will not be restored until the initiation
of a new sequence. The following figure shows an example of the repeat measurements.

Figure 12-12 Repeat Measurements Example

Cycle Count = 1

Cyele Counter : 1/1 171 1/1 /1

D s Meas, D s Meas, D 8 Meas. 3 208
L1 1 1.1 1 s | R I | s 1 II)l5 1 Meas. |
Trigger Event : * * * *
Cycle Count =N
Cvele Counter : 1/N 2/N 3N N/N
I1) IS , Meas. L. IDI Meas. L II) A Meas. I IDI Meas.
Trigger Event : + * +
D: Delay time
S: Synchronization repeatl
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Testing Signal Definitions

The timing diagram <Keysight Red >Figure 12-13, “Testing Signal Definitions,” shows the
relationships between a trigger event and the output signals at the BER MEAS END and BER TEST
OUT connectors.

If a BER MEAS END signal stays high following a trigger event, the BERT measurement is in
progress and other trigger events are ignored. This state is stored in the status register and can be
queried.

Figure 12-13 Testing Signal Definitions
Tl T2 T3
«—> >
Trigger Event
(Bus/Trigger Key/Ext.) A A
BER MEAS END Nth- 1 Nth measurement J

BER TEST OUT Result of Nth - 1 ) Result of Nth

timing

— T1is afirmware handling time measured from a Trigger event to the rising edge of a BER MEAS
END signal.

— T2 s afirmware handling time measured from the falling edge of a BER TEST OUT signal to the
falling edge of the BER MEAS END signal.

— T3 is a minimum requirement time measured from the falling edge of the BER MEAS END signal
to the next trigger event. T3 should be greater than O second.

The pulse output of the BER TEST OUT for the Nth-1 test result ends prior to the falling edge of the
BER MEAS END signal for the Nth measurement; so you can use this edge to start latching the Nth
test result.
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Verifying BERT Operation

The following procedures verify the operation of the signal generator’s bit error rate test (BERT)
function. The tests can be performed as part of a daily validation routine or can be used whenever
you want to check the validity of your BERT measurements.

The following procedures check the signal generator’s BERT operation and
do not ensure system performance to specifications.

Figure 12-14 BERT Softkeys
Aux — BERT Configure BERT Data
35 EERT Dat
JED, o
on (= L — HS
\ Configure, > Total Bits PN11
Auxiliary 7 BERT 10000
il Confioure,.  see page 335 et PHLS
BERT® BEF Displaus—— see page 335 ? PN20
1/0 Setup»—— see page 335 P23
Digital Bus More 1 of 2 More 1 of 2

Comnectivity
PHE/BERT NESHImEE]

BERT
Configure BERT

EERT Resunc
Off Iiil

Frequency
. 00000000000GHz

Amplitude
e Resunc Limits
0.L000
Select PXB/BERT to enable

BERT functionality. Spcl Pattern
Torore

Iﬂiii 0n

Threshold # of
Events to Stopk

fore 2 of 2 (No Thresholds)

fore 2 of 2
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Digital Bus
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Select PXB/BERT to enable
BERT functionality.

The highlighted BNC connectors in Figure 12-16 are used for different signals in the BERT

BERT 1/0 Setup Softkeys

BERT

BERT
TN On

Conf igure,
Trigger

BER Displaub——

I/0 Setup

fore 1 of 2
BERT
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. 00000000000GHz
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fore 2 of 2
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Cucle End
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Gate BMC
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Oata BMNC
Ewent 1
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Route To,
Easeband BMCs

Trigoer Config

BERT Trigger,

(Trigger kel

Cucle Eoun%

Eit. Delay
[ Off i

Aux 10

Error Out
Feference Out

PN3 Out

Polarity

Clock Polarit
Heg IEEEH

Data Polarit
Heg IEEEH

Gate Polarit
Heg IEEEH

Clock Delay
Clock DOels
aOff IEEH

Clock Time Delay
10.0 nsec

Resolution
5.0 nsec

Gate Control

Gate
0ff W

Gate Delad,
(om3

Trioger

Immediate
Trigger Key

Bus

EXT,
(Trigger 1)

ALK I/0

Gate Delay
Gate Dels
aff IEEH

Gate Mode
| Tim= [elA

Gate Time Delay
10.0 nsec

Resolution
5.0 nsec

capability mode. The BERT-specific configuration is shown here. The AUX /O connector
configuration is customizable for the applications/options being used. Figure 12-16 shows the rear
panel connectors used for the BERT capability, and the configuration of the AUX I/0 connector. For
more information about the AUX I/0 connector, refer to Rear Panel Overview (N5171B, N5172B,

N5181B, & N5182B) on page 12.
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Measurement Setup Using Self-Test Mode

The following steps set up the signal generator for the BERT measurement selt-test.

1. Refer to Figure 12-16 and make the following connections on the signal generator’s rear panel.
— DATA QUT (Aux | / Oconnector pin 15) to BER DATA IN (BNC connector labeled EVENT 1).
- _I[_)QLA%)CLK QUT (Aux |/ Oconnector pin 17) to BER CLK IN (BNC connector labeled BB

Figure 12-16 Rear Panel Connectors for BERT Configuration

BER Gate In
BER Data In

BER Clock In

30328882511

BER Gate Out
BER Test Out
BER Sync Loss
BER Meas End

AUX 1/0

18 17 16 15 14 13 12 11 10 9 8

A EAANNNNRRRNNNREE
mmmmmm

35353433323130?3282?2525242322212019

[}
z
o

Bled ON d3g

2. Press the Preset hardkey. This configures the signal generator to a pre-defined state.

3. Press the Aux Fctn hardkey.

4. Press Digital Bus Connectivity PXB/BERT N5102A to PXB/BERT > Confirm Changes > BERT >
BERT Off On to On > BER Display > BER Display % Exp to % > Display Update Cycle End Cont

to Cont.
5. Press BERT > I/0 Setup > AUX I/0 Out > PN9 Out.

6. Press Return > Configure Trigger > BERT Trigger > Immediate.
7. Press Return > BERT > On.
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The Total Bits will count to 10000 Bits (default setting) and the Error Bits should read 0 Bits.
See Figure 12-17.

Figure 12-17 Self-Test Mode Results

FREQUEHCY RF_OFF BERT
6.000 000 000 000 sz 50
B 0ff HEN
BERT
Conf igure,
BERT EERT
Total Bits: 10000 Resunc: OnCD.LoDO) Clock Pol: Pos .
Data: PN Update Displau: Cont Clock Delau: OfFf CDHF;QUFE,
Trigger: Immediate Spcl Pattern Ionore: OfF Oata Pol: Pos Trigger
Cucle Count: 1 Gate: Off
Delad: Off P/ OFF
EER Displaue
Total Bits ﬁrur Bits BER
10000 Bits 0 Bits 0.00000000 ¥ 1/0 Setups
O1/31/2014 16:18 fore 1 of 2
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Measurement Example Using Custom Digital Modulation (Requires Option
4317)

The following steps set up the signal generator for a BERT measurement using Custom Digital
Modulation.

1. Referto Figure 12-16 and make the following connections on the signal generator’s rear panel.
— DATA QUT (Aux |/ Oconnector pin 33) to BER DATA IN (BNC connector labeled EVENT 1).

— DATA CLK QUT (Aux |/ Oconnector pin 7) to BER CLK IN (BNC connector labeled BB
TRIG1).

Press the Preset hardkey. This configures the signal generator to a pre-defined state.
Press the Mode hardkey.
Press Real-Time Custom > Modulation Setup > Modulation Type > QPSK.

Press Return > Return > Return > Data > PN Sequence > More > PN9.

o a &~ w N

Press Return > More > More > Data/Clk/Sync Signal Polarity Setup > Data/Clk/Sync Rear
Outputs On.

™~

Press the Aux Fctn hardkey.

8. Press Digital Bus Connectivity PXB/BERT N5102A to N5102A > Confirm Changes > BERT >
BERT Off On to On > BER Display > BER Display % Exp to % > Display Update Cycle End Cont
to Cont.

The following steps configure BERT measurement parameters.

9. Press Return > Configure BERT > Total Bits to 100000 > Enter > More > Special Pattern Ignore
Off On to Off.

10.Press BERT Resync Off On to Off > Return > Pass/Fail Off On to Off.

11.Press Return > 1/0 Setup > Gate Control > Gate Off On to Off.

12.Press Return > Polarity Setup > Clock Polarity Pos Neg to Neg > Data Polarity Pos Neg to Pos.
13.Press Return > Return > Configure Trigger > Cycle Count O > Enter.

14.Press Bit Delay Off On to Off > BERT Trigger to Trigger Key.

15.Press the Trigger hardkey. Figure 12-18 shows the signal generator’s front-panel display after
completion of the these steps.
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Figure 12-18 Configuration Using Custom Digital Modulation

FREQUEHCY RE_OFF Trigaer Config
6.000 000 000 000 &z o e
BERT
BERT
Total Bits: 100000 Resunc: Off Clock Pol: Neg
Data: PMI pdate Display: Cont Clock Delag: OfF Cucle Count
Trigoer: Tricoer Key Spcl Pattern Ianore: OFF Data Pol: Pos o
Cucle Count: O Gate: Off
Oelau: Off F/F: OfF Bit. Delau
an
Total Bits Error Bits BER
0 Bits 0 Bits 0.00000000 #
' 01/26/2014 17:02 |

BERT Verification

1.

Press BERT Trigger to Immediate.

Notice the cycle counter updating in the lower left-hand corner of the signal generator
display.

Disconnect the cable connecting the DATA OUT to BER DATA IN connectors.

Notice the No Dat a annunciator in the lower left corner of the display and the BER result is
approximately 50%. The Error Bits counter updates the error bit count. Re-establishing the

connection turns the annunciator off, and sets the error bits count to 0 bits and BER
0.00000000%.

Disconnect the cable connecting the DATA CLK OUT to BER CLK IN connectors.

Notice the No A ock annunciator in the lower left corner of the display. This annunciator
turns off when you re-connect the cable, but the error bits counter and BER % readings
indicate loss of synchronization.

Press Return.

Toggle the BERT Off On softkey to Off and to On. You will see the new BER result as shown in
the previous front-panel display with the Error Bits counter reading 0 Bits and BER
0.00000000%.

If the verification procedures produce the expected results, then the signal generator BERT
measurement function is operating correctly. If the above procedure produces unexpected results,
then contact the Keysight Service Center. For a list of Keysight Service Centers, refer to the
X-Series Signal Generators Getting Started Guide.
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13 Real-Time Noise—AWGN (Option 403)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option 431. Option
431 requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform
generator, which is available only in vector signal generators with Option 403.

— Adding Real-Time Noise to a Dual ARB Waveform on page 342
— Using Real Time I/Q Baseband AWGN on page 348
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Adding Real-Time Noise to a Dual ARB Waveform

NOTE The procedures in this section that pertain specifically to adding Real-
Time Noise (AWGN) to a waveform, are applicable to the Custom ARB,

Multitone, and Two-Tone modulation standards too.

A vector signal generator with option 403 enables you to apply additive white gaussian noise
(AWGN) to a carrier in real time while the modulating waveform plays in the dual ARB waveform

player. This feature appears in each of the arb formats and as a stand-alone menu (Refer to Figure
13-7 on page 348).
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Figure 13-1 Real Time 1/Q Baseband AWGN Softkeys
For details on each key, use key help
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as described on page 40.
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Keysight EXG and MXG X-Series

carrier bit rate. (The default carrier bit
rate is 1 bps.)

Carrier Bit Rate
1.000 bps

OULpUL. Ml
(Carrier+Noise)

The Carrier Bit Rate softkey is only
available when the Carrier to Noise

which should be slightly wider than
the carrier bandwidth (typically 1.6
times wider). The occupied
bandwidth is =

(1.25 * the Flat Noise Bandwidth)

Ratio Format Softkey is set to Ep/N,.
See also page 346.
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Figure 13-2 Real Time I/Q Baseband AWGN - Power Control Mode Softkeys

Mode > Dual ARB > Arb Setup > For details on each key, use key help
Real-Time AWGN Setup as described on page 40.
¢ Figure 13-6 on page 346
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Selecting Carrier as the power
control mode makes the carrier
Carrier power and C/N independent
\variables while making the total

power and total noise power
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dependent variables total power
and total noise power are set by
Channel MNoise the carrier power, C/N, and the
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total power and total noise
power change as any noise
parameter is adjusted to keep
the carrier power and the C/N at
their last specified values.

Selecting Total Noise as the
power control mode makes the
total noise power and C/N
independent variables while
making the total power and
carrier power dependent
variables. The dependent
variables total power and carrier
power are set by the total noise
power, C/N, and the rest of the
Noise settings. The total power
and carrier power change as
any noise parameter is adjusted
to keep the total noise power
and the C/N at their last
specified values.
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Figure 13-3

Mode > Dual ARB > Arb Setup >
Real-Time AWGN Setup > More

'

AUGH Setup
Carrier Bandwidth
1.000 Hz
ik eiee
I andu i
The Carrier Bit 1.000 Hz

Rate softkey is 4/—
only available Carrier Bit Rate

when the Carrier 1.000 bps

to Noise softkey
is set to Ep/N,,. OUtpUt. M,
(Carrier+Noise)

Hoise Hux

Carrier+Hoise

Carrier

MNoise

Real-Time Noise—AWGN (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform

Real Time 1/Q Baseband AWGN - Noise Mux Menu Softkeys

Figure 13-6 on page 346

_ ) provides additional details on
Ena_b_les dlagnostlc control of these settings.
additive noise, so that only the
noise, only the carrier, or the
sum of both the noise and the
carrier are output from the
internal baseband generator.
With the ALC off, this feature
enables direct measurement of
the carrier or the noise
contributions independently
from the total power. The system
still behaves as if both the noise
and the carrier are present on
the output when it comes to .
determining the Auto Modulation ~ For details on each key, use key help
Attenuation and the RMS level  as described on page 40.
for RMS Power Search.

Ep/Ng Adjustment Softkeys for Real Time 1/Q Baseband AWGN

This feature allows the AWGN C/N to be set using the E,/N,, (energy per bit over noise power

density at the receiver or signal to noise ratio per bit) form. This requires the carrier bit rate to be
known. Refer to Figure 13-4, “Eb/No Carrier Bit Equation.”

Figure 13-4

N

Ep/N, Carrier Bit Equation

= (NE%) dB + 10Ioglo(

bitRate )

carrierBandwidth
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Figure 13-5 Real Time I/Q Baseband AWGN - E,/Ng Adjustment Softkeys

Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup Figure 13-6 on page 346
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these settings.
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Figure 13-6

Example

Use the following steps to modulate a 1 GHz, =10 dBm carrier with the factory-supplied waveform
SINE_TEST_WFM, and then apply noise with a 45 MHz bandwidth signal that has a 30 dB carrier-

rate is 1 bps.)

The Carrier Bit Rate softkey is only
available when the Carrier to Noise
Ratio Format Softkey is set to Ep/N,.

To view the carrier bit rate equation,
refer to page 40.

Carrier Bit Rate
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Real-Time ALGH
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Fower Control
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fore 1 of 2

to-noise ratio across a 40 MHz carrier bandwidth.

Whether a softkey is available
epends on the Carrier to
Noise Ratio Format softkey
setting (e.g. C/N or Ep/N,).

CIN selected

Carrier to MNoise
Ratio |

0.00 dB

Eb/No

0.00 dg

Ep/N, selected

Carrier to Noise Ratio Components

1. Preset the signal generator and set the following:
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Carrier Bandwidth (CBW) is typically the occupied

bandwidth of the carrier and the Noise Bandwidth is the

flat noise bandwidth (NBW).
The carrier now appears
larger because of the

Noise BW added noise power.

(NBW) =

\ : . flat noise
Carrier BW -
(CBW) ! ! bandwidth
' 1

' Carrier BW
caw)

RMS
(total carrier power)

Carrier

Noise N

— Frequency: 1 GHz
— Amplitude:

10 dBm
— RF output: on
2. Select the factory-supplied waveform SI NE_TEST_ WM

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight SI NE_TEST_WMand press Select Waveform.

3. Turn on the dual ARB player: press ARB Off On to highlight On.
4. Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.
5. Press Real-Time AWGN Setup and set the following:

— Carrier to Noise Ratio: 30 dB
— Carrier Bandwidth: 40 MHz
— Noise Bandwidth: 45 MHz

— Real-time AWGN: on

The signal generator’s displayed power level (=10 dBm) includes the noise power.
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Using Real Time I/Q Baseband AWGN

Figure 13-7 Real Time 1/Q Baseband AWGN Softkeys
Mode
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Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, —=10 dBm carrier.
1. Configure the noise:

a. Preset the signal generator.

b. Press Mode > More > Real-Time AWGN

c. Press Bandwidth > 10 > MHz.
2. Generate the noise:

Press Real-Time AWGN Off On until On highlights.

During generation, the AWGNand | / Q TREUEHCT
annunciators activate (as shown at
right). AWGN is now available to
modulate the RF carrier.

©00.00000000 mz=.  -10.00 cen
[T/0ll AUGH |
anota: —10.00 dBm Incr: 1.00dB

3. Configure the RF output:
— Frequency: 500 MHz
— Amplitude: =10 dBm
— RF output: on

The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.
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14 Real-Time Phase Noise Impairments (Option 432)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option 431. Option
431 requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and
information on the use of this feature.

— Real-Time Phase Noise Impairment on page 350

— Phase Noise Shape and Additive Phase Noise Impairments on page 351
— Understanding the Phase Noise Adjustments on page 353

— DAC Over-Range Conditions and Scaling on page 354
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Real-Time Phase Noise Impairment

Real-Time Phase Noise Impairment

This feature lets you degrade the phase noise performance of the signal generator by controlling
two frequency points and an amplitude value. The signal generator adds this phase noise to the
phase noise normally produced by the signal generator. This feature appears in each of the arb
formats and as a stand-alone menu. While the following figure shows how to access the controls
using both the stand-alone menu and the Dual ARB player, the location and softkeys within each
arb format is the same as for the Dual ARB player.

Figure 14-1 Stand-Alone and Dual ARB Player Real-Time Phase Noise Softkeys
Mode |  ~oiition Tiode | e ol ar
formats.
Oual ARER—P Arb
EEB Arb Setup

ﬁﬁﬁu%ﬂgﬂ' Arb Sample Clock

200. 000000000MHz

m Se%ect'
=4 e form
Feal Tﬁgﬁuﬁﬁgﬂ' / Feal-Time ALGN,
Setup
. Arb Setupkf——»
Feal-Time .
Applicat ions Feal-Time,
Triogger Tupe FPhase Moise Setup
(Cont inuous ,»
Mult itones IAES (VD Runtime Scaling
70.00 =
fore 1 of 2
Modulator Atten
lore 1 of 2 6.00 dB

Hanual
fore 1 of 2

NModulation Hode
Stand-alone menu

THo-Tanek

Real-Time,
AHGH

Use to add phase noise to the
CW output without having to
play a waveform.

For an explanation on these
settings see

PhHealﬁTim “Phase Noise Shape and
ase Noisew P ;
Impairment The display updates even Additive Phase Noise

Standalone Additive Phase Noise Impairment

when the feature is off.

100Hz

Frequency, Loo Scale

1MHz
03/07/2012 17:17

Y

Phase Hoise

Fhaze Moise
aOff

S ired

De
Start Fregifl) +——

1.000000kHz

For details on each key, use key help
as described on page 40.

350

Impairments” on page 351.

The start frequency for the flat
mid—frequency characteristics.

-L0 £l fe Stop FES?,%KE%? ] The end frequency for the flat
I L 30, 000000kHz mid—frequency characteristics.
. ; Desired Flat
dBIEf’ﬂ; _________ ! — Lmid Amplitude(Lmid) The amplitude for the flat mid—
Fl t M d -70.00 dBc/Hz frequency characteristics.
a 1a- (Lmid stands for the level
110 amplitude of the mid—frequency

characteristic.)

NOTE: The phase noise impairment is added to the base phase noise of

the signal generator.
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Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Shape and Additive Phase Noise Impairments

Keysight X-Series Phase Noise Plots Without Phase Noise Impairment

—50 dBc/Hz — -50 dBc/Hz

The Keysight X-Series vector signal
generator demonstrates a definitive shape to
its phase noise plot. The mid-frequency
offsets are characterized by a leveling

(flattening) of the phase noise amplitude from
approximately a 3 kHz offset to approximately
a 70 kHz offset.

™.

Close in and far out offsets demonstrate
sloping characteristics (areas before and after
the mid-frequency offsets).

Frequency Offset

The signal generator degrades the phase noise by moving the mid-frequency
characteristics and/or changing its amplitude using the following settings:

Start frequency (f1) of the mid-frequency characteristics
Stop frequency (f2) of the mid-frequency characteristics
Amplitude (Lmid) of the mid-frequency characteristics

-50 dBc/Hz —-50 dBc/Hz

This is a plot of the unmodified phase noise
shape that shows the location that each

Amplitude value alters.
(Lmid)

Frequency Offset
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Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Plots With Phase Noise | mpair ments

—-50 dBc/Hz - Hat mid-frequency offset —-50 dBc/Hz
characteristics (L mid)
When turned on, this phase noise is added
Resultant phase . .
t to the base phase noise of the signal
4\ / generator.
\\
m\ I Even though it is only the mid-frequency
N characteristics placement that are modified,
o these changes affect the entire phase noise
- shape. The close in and far out offset
T . e Pl
No additive ] characteristics change by exhibiting
phase noise Tr—rr LU approximately a 20 dBc/Hz slope for each
characteristics _(Lmid) octave of frequency offset.
18 Hz Frequency Offset 18 MHz
-50 dBc/Hz —-50 dBc/Hz

The resultant phase noise plot shown on the
left has the following settings:

— f1=100Hz
— f2=1kHz
—  Amplitude (Lmid) = -70 dBc

Ensure that the f1 value is less than or equal

20 dBc/Hz to f2. If not, f2 changes its value to match
slope f1. Conversely if f2 is set to a value that is
less than f1, f1 changes its value to match

Frequency Offset 16 MHz f2.

The frequency values entered for the impairments may not be the exact values when
viewed on the RF output. The entered values are guidelines that the signal generator uses
to calculate the real values. See “Understanding the Phase Noise Adjustments” on

page 353 for more information.

| standalone Additive Phase Noise Inpairment on |
D 1 P Signal generator front panel plot:
— f1=100Hz
dBLf’ﬂ) Lmid - f2=1kHz
e ~ Lmid =-70 dBc

-110 100Kz Frequency, Loo Scale 1MHz
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Understanding the Phase Noise Adjustments

Understanding the Phase Noise Adjustments

The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), 7
(start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as 2 increases in value, Lmid’s upper boundary decreases. If
the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid
value and generates an error to alert you to the change. In addition, the actual Lmid value can vary
by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate
the real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop
frequency values are an approximation and may not be the values seen on a measurement
instrument, however they will be close.

The effects of the f1 and 2 parameters are based on a varying logarithmic scale. This scale is
determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior
more noticeable at higher frequency settings. This becomes apparent when a change in the f1 or {2
value causes little to no change in the f1 or f2 position. This is easy to view using the signal
generator’s front panel phase noise graph and demonstrated in Figure 14-2. This behavior makes
the frequency adjustments coarser as the 2 frequency value increases.

Figure 14-2 f1 and f2 Frequency Setting Behavior

on | Desired
Start Fregifill
10, 500000000HHz

Desired
Stop Fregif2)
30. 000000000MHz

Desired Flat
Amplitude (Lmid)
-81.00 dBc/Hz

f1 and f2 softkey settings for the front

Standalone Additive Phase Noise Impairment )
panel phase noise graph.

-60

LCF)

dBc/Hz Lmid

-100 1nz Frequencu, Loo Scale 100MHz

Standalone Additive Phase Noise Impairment '

on |

-60 'f1 ' 2
T T [

Fre7 Log cale

fl—original 10.5 MHz
setting

LCF
dBcsz

=90 1nHz

f1—12.1 MHz setting that setting

moved the offset position
For details on each key, use key help
as described on page 40.

Lmid

f2—original 30 MHz

Desired
Start Fregifl)
12, 100000000MHz

Desired
Stop Fregif2)
L0. 000000000MHz

Desired Flat
Amplitude (Lmid)
-81.00 dBc/Hz

1 did not change frequency until

12.1 MHz was set. This means that it
took an increase of 1.6 MHz to change
its frequency offset.

f2 did not change frequency until 40
MHz was set. This means that it took an
increase of 10 MHz to change its
frequency offset.

f2—40 MHz setting that
moved the offset position

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing
the front panel graph or making a measurement. You can view the front panel graph remotely by

using the LXI interface. For more information on the LXI interface, see the Programming Guide.
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DAC Over-Range Conditions and Scaling

When using phase noise impairment, it is possible to create a DAC over-range condition, which
causes the signal generator to generate an error. To minimize this condition with the phase noise
impairment feature, the Keysight X-Series signal generator incorporates an automatic DAC over-
range protection feature that scales down the I/Q data. Because it can scale the data by more than
what is actually need, it typically decreases the dynamic range of the waveform. This is especially
noticeable when using a constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over-range protection can be turned off (on is the factory
default). The control for the Dual ARB DAC over-range protection feature is located in the key path
as shown in Figure 14-3.

Figure 14-3 Dual ARB DAC Over-Range Protection Softkey Location
Made p Hodulation Hode
Arb
Dual AREM— B Arb Setup

o Arb Sarple Clock

AFE Custom, 200, D00D00000MHE

Modulat ion Select
Haveform

Real-Time ALGN,

Real-Time Custom, Setup
Modulation arb SetupH

Real-Time,

Feal-Time . Fhase Moise Setup L
fpplications? IElQ%BP THDB. When the DAC over—range protection is off,
ont inuols , . g b
Free Run) Rurt ime Scaling A/ellmlnatg over- range conditions b)i )
MUl itanes 70.00 % decreasing the scaling value (see “Setting
AL LLOnE Waveform Runtime Scaling” on
Hore 1 of 2 FESUEEEE EET page 238).
Hore 1 of 2 Manual
fore 1 of 2
Arb Setup

For details on each key, use key help

as described on page 40.

Easeband
Freguency Offset
0.000 Hz

Multi-BBG Sunc
Setupk

Feal-Time
Modulation Filtere
(Off2

fore 2 of 2

/Default setting is On.
Turn off to manually control scaling while

using the phase noise impairment option.
Manually adjust the scaling using the
Waveform Runtime Scaling softkey
shown above.

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the
over-range protection off and use the Waveform Runtime Scaling softkey to eliminate DAC over-
range conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over-range condition
are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself.
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15 Real-Time Fading (Option 660)

The feature described in this chapter is available only in Keysight N5172B EXG and N5182B MXG
X-Series signal generators with Option 660 Upgrade Baseband Generator with Real-Time
Capability.

Option 660 requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

Before using the information in this chapter, you should be familiar with the basic operation of the
signal generator. If you are not comfortable with functions such as setting the power level and
frequency, refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the
information in that chapter.

This chapter contains the softkey maps to locate the Real-Time Fading information for this feature.

— Using Real-Time Fading Softkeys on page 356
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Using Real-Time Fading Softkeys

Using Real-Time Fading Softkeys

This feature lets you open a menu to configure Real-Time Fading simulations.

Figure 15-1 Real-Time Fading Softkeys
Mode flodulation fode
Dual ARB»
HBGUISE fon®

Real-Time Custom,
HModu lat. 1on

Real-Time,
Applicat ions
Hultitones

flore 1 of 2

Fadine—® " Fading

- Turns off Fading Mode;
do not route through the
Fading path.

Feding Hedeyl — m-""Fading fode
0FF

Nore 2 of 2
- Turns on Fading Mode;

on | route through the Fading path with
the Fader in operation.

Pass-Through | - Sets to Pass-Through Mode;
route through the Fading path with the Fader
having only a latency and scale effect.

For details on each key, use key help
as described on page 40.
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Using Real-Time Fading Softkeys

To configure a Real-Time Fading simulation

When configuring a Real-Time Fading simulation, perform the following steps:

1.
2.

Press Mode

Press Fading Mode
(Default selection is Off.)

Select either: Off | On | Pass-Through

Selecting Off sets the state of the Real-Time Fading simulation to Off; do not route through the
Fading path.

Selecting On sets the state of the Real-Time Fading simulation to On; route through the Fading
path with the Fader in operation. When Real-Time Fading is On, the FADING annunciator
appears in the same annunciator position as ALC OFF. See 3. Annunciators on page 9.

Selecting Pass-Through sets the state of the Real-Time Fading simulation to Pass-Through;
route through the Fading path with the Fader having only a latency and scale effect.

Before Real-Time Fading can be set to On or Pass-Through, a modulation format
must be selected and Real-Time Custom Modulation must be set to On; if this is
notdone,anError: -221 Setting Conflict isgenerated and written to the
error queue.

If an error occurs, clear the error queue and turn on a modulation format.

To clear the error queue

1. Press Error
2. Press Clear Error Queue(s).

To turn on a modulation format

1. Press Mode
2. Press Real-Time Custom Modulation

3. Press Modulation Setup > Modulation Type and select a modulation type.
(Default selection is QPSK.)

4. Press Mode > More > Real-Time Custom Modulation and change the selection
to On.
(Default selection is Off.)

5. Press Mode > Fading Mode
(Default selection is Off.)

6. Select On or Pass-Through

Keysight EXG and MXG X-Series Signal Generators User’s Guide 357



Real-Time Fading (Option 660)
Using Real-Time Fading Softkeys

358 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

16 Custom Digital Modulation (Option 431)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in
that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option 431. Option
431 requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

— Custom Modulation on page 360

— Creating and Using Bit Files on page 368

— Using Customized Burst Shape Curves on page 373

— Using the Arbitrary Waveform Generator on page 379

— Using Finite Impulse Response (FIR) Filters with Custom Modulation on page 394
— Modifying a FIR Filter Using the FIR Table Editor on page 401

— Differential Encoding on page 404
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Custom Modulation

Custom Modulation

For creating custom modulation, the signal generator offers two modes of operation: the ARB
custom modulation mode and the real-time custom modulation mode. The ARB custom
modulation mode has built-in modulation formats such as NADC or GSM and pre-defined
modulation types such as BPSK and T6QAM that can be used to create a signal. It also provides the
flexibility to modify the digital format’s attributes. The real-time custom modulation mode can be
used to create custom data formats using built-in PN sequences or custom-user files along with
various modulation types and different built-in filters such as Gaussian or Nyquist.

Both modes of operation are used to build complex, digitally modulated signals that simulate
communication standards with the flexibility to modify existing digital formats, define or create
digitally modulated signals, and add signal impairments.

ARB Custom Modulation Waveform Generator

The signal generator’'s ARB Custom Modulation mode is designed for out-of-channel test
applications. This mode can be used to generate data formats that simulate random
communication traffic and can be used as a stimulus for component testing. Other capabilities of
the ARB Custom Modulation mode include:

— configuring single or multicarrier signals. Up to 100 carriers can be configured.

— creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing
where device performance such as adjacent channel power (ACP) can be measured. The
AUTOGEN_WAVEFCRM(file, that is automatically created when you turn the ARB Custom Modulation
on, can be renamed and stored in the signal generator’s non-volatile memory. This file can later be
loaded into volatile memory and played using the dual ARB waveform player.

For more information, refer to “Waveform File Basics” on page 187 and “Modes of Operation” on
page 3.

Real-Time Custom Modulation Waveform Generator

The real-time mode simulates single-channel communication using user-defined modulation types
along with custom FIR filters, and symbol rates. Data can be downloaded from an external source
into PRAM memory or supplied as real-time data using an external input. The real-time 1/Q
baseband mode can also generate pre-defined data formats such as PN9 or FIX4. A continuous
data stream generated in this mode can be used for receiver bit error analysis. This mode is limited
to a single carrier. The real-time custom modulation mode:

— has more data and modulation types available than the ARB waveform generator mode
— supports custom I/Q constellation formats
— has the capability to generate continuous PN sequences for bit error rate testing (BERT)

— needs no waveform build time when signal parameters are changed.
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Custom Modulation

Figure 16-1 ARB Custom Modulation Softkeys

ARB Custom
Nodulation Mode Digital Enables the current ARB custom
Modulst ion dulati :
i modulation settings.
DOual ﬂHBr—bpage 187
Multicarrier
AFE Custom on [~#- Page 391
Modulat ion™ This softkey changes
Single Carrier, | depending on the selected
Real-Time Custom, setup mode of modulation. Available only when
Hodulat ion*[ ™ page 365 Multicarrier is Off.
Art Setupe— page 241 /
Feal-Time >
Applications] page 275
. Sinole Eaggéﬁgr page 362
U1t itonem—e—
page 411 fore 1 of 2
flore 1 of 2 Multicarrier
Setup® page 391
ARB Custom

Trigoer Tupe
(Cont inuous ,»

Available only when

Free Run) page 219 Multicarrier is On.
Marker
Utilities® page 188
HMore 2 of 2

For details on each key, use key help as described on page 40.
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Custom Modulation

Figure 16-2

Quick Setup Softkeys

Mode > ARB Custom Modulation > Single Carrier Setup

This softkey label shows th

e currently

selected modulation standard.

Setup Hod
Lick Setun |
i (Defaulty) Quick Setup
Custom Digital >
Modulation TupeM——=page 363 Mod State® page 384
—_ ~
. / GSM
Fllter“r—bpage 394 |
Sumbol Rate EOGE — i
1.000000 Maps | Suick Selup
N
s oot | e / APCO 25k
ore Cipstom,
Dig Hod State®] > page 364 | |
oo DVE-52 APSKY|
\ / |
| TETRA
CECT |
Press Symbol'Rate | Ouick Setup
softkey and use ) — — ~
numeric keypad to Bluetooth / FHS
change value as 7 \
required. fore 2 of 3 |
The default (initial) COPD |
Symbol Rate
maximum range value When one of these pre—defined |
is dependent upon the modulation standards is selected, PUT
modulation standard default values for components of the Default: This softkey selects the |
selected with the setup (including filter, symbol rate, and following default settings: l
Quick Setup softkey. modl_JI_ation type) are automatically Modulation Type = QPSK Default. }
specified. Symbol Rate = 1 Msps, A\ _z
Filter = Root Nyquist, and —
Filter Alpha=0.5
For details on each key, use key help as described on page 40. Hore 2 of 3
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Figure 16-3 Mod Type Softkeys

Mode > ARB Custom Modulation > Single

Custom Digital Modulation (Option 431)
Custom Modulation

Setup Hod
Quick Setup
(Oefault) ™ page 362
Modulation Tupepp——— fod Type fiod Tupe
Select PSK
G5 opsk)y*—®page 380
FilterH——®nage 394
M5k
Sumbol Rate
1.000000 Msps FSK
FSKMH—3
Store Custom, |
Dig Mod State*| ™ page 364 B RS
QArH—
L-Lwl FSK
ASk
8-Lwl FSK
fore 1 of 2
\
HMod Tupe 16-Lwl FSK
S?égﬁ%b fiod Tupe
OVE-S2 APSKK XA
ASK Depth
100.000 # fore 1 of 2
Select,
User I/0
Sets the modulation depth for the _— FSK
i i i efine
Amplitude Shift Keying (ASK). User. TAg*
HCFM
Select,
User F5SK
Oefine,
User F5SK
fore 2 of 2
(LTIl (LTIl (LTIl
LOAM Z2560AM WSA 1280AM
These symbol
1B0AM maps utilize Gray 10240AMH WSA 25E0AM
coded bit mapping.
220611 VSA 160AM These symbol maps VSR 51208H
are consistent with
the symbol maps in
LA VSA 320AM the VSA software. SA 102406
1280aM1 WSA BLOAN
HMore 1 of 3 p flore 2 of 3 Hore 3 of 3

For details on each key, use key help as described on page 40.
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Custom Modulation

Figure 16-4

Modulation format

Custom Modulation Formats and Applications

Application where used

MSK, GMSK GSM, CDPD
BPSK Deep space telemetry, cable modems
QaPsSK Satellite, COMA, NADC, TETRA, PHS, PDC, LMDS,
DVB-S, cable (return path), cable modems, TFTS
0aPsSK CDMA, satellite
FSK DECT, paging. RAM mobile data, AMPS, CT2,
ERMES, land maobile radio, public safety
8 16 VsSB Morth American digital TV (ATV), broadcast, cable
8PSK Satellite, aircraft
16 0AM Microwave digital radio, modems, DVB-C, DVB-T
32 QAM Terrestrial microwave, DVB-T
64 0AM DVB-C, modems, broadband set top boxes, MMDS
256 0AM Modems, DVB-C (Europe), Digital Video (US)
Figure 16-5 Store Custom Dig Mod State Softkeys
Mode > ARB Custom Modulation > Single Carrier Setup > Store Custom Dig Mod State
FREQUEHCY ANPLITUDE

6.000 000 000 00 &+

Catalog of DNOD Files in Int Storage
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File

-144.00 den

Confirm Delete

36kB used 29.2GE free
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For details on each key, use key help as described on page 40.
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Figure 16-6

Mode

NModulation Hode
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Custom Digital Modulation (Option 431)
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For details on each key, use key help as described on page 40.
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Custom Modulation

Figure 16-7

Modulation Setup Softkeys

Mode > Real-Time Custom Modulation > Modulation Setup

;

This softkey label shows
the currently selected

Setup Hod /
[/ WE PR
) 5
(EDGE) —»- [Isctupliionc) 4
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Modulation Tuper{—page 367 |
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7
Hore 1 of L
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softkey and use
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Symbol Rate
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modulation standard
selected with the
Quick Setup softkey.

When one of these pre—defined modulation
standards is selected, default values for
components of the setup (including filter,

symbol rate, and modulation type) are
automatically specified.

For details on each key, use key help as described on page 40.
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Custom Modulation

Figure 16-8 Modulation Type Softkeys
Mode > RgaI—Time Custom Modulation fiod Tupe fod Tupe PSR
> Modulation Setup QPSK and 0OPSK
Select an
¢ = — R (0PSK)”
Setup Hod
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For details on each key, use key help as described on page 40.
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Creating and Using Bit Files

This procedure teaches you how to use the Bit Fi |l e Editor to create, edit, and store
user-defined files for data transmission within real time 1/Q baseband generated modulation. For
this example, a user file is defined within a custom digital communications format.

User files (user-defined data files) can be created on a remote computer and moved to the signal
generator for subsequent modification, or they can be created and modified using the signal

generator'sBit File Editor.

These user files can then be transmitted data as a continuous unframed data stream according to
the protocol of the active format, transmitted as the data for a custom ARB modulation or real-time
format. User files are not available for signals generated by the dual ARB waveform generator.

For information on creating user-defined data files on a remote computer,
see the Keysight Signal Generators Programming Guide.

Figure 16-9 Data Selection Softkeys

Mode > Real-Time Custom Modulation >
Modulation Sftup

Setup Hod

Ouick Setup,
(EOGE )

Modulation Tupek
Filtere
Sumbol Ratee

(PN23—NDPE§IE)I"—> Data Selection
PH_Sequence |
(PH23-Hormal)

Press this key to select from a
number of P sequences and
whether to invert them.

FIxL
oooo
Press this key to select data
Other Patternsk patterns of 1s and Os.
_ Press this key to create, select, and
User Filek edit files to use as the bit pattern.
Ext
fore 1 of 2

Data Selection

PRAM Filedf——

For details on each key, use key help as described on page 40.
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Press this key to select a Pattern
RAM (PRAM) file.

PRAM files are binary arrays in byte
format. Each byte consists of a data
bit (LSB/bit 0), a burst bit (bit 2), and
an Event 1 output bit (bit 6). The
PRAM internal format consists of 4
bytes for each PRAM byte.

PRAM files are useful for specifying
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Creating a User File

Accessing the Table Editor

1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Data > User File > Create
File.

ThisopenstheBit File Editor.TheBit File Editor contains three columns: O f set,
Bi nary Dat a, and Hex Dat a, as well as cursor position (Posi t i on) and file name (Nane)
indicators, as shown in the following figure.

Figure 16-10 Bit File Display

Bit File Editor
6.000 000 000 00 &z
Bit File Editor Fos:0 Size:0 UNTITLED1 H=ERE
Offset Binary Data Hex Data
i i Deleter

Gotok

APply Bit Errorse

03/18/2012 15:16 Hore 1 of 2

Offset Bit Data  Cursor Position Hexadecimal Data File Name
(in Hex) Indicator (in Hex) Indicator

When you create new file, the default name appears as UNTI TLED, or
UNTI TLEDL, and so forth. This prevents overwriting previous files.

Entering Bit Values

Bit data is entered into the table editor in 1-bit format. The current hexadecimal value of the binary
data is shown in the Hex Dat a column, and the cursor position (in hexadecimal) is shown in the
Posi ti on indicator.

1. Refer to the following figure.

2. Enter the 32 bit values shown.
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Figure 16-11 Entering Bit Values
FREQUEHCY RF_OFF Bit File Editor
6.000 000 000 00 &+
. . . . Inserte
Bit File Editor Pos:&0 Size:96 UMTITLEDL
Offset inary Data Hex Data
0 0110 1101 1011 0110 1110 1101 1011 0110 EDBEEDEE
20 1101 1011 0110 1101 1011 0130 1101 1011 DOBEDEECE Deleted
Lo %111 0110 1101 0100 0110 1191 1011 0110 7eOLEDOBE
60
Gotok
APply Bit Errorse
03718720 15:4L Hore 1 of 2
Enter these bit Cursor Position Hexadecimal
values Indicator Data

Renaming and Saving a User File

In this example, you learn how to store a user file. If you have not created a user file, complete the
steps in the previous section, “Creating a User File” on page 369.

1. Press More (1 of 2) > Rename > Editing Keys > Clear Text.

2. Enter a file name (for example, USERL) using the alpha keys and the numeric keypad.

3. Press Enter.

The user file has now been renamed and stored to the Bi t memory catalog with the name

USER1.
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Recalling a User File

In this example, you learn how to recall a user-defined data file from the memory catalog. If you
have not created and stored a user-defined data file, complete the steps in the previous sections,
“Creating a User File” on page 369 and “Renaming and Saving a User File” on page 370.

1. Press Preset.
2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Data > User File.
3. Highlight the file USERL.
4. Press Edit File.
TheBit File Editor opens the file USERL.

Modifying an Existing User File

In this example, you learn how to modify an existing user-defined data file. If you have not created,
stored, and recalled a user-defined data file, complete the steps in the previous sections, “Creating
a User File” on page 369, “Renaming and Saving a User File” on page 370 and “Recalling a User
File” on page 371.

Navigating the Bit Values

1. Press Return > Goto > 4 > C > Enter.

This moves the cursor to bit position 4C in the table, as shown in the following figure.

Figure 16-12 Navigating the Bit Values

Position indicator
changes

Bit File Editor

FREQUEHCY RF_OFF

6.000 000 000 00 &

Insertr

Bit File Editor Fos:LC Size:S6
Offset Binary Data Hex Data
0 0110 1101 1011 0110 1110 1101 1011 0110 EDBEECEG

20 1101 1011 0110 1101 1011 0110 1101 1011 DBEDBEOE Delster
gg 0111 0110 1101 W100 0110 1101 1011 0110 7e0L4E0EE

Gotok

APply Bit Errorse

03/18/2012 15:53 Hore 1 of 2

Cursor moves to new
position
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Inverting Bit Values
1. Press 1011.

This inverts the bit values that are positioned 4C through 4F. Notice that hex data in this row
has now changed to 76DB6DB6, as shown in the following figure.

Figure 16-13 Inverting Bit Values
FREQUEHCY Bit File Editor
6.000 000 000 00 &z
= = = - Insertr
Bit File Editor Pos:50 Size:S6 LUSER1
Offset Binary Data Hex Data

0 0110 1101 1011 0110 1110 1101 1011 0110
20 1101 1011 0110 1101 1011 0110 1101 1011
Lo 0111 0110 1101 1011 E110 1101 1011 0110
60

GOBEEDEG
DEE0BE0E
7eOBEOEG

Deleter

Gotok

APply Bit Errorse

03/18/3012 16:03 Hore 1 of 2

Bits 4C throug(4F are
inverted

Hex Data changed

Applying Bit Errors to a User File

In this example, you learn how to apply bit errors to a user-defined data file. If you have not created
and stored a user-defined data file, complete the steps in the previous sections, “Creating a User
File” on page 369 and “Renaming and Saving a User File” on page 370.

1. Press Apply Bit Errors.
2. Press Bit Errors > 5 > Enter.

3. Press Apply Bit Errors.

Notice both Bit Errors softkeys change value as they are linked.
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Using Customized Burst Shape Curves

You can adjust the shape of the rise time curve and the fall time curve using the R se Shape and
Fal | Shape editors. Each editor allows you to enter up to 256 values, equidistant in time, to
define the shape of the curve. The values are then resampled to create the cubic spline that passes
through all of the sample points.

The R se Shape and Fal | Shape table editors are available for custom real-time 1/Q baseband
generator waveforms.

Understanding Burst Shape

The default burst shape of each format is implemented according to the standards of the format
selected. You can, however, modify the following aspects of the burst shape:

Rise time the period of time, specified in symbols or bits, where the burst
increases from a minimum of =70 dB (0) to full power (1).

Fall time the period of time, specified in symbols or bits, where the burst
decreases from full power (1) to a minimum of —=70 dB (0).

Rise delay the period of time, specified in symbols or bits, that the start of
the burst rise is delayed. Rise delay can be either negative or
positive. Entering a delay other than zero shifts the full power
point earlier or later than the beginning of the first useful symbol.

Fall delay the period of time, specified in symbols or bits, that the start of
the burst fall is delayed. Fall delay can be either negative or
positive. Entering a delay other than zero shifts the full power
point earlier or later than the end of the last useful symbol.

User-defined burst shape up to 256 user-entered values which define the shape of the
curve in the specified rise or fall time. The values can vary
between 0 (no power) and 1 (full power) and are scaled linearly.
Once specified, the values are resampled as necessary to create
the cubic spline that passes through all of the sample points.

User-Def User-Def
1
o] . .
= Ris Ris Fall Fall
g g
@ 4 L )
Time —»

Burst shape maximum rise and fall time values are affected by the following factors:

— the symbol rate
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— the modulation type

When the rise and fall delays equal O, the burst shape is attempting to synchronize the maximum
burst shape power to the beginning of the first valid symbol and the ending of the last valid symbol
of the timeslot. The following figure illustrates a bursted signal in an EDGE frame with a rise delay of
0 and a fall delay of +1 bit.

EDGE
Frame 0|1]2|3]|4[5]|6]|7
Burst | |
Signal
Timeslot number 4
EDGE |GUARD| DATA GUARD
Timeslot 1 l

Signd —-| %—Rise‘l’lme Fall‘l'lme—o! |-—

Rise Delay =0 Fall Delay = + 1 Bit

pk743b

The signal generator firmware computes optimum burst shape based on the settings you’ve chosen
for modulation. You can further optimize burst shape by lining up the data portion with the
modulation. For example, if you're designing a new modulation scheme, do the following:

— Adjust the modulation and filtering to set the spectrum you want.
— Adjust the burst rise and fall delay and rise and fall time for the timeslots.

If you find that the error vector magnitude (EVM) or adjacent channel power (ACP) increases when
you turn bursting on, you can adjust the burst shape to assist with troubleshooting.
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Burst Shape Softkeys
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Burst Shape Tupe,
(5inel

fore 1 of 2

—

Burst Shape

Oefine,
User Burst Shape

Festore Default
Burst. Shape

For details on each key, use key help as described on page 40.

Creating a User-Defined Burst Shape Curve

Using this procedure, you learn how to enter rise shape sample values and mirror them as fall
shape values to create a symmetrical burst curve.

This section teaches you how to perform the following tasks:

— “Accessing the Table Editors” on page 375

— “Entering Sample Values” on page 376

Accessing the Table Editors

1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Burst Shape.

3. Press More > Define User Burst Shape > More (1 of 2) > Delete All Rows > Confirm Delete Of

All Rows.
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Entering Sample Values

Use the sample values in the following table.

Rise Shape Editor

Sample Value Sample Value

0 0.000000 4 0.830000
1 0.400000 5 0.900000
2 0.600000 6 1.000000
3 0.750000

. Highlight the value (1. 000000) for sample 1.
. Press .4 > Enter.
. Press .6 > Enter.

. Enter the remaining values for samples 3 through 6 from the table above.

ga A WO N =

. Press Return > Edit Fall Shape > Load Mirror Image of Rise Shape >
Confirm Load Mirror Image Of Rise Shape.

This changes the fall shape values to a mirror image of the rise shape values, as shown in
Figure 16-15 on page 376.

Figure 16-15 Mirror Image of Rise Shape

FREQUENCY RE_OFF User Fall Burst
6.000 000 000 00 GHz Load/Storer
Load Mirror Imege,
|Hise Shape Editor (UNSTORED) Fall Shape Editor (UNSTORED) of Rise Shape
Sample Ualue Sample Ualue
0 0.000000 0
1 0.400000 1 0.900000 Delste ALl Rausk
2 0.600000 2 0.§30000
3 0.750000 3 0.750000
M 0.830000 M 0.500000 Display,
5 0.900000 5 0400000 Burst. Shape
6 1.000000 6 0.000000
2 ——— 2 ——
03/16/2012 16:46  Hore 2 of 2
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Display the Burst Shape
Press Display Burst Shape.

This displays a graphical representation of the waveform’s rise and fall characteristics, as shown in
Figure 16-16.

Figure 16-16 Burst Shape

FREQUEHCY RF_OFF

6.000 000 000 00 &+

A Burst Shape
1 Burst Rise Shape Burst Fall Shape

LR =g - TR —

03/18/2012 16:52

To return the burst to the default conditions, press the following keys:

Return > Return > Return > Confirm Exit From Table Without Saving > Restore Default Burst
Shape.

Storing a User-Defined Burst Shape Curve

1. Press Define User Burst Shape > More (1 of 2) > Load/Store > Store To File.

If there is already a file name from the Cat al og of SHAPE Fi | es occupying the active entry
area, press the following keys:

Editing Keys > Clear Text
2. Enter a file name (for example, NEVBURST) using the alpha keys and the numeric keypad.
The maximum file name length is 23 characters (alphanumeric and special characters).
3. Press Enter.

The contents of the current R se Shape and Fal | Shape table editors are stored to the Cat al og
of SHAPE Fi | es. This burst shape can now be used to customize a modulation or as a basis for a
new burst shape design.

Recalling a User-Defined Burst Shape Curve

Once a user-defined burst shape file is stored in memory, it can be recalled for use with real-time
I/Q baseband generated digital modulation.

This example requires a user-defined burst shape file stored in memory. If you have not created and
stored a user-defined burst shape file, complete the steps in the previous sections, “Creating a
User-Defined Burst Shape Curve” on page 375 and “Storing a User-Defined Burst Shape Curve”
on page 377.
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Press Preset.
Press Mode > Real-Time Custom Modulation > Burst Shape > Burst Shape Type > User File.
Highlight the desired burst shape file (for example, NEVBURST).

e

Press Select File.

The selected burst shape file is now applied to the current real time I/Q baseband digital
modulation state.
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Using the Arbitrary Waveform Generator

This section teaches you how to build dual arbitrary (ARB) waveform files containing custom digital
modulation for testing component designs.

Figure 16-17 Adding Custom Modulation to a Waveform

Mode > ARB Custom Modulation > Single Carrier Setup

This softkey label updates to reflect the fuickgsetup

current modulation type. Custom Digital |
v Mod State*| ™ page 384

/ GSH

Setup Hod
Quick Setup >
( (e faLIt) v ELCE
Modulation Tuper—page 363 NAOC
Filters—®page 394 FOC

Sumbol Rate Hore 1 of 3

1.000000 Msps

Store Custom, |
Dig Mod State*] ™ page 364

For details on each key, use key help as described on page 40.

Using Predefined Custom Digital Modulation
This section teaches you how to perform the following tasks:
— Selecting a Predefined EDGE Setup on page 379

— Generating the Waveform on page 379

— Configuring the RF Output on page 379

Selecting a Predefined EDGE Setup

1. Press Preset.

2. In the ARB Custom Modulation menu (page 379), press Single Carrier Setup > Quick Setup >
EDGE.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the pre-defined EDGE state selected in the step. The display
changesto Dig Mbd Setup: EDCE During waveform generation, the Dl GMCDand 1/ Q
annunciators appear and the pre-defined digital modulation state is stored in volatile memory
(BBG). The waveform is now modulating the RF carrier.

Configuring the RF Output
1. Set the RF output frequency to 891 MHz.
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2. Set the output amplitude to -5 dBm.

3. Press RF On/Off.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.

Creating a Custom Digital Modulation State

In this procedure, you learn how to set up a single-carrier NADC digital modulation with
customized modulation type, symbol rate, and filtering.

Figure 16-18

|

Setup Hod
Ouick Setupy

Setting a Digital Modulation Filter

Mode > ARB Custom Modulation > Single Carrier Setup

(Default)
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imize ar
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page 394)
and modulation Festore Default
type selected Filter User FIR®
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page 363). Hore 1 of 3

Mod Tupe
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(OPSK

\J

L4

L Opens a menu to select a

1S-95 filter.

For details on each key, use key help as described on page 40.
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Figure 16-19 Modifying a Digital Modulation Type
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This section teaches you how to perform the following tasks:
— Selecting a Digital Modulation Setup on page 381

— Configuring the RF Output on page 379

— Selecting the Filter on page 382

— Configuring the RF Output on page 379

Selecting a Digital Modulation Setup
1. Press Preset.

2. In the ARB Custom Modulation menu (page 380), press Single Carrier Setup > Quick Setup >
NADC.

Modifying the Modulation Type and Symbol Rate

1. In the ARB Custom Modulation menu (page 380), press Single Carrier Setup > Modulation
Type > Select > PSK > QPSK and OQPSK > QPSK.

2. Press Return > Symbol Rate > 56 > ksps.
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Selecting the Filter
1. In the Setup Mod menu (page 380), press Filter > Select > Nyquist.

2. Press Return > Return.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the custom, single—carrier NADC, digital modulation state created
in the previous sections. The display changesto D g Mbd Set up: NADC ( Modi fi ed) . During
waveform generation, the DI GMCD and | / Qannunciators appear and the custom single—carrier
digital modulation state is stored in volatile memory. The waveform is now modulating the RF
carrier.

For instructions on storing this custom, single-carrier NADC, digital modulation state to the non-
volatile memory catalog, see Storing a Custom Digital Modulation State on page 382.

Configuring the RF Output

1. Set the RF output frequency to 835 MHz.

2. Set the output amplitude to O dBm.

3. Press RF On/Off.

The user-defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom
multicarrier digital modulation state to non-volatile memory.

If you have not created a custom, single-carrier, digital modulation state, complete the steps in the
previous section, Creating a Custom Digital Modulation State on page 380.
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Figure 16-20 Storing a Custom Digital Modulation State
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Catalog displays DMOD files that have

been previously saved by the user. For details on each key, use key help as described on page 40.

1. Return to the top-level ARB Custom Modulation menu, where Digital Modulation Off On is the
first softkey.

2. In the ARB Custom Modulation menu (page 383), press Single Carrier Setup > Store Custom
Dig Mod State > Store To File.

If there is already a file name from the Cat al og of DMCID Fi | es occupying the active entry
area, press the following key: Clear Text

3. Enter a file name (for example, NADOQPSK) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

4, Press Enter.

The user-defined, single-carrier, digital modulation state is now stored in non-volatile memory.

The RF output amplitude, frequency, and operating state settings are not stored as part of a user-
defined, digital modulation state file.

Recalling a Custom Digital Modulation State

Using this procedure, you will learn how to recall a custom digital modulation state from signal
non-volatile memory.
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If you have not created and stored a user-defined, single-carrier, digital modulation

state, complete the steps in the previous sections, Creating a Custom Digital Modulation State on
page 380 and Storing a Custom Digital Modulation State on page 382, then preset the signal
generator to clear the stored user-defined, digital modulation waveform from volatile ARB memory.

Figure 16-21 Recalling a Custom Digital Modulation State
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1. In the Quick Setup menu, press Custom Digital Mod State.
2. Highlight the desired file (for example, NADOQPSK).

3. Press Select File > Return.

4. Press Digital Modulation Off On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After
waveform generation, the custom, digital modulation waveform is available to be modulated on the
RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 379.

Defining a Modulation

You can build a unique modulation by utilizing two tools, the FSK table editor or the I/Q table
editor. These tables map data onto specific absolute modulation states. To map transitions
between states, a differential table editor is provided.
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Building an Asymmetric FSK Modulation with the FSK Table Editor

You can use the FSK table editor to create customized asymmetric FSK modulation of up to 16
levels, then apply the custom FSK modulation to one of the modulation standards. An example of
this capability is to create an interfering signal for adjacent channel selectivity testing of FLEXTM
pagers. To do this, build a 4-level FSK modulation at 4.8 kHz and 1.6 kHz in the FSK table editor,
shown in Figure 16-22. Then use this signal to modulate a PN15 data transmission. In the FLEXTM
protocol, each of the levels in 4-level FSK represents a 2-bit sequence.

Create a Continuous 4-Level FSK Signal

Use this procedure to create a 4-level FSK signal for adjacent channel testing of FLEXTM pagers.

1.

Press Preset on the signal generator.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define

© ® N g ;W

User FSK.

Enter the frequency deviations shown in Figure 16-22 into the FSK table editor.

Store the file as 4FSK. Press Load/Store > Store To File > 4FSK > Enter.

Load the file. Press Load from Selected File > Confirm Load From File.

Turn on Custom Modulation. Press Return > Return > Return > Real-Time Custom On.
Set the Frequency to the desired carrier frequency for the adjacent channel.

Set the desired Amplitude.

Press RF On. The amplitude of the interferer can then be adjusted to measure the performance
of the device under test.
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Figure 16-22 FSK Table Editor
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For details on each key, use key
help as described on page 40.

Mapping I/Q Values with the I/Q Table Editor

In most digital radio systems, the frequency of the carrier is fixed so only phase and magnitude
need to be considered. The phase and magnitude of symbols can be represented as a discrete point
in the 1/Q plane. | represents "in phase" and Q represents "quadrature".

Figure 16-23 I/Q Constellation Diagram

Momel & 324sp modes
myen |8 O levels)
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By modulating the carrier to one of several predetermined positions in the I/Q plane, you can then
transmit encoded information. Each position or state represents a certain bit pattern that can be
decoded at the receiver. The mapping of the states at each symbol decision point on the I/Q plane
is referred to as a constellation diagram. You can create a unique signal by mapping your
constellation diagram into the I/Q table editor, shown in Figure 16-24. The table editor also has a
display feature, which provides a quick visual check of the expected I/Q constellation.

Figure 16-24 I/Q Table Editor

Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User 1/Q

FREQUEHCY ANPLITUDE User MHod Tupe

6.000 000 000 00 &z -144.00 cen Tnsert, Rou

Delete Row

I/0 Values
Data I Value 0 Value

[
0000000000 Goto FRowe

For details on each key, use key help

Delete ALL RoHSH o described on page 40.

10/10/2012 13:57 Hore 1 of 2

Utilizing this I/Q mapping flexibility, you can create unique modulation schemes. For example, a
circular constellation arrangement called a STAR QAM is easily implemented and saved for later
recall with the real-time I/Q baseband generator. Figure 16-25 shows that the STAR QAM has 16
states or symbols. Four data bits define each symbol. Thus, the diagram and the table are
equivalents.

Create a STAR QAM Modulation Scheme
1. Press Preset on the signal generator.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define
User 1Q.

3. Enter the values shown in Figure 16-25 for | and Q using the numeric keypad and arrow keys.
Press Display 1Q Map to check your entry and adjust any entry errors.

Press Return > Store To File > Clear Text.

Turn on Custom Modulation. Press Return > Return > Return > Real-Time Custom On.

Name the file STAR and press Enter.

Load the file. Highlight STAR and press Load from Selected File > Confirm Load From File.
Turn on Custom Modulation. Press Return > Return > Return > Return > Real-Time Custom On.
Set the Frequency and Amplitude to the desired values.

0.Press RF On.

= © ® N o »
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Figure 16-25 STAR QAM Diagram and Table

Smbol  Data bits | Value Q Value

Radius = 1
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Figure 16-26 shows the X-Series setup and the I/Q display.

Figure 16-26 Custom Modulation and I/Q Display
ANPLITUDE User Mod Tupe
6.000 00000000 &z -144.00 den Tnsert, Fou
[1/0]
Oelete Row
1/0 Values
Data I Value 0 Ualum

0000000010 0.333333333 1. 000001 -
0000000011 1.000000000 1. 000001 6000 000 000 00 GHz 14400 dBn
0000000100 0.333333333 -0.33333;
0000000101 0.333333333 ~1.00000i
0000000110 1.000000000 -0.33333
0000000111 1.000000000 -1.000001|1/Q State Map aft o+ T+ &
0000001000 -0.333333333 0.3333% 170 states: 16
0000001001 -0.333333333 1. 000001

TS o

-1 I Value +1

03/20/2012 13:13

Hints for Constructing Modulations

— The map is limited to 16 total signal levels for I and @ combined. The readout on the right-hand
side of the table tracks the number of I and Q levels utilized. Levels are | or Q values. Figure
16-27 shows an 8PSK signal built in two different ways. The 8PSK signal in Figure 16-27 utilizes
five of the available sixteen I/Q values on the left, and utilizes four of the available sixteen I/Q
values on the right.

— Following this example, the real-time I/Q baseband generator supports a symmetric 256QAM
constellation but not an asymmetric 256QAM constellation, since the asymmetry requires more
than sixteen 1/Q values.

— The levels do not have to be equally spaced or symmetric in the I/Q plane. For example, the
16QAM modulations shown in Figure 16-28 are both possible.

Figure 16-27 8PSK Signal Built Two Ways
Q Q
4levels
5 levels
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Figure 16-28 16QAM I/Q Map with Even and Uneven Levels
Q Q
I |
Mol & 324mp modes Doudle=peed  mode
jen 18 Q levels) megen, 18 Q levds)
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Creating a Custom Multicarrier Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup
by creating a custom, 3-carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:

— Creating a Multicarrier Digital Modulation Setup on page 392
— Modifying Carrier Frequency Offset on page 392

— Modifying Carrier Power on page 392

— Generating the Waveform on page 392

— Configuring the RF Output on page 392

Figure 16-29 Creating a Multicarrier Digital Modulation Setup
Mode > ARB Custom Modulation NCarrier Init
B Gl
ARERCOSHO # of Carriers
Digital 2
Modulat ion
on Fregq Spacing
il SR e 1.000000 FHz
on

Done

Single Carrier,
Setup NCarrier Setup

Custom I:li ital
Art Setupk Hod Stats”

* GSH

fore 1 of 2
EOGE

FREQUEHCY ANPLITUDE NCarrier Setup

6.000 000000 00 s -144.00 mn  oi=tioro,

Initialize Table

POC
. . . Insert Row

Nulticarrier Setup: Default Carriers fore 1 of 3
Carrier Ph : Fixed

ArTIer Fheses: xS Carrier Freq Offset Pouer

1 -500.000 kHz 0.00 dg Delete Row

2 Default 500.000 kHz 0.00 dB

3

Gota Rowe Becomes active when a change

has been made to the
Multicarrier Setup table values
) or to the multicarrier menu
values (i.e. Carrier Setup, # of
Dz2/20/2012 15:13  Hore 1 of 2 Carriers, Freq Spacing, or to the
Carrier Phases).

For details on each key, use key help as described on page 40.
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Creating a Multicarrier Digital Modulation Setup

1. Press Preset.
2. Press Mode > ARB Custom Modulation > Multicarrier Off On to On.

3. Press Multicarrier Setup > Select Carrier and Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset
1. Highlight the Freq O f set value (500. 000 kHz) for the carrier in row 2.
2. Press -625 > kHz.

Modifying Carrier Power
1. Highlight the Power value (0. 00 dB) for the carrier in row 2.
2. Press -10 > dB.
You now have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of

-625 kHz and a power level of -10.00 dBm, as shown in the following figure.

FREQUEHCY ANPLITUDE NCarrier Setup

6.000 000 000 00 &= -144.00 o Sieoorier, oo

an
Initialize Table

. . . Insert Row
Nulticarrier Setup: EDGE Carriers

Carrier Phases: Fixed
Carrier Freq Offset Pouer

1 EDGE -500.000 kHz 0.00 de Delete Row
2 EDGE -E25.000 kHz -10.00 dB
3 | ————— |

Goto Rowk If Digital Modulation is already on, you
must press Apply Multicarrier to apply
the changes and generate a new

custom multicarrier digital modulation

waveform based on the updated
values.

02/20/2012 15:08 Hore 1 of 2

Generating the Waveform
Press Return > Digital Modulation Off On.

This generates a waveform with the custom, multicarrier, EDGE state created in the previous
sections. The display changesto Dig Mbd Setup: Milticarrier (Mdified). During
waveform generation, the Dl GMODand | / Qannunciators appear and the new custom, multicarrier,
EDGE state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non-volatile memory, see
“Storing a Custom Multicarrier Digital Modulation State” on page 393.

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz.
2. Set the output amplitude to —10 dBm.

3. Press RF On/Off.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.
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Storing a Custom Multicarrier Digital Modulation State

Using this procedure, you learn how to store a custom, multicarrier, digital modulation state to
non-volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the
previous section, “Creating a Custom Multicarrier Digital Modulation State” on page 391.

Figure 16-30 Storing a Custom Multicarrier Softkeys

Fixed: All the carriers are setto a
FREQUEHCY ANPLITUDE NCarrier Define phase of 0

6.000 000 000 00 ez -144.00 dsn  jearrier prases 0o Drace valie.

- - - — Load/Storer—®page 41
NMulticarrier Setup: EDGE Carriers (Modified)

Carrier Phases: Fixed

Carrier Freq Offset Pouer
1 EOGE -500.000 kHz 0.00 dg
2 EOGE -£25.000 kHz -10.00 dB
3 | ——————— |

For details on each key, use key help as
described on page 40.

02/20/2012 15:32 Hore 2 of 2

1. Return to the top-level Digital Modulation menu, where Digital Modulation Off On is the first
softkey.

2. Press Multicarrier Setup > More > Load/ Store > Store To File.

If there is already a file name from the Cat al og of MDMOD Fi | es occupying the active entry
area, press the following key: Clear Text

3. Enter a file name (for example, EDGEML) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

4. Press Enter.
The user-defined, multicarrier, digital modulation state is now stored in non-volatile memory.

The RF output amplitude, frequency, and operating state settings are not stored as part of a user-
defined, digital modulation state file.

Applying Changes to an Active Multicarrier Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while
changes are made in the Mul ti carri er Setup table editor, you must apply the changes before
the updated waveform will be generated.

From the Mul ti carrier Setup table editor, press Apply Multicarrier to apply the changes and
generate a new custom multicarrier digital modulation waveform based on the updated values.
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Using Finite Impulse Response (FIR) Filters with Custom Modulation

Finite Impulse Response filters can be used to refine the transitions between symbol decision points
of the generated waveforms.

Figure 16-31 Filter Menu

Mode > ARB Custom Modulation > Single Carrier Setup > Filter

Filter Select
¢ Root Huquist
Filters

Select . y Mugquist
(Root. Muguist * Available only when the filter selected = =

Root Nyquist or Nyquist
\\\\\\\\\\\‘ Gaussian

Filter Alpha
0.500

Define
User FIR*—page 396

This softkey changes, depending

on the selected filter—type.

Opens the 1IS-95
I5-35»|—filter selection
menu.

Filter Alpha
0.500

Filter BOT
0.500

Dptlmlz-IHﬂEgr“ ——Only applies to Dual ARB User FIRM—page 401
- Modulation. Refer to ) ] DR INGERS
page 185. Available only when the filter

selected = Gaussian

Festore Default
Filter

Filter Select
This replaces the current LCOMA
FIR filter with the factory
installed default filter
settings for the current Rectangle
modulation type.
EDGE
EDGE Wide
EDGE HSR
fore 2 of 3

For details on each key, use key help as described on page 40.
Filter Select

APCO 25 CLFM
APCOZS HOOPSK

APCO25 HCPH

Understanding FIR Filters

FIR filters are used to limit the bandwidth of the input to the | and @ modulators. Several different
types of FIR filters exist. The NADC, PDC, PHS, and TETRA standards specify a root Nyquist filter in
both the transmitter and the receiver. The combined response is equivalent to a Nyquist filter. The
Nyquist filter has an impulse response that rings at the data clock rate so nulls appear at all symbol
decision points except the desired one at the center of the impulse response. Since each symbol
causes zero response at all undesired decision points, there can be no inter-symbol interference
(ISI). The alpha term (a) defined for Nyquist-type filters identifies the frequency cutoff point were
the filter response is zero. The closer the alpha term is to zero, the steeper the filter roll-off
becomes. Alpha gives a direct measure of the occupied bandwidth of the system and is calculated
as

Occupied Bandwidth = Symbol Rate x (1 + o)
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The NADC and TETRA standards specify an alpha of 0.35. PDC and PHS standards specify an alpha
of 0.50. For each of these standards, the Keysight X-Series signal generator provides a root Nyquist
filter with the designated alphas as the default premodulation filter. Figure 16-32 shows the
Nyquist impulse response for several values of alpha.

Notice that the half-amplitude point is always at the half-symbol rate. Since all of the information
is contained within the half symbol rate bandwidth, alpha is a measure of the additional occupied
bandwidth.

Another type of FIR filter, which is specified in the GSM and DECT standards, is the Gaussian filter.
Gaussian filters typically have more inter-symbol interference than Nyquist filters, but their
adjacent channel power performance is better for constant-amplitude modes like MSK, where
Nyquist filtering of | and Q is not possible. The bandwidth bit time (BbT) product (similar to o) is
defined by the GSM standard as 0.30 and by the DECT standard as 0.50. For each of these
standards, the Keysight X-Series signal generator provides a Gaussian filter with the designated
BbT product as the default premodulation filter.

Figure 16-32 Nyquist Filter Impulse Response

1 r! Y. 1
N R P
08 \ o
" 1
R
06 \I
AL
: =03
—

AN

] ot

0 02 04 06 08 1
Es.; Symbol Rate

Selecting a Filter and the Alpha (o) or Bandwidth Bit Time (Bbt) Product

Due to individual system design requirements, you may decide to change the filter or the filter o or
BbT. You can adjust the alpha from O to 1 and the BbT from 0.1 to 1.

To change the filter alpha:
1. Preset the instrument.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Filter > Select Nyquist >
Filter Alpha.

3. Enter a new value between 0 and 1. Press Enter.

4. To restore the default filter values, press Restore Default Filter.
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To change the filter Bbt, press Mode > Real-Time Custom Modulation >
Modulation Setup > Filter > Select Gaussian > Filter Bbt.

Enter a new value between 0.1 and 1.

Creating a User-Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FI R Val ues table editor to create and store an 8-symbol, windowed
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press Preset.

2. Press Mode > ARB Custom Modulation > Single Carrier Setup > Filter > Select > Nyquist.
3. Press Filter > Define User FIR.

4. Press More 2 of 2 > Delete All Rows > Confirm Delete of All Rows.

This will initialize the table editor as shown in Figure 16-33.

Figure 16-33 Creating a User-Defined FIR Filter Using the FIR Filter Table Editor

Mode > ARB Custom Modulation> Single Carrier Setup > Filter > For details on each key, use key help as described on page 40.
Define User FIR > More > Delete All Rows > Confirm Delete of All

Opens a menu that

FrEcuEnc G v 7o M Ueer Filter | Pt T
6000 000 000 00 GHz —14400 dBm Load/Storer and load a saved file
e —

into volatile memory.

Lomd Default,
FIR Ualues Oversample Ratio: 4, Lenoth In Sumbols: O FIR
Coeff. Real Value

0 Oelete ALl Rowse

Convert To |
Comelex Filter page 255

Display Filterw
| Hore 2 of 2
Active only when:

FIR filter coefficient table
has minimum of two
values visible.

Note:
Modulation filters are typically real and have an oversample ratio (OSR) of two or greater.
Equalization filters are typically complex and have an oversample ratio (OSR) of one (Dual ARB only).

Entering the Coefficient Values
1. Press the Return softkey to get to the first page of the table editor.
2. Use the cursor to highlight the Val ue field for coefficient 0.
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3. Use the numeric keypad to type the first value (-0.000076) from Table 16-1. As you press the
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you
can correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been
entered.

Table 16-1

Coefficient Value Coefficient Value

0 —0.000076 8 —0.035667

1 —0.001747 9 -0.116753

2 —0.005144 10 —0.157348

3 —0.004424 17 —0.088484

4 0.007745 12 0.123414

5 0.029610 13 0.442748
0.043940 14 0.767329

7 0.025852 15 0.972149
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Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in
reverse order. The signal generator provides a mirror table function that automatically duplicates
the existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and
the first of these coefficients (number 16) highlights, as shown in Figure 16-34 on page 398.

Figure 16-34
FIR table coefficient values, FREQUEHCY ANPLITUDE User Filter
may be from the factory
default values or entered by 6.000 000 000 00 GHz _144.00 dBn Inzert Row
the user. -]
. Oelete Rou
FIR Ualues (UHSTORED) Oversample Ratio: 4, Lenoth In Sumbols: 2
Coeff.  __ _ Real U_alue\
10 —0. 15734800
11 -0.08848400 Goto Rane
12 0. 12341400
| 13 D.LLZ7LE00 |
14 0.76732900 Mi Tabl
| 15 0.97214300 irrer fahse
16 0. 97214500 |

17 0. 76732900
\ 18 0.L4274300

Oversample HatiE
~19  _ _ 0,12341L00

02/20/2012 Ak: L0 Hore 1 of 2

Use the Goto Row menu
to move around and
make changes to the FIR

X X Values coefficient table.
For details on each key, use key help as described on page 40.

Setting the Oversample Ratio

Modulation filters must be real and have an oversample ratio (OSR) of two
or greater.

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the
table editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an
oversample ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or
512 coefficients, the instrument is unable to use the filter. If the oversample ratio is different from
the internal, optimally selected one, then the filter is automatically resampled to an optimal
oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and
frequency dimensions.

1. Press More > Display Filter > Display FFT (fast Fourier transform).
Refer to Figure 16-35 on page 399.
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Figure 16-35
FREQUEHCY
6.000 000 000 00 s+
I
FFT
1}
8
For details on each key, use key
help as described on page 40.
-100 Symbol Rate 2
02/20/2012 16:4LL
2. Press Return.
3. Press Display Impulse Response.
Refer to Figure 16-36.
Figure 16-36
FREQUEHCY
6.000 000 000 00 s+

Real Impulse Response A
1 Length In Sumbols: 8 Oversample Ratio: L

For details on each key, use key
help as described on page 40.

-0-5 g Coefficient

3
02/20/2012 16:45

4. Press Return to return to the menu keys.

Storing the Filter to Memory

Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of
memory available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 189, name and
store this file as FI R_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional file
names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The amount
of memory used is also displayed. The number of files that can be saved depends on the size of the
files and the amount of memory used. Refer to Figure 16-37.
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Figure 16-37
FREQUEHCY ANPLITUDE List. Load/5tore
6.000 000 000 00 &= -144.00 sn ., iwsrem
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Store To,
File
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Delete Filew
These keys manage the table of DMOD

files in internal storage.
Goto FRowe

02/20/2012 16:43

Catalog displays FIR files that have For details on each key, use key help as described on page 40.
been previously saved by the user.

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new
filter design.
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Modifying a FIR Filter Using the FIR Table Editor

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You
can load the FIR table editor with coefficient values from user-defined FIR files stored in non-
volatile memory or from one of the default FIR filters. Then you can modify the values and store the

new files.

Loading the Default Gaussian FIR File

Figure 16-38
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Setup Hod Quick Setup
i Custom Digital
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Modulat.ion Tuper GSM
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Loading the Default Gaussian FIR File

Mode > ARB Custom Modulation > Single Carrier

For details on each key, use key help as described on page 40.
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Press Preset.

A
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5. Press Filter Symbols > 8 > Enter.

6. Press Generate.

The actual oversample ratio during modulation is automatically selected
by the instrument. A value between 4 and 16 is chosen dependent on the
symbol rate, the number of bits per symbol of the modulation type, and
the number of symbols.

7. Press Display Filter > Display Impulse Response (refer to Figure 16-39).

Figure 16-39 Impulse Response Display
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8. Press Return.

Modifying the Coefficients

1. Using the front panel arrow keys, highlight coefficient 15.
2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 16-40 Impulse Response Display with Modified Coefficients
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02/20/2012 17:07

Refer to Figure 16-40 on page 402. The graphic display can provide a useful troubleshooting
tool (in this case, it indicates that a coefficient value is missing, resulting in an improper
Gaussian response).

4. Press Return.
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5. Highlight coefficient 15.

6. Press 1 > Enter.

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).
1. Press Return > Load/Store > Store To File.

2. Name the file NEWFIR2.

3. Press Enter.

The contents of the current FIR table editor are stored to a file in non-volatile memory and the
catalog of FIR files is updated to show the new file.
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Differential Encoding

Differential encoding is a digital-encoding technique whereby a binary value is denoted by a signal
change rather than a particular signal state. Using differential encoding, binary data in any user-
defined I/Q or FSK modulation can be encoded during the modulation process via symbol table
offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user-defined
modulation based on the default 4QAM template, the I / Q Val ues table editor contains data that
represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values,
1.000000 and -1.000000. The following illustration shows the 4QAM modulation in the I / Q

Val ues table editor.

FREQUEHCY ANPLITUDE User MHod Tupe

6.000 000 000 00 &z -144.00 cen Loaa stores

I/0 Values
Data I Value 0 Value

0000000000 [ ———————————— | ——— Differential
Encoding
| Off ]
Conf igure

Differentiale
Encoding

Offset 0
INTE On

10/10/2012 13:58 Hore 2 of 2

The following illustration shows a 4QAM modulation I/Q State Map.

2nd Symbol 1st Symbol
Data = 00000001 Data = 00000000
Distinct values: -1, +1 Distinct values: +1, +1
I/Q State Map
I/0 States: L
+1 16 o}
0
)
d
1
u
e
_, e o)
/P =1 I Ualue .a'.‘1\
3rd Symbol
- 4th Symbol
Data = 00000010 _
Distinct values: -1, -1 Data = 00000011

Distinct values: +1, -1

Differential encoding employs relative offsets between the states in the symbol table to encode
user-defined modulation schemes. The Di fferential State Map table editor is used to
introduce symbol table offset values which in turn cause transitions through the I/Q State Map
based on their associated data value. Whenever a data value is modulated, the offset value stored
in the Differential State Map is used to encode the data by transitioning through the 1I/Q State Map
in a direction and distance defined by the symbol table offset value.
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Entering a value of +1 will cause a T-state forward transition through the I/Q State Map, as shown

in the following illustration.

The following 1/Q State Map illustrations show all of the possible state
transitions using a particular symbol table offset value. The actual state-
to-state transition would depend upon the state in which the modulation

had started.

As an example, consider the following data/symbol table offset values.

Table 16-2
Data Offset Value
00000000 +1
00000001 -1
00000010 +2
00000011 0

The number of bits per symbol can be expressed using the following
formula. Because the equation is a ceiling function, if the value of x
contains a fraction, x is rounded up to the next whole number.

x= Lo&@)

Where x = bits per symbol, and y = the number of differential states.
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These symbol table offsets will result in one of the transitions, as shown.

Data Value 00000000 _ Data Value 00000001
with Symbol Table Offset +1 with Symbol Table Offset —1
transition 1 state forward transition 1 state backward
I/0 State Map I/0 State Map
) I/0 States: L4 . 1/0 states: L
+1 [ +1 [ 1

1
B mERQc O

o

B mERQc O

[ J

| 1 Tualue 41 | -1 T Ualue ]

Data Value 00000010 Data Value 00000011
with Symbol Table Offset +2 with Symbol Table Offset O
transition 2 states forward notransition
I/Q State Map I/0 State Map
. I/0 States: L , I/0 States: L
+1 [ 1 +1 [ al
0 0 : ) ( ;
) )
i | i |
1 1
u u
E 10 Q
-1 5 — -1 . d
=1 I Ualue +1 -1 I Ualue +1
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When applied to the user-defined default 4QAM I/Q map, starting from the 1st symbol (data 00),
the differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in
the following illustration.

1st Symbol 5th Symbol
+1 Sy\:ﬂd Symby

0 Data = 0011160001
U 2nd Symbol 4th Symbol
a 4th
1 DataValue  Symbol Table Offset
u 00 +1

01 -1
e 10 +2

11 +0

-1 1@ L}
-1 I Value +1

As you can see from the previous illustration, the Tst and 4th symbols, having the same data value
(00), produce the same state transition (forward 1 state). In differential encoding, symbol values do
not define location; they define the direction and distance of a transition through the I/Q State
Map.

Using Differential Encoding

The signal generator's Differenti al State Map table editor enables you to modify the
differential state map associated with user-defined I/Q and user-defined FSK modulations. In this
procedure, you create a user-defined I/Q modulation and then configure, activate, and apply
differential encoding to the user-defined modulation. For more information, see “Differential
Encoding” on page 404.

Configuring User-Defined 1/Q Modulation
1. Press Preset.
2. Perform the following keypress sequence required for your format type.

For Custom ARB Format

Press Mode > ARB Custom Modulation > Single Carrier Setup > Modulation Type > Select >
More 1 of 2 > Define User I/Q > More > Load Default I/Q Map > QAM > 4QAM.

Or this alternate sequence:
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Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup (desired format) >
Modulation Type > Select > More > Define User I/Q > More 1 of 2 > Load Default I/Q Map >
QAM > 4QAM.

This loads a default 4QAM I/Q modulation and displays it in the 1/Q table editor.

The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11)
mapped into the 1/Q plane using 2 distinct values (1.000000 and —1.000000). These 4 symbols will
be traversed during the modulation process by the symbol table offset values associated with each
symbol of data. Refer to Figure 16-41.

Figure 16-41
[FREQUEHCY N AriPL ITUDE MM  User Tiod Tupe |
6.000 000 000 00 &=z -144.00 aen Loadi/Stores
-]
Lomd Default,
I/0 Ualues 1/0 Map
Data I Value 0 Value
0000000000 | ———————————— [ Differential
Encoding
| Off ]
Conf igure
Differentiale
Encoding
Offset 0
INTE On
10/10/2012 13:58 More 2 of 2

Accessing the Differential State Map Table Editor
Press Configure Differential Encoding.

Thisopensthe D fferential State Mp table editor, as shown. At this point, you see the data
for the 1st symbol (00000000) and the cursor prepared to accept an offset value.You are now
prepared to create a custom differential encoding for the user-defined default 4QAM 1/Q
modulation. Refer to Figure 16-42 on page 408.

Figure 16-42

Data Symbol Table Offset Values Entry Area

ANPLITUDE

-144.00 den

Diff Encode

6.000 000 000/00 &+

Edit Item

Inzert Row

ifferential State Hap
Data Sumbol Table Offset

00000000 | ——— | Delete Row

Goto FRowe

Oelete ALl Rowse

02/20/2012 17:25

Editing the Differential State Map

1. Press 1 > Enter.
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This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward
through the state map by 1 value when a data value of 0 is modulated.

2. Press +/- > 1 > Enter.

This encodes the second symbol by adding a symbol table offset of

1. The symbol rotates backward through the state map by 1 value when a data value of 1 is
modulated.

At this point, the modulation has one bit per symbol. For the first two data
values (00000000 and 00000001) only the last bits (the 0 and the 1,
respectively) are significant.

3. Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates
forward through the state map by 2 values when a data value of 10 is modulated.

4, Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not
rotate through the state map when a data value of 11 is modulated.

At this point, the modulation has two bits per symbol. For the data values
00000000, 00000001, 00000010, 00000011, the symbol values are 00, 01,
10, and 11 respectively.

Applying Custom Differential Encoding
Press Return > Differential Encoding Off On.

This applies the custom differential encoding to a user-defined modulation.

Notice that (UNSTORED) appears nextto Differential State Map on the
signal generator’s display. Differential state maps are associated with the
user-defined modulation for which they were created.

In order to save a custom differential state map, you must store the user-
defined modulation for which it was designed. Otherwise the symbol table
offset data is purged when you press the Confirm Exit From Table Without
Saving softkey when exiting from the 1/Q or FSK table editor.
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17 Multitone and Two-Tone Waveforms (Option 430)

Before using this information, you should be familiar with the basic operation of the signal
generator. If you are not comfortable with functions such as setting the power level and frequency,
refer to Basic Operation on page 39 and familiarize yourself with the information in that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option 430. Option
430 requires Option 653 or 656.
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Creating a Custom Two-Tone Waveform

Using the Two- Tone menu, you can define, and modify user-defined Two-Tone waveforms. Two-
Tone waveforms are generated by the dual arbitrary waveform generator.

The section Using Two-Tone Modulation on page 413 teaches you how to perform the following
tasks:

— Creating a Two-Tone Waveform on page 414
— Viewing a Two-Tone Waveform on page 414
— Minimizing Carrier Feedthrough on page 415

— Changing the Alignment of a Two-Tone Waveform on page 416

Creating a Custom Multitone Waveform

Using the Mul ti t one Set up table editor, you can define, modify and store user-defined multitone
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 418 teaches you how to perform the following tasks:
— Initializing the Multitone Setup Table Editor on page 418

— Configuring Tone Powers and Tone Phases on page 419

— Removing a Tone on page 419

— Generating the Waveform on page 419

— Configuring the RF Output on page 419

412 Keysight EXG and MXG X-Series Signal Generators User’s Guide



Multitone and Two-Tone Waveforms (Option 430)
Using Two-Tone Modulation

Using Two-Tone Modulation

In the following sections, this chapter describes the two-tone mode, which is available only in
Keysight X-Series vector signal generators with Option 430:

— Creating a Two-Tone Waveform on page 414
— Viewing a Two-Tone Waveform on page 414
— Minimizing Carrier Feedthrough on page 415
— Changing the Alignment of a Two-Tone Waveform on page 416

See also: Saving a Waveform’s Settings & Parameters on page 197

For more information about two-tone waveform characteristics, and the
two-tone standard, download Application Note 1410 from our website by
going to http://www.keysight.com and searching for “AN 1410” in Test &
Measurement.

Two-Tone Modulation Softkeys

Mode . .
Becomes active when a change is made to the Freq
: Separation or Alignment Softkeys. Becomes active when Two Tone is
turned On.
\ -
NModulation Hode Tuo Tone Arb Setup -
o T — — — — <\ TGN Setup
- Lo Tone

Dzl FFED an Real-Time ALGN
——————,— an

ARE Custom Freq Separation - Feal-Time AHGM
Hodulation 10.000 KAz > setup®[ Power Contral

Moder
(Totaly page 342

Feal-Time Custom A 1ignment. Feal-Time . .
Hodulat ion® Left AR Aignt Phase Noise Setup®) e 16 Naiies

R

. Il EGMo
ﬂpplﬁgéﬂégg' Carrier to Hg%se

io
0.00 dB

Modulator Atten

Multitonew Arb Setupk " }2.3 [u=]
- anuzl IENEEE
fore 1 of 2 page 418 fore 1 of 2 fore 1 of 2
fodulation Hode Tuo Tone firb Setup
Easeband page 350
Tho-Taoner Frequency Offset
0.000 Hz
Feal-Time Marker
ALGH® Utilities®
Feal-Time
Fhase Moisee
Impairment
Active when Two— see page 188 o
Tone enabled. (Two—Tone’s Arb Setup is similar to the Dual Arb Setup.)
For softkey usage, E "
188. xceptions:
see page 188 > No Waveform Runtime Scaling softkey,
> No Multi-BBG Sync Setup softkey, and
For details on each key, use key help as described on page 40. > No DAC Over—Range Protection softkey
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Creating a Two-Tone Waveform

This procedure describes how to create a basic, centered, two-tone waveform.
1. Preset the signal generator.

2. Set the signal generator RF output frequency to 6 GHz.

3. Set the signal generator RF output amplitude to -10 dBm.

4. Press Mode > More > Two-Tone > Freq Separation > 10 > MHz.

5. Press Two Tone Off On to On.

6. Turn on the RF output.

The two-tone signal is now available at the signal generator RF OUTPUT connector. Figure 17-1 on
page 414 shows what the signal generator display should look like after all steps have been
completed. Notice that the T- TONE, | / Q annunciators are displayed; the RF QN MCD ON  are on;
and the parameter settings for the signal are shown in the status area of the signal generator
display.

Figure 17-1
Mode > Two-Tone
FREQUEHCY AAPLITUDE Tuo Tone
6.00000000000 &z  -10.00 aen Lo
Freq Separation: 10000 000 MHZ Frgg-ggggﬁgtﬁﬂg
ARBTTOHE On
flionment
Fregq Separation: 10.000000MHz Left mgﬁight
Alignment.: Center
For details on
each key, use
key help as
described on RID EEEUEC
page 40. 05/08/2012 12:07  Hore 1 of 2

Viewing a Two-Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two-tone waveform and
its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you
are using.

. Preset the spectrum analyzer.
. Set the carrier frequency to 6 GHz.

1

2

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a -10 dBm reference.
5

. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD
products. A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.
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7. Set the attenuation to 4 dB, so you’re not overdriving the input mixer on the spectrum
analyzer.

You should now see a two-tone waveform with a 6 GHz center carrier frequency that is similar to
the one shown in Figure 17-2 on page 415. You will also see IMD products at 10 MHz intervals
above and below the generated tones, and a carrier feedthrough spike at the center frequency with
carrier feedthrough distortion products at 10 MHz intervals above and below the center carrier
frequency.

Figure 17-2
#Atten 10 dB
Two-Tone
Channels
Intermodulation Carrier
Distortion Feedthrough
For details on each key, use key help as described on page 40. Carrier Feedthrough

Distortion

Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power
between the tones and their intermodulation distortion products. Before beginning this procedure,
it is important that a recent I/Q calibration has been performed on the instrument. The procedure
for performing an 1/Q calibration (refer to “I/Q Calibration” on page 250).

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100 to 200 ms. This will allow you to dynamically view the carrier feedthrough spike as you
make adjustments.

2. On the signal generator, press I1/Q > 1/Q Adjustments > I/Q Adjustments Off On to On.

3. Press Internal Baseband Adjustments > | Offset and turn the rotary knob while observing the
carrier feedthrough with the spectrum analyzer. Changing the | offset in the proper direction
will reduce the feedthrough level. Adjust the level as low as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.
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Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.
On the spectrum analyzer, return the resolution bandwidth to its previous setting.
Turn on waveform averaging.

Create a marker and place it on the peak of one of the two tones.

© © N o o

Create a delta marker and place it on the peak of the adjacent intermodulation product, which
should be spaced 10 MHz from the marked tone.

10.Measure the power difference between the tone and its distortion product.

You should now see a display that is similar to the one shown in Figure 17-3 on page 416. Your
optimized two-tone signal can now be used to measure the IMD products generated by a device-
under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to
periodically readjust your | and Q offsets to keep your signal optimized.

Figure 17-3

Main Marker
#Atten 18 dB

Minimized
Carrier
Feedthrough

Marker a
10.0P0000 MHz
-68.939 dB

Delta Marker

I‘I |
Aty f.n’ﬁ-,"n‘n‘w“ lw"'n"h'?vl bty k',ba‘r-" s, S

For details on each
key, use key help as
described on

page 40.

Changing the Alignment of a Two-Tone Waveform

This procedure describes how to align a two-tone waveform left or right, relative to the center
carrier frequency. Because the frequency of one of the tones is the same as the carrier frequency,
this alignment typically hides any carrier feedthrough. However, image frequency interference
caused by left or right alignment may cause minor distortion of the two-tone signal. This procedure
builds upon the previous procedure.

1. On the signal generator, press Mode > Two Tone > Alignment Left Cent Right to Left.
2. Press Apply Settings to regenerate the waveform.
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Whenever a change is made to a setting while the two-tone generator is
operating (Two Tone Off On set to On), you must apply the change by
pressing the Apply Settings softkey before the updated waveform will be
generated. When you apply a change, the baseband generator creates a
two-tone waveform using the new settings and replaces the existing
waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more
quickly. You should now see a left-aligned two-tone waveform that is similar to the one shown

in Figure 17-4.

Figure 17-4
#Atten 18 dB
Upper Tone
Aligned with
Two-Tone Carrier
Channels Eregliency
Intermodulation
Distortion
For details on each key, use key help as described on page 40. Carrier

Frequency
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Using Multitone Modulation

Multitone Modulation Softkeys

This softkey is active if changes have been made to
the current Multitone waveform in the table editor. The
softkey must be pressed to apply those changes.

Mode
|
— \ Hultitone
Mult itone
{ an
NModulation Hode \
Initialize
Oual ARE® \ Table?] page 418
Edit
e \ e —page 19
Feal-Time Custom, ( Arb Setup ] Arb Setup
Modulat ion® page 420 / Baseband
Freguency Offset
Real-Time Load/Stores page 420 0.000 Hz
ApPplications F——
Hore 1 of 2 Setop®
Multitonesi—
Feal-Time
fore 1 of 2 Fhase Moise Setup
Multitone
Arb Setupk -
Modulator Atten
12.43 dB
Hanual
Active when Knore 1of 2 /
Multitone enabled,
For softkey usage, Marker,
see page 187 Utilities page 187
see page 188
(Multitone’s ARB Setup is similar to Dual Arb Setup.)

Exceptions:

> No Waveform Runtime Scaling softkey,
> No Multi-BBG Sync Setup softkey, and
> No DAC Over—Range Protection softkey
For details on each key, use key help as described on page 40.

Initializing the Multitone Setup Table Editor

1. Press Preset.
2. Press Mode > Multitone
3. Press Initialize Table > Number of Tones > 5 > Enter.

4. Press Freq Spacing > 20 > kHz.
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Figure 17-5
FREQUEHCY RF_OFF Init Tones
6.000 000 000 00 &z Hurber. 0F Tones
Humber of Tones: 5 Freg Spacing
fultitone Setup: default CUNSTORED) 20.000 kHz
Tone Freq Offset Pouer Phase State
1 —L0.000 kHz u] on Initialize Phase
2 —20.000 kHz 0.00 dB u] 0n 5l Random
3 0.000 kHz 0.00 dB u] on
L 20.000 kHz 0.00 dB u] on
b LO.000 kHz 0.00 de u] on
Done
03/08/2012 12: 14 Hore 1 of 2
Init Tones The Random Seed
softkey that affects the
- Handagﬂgg%d 1 Multitone’s phase values
is not used in the following
examples and is shown
For details on each key, use key help as described on page 40. for reference, only.

5. Press Done.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at
the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center
tone.

Configuring Tone Powers and Tone Phases

1. Highlight the value (0 dB) in the Power column for the tone in row 2.
2. Press Edit Table > Edit Iltem > -4.5 > dB.

3. Highlight the value (0) in the Phase column for the tone in row 2.

4. Press Edit Item > 123 > deg.

Removing a Tone

1. Highlight the value (On) in the St at e column for the tone in row 4.
2. Press Toggle State.

Generating the Waveform
Press Return > Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections.
During waveform generation, the M TONE and | / Qannunciators activate and the multitone
waveform is stored in volatile ARB memory. The waveform is now modulating the RF carrier.

Configuring the RF Output
1. Set the RF output frequency to 100 MHz.
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2. Set the output amplitude to O dBm.
3. Press RF On/Off.

The multitone waveform is now available at the signal generator’s RF OUTPUT connector.

Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made
inthe Mul ti t one Set up table editor, you must apply the changes before the updated waveform
will be generated.

From the Mul tit one Set up table editor, press the following key to apply the changes and
generate a multitone waveform based on the updated values: Apply Multitone
Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone
waveform, complete the steps in the previous section, Creating a Custom Multitone Waveform on
page 412.

1. Press Load/Store > Store To File.

If there is already a file name from the Cat al og of MIONE Fi | es occupying the active entry
area, press the following keys (see page 41):

Edit Keys > Clear Text

2. Enter a file name (for example, 5TONE) using the alpha keys and the numeric keypad with a
maximum length of 23 characters (see page 41).

3. Press Enter.

The multitone waveform is now stored in the Cat al og of MIONE Fi | es.

The RF output amplitude, frequency, and operating state settings are not
stored as part of a multitone waveform file. Similarly, the multitone
settings are not stored as part of the instrument state. Therefore, in most
cases you should save both the instrument states and the multitone
settings to be able to restore all of your settings later.
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Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s
memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous
sections, Creating a Custom Multitone Waveform on page 412 and Storing a Multitone
Waveform on page 420, then preset the signal generator to clear the stored multitone waveform
from volatile ARB memory.

1. Press Mode > Multitone.

2. Press Load/Store.

3. Highlight the desired file (for example, STONE).

4. Press Load From Selected File > Confirm Load From File.
5. Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the
multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 419.
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— Display on page 424
— Signal Generator Lock-Up on page 424
— RF Output on page 425

— No RF Output

— Power Supply Shuts Down

— No Modulation at the RF Output

— RF Output Power too Low

— Distortion

— Signal Loss While Working with a Spectrum Analyzer
— Signal Loss While Working with a Mixer

— Sweep on page 429

Cannot Turn Off Sweep

Sweep Appears Stalled

Incorrect List Sweep Dwell Time

— List Sweep Information is Missing from a Recalled Register
— Amplitude Does Not Change in List or Step Sweep

— Internal Media Data Storage on page 430

— Instrument State Saved but the Register is Empty or Contains the Wrong State
— USB Media Data Storage on page 430

— Instrument Recognizes USB Media Connection, but Does Not Display Files
— Preset on page 430

— The Signal Generator Does Not Respond
— Pressing Preset Performs a User Preset

— Error Messages on page 431

— Front Panel Tests on page 432

— Self Test Overview on page 432

— Licenses on page 434

— Contacting Keysight Technologies on page 435

— Returning a Signal Generator to Keysight
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Display

Display

The Display is Too Dark to Read

Brightness may be set to minimum. Use the figure in “Display Settings” on page 27 to locate the
brightness softkey and adjust the value so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black.
Cycle instrument power.

Signal Generator Lock-Up

— Ensure that the signal generator is not in remote mode (the Rannunciator shows on the display).
To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

— Ensure that the signal generator is not in local lockout, which prevents front panel operation. For
information on local lockout, refer to the Programming Guide.

— If a progress bar appears on the signal generator display, an operation is in progress.
— Preset the signal generator.

— Cycle power on the signal generator.
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RF Output

No RF Output
— Check the RF ON/OFF LED (shown on page 5). If it is off, press RF On/Off to turn the output on.

— Ensure that the amplitude is set within the signal generator’s range.

— If the instrument is playing a waveform, ensure that marker polarity and routing settings are
correct (see “Saving Marker Polarity and Routing Settings” on page 204).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the
instrument, send the signal generator to an Keysight service center for repair (see “Contacting
Keysight Technologies” on page 435).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are
on. See also “Modulating the Carrier Signal” on page 54.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on
(the I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating
within the signal generator’s specified limits.

RF Output Power too Low

— If the AMPLI TUDE area of the display shows the GFFS indicator, eliminate the offset:

Press Amptd > More 1 of 2 > Amptd Offset > 0 > dB. See also “Setting an Output Offset” on
page 106.

— If the AMPLI TUDE area of the display shows the REF indicator, turn off the reference mode:
1. Press Amptd > More > Amptd Ref Off On until O f highlights.
2. Reset the output power to the desired level.
See also “Setting an Output Reference” on page 107.

— If you are using the signal generator with an external mixer, see page 427.

— If you are using the signal generator with a spectrum analyzer, see page 426.

— If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display
the sequence header information and recalculate the RMS value (see page 197).
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Signal Loss While Working with a Spectrum Analyzer

To avoid damaging or degrading the performance of the signal generator,
do not exceed 33 dBm (2W) maximum of reverse power levels at the RF
input. See also Tips for Preventing Signal Generator Damage on
www.keysight.com.

The effects of reverse power can cause problems with the RF output when you use the signal
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating
mode (described on page 102).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF
output. The rate of the undesired AM equals the difference in frequency between the spectrum
analyzer’s LO feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes.
See:
— “ALC Off Mode” on page 102

and

— “Power Search Mode” on page 103
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Troubleshooting
RF Output

Signal Loss While Working with a Mixer

To avoid damaging or degrading the performance of the signal generator,
do not exceed 33 dBm (2W) maximum of reverse power levels at the RF
input. See also Tips for Preventing Signal Generator Damage on
www.keysight.com.

To fix signal loss at the signal generator’s RF output during low-amplitude coupled operation with
a mixer, add attenuation and increase the RF output amplitude.

The figure at right shows a

configuration in which the signal Effects of Reverse Power on

generator provides a low _
. . . Signal Generator
amplitude signal to a mixer. Output Control
The internally leveled signal ALC RE Mixer
generator RF output (and ALC "6 dam e
level) is RE " -
Level =
~8 dBm. The mixer is driven with <j
an LO of +10 dBm and has an LO- Detector o LO Level
to-RF isolation of 15 dB. The r?]itaesclﬂs measures Feedltjhru =+10 dBm
. _ -5dBm =-5dBm
resulting ALC love G roverse i
-5 dBm LO feedthrough enters the

signal generator’s RF output
connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector.
Because the detector responds to its total input power regardless of frequency, this excess energy
causes the ALC to reduce the RF output. In this example, the reverse power across the detector is

actually greater than the ALC level, which can result in loss of signal at the RF output.
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RF Output

The solution at right shows a
similar configuration with the
addition of a 10 dB attenuator
connected between the RF output
of the signal generator and the
input of the mixer. The signal
generator’s ALC level increases to
+2 dBm and transmits through a
10 dB attenuator to achieve the
required -8 dBm amplitude at the
mixer input.

Compared to the original
configuration, the ALC level is 10
dB higher while the attenuator
reduces the LO feedthrough (and

Reverse Power Solution

Signal Generator

Output Control
ALC Level/ gEt ot _
RF Output = —8p Mixer
=+2dBm -
RF 10 dB
Level ™| ATTEN —'j Lo
Detector Detector LO LO Level
measures measures Feedthru =+10 dBm
+2 dBm -15dBm =_5dBm
ALC level reverse IF
power

the signal generator’s RF output) by 10 dB. Using the attenuated configuration, the detector is
exposed to a +2 dBm desired signal versus the

-15 dBm undesired LO feedthrough. This 17 dB difference between desired and undesired energy
results in a maximum 0.1 dB shift in the signal generator’s RF output level.
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Troubleshooting
Sweep

Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see
“Configuring a Swept Output” on page 46). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq
Sweep > Sweep > Amptd
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey.

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to
Free Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time

1. Press Sweep > More > Configure List Sweep.
2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them.
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step
sweep rather than list sweep.

See also “Configuring a Swept Output” on page 46.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register.
Only the current list sweep is available to the signal generator. You can store list sweep data in the
instrument catalog (see “Loading (Recalling) a Stored File” on page 61).
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Troubleshooting
Internal Media Data Storage

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep
type is set to frequency (Freq) or waveform.

Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong
State

If the register number you intended to use is empty or contains the wrong instrument state, recall
register 99. If you selected a register number greater than 99, the signal generator automatically
saves the instrument state in register 99.

See also “Working with Instrument State Files” on page 62.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the
signal generator; try a different USB media. Refer to http://www.keysight.com/find/mxg for
details on compatible USB media.

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which
locks the keypad.

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward-compatible SCPI command. To return the signal
generator to normal use, send the command : SYST: PRESet : TYPE NCRM

For information on SCPI commands, refer to the SCPI Command Reference.
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Troubleshooting
Error Messages

Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query
error does not generate a device-specific, execution, or command error.

Query Errors (-499 to -400) indicate that the instrument’s output queue control has detected a
problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this
class set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These
errors correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

— Either an attempt is being made to read data from the output queue when no output is either
present or pending, or

— data in the output queue has been lost.

Device Specific Errors (-399 to -300, 201 to 703, and 800 to 810) indicate that a device operation
did not properly complete, possibly due to an abnormal hardware or firmware condition. These
codes are also used for self-test response errors. Errors in this class set the device-specific error bit
(bit 3) in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates
that the instrument detected an error within the GPIB system, within the instrument’s firmware or
hardware, during the transfer of block data, or during calibration.

Execution Errors (-299 to -200) indicate that an error has been detected by the instrument’s
execution control block. Errors in this class set the execution error bit (bit 4) in the event status
register (IEEE 488.2, section 11.5.1). In this case:

— Either a <PROGRAM DATA> element following a header was evaluated by the device as outside
of its legal input range or is otherwise inconsistent with the device’s capabilities, or

— avalid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed.
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (-199 to -100) indicate that the instrument’s parser detected an IEEE 488.2
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE
488.2, section 11.5.1). In this case:

— Either an IEEE 488.2 syntax error has been detected by the parser (a control-to-device message
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data
element that violates device listening formats or whose type is unacceptable to the device.), or

— an unrecognized header was received. These include incorrect device-specific headers and
incorrect or unimplemented IEEE 488.2 common commands.

Error Message File A complete list of error messages is provided on the CDROM supplied with the
instrument. In the error message file, an explanation is generally included with each error to further
clarify its meaning. The error messages are listed numerically. In cases where there are multiple
listings for the same error number, the messages are in alphabetical order.
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Front Panel Tests

Front Panel Tests

@

Utility Instrument Info
I/0 Configk Diagnostic Infor TFront Panel Test | _?et atll distplay pixells to th? selected colork
0 return to normal operation, press any key.
Pixelr/ P p Y KeY
Instrument., ) Screen Tests
Adjustments Options Infoe
LED Blirk TestM Blink RF On/Off, Mod on/Off, and More LEDs
DSllEu Self Teste
Keu Testr Displays a keyboard map.
Power On/y Installed, As you press a key, the map indicates the key
Preset Board Info location.
RPG Testhk .
Instrument InfoM—® oot Panel Toastok|l— \ Correct operation:
FullCCW = 10
—flore 1 of 2 Full CW = 10

For details on each key, use key help
as described on page 40.

Self Test Overview

The self test is a series of internal tests that checks different signal generator functions. The self
test, is also available by via the remote web interface. For more information on the Web-Enabled
MXG, refer to the Programming Guide.

FREQUEHCY RF_OFF

6.000 000 000 00 &+

Self Test Summary

The current status of self test is: Failure
One or more tests have failed. Sustem disgnostics
indicate this test as the root failure: 707
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Utility > Instrument Info ————Tnstrument Info

FREQUEHCY

6.000 000 000 00 &+

Self Test Summary

Dimgnostic Infoe

Options Infoe

Self Testk

Installed,
Eoard Info

Front. Panel Testse

RF_OFF

C

The current status of self test is: InCDI‘I‘DlBt;B\
Mot all tests hawve been run.

Self Test

Fun_Complete
Self Test

Troubleshooting
Self Test Overview

Automatically runs diagnostic
self test.

Self Test Summary displays
current status.

o4/ 1h /2012

17:LL

Opens a table in which user
selects specific tests and view

View Test Infow

FREQUEHCY

6.000 000 000 O

RF_OFF

= T T
101 Digital FFGA

102 Digital JTAG

103 Dioital Woltages
104 Board Temperature
105  Sweep Out

-——— RF: Reference Self Tests

201 Reference Voltages

202  Reference 100MHz Tank DAC

Self Test
View Detailse
Rurn Highlighted

4 Select /Deselect

Select /Deselect
A1l

203 Reference Tuning Woltage (Internal Ref)

Fun Selected

17:L47 fore 1 of 2

For details on each key, use key help
as described on page 40.

Self Test

Loop Selected

Go To Testk
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details in Test Editor display.

Displays detailed
information of highlighted
test. Refer to page 40

Executes highlighted

operation.

Selects or deselects
highlighted operation.

Selects or deselects all
operations.

Executes all selected
operations.

Runs a loop of selected

Opens the Go To Menu.
| Adds navigation keys to
the self test menu.

tests until a failure occurs.
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Troubleshooting
Licenses

Licenses

A Time-Based License Quits Working

— The instrument’s time or date may have been reset forward causing the time-based license to
expire.

— The instrument’s time or date may have been reset backward more than approximately 25 hours,
causing the instrument to ignore time-based licenses.

See page 29 for details and cautions on setting time and date.

Cannot Load a Time-Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours,
causing the instrument to ignore time-based licenses.

See page 29 for details and cautions on setting time and date.
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Troubleshooting
Contacting Keysight Technologies

Contacting Keysight Technologies

— assistance with test and measurements needs, and information on finding a local Keysight
office:
http://www.keysight.com/find/assist

— accessories or documentation: http://www.keysight.com/find/X-Series_SG.
— new firmware releases: http://www.keysight.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

In any correspondence or telephone conversation, refer to the signal
generator by its model number and full serial number. With this
information, the Keysight representative can determine whether your unit
is still within its warranty period.

Returning a Signal Generator to Keysight
Use the following steps to return a signal generator to Keysight Technologies for servicing:
1. Gather as much information as possible regarding the signal generator’s problem.

2. Call the phone number listed on the Internet (http://www.keysight.com/find/assist) that is
specific to your geographic location. If you do not have access to the Internet, contact your
Keysight field engineer.

After sharing information regarding the signal generator and its condition, you will receive
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar
packaging to properly protect the signal generator.
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Keysight X-Series Signal Generators
N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

19 Working in a Secure Environment

If you are using the instrument in a secure environment, you may need details of how to clear or
sanitize its memory, in compliance with published security standards of the United States
Department of Defense, or other similar authorities.

For the Series B MXG and EXG instruments, this information is contained in the PDF document
"Security Features and Document of Volatility". This document is not included in the
Documentation CD, but it may be downloaded from Keysight's web site, as described below.

The document includes the following topics:
— Security Terms and Definitions
— Instrument Memory Types

— Memory Clearing and Sanitization (Erase All, Erase and Sanitize All functions—requires
Option 006)

— Clearing Persistent State information

— Using the Secure Display feature (also documented in Using Secure Display (Option 006) on
page 438 below and requires Option 006)

— Using Restricted Display on page 439—not in the "Security Features and Document of Volatility"

— Declassifying a Faulty Instrument

How to Obtain the Security Features Document

Step Action

1 Click on or browse to the following URL:
http://www.keysight.com/find/security

2 To locate and download the document, select Model Number "N5183B", "N5182B", “N5181B”,
"N5173B", “N5172B” or “N5171B” then click "Submit".
3 Follow the on-screen instructions to download the PDF file.
KEYSIGHT

TECHNOLOGIES
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http://www.agilent.com/find/security

Working in a Secure Environment
Using Secure Display (Option 006)

Using Secure Display (Option 006)

This function prevents unauthorized personnel from reading the instrument display or tampering
with the current configuration via the front panel. When Secure Display is active, the display is
blank, except for an advisory message, as shown in Figure 19-1 below. All front panel keys are
disabled.

To set Secure Display, press: Utility > Display > More > Activate Secure Display >
Confirm Secure Display.

Once Secure Display has been activated, the power must be cycled to re-enable the display and
front panel keys.

Figure 19-1 Signal Generator Screen with Secure Display Activated

(]
(]
(]
** SECURE DISPLAY ACTIVATED *+ :[3
(]
(]
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Using Restricted Display

Using Restricted Display

While in restricted display mode, all frequency information is hidden and the front panel frequency
control is disabled.

To set Restricted Display, perform the following key presses:
Utility > Display > More > Activate Restricted Display > Confirm Restricted Display.

Once Restricted Display has been activated, an instrument preset or power cycle is required to
re-enable the front panel frequency control.
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Glossary

A

Active Entry The currently selected, and therefore editable, entry or parameter

ARB Arbitrary waveform generator

Avionics Avionics is a term used to describe the electronic instrumentation on aircraft.
AWG Arbitrary waveform generator. Additive white Gaussian noise

B

BBG Media Baseband generator media. Volatile memory, where waveform files are played or
edited.

BNC Connector Bayonet Neill-Concelman connector. A type of RF connector used to terminate
coaxial cable.

C

CCW Counterclockwise

C/N Carrier-to-noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 47), the time that the signal is settled and you can make a
measurement before the sweep moves to the next point.

E

EVM Error vector magnitude; the magnitude of the vector difference at a given instant between the
ideal reference signal and the measured signal.

F
Filter factor Alpha The filter’s alpha coefficient. It is only valid for root Nyquist and Nyquist filters.

Filter Factor BbT The filter's bandwidth-bit-time (BbT). It is only valid for a Gaussian filter (similar
to alpha). BbT is defined by the GSM standard as 0.3 and by the DECT standard as 0.5.
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G

Gaussian filter The Gaussian filter does not have a zero Inter-Symbol Interference (ISI). Wireless
system architects must decide just how much of the ISI can be tolerated in a system and combine
that with noise and interference. The Gaussian filter is Gaussian shaped in both the time and
frequency domains, and it does not ring like the root Nyquist filters do. The effects of this filter in
the time domain are relatively short and each symbol interacts significantly (or causes ISI) with only
the preceding and succeeding symbols. This reduces the tendency for particular sequences of
symbols to interact, which makes amplifiers easier to build and more efficient.

GPIB General purpose interface bus. An 8-bit parallel bus common on test equipment.

H

Hard key A labeled button on the instrument.

|

IF Intermediate frequency

Int Media Internal media. Nonvolatile signal generator memory, where waveform files are stored.

IP Internet protocol. The network layer for the TCP/IP protocol suite widely used on Ethernet
networks.

L

LAN Local area network

LO Local oscillator

LXI LAN eXtension for Instrumentation. An instrumentation platform based on industry standard
Ethernet technology designed to provide modularity, flexibility, and performance to small- and
medium-sized systems. See also http://www.lxistandard.org

M

Modulation Format Custom modulation, Two-Tone, or Multitone.

Modulation Mode Dual ARB, Custom modulation, Two-Tone, or Multitone.

Modulation Standard Refers to a Cellular standard format (i.e. NADC, PDC, PHS, etc.).
Modulation Type Refers to the various I/Q constellation types (i.e. PSK, MSK, FSK, C4FM, etc.)
N

Non - volatile That which survives a power cycle (such as files stored in USB media).
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Nyquist filter Also referred to as a cosine filter. These filters have the property that their impulse
response rings at the symbol rate. Adjacent symbols do not interfere with each other at the symbol
times because the response equals zero at all symbol times except the center (desired) one.

P
Persistent That which is unaffected by preset, user preset, or power cycle.

Point-to-point Time In a step sweep (page 47), the sum of the dwell time, processing time,
switching time, and settling time.

R

Rectangular filter Also referred to as a ideal low pass filter. These filters have very steep cut-off
characteristics. The pass band is set to equal the symbol rate of the signal. Due to a finite number
of coefficients, the filter has a predefined length and is not truly “ideal”. The resulting ripple in the
cut-off band is effectively minimized with a Hamming window. This filter is recommended for
achieving optimal ACP. A symbol length of 32 or greater is recommended for this filter.

Root Nyquist filter Also referred to as a Root cosine filter. These filters have the property that their
impulse response rings at the symbol rate. Adjacent symbols do not interfere with each other at the
symbol times because the response equals zero at all symbol times except the center (desired) one.
Root Nyquist filters heavily filter the signal without blurring the symbols together at the symbol
times. This is important for transmitting information without errors caused by ISI. Note that ISI does
exist at all times except the symbol (decision) times. A cascade of two of these filters has the
transfer function of a Nyquist filter. One is in the transmitter, the other in the receiver, so that the
system taken as a whole has the zero-ISI properties of an IS filter.

RMS Root mean square. A time-varying signal’s effective value (the equivalent DC voltage required
to generate the equivalent heat across a given resistor). For a sinewave, RMS = 0.707 x peak value.

S

Softkey A button located along the instrument’s display that performs whatever function is shown
next to it on that display.

T

TCP Transmission control protocol. The most common transport layer protocol used on Ethernet
and the Internet.

Terminator A unit indicator (such as Hz or dBm) that completes an entry. For example, for the entry
100 Hz, Hz is the terminator.

Type-N Connector Threaded RF connector used to join coaxial cables.

U

USB Universal serial bus. See also http://www.usb.org
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User FIR Selects a user-defined set of coefficient values. Each line in the FIR values table contains
one coefficient value. The number of coefficient values listed must be a multiple of the selected
oversampling ratio. Each coefficient applies to both | and Q components.

V

Volatile That which does not survive a power cycle (such as files stored in BBG media).
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Index

Symbols

, 254
oM
annunciator, 9
dc offset, removing, 163
hardkey, 159
softkeys, 159, 163
# points softkey, 47
# Skipped Points softkey, 208

Numerics

10 MHz OUT connector, 14, 23,
24
100Base-T LAN cable, 32
128 QAM softkey, 363,367, 368,
369, 370,371,372,375
16-Lvl FSK softkey, 363, 367,
368, 369, 370,371, 372,375
16QAM softkey, 363, 367, 368,
369, 370,371,372,375
2’s complement
description, 304,318
256 QAM softkey, 363, 367, 368,
369, 370,371,372,375
2-Lvl FSK softkey, 363,367, 368,
369, 370,371,372,375
32QAM softkey, 363,367, 368,
369, 370,371,372,375
430, option
multitone mode, 418
two-tone, 413
two-tone mode, 413
4-Lvl FSK softkey, 363,367, 368,
369, 370,371,372,375
4QAM softkey, 363,367, 368,
369, 370,371,372,375
628, error, 247
64QAM softkey, 363,367, 368,
369, 370,371,372,375
651/652/654, option
description, 4
multitone mode, 418
two-tone mode, 413
8557D GPIB only softkey, 33, 35
8648A/B/C/D GPIB only
softkey, 33,35
8656B,8657A/B GPIB only
softkey, 33,35

8-Lvl FSK softkey, 363,367, 368,

369, 370, 371,372,375

A

AC power receptacle, 12, 21
ACP, 360
Activate Secure Display
softkey, 27
active
entry, 441
entry area, 9
Active High softkey, 220
Active Low softkey, 220
Add Comment To softkey, 63
additive white Gaussian noise.
See AWGN
address, GPIB, 31
Adjust Phase softkey, 43,45
Adjustable doublet
softkey, 170
adjustments
1/Q, 182,249
quadrature, 249
real-time phase noise, 353
advance, segment, 222
Advanced Settings softkey, 32
Aeroflex softkey, 33, 35
ALC
hold, 204,205
OFF annunciator, 9
off mode, 102
softkeys, 43, 45, 208
alc
setting, 45
All softkey, 57
Alpha, 441
AM
annunciator, 9
external source, 163
hardkey, 159
softkeys, 159
wideband, 164
amplitude
display area, 10
hardkey, 43, 45
LF output, 166, 167
modulation, 159
offset, 106
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reference, 107
setting, 43,45
troubleshooting sweep, 430
AMPTD hardkey, 43, 45
analog modulation, 3, 159
configuring, 160, 165
angle, quadrature, 182
annunciators, 9
APCO 25 w/C4FM softkey, 362,
366
APCO 25 w/CQPSK
softkey, 362, 366
apodization settings, FIR
filter, 260, 401
Apply To Waveform
softkey, 208
ARB
definition, 441
player, dual, 187
softkeys, 187,218,343, 344,
345, 346, 350, 356
waveform clipping, 226
arb, 360
Arb Custom
FIR filters, 394
FIR table editor, 401
Arb Segment softkey, 62
Arb Sequence softkey, 62
arb setup
softkey, 263
ARMED annunciator, 9
arrow keys, 41
ASK Depth softkey, 363, 367,
368, 369, 370,371, 372,375
ASK softkey, 363, 367, 368, 369,
370,371,372,375
ATTEN HOLD annunciator, 9
Atten/ALC Control softkey, 43,
45
Auto softkeys
(DHCP/Auto-IP), 32
Auto, 79,102
Recall, 112
AUTOGEN_WAVEFORM
file, 360
auto-IP, 32
Auto-IP softkey, 32
Automatically Use USB Media
If Present softkey, 57
AUX 1/0 connector, 17



Index

Auxiliary Software Options
softkey, 37
Avionics
definition, 441
Avionics (VOR/ILS)
Option 302, 113
Avionics Softkey Menus, 113,
319, 320, 321, 322
AWGN
adding, 341
annunciator, 9
definition, 441
dual ARB player, 342
softkeys, 348
AWGN softkeys, 343, 344, 345,
346

B

backspace hardkey, 41
bandwidth ratio, 348
Bandwidth softkey, 348
baseband, 17

aligning signals at, 204

clipping, 226

frequency offset

softkey location, 241

frequency offset, setting, 241
I/Q output connectors, 15
memory, 187

noise, 341

noise annunciator, 9
quadrature adjustment, 249

real time I/Q AWGN, 343, 344,

345, 346, 348
softkey, 241
summing signals, 248
waveforms convert to
analog, 236
baseband frequency offset
DAC over range &
scaling, 243
softkey, 241
baseband generator, 360
custom arb mode, 4
dual arb mode, 4
multiple BBG
synchronization, 265
multitone mode, 4,418
two-tone mode, 413
BB GEN, 248
BBG
media, 187,189
media (definition), 441
Memory softkey, 62
Memory to USB softkey, 62

446

routing, 248
Segments softkey, 57,197
BBG sync, 265
configure setup, 268
equipment setup, 268
resynchronization, 270
system, 267
system delay, 266
trigger setup, 267
BbT, 441
BERT
Option UN7, 319
Binary softkey, 57
bit file editor, using, 368
bits per symbol, equation, 405
Bk Sp hardkey, 41
Bluetooth softkey, 362,363, 366,
367,368, 369, 370, 371, 372,
375
BNC, 441
Bright Color softkey, 27
brightness adjustment, 27
Brightness softkey, 27
Buffered Trig softkey, 220
Build New Waveform Sequence
softkey, 192,216
Burst Envelope softkey, 246
Bus softkey, 46

C

C/N, 441
C4FM softkey, 363,367, 368,
369, 370, 371,372,375
cables
crossover, 32
multi-BBG sync, 266
cables, 100Base-T LAN, 32
Calculate softkey, 197
calibration
1/Q, 250
softkey, 250
Calibration Type softkey, 250
Cancel hardkey, 6
carrier
bandwidth, 342
configuring, 44
feedthrough, 182
modulating, 54
softkeys, 343, 344,345, 346
to noise ratio, 342
Carrier Bandwidth
softkey, 343, 344,345,346
carrier feedthrough,
minimizing, 415

Carrier Softkey, 343, 344, 345,
346

Carrier to Noise softkey, 343,
344

Carrier+Noise softkey, 343, 345,
346

Catalog Type softkey, 57,58,62,
197

catalog, state files, 66
ccw, 441
CDPD softkey, 362, 363, 366,
367, 368, 369, 370, 371, 372,
375
ceiling function, bits per
symbol, 405
Channel Band softkey, 43, 45
channel bandwidth, 348
Channel Number softkey, 43, 45
circular clipping, 230, 233
classified. See security
Clear softkeys
Error Queue(s), 68
Header, 197
Text, 41
clipping
circular, 230, 233
rectangular, 231, 234
softkeys, 226
clock adjustment
phase and skew, 295
clock gate, 324
clock rate limits, logic type
output, 286
clock source
setting, 307,314
clock timing
parallel data, 297
parallel interleaved data, 293
phase and skew, 295
serial data, 294
clock, sample rate, 17
clocking, frequency
reference, 289
clocking, frequency reference
diagrams, 290
clocks per sample
parallel data, 291
parallel interleaved data, 293
coefficient values,
entering, 255, 396
color palette, display, 27
COM/ID Softkey Menus, 124
comments, adding & editing
(instrument state), 64
common frequency reference
diagrams, 290
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component test, 360
Config Type softkey, 32
Configure softkeys
Cal Array, 83
List Sweep, 46, 49
Step Array, 83
Step Sweep, 46,47
Confirm Load From File
softkey, 61
Connection Monitoring
softkey, 32
Connection Type softkeys
Sockets, 85
USB, 85
VXI-11, 85
connections
common frequency
reference, 290
connectors
external triggering
source, 223,225
front panel, 5
rear panel
n5161a, 12,21
n5162a, 12,21
n5181a, 12,21
n5182a, 12,27
routing signals, 47
Continuous softkey, 220
continuous step sweep
example, 52
continuous wave
description, 3
continuous wave output, 44
contrast adjustment, 27
Contrast softkey, 27
Copy & softkeys
Play Sequence, 61
Play Waveform, 61
Select User Flatness, 61
Select User Flatness
Corrections, 61
Copy softkeys
All Files, 62
File, 57
File to Instrument, 57,62
File to USB, 62
correction array (user
flatness), 88
viewing, 89
See also user flatness
correction
corrections, internal
channel, 97
cosine filter. See nyquist filter
Create Directory softkey, 57,62

crossover cable, 32
custom
multicarrier TDMA waveforms
creating, 391
TDMA digital modulation, 379
custom arb, 275, 360
Custom ARB softkeys, 275, 361,
365
custom arb waveform
generator, 4
custom mode, 360
custom modulation
adding to a waveform, 379
waveform, adding to, 379
CW, 447
CW (no modulation)
softkey, 49
CW mode
description, 3

D

DAC over range error, 236, 241
DAC over range protection
baseband frequency
offset, 243
phase noise, 354
Dark Color softkey, 27
data
entry softkeys, 41
erasing, 437
files, 56t0 62
removing, 437
serial, synchronizing, 17
storage
comments, adding and

editing, 64
troubleshooting, 430
type, 67
using, 56

data files
creating, 369
modifying, 371
data filtering, pre or post
fir, 304,317
data processing, 331
data types, 299
date, setting, 29
dc offset, 182
dc offset, removing, 163
DCFM®/DCfM Cal softkey, 161
Declassifying faulty
instrument, 437
DECT softkey, 362, 366
Default Gateway softkey, 32
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default settings
restoring, 28, 32, 250
system, restoring, 40
Default softkey, 362, 366
delay
1/Q, 249
multiple BBG sync, 266
Delete softkeys
All Regs in Seq, 63
All Segments On Int
Media, 189
All Segments On USB
Media, 189
All Sequence Files, 57
All Sequences, 63,112
All Waveforms, 192
All Waveforms softkey, 216
File, 57
File or Directory, 57,59, 62,67
Item, 49
Row, 49
Selected Waveform, 192,216
Seq Reg, 63
Waveform Sequence, 216
description & plots, phase
noise, 357
DETHTR annunciator, 9
device clock source
selection, 307,314
Device softkey, 43,45
DHCP, 32, 441
DHCP softkey, 32
diagram
data types, 299
diagrams
clock timing
parallel data, 291
parallel interleaved
data, 293
phase and skew, 295
serial data, 294
common frequency
reference, 290
Diff Mode softkeys, 249
differential encoding, 404
differential encoding, bits per
symbol, 405
differential state map, bits per
symbol, 405
DIGBUS annunciator, 9
digital bus, 16
digital modulation
formats, 4
IQ map, QAM, 404
multitone, 418t0421
TDMA, 379
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two tone, 413t0417
digital modulation type
modifying, 381
digital operation, 185,276
Digital Signal Interface Module
Option 003 or 004, 319
digital signal interface module
N5102A, 285
digital signal to analog
waveform, 236
discrete steps, skew range, 295
display
blanking, 437
error message area, 10
overview, 5
overview,
N5181A/82A/83A, 9
secure, 437
settings, 27
softkey labels, 11
softkeys, 25,41, 208
tests, 432
text area, 10
troubleshooting, 424
Display softkeys
Case, 41
display, 25
Waveform And Markers, 208
Displayed Case softkeys, 41
distortion, troubleshooting, 425
DNS Server Override
softkey, 32
DNS Server softkey, 32
documentation, xv
Domain Name softkey, 32
doublet
adjustable, 172
softkeys, 170
trigger, 172
Dual ARB
FIR table editor, 255, 260
real-time modulation, 263
user-defined FIR, 255
dual ARB
multi-BBG sync, 265
player, 187
real-time noise, 342
softkeys, 188,343, 344, 345,
346, 350, 356
dual arb, 360
dual ARB player, 4
Dual ARB Real-Time
filters, 254
dual arbitrary waveform
generator, 4
dual display, power meter, 70

448

dwell time, 49, 447

Dwell Type softkey, 49

dwell, troubleshooting, 429

Dynamic DNS Naming
softkey, 32

Dynamic Hostname Services
softkey, 32

E

E4428C, E4438C softkey, 33,35
E442xB, E443xB softkey, 33,35
E8241A, E8244A, E8251A,
E8254A softkey, 33, 35
E8247C, E8257C, E8267C
softkey, 33,35
E8257D, E8267D softkey, 33, 35
EDGE
custom digital modulation,
predefined, 379
EDGE softkey, 362, 366
Edit softkeys
Description, 197
Noise RMS Override, 197
Repetitions, 216
RMS, 197
Selected Waveform
Sequence, 192,216
Editing Keys softkey, 41
Editing Mode softkey, 41
editor, bit file, 368
Enable/Disable Markers
softkey, 192,216
Enter Directory softkey, 61
entry, active, 447
equalization
filter, 252
filter, user, 252
equipment setup, 268
equipment, user flatness
correction, 84, 85
Erase All, 437
Erase and Sanitize All, 437
ERR annunciator, 10
Error hardkey, 68
error messages, 68
DAC over range, 236, 241
display area, 10
message format, 68
types, 431
Esc hardkey, 6
EVENT
connector, AUX I/0, 17
connector, BNC, 15, 203
output jitter, 218
outputs, 203

EVM, 441
EVM error, 182
example
Waveform license, Opt 25x
adding a waveform, 287
locking a slot, 281
examples
FIR filters
creating, 255, 394, 396
modifying, 260, 401
LF output, configuring, 165
Execute Cal softkey, 250
EXT CLOCK connector, 15
EXT REF annunciator, 9,10

Ext softkeys
Delay, 221
Delay Time, 221
Ext, 46
I/Q Output, 246, 247
Pulse, 170
Source, 221
extension, file, 61
external
I and Q signals, 248
media, 67,430

modulation source, 163
reference oscillator, using, 44
trigger source, 223,225
triggering, 225
external clock source
selection, 307,314
external leveling, 95to 101
softkeys, 95
external leveling,
configuring, 98
External softkeys
External, 246
Input, 249
Input | Offset, 182
Input Q Offset, 182
Output, 249

F

factory defaults, restoring, 28,
32,250

Fading, 356

Fading, Baseband Generator
with Real-Time Capability

Option 660, 355

features, 2

feedthrough, 182

feedthrough, carrier,
minimizing, 415

File hardkey, 57,66

file headers
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creating, 197
editing, 199
example, 200
viewing a different file, 201
files
catalog. See data storage
extensions, 61
working with, 56
filter
equalization, 252
real-time modulation
softkey location, 263

user, equalization, 252
filter, interpolator, 236
filtered & unfiltered

samples, 304,317
filters
finite impulse response, 254,
394
FIR, 254,394
gaussian, loading
default, 260, 401

nyquist, selecting, 382
filters Dual ARB, 254
finite impulse response filters

using, 254,394
FIR filter

apodization settings, 260, 401

Hamming, 260, 401

Hann, 260, 401

Kaiser, 260, 401

window settings, 260, 401
FIR filters

Arb Custom, 394

creating, 255,394, 396

modifying, 260, 401

storing, 258,399

using, 254,394
FIR table editor

accessing, 255,396

Arb Custom, 401

coefficients, duplicating, 256,

398
coefficients, entering
values, 255,396
coefficients, modifying, 261,
402

Dual ARB, 255, 260

files, loading, 260, 401

filters

creating, 255, 394, 396

modifying, 260, 401

storing, 258, 262, 399,

403

oversample ratio, setting, 257,

398

firmware
upgrading, 31,435
First Mkr Point softkey, 208
First Sample Point softkey, 208
Fixed softkey, 79,102
flat bandwidth, 348
flatness correction. See user
flatness correction
Flatness softkey, 83
FM
annunciator, 10
dc offset, removing, 163
external source, 163
hardkey, 159
softkeys, 159
formula, skew discrete
steps, 295
Free Run softkey, 46,110, 220
Free-Run softkey, 170
Freq Dev softkey, 363, 367, 368,
369, 370, 371,372,375
FREQ hardkey, 43, 45
Freq softkeys, 83
frequency
display area, 9
hardkey, 7,8, 43, 45
LF output, 166

start and stop,

swept-sine, 167
modulation, 159
multiplier, 108
offset, 106
offset, baseband, 241
offset, softkeys, 241
reference, 107
setting, 43,45
softkeys, 43, 45
frequency output limits, clock
rates & logic levels, 286
frequency reference
common, 289
hookup diagrams, 290
frequency units, 43
front panel
disabling keys, 437
display, N5181A, 9
display, N5182A, 9
display, N5183A, 9
I/Q inputs, using, 183
knob resolution, 28
overview, 5
tests, 432
FSK softkey, 363, 367, 368, 369,
370,371,372,375
FTP Server softkey, 32
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fundamental operation See
basic operation

G

Gated softkey, 170, 220
gated triggering, 221, 223
Gaussian
definition, 442
gaussian filter, loading
default, 260, 401
Gaussian. See AWGN
glossary, 441
Go To Default Path softkey, 57,
59,67
Goto Row softkey, 49,57
GPIB
connector, 14,23
definition, 442
setup, 31
softkeys
Address, 31

Setup, 31

green LED, 8
GSM softkey, 362, 366
guides, content of, xv

H

hardkeys
help on, 40
overview, 5

See also specific key
header utilities softkeys, 197
Help hardkey, 6, 40
Hostname softkey, 32
hostname, setting, 32
HP 3300A, emulating, 112

| connector, 7
| Offset softkey, 249
| OUT connector, 15
I/0 Config softkey, 25
1/Q
adjustments, 182, 249
front panel inputs, using, 183,
248
Int Equalization Filter
softkeys location, 253
modulation, 182,245
optimizing, 247
rear panel outputs, 15
rear panel outputs, using, 247
signal path, optimizing, 247
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signal, aligning, 204
softkey, 253
softkeys, 182,246 t0 251
waveform, clipping, 226
ideal low-pass filter. See
rectangular filter
IF, 442
ILS Glide Slope 334.70 MHz w/
90 Hz AM (Up), 150 Hz AM
(Down) @ 40%, 130, 142
ILS Glide Slope Softkey
Menus, 143
ILS Localizer 108.10 MHz w/
90 Hz AM (Left), 150 Hz AM
(Right) @ 20%, 130, 142
ILS Localizer Softkey
Menus, 131
ILS Marker Beacon Softkey
Menus, 153
ILS Marker Beacons 75 MHz w/
Inner 4000 kHz, Middle
1300 Hz, Outer 400 Hz, 130,
142
images, 182
impairments
I/Q adjustments, 182
impairments, real-time
phase noise, 349
Import Waveform softkey, 216
improve non-harmonics, 43
Incr Set hardkey, 8
information, removing from
memory, 437
Insert softkeys
Insert, 192
ltem, 49
Row, 49
Waveform, 192
Waveform Sequence
Contents, 192
Install Assembly softkey, 38
Install licenses softkey, 61
installation guide content, xv
instrument
firmware, upgrading, 31
softkeys
Adjustments, 25

Info, 25
Options, 37
state

associating with
waveform, 64

files, 62,66

register. See data stor-
age

450

softkey, 62

Int Equalization Filter
softkeys, 253
int media, 442
Int Phase Polarity softkey, 246
interface
GPIB, 31
LAN, 32
internal
reference oscillator, using, 30
Internal Baseband Adjustments
softkey, 249
internal clock source
selection, 307,314
internal media, 67
Internal Storage to USB
softkey, 62
Internal/USB Storage Selection
softkey, 57
interpolator filter, 236
IP
Address softkey, 32
address, setting, 32
auto, 32
definition, 442
1Q
clock rates, 288
IQ map, QAM modulation, 404

J
jitter on EVENT output, 218

K

keyboard, using, 112
keys

definition, 442

disabling, 437

front panel, 5

help on, 40

numeric, 5

test, 432

See also specific key
Keysight MXG

modes of operation, 3
Keysight sales and service

offices, 435

knob, 8,28, 41

L

L annunciator, 10
LAN
connector, 14,23
definition, 442

Services Setup softkey, 31
setup, 32
Setup softkey, 31
Last Mkr Point softkey, 208
Last softkey, 28
LEDs, 8
blink test, 432
front panel, 8
modulation, 54
leveling
external, 95to 101
turn off ALC, 102
LF Out, 165
LF output
amplitude, 166, 167
configuration example, 166,
167
description, 165
frequency, 166
source
function generator, 167

internal modulation
monitor, 166
swept-sine
start frequency, 167
stop frequency, 167

waveform, 160, 165, 167
LFO. See LF output
licenses

manager, 37

service software, 37

signal studio, 37

time-based, 29

troubleshooting, 434

viewing, 37

waveform, 37
limits, clock & sample rates,

logic outputs, 286
line power (green) LED, 8
linear sweep, 47
list mode values, 50
List softkey, 57
list sweep

parameters, 50

status information, 50

troubleshooting, 429

using, 49

waveform, 51
listener mode annunciator, 10
LO, 442
Load From Selected File

softkey, 60,61
Load List softkey, 61
Load softkeys

All From Int Media, 189

All From USB Media, 189
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Cal Array From Step Array, 83
From Selected File, 60,61
Load/Store, 49, 60,61
Segment From Int Media, 189
Segment From USB
Media, 189
Store, 189
Sweep List, 61
Load/Store softkey, 49, 60, 61
Local hardkey, 6
lock up, troubleshooting, 424
logarithmic sweep, 47
logic type
output levels, 286
selecting, 301
low frequency output. See LF
output
low spurs, 43
LVDS compatibility with the
PXB, 3
LXI, 442

M

manual control, sweep, 53
Manual softkey, 79, 102
Manual softkeys

Config Settings, 32

Manual, 32

Mode, 46

Point, 46
manuals, content of, xv
Marker softkeys, 208
markers, aligning signal, 204
markers, waveform, 203t0 218
media

BBG, 441

erasing, 437

Flash Drive, 67

int, 442

storage, 67

types, 187,437

USB, 67,430
memory

erasing data from, 437

See also media
menu keys, 6
messages, error, 431
messages, warning

Opt 25x Licensing, 283
mirror table, duplicating

coefficients, 256, 398
mixer, troubleshooting signal
loss, 427

Mod On/Off hardkey, 7,54
Mod On/Off, Option UNT, 159

Mod Type Softkeys, 363, 367,
368, 369, 370, 371,372,375
Mode hardkey, 188, 343, 344,
345, 346, 348, 350
Mode key, 356
mode, modulation, 442
modes of operation, 3
Modulated softkey, 79, 102
modulation
AM, 159
analog, 3
configuring, 160, 165
annunciators, 10
carrier signal, 54
digital, 4
external source, using, 163
FM, 159
generating, 54
I/Q, 182,245
phase, 159
pulse, 3,169
real-time filter, softkeys, 263
simultaneous, 55
troubleshooting, 425
Modulator Atten softkey, 348
module user interface
location, 300,310
monochrome display,
setting, 27
Monochrome softkey, 27

MSK softkey, 363, 367, 368, 369,

370,371,372, 375
MULT annunciator, 10
multi-BBG sync, 265

configure setup, 268

equipment setup, 268

resynchronize, 270

system delay, 266

system sync, 267

trigger setup, 267
multicarrier setup

APCO 25 w/C4FM, 391

APCO 25 w/CQPSK, 391

Bluetooth, 391

CDPD, 391

DECT, 391

Default, 391

EDGE, 391

GSM, 391

NADC, 391

PDC, 391

PHS, 391

PWT, 391

TETRA, 391
multicarrier setup

softkeys, 391
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multicarrier TDMA waveforms
creating, 391
multicarrier, Default softkey.
See quick setup, Default
softkey, settings
multiplier, using, 108
multitone, 360, 41810421
multitone mode, 4
Multitone softkeys, 418
multitone waveform,
setup, 412

N

N5102A
baseband data, 300
clock rates, 286
clock settings, 305,312
clock source
description, 288

clock timing, 286, 291
common frequency
reference, 289
connections to clock and
device, 297
data parameters, setting, 302,
316
data types, 299
digital data, 318
digital signal interface
module, 285
frequency reference
connector, 289
generating data, 309
input direction, 311
input mode, 299,310
interleaving clock timing, 293
logic type, port
configuration, 311
logic types, 301
Option 003 or 004, 319
output direction, 302
output mode, 299, 300
phase and skew clock
timing, 295
serial clock timing, 294
user interface, 300
user interface module, 310
NADC softkey, 362, 366
Name And Store softkey, 216
negation description, 305,318
Next REG softkey, 112
Next SEQ softkey, 112
No action softkey, 61
No Retrigger softkey, 220
noise, 341
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noise bandwidth factor, 342
Noise Bandwidth softkey, 343
Noise Mux softkeys, 345, 346
Noise softkey, 343, 345, 346
non-harmonics, 43
non-volatile memory, 187
non-volatile, definition, 442
number keys, 41

numeric format selection, 304,

318
numeric keypad, 5
nyquist filter
definition
nyquist filter, selecting, 382

0]

OFFS annunciator, 10
offset, 182
offset binary use, 304,318
offsets
baseband frequency, 241
1/Q, 249
output, using, 106
on/off switch, 8
operation
modes of, 3
operation, basic, 39
operation, remote, 31
optimization, 1/Q, 182, 246
option
430
multitone mode, 418
two tone mode, 413
two-tone mode, 413
Option UO1, 91
internal channel
correction, 97
Option UNT
Mod On/Off hardkey, 159
Options
003 or 004 Digital Signal
Interface Module, 319
302 Avionics (VOR/ILS), 113
660 Real-Time Fading, 356
660 Upgrade Baseband
Generator with Real-Time
Capability, Fading, 355
UN7 BERT, 319
options
651/652/654
description, 4
multitone mode, 418
two-tone mode, 413

enabling, 25,37

452

resource, 3
UNT, 3
UNU, 3
UNW, 3
Options 250-259, 276
Options Info softkey, 37
oscillator, external
reference, 44
oscillator, internal
reference, 30
Output Blanking softkey, 43, 45
output levels, logic types, 286
Output Mux softkeys, 343
output, swept, 46

over range error, DAC, 236, 243,

354
overshoot, 236
overview, signal generator, 1

P

Page Up hardkey, 6
parallel
clock rates, 288
data clock timing, 291
interleaved data clock
timing, 293
sample rates, 288
parameters, saving a
waveform’s, 197
path delay, 182
PATT TRIG IN connector, 16
Patt Trig In softkeys, 221
PDC softkey, 362,366
peak-to-average power,
reducing, 230
performance, optimizing, 69
persistent settings
definition, 443
resetting, 40
restoring defaults, 28
phase clock timing, 295
phase noise
adjustments, 353
DAC over range &
scaling, 354
description & plots, 351
impairments, 349
softkeys, 350, 356
Phase Ref Set softkey, 43, 45
phase skew, 182
PHS softkey, 362,366
pixel test, 432
Plot CDDF softkey, 235
PM Config
Calibrate Sensor, 85

Zero Sensor, 85
PM Config softkeys
Connection Type, 85
PM VXI-11 Device Name, 85
Power Meter IP Address, 85
Power Meter IP Port, 85
Point Trigger softkey, 46
point-to-point time, 443
polarity, external trigger, 221
polarity, marker, setting, 215
port configuration,
selecting, 301
power
meter, 82,87
on, settings, 28
peak-to-average,
reducing, 230
receptacle, 12,21
search, 103
search automatic, 105
search settings, 105
sensor, models, 84, 85
setting, 43,45
softkeys, 25, 28,79, 102
supply, troubleshooting, 425
switch, 8
troubleshooting, 425
user settable, maximum, 45
Power Control Mode
softkeys, 344
power meter
configuration, 86
U2000 Series, 86
U2000A/01A/02A/04A,
86
dual display, 70
power meter configuration
sofkeys. See PM Config
softkeys
power meter sofkeys. See PM
Config softkeys
Power Search Reference
softkey, 79,102
Power Search References, 103
Power softkeys
On, 28
On/Preset, 25
Search, 79,102
power units, 43
preferences, setting, 25
pre-fir samples selection, 304,
317
preset
hardkey location, 7
settings, 28
troubleshooting, 430
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using, 40
Preset softkeys
Language, 28
List, 49,83
Preset, 28
Prev REG softkey, 112
Prev SEQ softkey, 112
Proceed With Reconfiguration
softkey, 32
programming guide content, xv
protection, DAC over range
baseband offset
frequency, 243
phase noise impairment, 354
PSK softkey, 363,367, 368, 369,
370,371,372,375
pulse
annunciator, 10
characteristics, 171
connector, 13,22
marker, viewing, 212
modulation, 169
narrow, 102
sync signal, 47
video signal, 47
Pulse hardkey, 170
pulse modulation, 3
Pulse softkeys, 47,170
Pulse/RF Blank softkey, 208
PWT softkey, 362, 366

Q

Q connector, 8
Q Offset softkey, 249
QAM modulation 1Q map, 404
QAM softkey, 363,367, 368, 369,

370,371,372,375
quadrature adjustment, 249
quadrature angle, 182
Quadrature Angle Adjustment

softkey, 182,249
queue, error, 68
quick setup

Default softkey
settings, 362, 366

Quick Setup Softkeys, 362, 366

R

R annunciator, 10
raised cosine filter. See nyquist
filter
real time, 275, 360
real-time
AWGN

softkeys, 343, 344, 345,
346
I/Q Baseband AWGN
softkeys, 348
modulation filter, 263
modulation filter, setting, 263
noise, 342
phase noise, 349
adjustments, 353
DAC over range &
scaling, 354
description & plots, 351
impairments, 349
softkeys, 350, 356

real-time AWGN,bandwidth
ratio, 348
real-time AWGN,channel
bandwidth, 348
real-time AWGN,flat
bandwidth, 348
Real-Time Fading
Option 660, 356
real-time modulation
Dual ARB, 263
real-time modulation filter
softkey, 263
rear panel
I/Q outputs, 247
overview
n5161a, 12,21
n5162a, 12,27
n5181a, 12,21
n5182a, 12,21
Recall hardkey, 63
Recall keys
hardkey, 112
Instrument State, 57,61
Reg, 112
State, 61
recall register,
troubleshooting, 429
receiver test, 360
rectangular clipping, 231, 234
rectangular filter
definition, 443
REF annunciator, 10
REF IN connector, 13,22
Ref Oscillator Ext Bandwidth
key, 44
Ref Oscillator Ext Freq key, 44
Ref Oscillator Source
softkey, 43,45
Ref Oscillator Tune key, 30
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reference oscillator tune,
internal, 30
reference oscillator,
external, 44
reference, using, 107
references, content of, xv
regrowth, spectral, 229
remote interface, emulate HP
3300A, 112
Remote Language softkey, 31,
33,35
remote operation
annunciator, 10
remote operation
preferences, 31
Remove Assembly softkey, 38
Rename File softkey, 57
Rename Segment softkey, 189
repeat measurements, 332
Reset & Run softkey, 220
Restart on Trig softkey, 220
Restore softkeys
LAN Settings to Default
Values, 32
System Settings to Default
Values, 28
resynchronize,
multi-BBGs, 270
Return hardkey, 8
Reverse Power Protection
softkey, 28
Revert to Default Cal Settings
softkey, 250
RF
blanking
marker function, 214
settings, saving, 204
hardkey, 7
output
configuring, 44
connector, 7/
leveling, external, 95 to
107
troubleshooting, 425

RF During Power Search
softkey, 79,102

RF Output softkey, 246, 247

RFC NETBIOS Naming
softkey, 32

ringing, 236

ripple, 236

RMS, 443

RMS softkey, 79, 102

Rohde & Schwarz softkey, 33,
35
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roort, 443
root cosine filter. See root
nyquist filter
root mean square, 443
Root Nyquist Filter
definition, 443
root nyquist filter
definition, 443
rotary knob, 41
Route Connectors softkey, 46,
170
Route To softkeys, 47,170
routing
1/Q, 182,246
marker
ALC hold, 205

RF blanking, 214
saving settings, 204
RPG test, 432
runtime scaling, 238

S

S annunciator, 10
sales, Keysight offices, 435

sample
rates, 286

parallel/parallel intrlvd
port
configuration, 2
88

serial port
configuration, 2
87

type selection, 304,317
sample rate clock, 17
sample rate softkey, 218
Save hardkey, 63
SAVE Seq Reg softkey, 63
Save Setup To Header

softkey, 197
Scale Waveform Data
softkey, 235
scaling softkeys, 235
SCPI

enabling, 32

reference content, xv

softkey, 33,35
screen saver settings, 27
Screen Saver softkey, 27
search, power, 103
secure

display, 437
security, 437
Security softkey, 57

454

Segment Advance softkey, 220
segment advance
triggering, 221
segments
advance triggering, 222
file headers, 197
loading, 189
softkeys, 189
storing, loading, &
playing, 189
Select hardkey, 41
Select Seq softkey, 112
Select softkeys
Color Palette, 27
Different Header, 197,201
Header, 197
Internal File(s) to Copy to
USB, 62
Reg, 63
Seq, 63
Waveform, 49
self test, 432
Sequence softkey, 57,197
sequences
editing, 194
file headers, 197
marker control, 215
playing, 195
waveform, 192
serial
clock and sample rates, 287
clock timing, 294
serial data, synchronizing, 17
server, enabling, 32
service
guide content, xv
Keysight offices, 435
request annunciator, 10
Set Marker softkeys, 208
settings, persistent, 443
settings, phase noise, 353
Show softkeys
Alpha Table, 41
Waveform Sequence, 192
Waveform Sequence
Contents, 192,216
signal generator
modes, 3
Signal Studio, 3
signal studio licenses, 37
sinewave, 443
Single softkey, 220
Single Sweep softkey, 46
skew
clock timing, 295
range, 295

skew, 1/Q, 249
Sockets SCPI softkey, 32
sockets, enabling, 32
Softkeys, 114
softkeys
definition of, 443
help on, 40
label area, 11
location, 5
See also specific key
source settled signal, 47
Source Settled softkey, 47,170
Span softkey, 79, 102
special pattern ignore
function, 337
Specify Default Storage Path
for User Media softkey, 57
spectral regrowth, 229
spectrum analyzer,
troubleshooting signal
loss, 426
square root raised cosine filter.
See root nyquist filter
Square softkey, 170
standard, modulation, 442
standby (yellow) LED, 8
State softkey, 57
states, persistent, 443
step array (user flatness), 88
See also user flatness
correction
Step Dwell softkey, 47,110
Step Spacing softkey, 47
step sweep
spacing, 47
troubleshooting, 429
using, 47
Step/Knob Ratio softkey, 28
Storage Type softkey, 59,67
Store Custom Dig Mod State
softkey, 364
Store To File softkey, 60, 61
Stored Segments softkey, 57,
197
Subnet Mask softkey, 32
Sum softkey, 246
sweep
annunciator, 10
hardkey, 46
linear, 47
list parameters, 50
list status information, 50
logarithmic, 47
manual control, 53
mode, 3
out connector, 13,22, 47
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out signal, 47
softkeys, 461053,170
step, 47
troubleshooting, 429
waveform, including, 51
SWEEP hardkey, 46
Sweep softkeys, 46t053,62,170
swept output, 46
switch, power, 8
SWMAN annunciator, 10
synchronization, 331, 332
synchronize multi-BBGs, 265
configure setup, 268
equipment setup, 268
resynchronize, 270
system delay, 266
system sync, 267/
trigger setup, 267
system defaults, restoring, 28

T

T annunciator, 10
talker mode annunciator, 10
TCP, 443
TCP Keep Alive softkeys, 32
TDMA

custom digital modulation,

predefined, 379

TDMA digital modulation, 379
terminator, 443
test, self, 432
test, self-web-enabled, 432
tests, front panel, 432
TETRA softkey, 362, 366
text area (on display), 10
text entry softkeys, 189
time, dwell, 447
time, setting, 29
time/date reference point, 29
Time/Date softkey, 29
time-based license, 29, 434
Timer Trigger softkey, 46, 110
Toggle softkeys, 216
Total Noise softkey, 344
Total softkey, 344
Trig

in connector, 13,22

out connector, 47

out signal, 47
trigger

connectors, 13,22

hardkey, 6

initiating, 6

multiple BBG sync, 267
Trigger setup softkeys, 111

Trigger softkeys

& Run, 220

Doublet, 170

Key, 46

Out Polarity, 46

Source, 219

Triggered, 170

Type, 219
Triggered softkey, 170
triggering

gated, 221,223

multiple BBG sync, 267

equipment setup, 268

segment advance, 221

softkeys, 219

waveforms, 219
troubleshooting, 423
two tone, 360,413t0417
two tone softkeys, 413
two-tone softkeys, 413
two-tone waveform, setup, 412
type, modulation, 442

U

unfiltered & filtered
samples, 304,317
UNLEVEL annunciator, 10
unleveled operation, 102
UNLOCK annunciator, 10
Unspecified softkey, 197
UNT, option, 3
UNU, option, 3
UNW, option, 3
Up Directory softkey, 57,59, 62
Update in Remote softkey, 27
urls, 3,31,37,435
USB
connecting media, 67
definition, 443
device connector, 14,23
host connector, 5, 14, 23
keyboard, using, 112
softkeys
File Manager, 57,58
Keyboard Control, 112
to BBG Memory softkey, 62
to Internal Storage
softkey, 62
troubleshooting, 430
Use softkeys
As, 61
Current Directory As Default
Path, 57,67
Only Internal Storage, 57
Only USB Media, 57
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user
documentation content, xv
files, backup and restore, 56
flatness correction, 82
preset, 40
preset, troubleshooting, 430
user files
modifying, 371
user files, data, 369, 371
user FIR
definition, 444
user interface location,
module, 300,310
User softkeys
Configure Power Meter, 83
Current Directory As Default
Path, 59
Do Cal, 83
Flatness, 43, 45,57
Flatness Correction, 83
Flatness Corrections, 62
Span, 79,102
User, 28
user-defined FIR
Dual ARB, 255
Utility hardkey, 25
Utility softkey, 38

Vv

vector operation, 185,276

Using VOR, 114

View Next Error Page
softkey, 68

View Previous Error Page
softkey, 68

volatile memory, 187,189

volatile, definition, 444

VOR mode, producing a full or
partial VOR signal, 116, 320,
321,322

VOR Softkey Menus, 115

VOR Transmitter Antenna
Pattern, 114,118

VXI-11, enabling, 32

VXT-11 SCPI softkey, 32

W

warranted logic output clock
rates, 286
waveform
adding custom
modulation, 379
Waveform license, Opt 25x
adding a waveform, 278
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backup warning, 283
file missing warning, 283
license status messages, 279
licensing, installing, 276
licensing, understanding, 276
licensing, warning
messages, 283
lock warning, 283
replacing a waveform, 278
status messages, 280
using, 276
waveform licensing
softkeys, 278
Waveform softkeys
Licenses, 37
Runtime Scaling, 235
Segments, 189
Sequences, 192,216
Utilities, 235
Waveform, 46, 49
waveforms
clipping, 226
file headers, 197
from digital baseband
waveform, 236
in a sweep, 51
license, 37
markers, 203, 204
multiple BBG
synchronization, 265
multitone, 41810421
overview, 187
saving instrument state, 64
scaling, 235
segment softkeys, 189
sequence, 192
storing, loading, &
playing, 189
triggering, 219
two-tone, 413t0417
Web Server softkey, 32
wideband AM, 164

window settings, FIR filter, 260,

401
WINIT annunciator, 10

Y
yellow LED, 8

z
Zoom softkeys, 208
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